Closed Bug 330208 Opened 14 years ago Closed 13 years ago

Unsupported windows versions need error message on startup (and in installer)

Categories

(Core :: Widget: Win32, defect)

x86
Windows 2000
defect
Not set

Tracking

()

RESOLVED WONTFIX
mozilla1.9alpha1

People

(Reporter: mikes, Unassigned)

References

Details

(Keywords: relnote)

User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows 98)
Build Identifier: Error Starting Program - Firefox.exe linked to missing export FDI32.DLL:GetGlyphIndicesW.

Error Starting Program

The FIREFOX.EXE file is
linked to missing export GDI32.DLL:GetGlyphIndicesW.

Then the OK button.



Reproducible: Always

Steps to Reproduce:
1.Installation of latest Deerpart build
2.
3.

Actual Results:  
ERROR MESSAGE

Expected Results:  
BROWSER TO LOAD
You can't use the latest builds on win98 because cairo stuff uses some commands that are only on more advanced windows oses.
but you can use these builds --> 
http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/experimental/non-cairo/latest-trunk/
Windows 98 users deserve at least a better error message :)
Summary: For the last few times, the nightly build install has failed with this message. → Nightly fails to start with "The FIREFOX.EXE file is linked to missing export GDI32.DLL:GetGlyphIndicesW."
Yep, they do.. should just be a matter of a os version check and a little alert very early in startup, before we load layout.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Nightly fails to start with "The FIREFOX.EXE file is linked to missing export GDI32.DLL:GetGlyphIndicesW." → Unsupported windows versions need error message on startup
The biggest problem I have with this, is that it then makes the program unusable, and if one doesn't have an earlier version handy they must then use IE, and install a newer version. The installer should check this before it wipes out the version that works. Currently, I have the 20060221 version that is working.
Summary: Unsupported windows versions need error message on startup → Unsupported windows versions need error message on startup (and in installer)
(In reply to comment #3)
> Yep, they do.. should just be a matter of a os version check and a little alert
> very early in startup, before we load layout.
It's impossible unless you switch to using GetProcAddress because Firefox links most components (including layout) statically.
IMO it's enough for installer to check this since only installer builds are official. Nightly users should know what they are doing.
Nightly build users might expect problems, but I treated this as a bug and was trying new builds hoping that it would be fixed in a later build, not that it was a design situation to block 98 users. If they have decided to not support 98, then they should be a use IE message at the front. I was under the impression that Mozilla was to support everything rather than being more restrictive than IE. If nothing else, they should put a message on the web page saying that nightly builds no longer support 98.
(In reply to comment #6)
> If they have decided to not support
> 98, then they should be a use IE message at the front. I was under the
> impression that Mozilla was to support everything rather than being more
> restrictive than IE. If nothing else, they should put a message on the web page
> saying that nightly builds no longer support 98.

Nightly builds are highly unstable, and the way information is made available regarding them is through the roadmap and other developer communications.  Firefox 1.5 and the Firefox 2 alphas (and Firefox 2 final) will continue to work fine on Win98.  What's on the trunk now is the basis for what will most likely become Firefox 3, sometime next year.   At that point, any version of windows less than Win2k will not be supported for Fx3 or beyond, due to technical limitations of those versions.
At this point, this is the only error message that seems to stop 98 from working with it, and fron discription below from the MicroSoft page, I don't see where this would be a critical function, or perhaps it would be possible for firefox to not support this feature on a 98 system rather than just not supporting it at all. 
Additionally, how is this handled for other OS's.

GetGlyphIndices

The GetGlyphIndices function translates a string into an array of glyph indices. The function can be used to determine whether a glyph exists in a font.
> Additionally, how is this handled for other OS's.

by using pango or ATSUI...
last working version found on my harddisk:
Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.9a1) Gecko/20060222 Firefox/1.6a1

next version found on ma harddisk was crashing:
2006-02-27-06-trunk/firefox-1.6a1.en-US.win32.zip	1.9a1: 2006022704

newer versions don't start, but are showing the error message from comment #0

This is a regression, without the possibility to find binaries for testing the timeframe. 
In http://mozilla.osuosl.org/pub/mozilla.org/firefox/nightly/ there are no trunk builds between 
2005-10-02-07-trunk/              05-Jan-2006 19:05    and
2006-02-26-05-trunk/              27-Feb-2006 14:03      

I'm marking this as regression, as a big change like this should be documented, which checkins did cause the bugs mentioned in this comment?
 
Keywords: regression
Version: unspecified → Trunk
Could this be a way of working around getglyphindicies on older versions:
http://support.microsoft.com/kb/q241020/
Granted I assume that's not the only problem on older versions of Windows.
Flags: blocking1.9a1?
I also want to report this bug

(In reply to comment #0)
> User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows 98)
> Build Identifier: Error Starting Program - Firefox.exe linked to missing export
> FDI32.DLL:GetGlyphIndicesW.
> 
> Error Starting Program
> 
> The FIREFOX.EXE file is
> linked to missing export GDI32.DLL:GetGlyphIndicesW.
> 
> Then the OK button.
> 
> 
> 
> Reproducible: Always
> 
> Steps to Reproduce:
> 1.Installation of latest Deerpart build
> 2.
> 3.
> 
> Actual Results:  
> ERROR MESSAGE
> 
> Expected Results:  
> BROWSER TO LOAD
> 

(In reply to comment #0)
> User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows 98)
> Build Identifier: Error Starting Program - Firefox.exe linked to missing export
> FDI32.DLL:GetGlyphIndicesW.
> 
> Error Starting Program
> 
> The FIREFOX.EXE file is
> linked to missing export GDI32.DLL:GetGlyphIndicesW.
> 
> Then the OK button.
> 
> 
> 
> Reproducible: Always
> 
> Steps to Reproduce:
> 1.Installation of latest Deerpart build
> 2.
> 3.
> 
> Actual Results:  
> ERROR MESSAGE
> 
> Expected Results:  
> BROWSER TO LOAD
> 

Depends on: 330276
*(P) FireFox -> Core
*(S) critical -> normal
*(K) regression -> (removed)

Quote from bug 330276:
{{
 ------- Comment #47 From Serge GAUTHERIE  2006-04-05 13:36 PDT  [reply] -------

Trying 2006-04-05 nighly builds, on W98SE:
*SeaMonkey v1.5a displays its splash screen then immediately exists.
*ThunderBird v3.0a1 refuses to start, complaining about missing export
"USER32.DLL:UpdateLayeredWindow".
}}
Severity: critical → normal
Component: Startup and Profile System → Widget: Win32
Keywords: regression
Product: Firefox → Core
The installer is the best place for this. Incompatible builds shouldn't pass the installer checks. I dare say that NSIS will make this pretty trivial. Is fixing this twice really necessary?

 - Chris
*** Bug 339499 has been marked as a duplicate of this bug. ***
*** Bug 339533 has been marked as a duplicate of this bug. ***
oops 

would someone mind to tell me, when this kidding stuff is terminated -
there are no excuses, that Mozilla/Seamonkey is not running on WinNT -
or am I wrong?

Thanks
Martin
(In reply to comment #17)
> oops 
> 
> would someone mind to tell me, when this kidding stuff is terminated -
> there are no excuses, that Mozilla/Seamonkey is not running on WinNT -
> or am I wrong?

In the dependencies you will find the preceding Bug 330276, so no you are wrong, support for Win9x, WinME, WinNT is removed from trunk. Use 1.8 builds, i.e. Firefox 1.5 or Firefox 2.
.. or SeaMonkey v1.0.x release (or v1.1a nightly).
@ Herman

can you please explain - or show the propriate link - why W98/WinNT are not supported by the "New" 1.9-based trunk ? 

And who was the decision-maker for that  ... - well, sorry, I am loosing the kind words for that nonsense.

Martin
I suggest you read Bug 331723, please do not add unnecessary comments to that bug or this bug :) (this bug here is about giving a useful error message to the user).
Assignee: nobody → win32
QA Contact: startup → ian
@ Frank

would you mind to explain what you mean by "unnecessary comments" ?

You mean, a lack in concept is not open for the discussion ? 
Wow, big opinion, but I have thought, that customers will is the main target, not what developers think, the customer "should have", right?

by the way: I am not sure, whether https://bugzilla.mozilla.org/show_bug.cgi?id=331723
will be closed for long - as the discussion is not over - and as you can see here - 1.9a1 is working fine. I does not make sense to drop old windows-versions and kick out the supporting code, just because MS force developers to use new compiler-versions, thats stupid.

so, lets see how this discussion will go on, as it is about the necessity of an error-message - for various reason.

Martin
(In reply to comment #22)
> would you mind to explain what you mean by "unnecessary comments" ?

Unnecessary comments are ones that try to discuss a decision that has already been made and finalized.

> Wow, big opinion, but I have thought, that customers will is the main target,
> not what developers think, the customer "should have", right?

I'm sure you can get a full refund if you're not 100% satisfied.

Please don't further clutter this bug with "discussion" - it will not get you anywhere.  See the newsgroups if you want to debate supporting older platforms.  I'm not personally a fan of dropping the support, but what's done is done.
One thing I found interesting about this, is that it was mentioned that this was required because of a windows change, and I had asked what was used in other OS's to do this, and was informed that it was something called PANGO. Then later on a linux list, there was a discussion that this PANGO was causing a lot of problems, and it was recommended to remove it. Don't know why they couldn't just have it not support the features that don't support this, rather than just dropping support. I'd like to have seen the pros and cons, and why it was decided to drop support. 
If you insist on discussing the dropped support for Windows 98 in Bugzilla, please do so in the correct bug, bug 331723.
(In reply to comment #25)
> If you insist on discussing the dropped support for Windows 98 in Bugzilla,
> please do so in the correct bug, bug 331723.

No; if someone wants to keep having that discussion, they need to do so in the newsgroups.
@ Vladimir

well, you already expressed, that you do not like to have the debate - for what reason soever. But this is personal to you. There is no place on the news-group-server of mozilla to do the discussion - you may have a look for yourself. So in here - in this small bug - it seems that we have more readers, than in the news.mozilla.wishlist. so why not to continue it in here?

However, I am using WinNT - at actual with no alternaty. Not being able to use the  Gecko 1.9-based versions IS a bug to me, as the 1.8-based versions are much too slow/too weak.
So what do you want me to do - shall I reopen Bug 339533 - because it is obviously not a duplicate of this bug here ?

I prefer to continue the discussion of the "why" to drop the old-Windows in here.


Martin




(btw: comment #23 : "get a full refund if you're not 100% satisfied" - sorry Chris, what a senseless remark - I personally prefer to deal with quality, problems and solutions, even if something is opensource !)
Martin,

This bug is about the firefox installer notifying users of unsupported OSs as to why firefox won't install on their machines; it is nothing to do with what you're whining about. The debate you're talking about has already happened - many months ago - on the mozillazine forums, on usenet, on IRC, on blogs and in bugs like bug 330276 - so kindly take your discussion elsewhere (preferably  mozilla.dev.apps.firefox on usenet) since all you're doing is polluting this bug with irrelevant bugspam. Thanks.
(In reply to comment #27)
> I prefer to continue the discussion of the "why" to drop the old-Windows in
> here.

I am a Win98SE user at this time, and support the _wish_ that this OS could be supported on Trunk yet.

Nevertheless, I would "vote" for the removal of your bugzilla account if you can't stop "spamming" by yourself after the situation has been so clearly repeated to you.

Please !
(In reply to comment #27)
> So in here - in this small bug - it seems that we have more readers,
> than in the news.mozilla.wishlist. so why not to continue it in here?

Bugzilla is for solving technical problems, not discussion of personal preferences. You can discuss solutions in a bug, if you are a developer, nut it doesn't make sense do do non-technical solutions in bugzilla. The more bugspam a bug contains, the less likely is it it gets fixed. 

> However, I am using WinNT - at actual with no alternaty. Not being able to use
> the  Gecko 1.9-based versions IS a bug to me, as the 1.8-based versions are
> much too slow/too weak.

I've opened Bug 331723 Don't kill Win98, to put away discussion from this bug, 
you could have argued there, as that was the bug about fixing Win98 (and maybe WinNT). This bug is fixed by removing the support.

> So what do you want me to do - shall I reopen Bug 339533 - because it is
> obviously not a duplicate of this bug here ?

It's not a duplicate, it depends, as it would never have been a bug if the error message would have been given.

> I prefer to continue the discussion of the "why" to drop the old-Windows in
> here.

This is not the place for discussing this. (That's also not the place for discussion)
Read Bug 330276 Drop support for pre-Win2k platforms (Win9x/Me/NT4).
Bug 330276 Comment #36 From Robert O'Callahan (Novell)  2006-03-29 21:07 PDT  

Here's what needs to be done to restore Win9x support, by whoever volunteers to
do so:...

and do something, but don't rant in bugzilla.

Bug 330276 Comment #67 From Robert O'Callahan (Novell)  2006-04-20 02:53 PDT  [
We have maintainers who have volunteered to do the work to keep those platforms
supported. We haven't yet had a single volunteer step up to keep Win98
supported.

We don't need more rants, we need a developer who can show by presenting code that previous rants are justified, or can make a shim library that Win9x/WinNT could be supported by a special compilation. 

Sorry for the bugspam, but sometimes it seems necessary. And WTF is support dropped, but no error message supplied? (rhetorical question, please don't bug-spam)

@ Herman

well, I am not clear to understand your position, do you want old-version-support in gecko-1.9. based products or not?

however, you are right, this is a non-technical-discussion, it is not about code-lines but concepts, and the reason we have it is, that developers with a lack in documentation and concept made a non-technical decision: it is much easier to use new MS-developement-tools and drop old-version-support, than to change something. you showed to the right bugs. 

As I understood, there will be no ability to do any programming for W98/ME/WinNT, if developers use the new App.Compatibility Toolkit to test everthing against XP, and it looks as this has been the decision in Mozilla. 
if you like examples, what the outcome of this can be, have a look at this: 
Winamp 5.21 did so - and became useless.
Openoffice-devolopers try go another way, and it looks as it will work.  

So the missing splash-screen is not a sort of "sorry - we missed it", but the shameful end of a misslead concept, saying an "oh sorry - we can not do better", even you can not read it. 
Yes, a non-technical discussion. No the last one I guess, let's see what will happen, when every user can see - from an appropriate splash-screen -, that old versions are not supported. So I prefer to have that "error"-message as soon as possible.

Martin
Here's an error message proposal :
"Firefox will not work on your OS, you should use MS Internet Explorer or Netscape 8 to browse the web, or upgrade your OS to Windows XP or Windows Vista. Bill Gates thanks you very much for all the money he earns with your help."
I'll skip comments and go straight to my scenario.

1. I wanted to report a bug.
2. I was told to install the latest nightly build. 3.0 cool, very happy...
3. I downloaded 7 MB installation file (about 8-10 minutes if not using the Internet).
4. Run the installation - nice new tweaks in looks, cool.
5. Run Minefield and got some error message.
6. Wanted to report this as I thought this might not have been tested under Win98.
7. Found that I shouldn't have gone through all this :(.

As you might see I should have been stopped at step 2.

Things I belive should be done:
1. When on bugzilla.mozilla.org I should get a warning saying that I should not report any bugs as there are no versions of nightly builds for me. I should also be encouraged to switch to Linux or latest version of Windows. Browser agent check should be enough to have this message triggered.
2. If I somehow managed to miss the warning I should still get a warning on a first step of the installation. If this is not easily done to check for pre-Win2k, then the warning should be visible for all.


Question: Should I uninstall Quality Feedback Manager for FF, under Windows 98? I'm serious. I usually take some time to think of what I have just done and try to explain it. Maybe this is not helping at all, so I would like to know.
> 2. I was told to install the latest nightly build. 3.0 cool, very happy...

There are also nightly builds of pre-2.0 which still supports Win98

> Question: Should I uninstall Quality Feedback Manager for FF, under
> Windows 98? [...] Maybe this is not helping at all, so I would like to know.

Only a few crashes are specific to a particular OS version so your crash data will still be helpful. And even crash information specific to Win98 would still help improve Firefox releases for the next year.
*** Bug 346069 has been marked as a duplicate of this bug. ***
I assume as support for Win98 has been dropped in Trunk long before fixing bug 330276, nobody will look at a bug whose Version is TRUNK, and OS is WIN98.
So I'm setting the OS to the oldest supported system, in the hope this annoyance may get a better visibility to be fixed, produce less dupes and less rants.

Unsupported Windows versions on Trunk are: Windows 95, 98, ME, NT

Bug 333221 is also a Win95/WinNT only issue and was filed under OS: WinXP

OS: Windows 98 → Windows 2000
*** Bug 346064 has been marked as a duplicate of this bug. ***
well Hermann 

did I got it right, that even if the development is running for Win2K and up, the unsupported versions will get an error-splash-screen, that they are not supported,  so this portion of the installation will work and show that screen on Windows 95, 98, ME, NT, right?

Martin
*** Bug 349277 has been marked as a duplicate of this bug. ***
I Believe That You Need A Message Before It Starts Unpacking Stuff (As That Takes A Long Time.)

thanks

~LAPS
Blocks: 352420
Filed Bug 352510 for the NSIS installer which is currently used by Thunderbird, Firefox, and Sunbird. I'm leaving installer in the summary in case someone wants to fix the XPInstall installer though that should probably be done in a separate bug.
Depends on: 352510
Note: this bug can be fixed without fixing bug 352510 so this bug doesn't actually depend on bug 352510
No longer blocks: 352420
Blocks: 352510
No longer depends on: 352510
Flags: blocking1.9a1? → blocking1.9+
Whiteboard: [blocking1.9a1+]
Target Milestone: --- → mozilla1.9alpha
Keywords: relnote
Whiteboard: [blocking1.9a1+]
No longer depends on: 352787
Duplicate of this bug: 382866
Duplicate of this bug: 382844
I'm actually thinking that we shouldn't fix this, and instead should just make the installer give an error -- there have been people who have played with DLLs and gotten something sort-of-working on windows < 2k, I think.
In relation to the installer (bug 378216) I am planning on not allowing installs if the OS is not supported. I think this is still the way to go since the number of users that get it sort-of-working on windows < 2k is most likely rather small when compared to the number of users that would end up with an unusable installation of Firefox especially when installing on top of an existing install of Firefox 2.0.
Yes, I definitely agree -- the installer needs to error out.  But, should the app itself on startup?  I'm thinking no, now; in fact, I don't think we even can do an error message -- as soon as we touch libxul we'll try to resolve symbols that don't exist, and we link to libxul instead of loading it dynamically.  So, going to WONTFIX this.

The installer error message is bug 352510, and that's something we should fix.
Status: NEW → RESOLVED
Closed: 13 years ago
Flags: blocking1.9+ → blocking1.9-
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.