Attachment panel in message reader is not focusable / accessible with the keyboard (needs [TAB] stop)

RESOLVED FIXED in Thunderbird 9.0

Status

Thunderbird
Message Reader UI
P3
normal
RESOLVED FIXED
11 years ago
6 years ago

People

(Reporter: Thomas D., Assigned: squib)

Tracking

(Depends on: 1 bug, Blocks: 5 bugs, {access})

Trunk
Thunderbird 9.0
access
Dependency tree / graph
Bug Flags:
wanted-thunderbird +
blocking-thunderbird3 -
in-testsuite +

Thunderbird Tracking Flags

(thunderbird8 fixed)

Details

(Whiteboard: needs followup bug to discuss F6 stop)

Attachments

(3 attachments, 1 obsolete attachment)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.8.1.2) Gecko/20070219 Firefox/2.0.0.2
Build Identifier: Version 1.5.0.10 (20070221)

In TB 1.5, when using <tab>-key to move focus around between components of the UI, attachment pane will be skipped, i. e. you cannot place focus in attachment pane using <tab>. Furthermore, I could not find keyboard shortcut to place focus on attachment pane. Which means, in the TB's main win, attachment pane if it exists will be inaccessable via keyboard. Has this changed with the new attachment pane implementation for TB2?


Reproducible: Always

Steps to Reproduce:
1. In TB's main win, move around focus using <tab> on a msg with attachments
2. When focus is on msg preview pane (dotted borders), press <tab> once more
3.
Actual Results:  
Focus skips the attachment pane (below preview pane) and jumps straight to folder list on the left

Expected Results:  
Focus should move into the attachment pane (first file attachment should have dotted border)

Comment 1

11 years ago
Not just the 3-pane; standalone mail windows show this as well.

This is true in the 2.0pre builds as well, after the reworking done to the attachment panel.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: access
OS: Windows XP → All
Hardware: PC → All
Summary: Using <tab>-key to move focus in TB main win, attachment pane does not get focus (Keyboard accessability) → Attachment panel is not focusable by <tab> (Keyboard accessibility)
Version: unspecified → Trunk

Comment 2

11 years ago
(In reply to comment #1)
> after the reworking done to the attachment panel.

Can you confirm that this used to work before the attachment panel reworking? I tried Mac builds from 2007, 2006 and 2004 (1.0) and haven't seen a time point at which it ever worked. Maybe it did on Windows, though.

But regression or not, I agree this would be a very useful addition.

Comment 3

11 years ago
Wayne, you misunderstand; this bug is reported against 1.5, I was just pointing out that it *continues* to exist in 2.0.

Comment 4

11 years ago
Cool. The wording made it sound like it was a regression from the attachment changes, and I was racking my brain wondering what could have done it.

Question: Once the attachment pane is focussed, do we want subsequent tabbing to iterate the focus over each individual attachment (similar to behaviour in the header pane, where it iterates over every header), or just jump to a different pane? I think I'd favour the former.
Blocks: 370226
(Reporter)

Comment 5

11 years ago
(In reply to comment #4)
> Question: Once the attachment pane is focussed, do we want subsequent tabbing
> to iterate the focus over each individual attachment (similar to behaviour in
> the header pane, where it iterates over every header), or just jump to a
> different pane? I think I'd favour the former.

Two remarks on this:

1) "behaviour in the header pane, where [tab] iterates over every header"
- oh, does it really? As for me, NOT in TB 1.5, where <tab> only focuses SUBJECT and DATE header in header pane and skips FROM and TO! (Although the latter would be far more important/useful to be focusable via keyboard...) Has this been fixed in TB 2?

2) @Wayne: "do we want focus to iterate over each indiv. attachment or just jump to a different pane?"
I would prefer/recommend that when <tab>ing, focus should jump straight from the first attachment to the next pane in the cycle. Although I am aware of the possible advantage/comfort of simply <tab>ing iteratively through attachments, there are good reasons against attachment iteration:

a) if there are many attachments, having to iterate through all of them just to get to the next pane will be very annoying, especially for keyboard users (including disabled), who want to get things done with as few steps as possible. So what might seem comfortable with 2 or 3 attachments will turn out a nuisance if you have to <tab> through 10+ attachments just to get to the next pane! (you can try out the effect with a mail containing a lot of links, when tb 1.5 forces you to iterate through every single link before you can actually <tab> into the attachment pane!)

b) I can't tell for unix or mac, but for Windows users, <tab>ing through a set of individual file objects within a pane will be very unusual - just have a look at the respective behaviour in Windows Explorer or in fact any simple File-Open-Dialog: <tab>ing ALWAYS gets you quickly to the NEXT PANE (or another UI-object within a dialogue), but NEVER iterates through file objects. To iterate, users will find it very normal that when the focus is on the first attachment file object inside the attachment pane, they will have to press cursor keys to move focus to another file attachment. Considering that your attachment pane, esp. in TB 2, looks more and more like a normal file explorer view, users will expect the respective behaviour...

c)Confusion about attachment selection: In case of <tab>-iteration through att/, seeing that <tab>ing focuses AND selects the next attachments, and knowing that within object lists, I can ALWAYS use <shift> to select a sequence of objects, why should I not use <shift+tab> to select subsequent attachments? Oh, you ALWAYS do THAT using <shift+CURSOR>? Yeah, 'cause <cursor> alone ALWAYS selects next (file/attachment etc.) object in the list (whereas <tab> moves me around the screen)... ;-)

What do you think?

BTW: For the same reason, I would not have been surprised that when focus sits on Subject header in header pane, <tab> would get me to the message text pane, whereas cursor keys would get me to the next headers (from, date, to) inside the header pane. But since there are usually only four headers visible (unless view-all-headers is on), the effect is more transparent and less surprising/annoying compared to attachment iteration with <tab>. Furthermore, <tab>ing through ALL headers view makes more sense than cursoring, since cursors might be needed for text/value selection.
(Reporter)

Comment 6

11 years ago
(In reply to comment #5)
"<tab> does NOT iterate through every header in header pane" is being worked on in bug 364376
(Reporter)

Comment 7

10 years ago
Should this be "blocking-thunderbird3?"

Due to this bug, currently (TB2) there is no way at all to access the attachment panel via keyboard. The only way to focus attachment (panel) is using mouse.
In other words, keyboard users and users with disabilities cannot perform ANY action on attachments at all (like opening, saving, deleting, etc.)


Flags: blocking-thunderbird3?
Still a problem in Shredder Alpha 2. Requesting blocking on this one.
Assignee: mscott → nobody

Updated

9 years ago
Blocks: 456814
Flags: blocking-thunderbird3? → blocking-thunderbird3+
Tweaking summary to describe the core problem (tabs may be a way to get there).
Priority: -- → P3
Summary: Attachment panel is not focusable by <tab> (Keyboard accessibility) → Attachment panel is not focusable with the keyboard
Target Milestone: --- → Thunderbird 3.0b3
message reader bugs to dmose for later processing.

Updated

9 years ago
Assignee: nobody → dmose
Component: Mail Window Front End → Message Reader UI
QA Contact: front-end → message-reader

Updated

9 years ago
Target Milestone: Thunderbird 3.0b3 → Thunderbird 3.0rc1
The Thunderbird drivers wish to release Thunderbird 3 as soon as possible. As a result, we feel that this bug shouldn't stand in the way of all the other good work getting into the hands of users sooner rather than later. Therefore we are retargeting it for 3.1. See http://ccgi.standard8.plus.com/blog/archives/242 for more details. The 3.1 release is expected to be a quick release soon after Thunderbird 3.
Flags: blocking-thunderbird3+ → blocking-thunderbird3-
Target Milestone: Thunderbird 3.0rc1 → ---
Flags: blocking-thunderbird3.1+
(Reporter)

Comment 12

8 years ago
Let's make this more actionable by clarifying the needed UI.

Bryan, this is basically the same issue as in bug 473901 (attachment panel not keyboard focusable /when composing/). So can we have ui-review+ for the following changes (adapted from bug 473901 which you already UI-reviewed)? :

-> Add a single <tab> stop and <F6> stop for attachment pane in msg preview and msg standalone window (effective only when it's visible = has attachments)

Note: We should only have a /single/ <tab> stop in attachment pane even if there are multiple attachments, for the following reasons 
- UI consistency, e.g. with OS-wide UI principles: collections/lists of multiple objects or files are more appropriately focused/navigated using cursor keys.
- speed up the <tab> sequence (especially now that we've lost fast-track <ctrl+tab> which is used for switching tabs)

This is a trivial change to ensure attachment pane keyboard accessibility while viewing messages (detailed reasons in bug 473901, comment #5).
Summary: Attachment panel is not focusable with the keyboard → Attachment panel is not focusable with the keyboard ([TAB], [F6])
(Reporter)

Comment 13

8 years ago
CC'ing Bryan for UI review as per comment 12.
See Also: → bug 473901
Removing myself as the assignee, as I'm not actively working on this bug at the moment.

If this were the last bug for tb 3.1, I don't think we'd hold for it.  That said, we'd love to see this make it.  Adding the new, non-versioned wanted-thunderbird+ flag so that we don't lose track of this.
Assignee: dmose → nobody
Flags: blocking-thunderbird3.1+ → wanted-thunderbird+
(Reporter)

Comment 15

8 years ago
Created attachment 432009 [details]
Add tab stop and F6 stop at message reader's attachment pane (consistency with composition stops as ui-reviewd+ in )

to put this into Bryan's ui-review queue
Attachment #432009 - Flags: ui-review?(clarkbw)

Comment 16

8 years ago
Please do not put an F6 stop on the attachment panel.  In the message-reading window, F6 should have exactly three stops: folder pane, thread pane, preview pane.
(Reporter)

Comment 17

8 years ago
Mike, there will still be three stops with what I propose in comment 15 if you don't have any attachments. If you *do* have attachments, I don't see why we shouldn't have an F6 stop there. Four stops still isn't a lot. Tab alone can be problematic, e.g. if there's lot's of links in the mail, you'd have to tab along all of them just to get to attachments pane, which adds a lot of unnecessary complexity to the process.
Could you elaborate on the reasons why you want only three stops for F6 even when there are attachments in the mail?
Comment on attachment 432009 [details]
Add tab stop and F6 stop at message reader's attachment pane (consistency with composition stops as ui-reviewd+ in )

Adding a tab stop sounds like a reasonable plan however I'm minusing because I don't think we want to add the F6 stop as well.  The F6 was meant to give a way to change focus around the main panes (like ctrl-tab did) and that never had access to the attachments previously so I'm not sure it should now.

To move this forward I'd suggest keeping this just to the <tab> stop and opening a new bug for the F6 so we can separate out the discussion.
Attachment #432009 - Attachment description: Add tab stop and F6 stop at message reader's attachment pane (consistency with composition stops as ui-reviewd+ in bug 473901) → Add tab stop and F6 stop at message reader's attachment pane (consistency with composition stops as ui-reviewd+ in )
Attachment #432009 - Flags: ui-review?(clarkbw) → ui-review-
(Reporter)

Updated

8 years ago
Summary: Attachment panel is not focusable with the keyboard ([TAB], [F6]) → Attachment panel is not focusable / accessible with the keyboard (needs [TAB] stop)
Whiteboard: good first bug, has ui-review+ (comment 18), needs followup bug to discuss F6 stop
(Reporter)

Comment 19

8 years ago
Created attachment 445322 [details]
Accessibility: Add *single* [tab] stop at message reader's attachment pane (already ui-reviewed+, seperate bug for F6 stop)

Bryan, as you requested in your ui-review comment 18, I have removed my request for F6 stop from this bug (so that it can be discussed seperately in new bug).

Please set ui-review+ for the remainder - adding the [tab] stop only - which you have already ui-reviewed+ in comment 18. Thanks!
Attachment #432009 - Attachment is obsolete: true
Attachment #445322 - Flags: ui-review?(clarkbw)

Updated

8 years ago
Blocks: 374212
(Reporter)

Updated

8 years ago
Blocks: 579473
(Reporter)

Updated

8 years ago
Depends on: 573230
(Reporter)

Updated

8 years ago
Summary: Attachment panel is not focusable / accessible with the keyboard (needs [TAB] stop) → Attachment panel in message reader is not focusable / accessible with the keyboard (needs [TAB] stop)
Attachment #445322 - Flags: ui-review?(clarkbw) → ui-review+
Blocks: 646171
(Assignee)

Updated

7 years ago
Depends on: 630759
(Assignee)

Comment 20

7 years ago
Created attachment 550944 [details] [diff] [review]
Fix this

This is a relatively simple patch. The treetwisty on the attachment bar is now focusable, and I improved the focusing when you click on it: expanding the attachment pane will put the focus in the attachment list; collapsing it will move focus to the message pane (but only if the attachment list was already focused).

I'm pretty sure the Mac and Linux themes are good here; not sure about Windows, since it's weird. What *should* happen is clicking on the twisty works like before (no focus ring), but tabbing to it should show a focus ring.

Also, pulling forward ui-r+. :)
Assignee: nobody → squibblyflabbetydoo
Status: NEW → ASSIGNED
Attachment #550944 - Flags: ui-review+
Attachment #550944 - Flags: review?(bwinton)
Comment on attachment 550944 [details] [diff] [review]
Fix this

Review of attachment 550944 [details] [diff] [review]:
-----------------------------------------------------------------

Okay, this took me a while to test, but I finally got the try server builds running on my Windows box, and I like the new way it works.

The code seems fine, and while the try-server had some issues (http://arbpl.visophyte.org/?tree=ThunderbirdTry&pushid=888), I don't think those were related to your patch.

So, to sum up, r=me.

Thanks,
Blake.
Attachment #550944 - Flags: review?(bwinton) → review+
(Assignee)

Comment 22

6 years ago
Checked in: http://hg.mozilla.org/comm-central/rev/5be353843ead
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 9.0
(Assignee)

Comment 23

6 years ago
Comment on attachment 550944 [details] [diff] [review]
Fix this

Should we try to get this on aurora? It's an accessibility bug, and it would be nice to have this in the same version as the other accessibility fixes to the attachment pane (specifically, bug 630759).
Attachment #550944 - Flags: approval-comm-aurora?
(Assignee)

Comment 24

6 years ago
Created attachment 554278 [details] [diff] [review]
Don't scroll when hitting space while the twisty is focused

Whoops, of course right after pushing this, I noticed a problem: if the message can be scrolled (or if there are unread messages after the current one), hitting space on the twisty to expand the attachment bar doesn't work. Here's a fix for this. I tried to write a Mozmill test for it, but it didn't seem to want to respond to the space bar at all...
Attachment #554278 - Flags: review?(bwinton)
(Assignee)

Updated

6 years ago
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Comment on attachment 554278 [details] [diff] [review]
Don't scroll when hitting space while the twisty is focused

Review of attachment 554278 [details] [diff] [review]:
-----------------------------------------------------------------

Yep, looks good.  My comment below was more idle curiousity, and doesn't affect the r=me.  :)

Thanks,
Blake.

::: mail/base/content/mailWindowOverlay.js
@@ +2305,2 @@
>      contentWindow = window.content;
> +    if (focusedElement && importantElements.indexOf(focusedElement.id) != -1)

I suspect it doesn't matter at this scale, but if there were a lot of these, I wonder if using "focusedElement.id in importantElements" would be better…
Attachment #554278 - Flags: review?(bwinton) → review+
(Assignee)

Comment 26

6 years ago
Checked in: http://hg.mozilla.org/comm-central/rev/bddcd2fad0df
Status: REOPENED → RESOLVED
Last Resolved: 6 years ago6 years ago
Resolution: --- → FIXED
Comment on attachment 550944 [details] [diff] [review]
Fix this

Given this is an enhancement, I don't think we need/want to rush it into 8, I'd rather let it have the full amount of testing on aurora and beta.
Attachment #550944 - Flags: approval-comm-aurora? → approval-comm-aurora-
(Reporter)

Comment 28

6 years ago
(In reply to Mark Banner (:standard8) from comment #27)
> Comment on attachment 550944 [details] [diff] [review] [diff] [details] [review]
> Fix this
> Given this is an enhancement, I don't think we need/want to rush it into 8,
> I'd rather let it have the full amount of testing on aurora and beta.

Mark, fwiw, I'd think that main UI parts that are inaccessible via keyboard is a major design bug, even though it's so old a bug that one might be inclined to think of it as an enhancement now that it finally has been fixed. For the good of relase notes and PR, I'd much agree with Jim's comment 23:

> Should we try to get this on aurora? It's an accessibility bug, and it would
> be nice to have this in the same version as the other accessibility fixes to
> the attachment pane (specifically, bug 630759).

Just my 2 cents, but if it's avoidable, and assuming this is low-risk, I'd think that it's a bit awkward having to say that we have fixed some, but not all of the accessibility bugs of attachment pane...
Comment on attachment 550944 [details] [diff] [review]
Fix this

I've had a discussion with bwinton and he's convinced me we should take this.
Attachment #550944 - Flags: approval-comm-aurora- → approval-comm-aurora+
Attachment #554278 - Flags: approval-comm-aurora+
Checked in both patches on aurora:

http://hg.mozilla.org/releases/comm-aurora/rev/61e68359839b
http://hg.mozilla.org/releases/comm-aurora/rev/69f72be98a48
status-thunderbird8: --- → fixed
(Reporter)

Comment 31

6 years ago
Mark and Blake, thank you!
status-thunderbird8: fixed → ---
Target Milestone: Thunderbird 9.0 → ---
(Reporter)

Comment 32

6 years ago
...and Jim, thank you!
(Reporter)

Comment 33

6 years ago
(In reply to Thomas D. from comment #31)
Weird, I didn't even touch the flags, why did they change?
Target Milestone is now 8, where this was checked in, right?
status-thunderbird8: --- → fixed
Target Milestone: --- → Thunderbird 8.0
Nope, milestone is 9 because that's where this landed on trunk (and the status-thunderbird8 indicates the fixed status for 8).
Target Milestone: Thunderbird 8.0 → Thunderbird 9.0
(Assignee)

Updated

6 years ago
Depends on: 695980
(Reporter)

Updated

6 years ago
Whiteboard: good first bug, has ui-review+ (comment 18), needs followup bug to discuss F6 stop → needs followup bug to discuss F6 stop
(Reporter)

Updated

6 years ago
Blocks: 713979
You need to log in before you can comment on or make changes to this bug.