clipboard items in context menus don't function (focus loss)

VERIFIED FIXED

Status

()

P1
critical
VERIFIED FIXED
19 years ago
17 years ago

People

(Reporter: rubydoo123, Assigned: saari)

Tracking

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
In any edit mode, the context menu slection does not perform the desired 
action/function. Using build 2000051508
(Reporter)

Updated

19 years ago
Keywords: nsbeta2
Priority: P3 → P1
Target Milestone: --- → M16

Comment 1

19 years ago
The Context menu produces the following Javascript errors:
XUL/Content JavaScript Error: chrome://navigator/content/nsContextMenu.js line
169, column 0: this.target has no properties Source line:
XUL/Content JavaScript: Javascript Error: line 0, column 0: contextMenu has no
properties Source line:
XUL/Content JavaScript: JavaScript Error: line 0, column 0: contextMenu has no
properties Source line:

Note: I couldn't cut and paste out of the JavaScript debug window, so all typos
are mine...

Build 2000051609
(Reporter)

Comment 2

19 years ago
added 'options' to the Summary to better reflect the actual issue
Summary: Context menus are not functional → Context menus options are not functional
(Reporter)

Comment 3

19 years ago
*** Bug 40161 has been marked as a duplicate of this bug. ***

Comment 4

19 years ago
Putting on [nsbeta2+][6/01] radar.  This work must be done by 06/01 or we may 
pull this for PR2.
Whiteboard: [nsbeta2+][6/01]
(Reporter)

Comment 5

19 years ago
*** Bug 40431 has been marked as a duplicate of this bug. ***

Comment 6

19 years ago
Changing from [6/01] to [6/15]
Whiteboard: [nsbeta2+][6/01] → [nsbeta2+][6/15]
(Reporter)

Comment 7

19 years ago
*** Bug 39765 has been marked as a duplicate of this bug. ***

Comment 8

19 years ago
cc mjudge and saari

I'm guessing it's some kind of focus problem since it works most of the time on 
Mac and almost never on Windows or Linux.  Maybe the context menu is stealing 
focus so the editor doesn't have a selection?

fyi--we need to focus on getting undo/redo/cut/copy/paste working

Comment 9

19 years ago
Using Yesterday's nightly (2000060820) Only the correct options appear on the
navigator context menu, and they seem to (after admittedly very minimal 
testing) work. When I first encountered the bug, all possible options were 
displayed in the context menu, and none of them worked. (This was all under 
Windows 98)

The JavaScript errors that this was producing don't appear anymore either.
I can't speak for Linux or the Mac builds.
(Assignee)

Comment 10

19 years ago
I'm glad that this seems to be working, but yes, context menus do seem to be 
stealing focus when selecting an item. I've been working on related things this 
week, so I'll just take this bug. I have it in a different bug anyway.
Assignee: brade → saari

Comment 11

19 years ago
Cleaning up status whiteboard by marking beta2 minus (6/15 has passed)

If this is really working... let's mark it fixed, and get it verified.
Whiteboard: [nsbeta2+][6/15] → [nsbeta2-]

Comment 12

19 years ago
M16 has been out for a while now, these bugs target milestones need to be 
updated.

Comment 13

19 years ago
is this just referring to Select All and the clipboard operations?  Other
choices seem to work.  Ugly, and wrong, but these are tertiary ways of invoking
these commands, I think we could ship with this bug.
(Assignee)

Comment 14

19 years ago
Select all not working is distrubing because it is platform specific (works on 
some platforms)
Status: NEW → ASSIGNED
(Assignee)

Comment 15

19 years ago
futuring, but I suspect fixing the context menu focus stealing will fix this bug 
as well
Target Milestone: M16 → Future

Comment 16

19 years ago
*** Bug 40162 has been marked as a duplicate of this bug. ***

Comment 17

19 years ago
*** Bug 45909 has been marked as a duplicate of this bug. ***

Comment 18

19 years ago
request nsbeta3 fix for this bug; this hurts Linux and Windows users of context 
menus (esp. in edit fields, mailcompose, and composer)
Keywords: nsbeta2 → nsbeta3
Summary: Context menus options are not functional → clipboard items in context menus don't function (focus loss)
Whiteboard: [nsbeta2-]
Target Milestone: Future → ---

Updated

19 years ago
Blocks: 44310
*** Bug 39629 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 20

18 years ago
Fixed
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Comment 21

18 years ago
Going to File-->Edit Page, right-clicking the page, and choosing Select All
produces the desired result on Windows 98 OG (original), build 9/28/08

verifying
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.