The default bug view has changed. See this FAQ.

Subscribe dialog should support "new" newsgroups

RESOLVED FIXED in Future

Status

SeaMonkey
MailNews: Message Display
P3
normal
RESOLVED FIXED
17 years ago
9 years ago

People

(Reporter: Henrik Gemal, Assigned: Markus Hossner)

Tracking

(Blocks: 1 bug)

Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment, 2 obsolete attachments)

65.13 KB, patch
neil@parkwaycc.co.uk
: review+
Bienvenu
: superreview+
Details | Diff | Splinter Review
(Reporter)

Description

17 years ago
The subscribe dialog should support "new" newsgroup like both Communicator and 
Outlook Express does.
The subscribe dialog should have 3 tabs:
[ All ] [ Search ] [ New ]

Comment 1

17 years ago
"New" newsgroups was decided as low priority for this release --  it is
currently listed as a P4 item on our spec, which means it is not likely to show
up in seamonkey.
QA Contact: lchiang → huang
laurel is right.

the "new" view isn't going to happen for this release.
Status: NEW → ASSIGNED
Target Milestone: --- → Future
moving to m30, instead of future.
Target Milestone: Future → M30

Comment 4

17 years ago
moving to future milestone.
Target Milestone: M30 → Future

Comment 5

17 years ago
mass change of huang's news bugs to stephend.
QA Contact: huang → stephend

Updated

17 years ago
OS: Windows 2000 → All
Hardware: PC → All

Comment 6

16 years ago
Adding 4xp keyword, since this is in Messenger 4 (verified with 4.7)
Adding [RFE] to summary
Keywords: 4xp
Summary: Subscribe dialog should support "new" newsgroups → [RFE] Subscribe dialog should support "new" newsgroups
Summary: [RFE] Subscribe dialog should support "new" newsgroups → Subscribe dialog should support "new" newsgroups
Depends on: 76552
(Reporter)

Comment 7

15 years ago
*** Bug 102804 has been marked as a duplicate of this bug. ***
Blocks: 176238
Product: Browser → Seamonkey

Updated

12 years ago
Assignee: sspitzer → mail
Status: ASSIGNED → NEW

Comment 8

10 years ago
Bug 102804 was reopened. It's not a duplicate of this bug.

Updated

10 years ago
Blocks: 377250
(Assignee)

Comment 9

10 years ago
Created attachment 275349 [details] [diff] [review]
Patch

The patch adds a new groups tab to the subscribe dialog and does some really needed cleanup (whitespaces, ...) to insert the changes properly in the surrounding code.
Attachment #275349 - Flags: superreview?(bienvenu)
Attachment #275349 - Flags: review?(neil)
(Assignee)

Comment 10

10 years ago
Created attachment 275352 [details] [diff] [review]
Patch (without whitespace changes)

The same patch but without the whitespace changes to see the really changes.
(Assignee)

Updated

10 years ago
Attachment #275352 - Attachment is patch: true
Attachment #275352 - Attachment mime type: application/octet-stream → text/plain

Updated

10 years ago
Assignee: mail → markushossner
QA Contact: stephend → mail

Comment 11

10 years ago
neat! I'll try to run with this when I can.

Comment 12

10 years ago
Comment on attachment 275349 [details] [diff] [review]
Patch

Although this "works" I found it really awkward to use - it did show me some "new" groups once but then never again. Assuming you have to do a refresh to find new groups then I suggest a button "Find New" (which would change to "Show All") as it would be clearer that this does something other than just switch views. (Even if you can somehow display only new groups without refreshing every time then I think I would still prefer a checkbox.)
Attachment #275349 - Flags: review?(neil) → review+

Comment 13

10 years ago
Comment on attachment 275349 [details] [diff] [review]
Patch

thx for adding the license blocks, and thx for the patch.
Attachment #275349 - Flags: superreview?(bienvenu) → superreview+

Comment 14

10 years ago
Comment on attachment 275349 [details] [diff] [review]
Patch

Markus and I found some issues with the hostinfo.dat update behaviour in this patch. So, please, everyone, don't check that in! We're on it...
(Assignee)

Comment 15

10 years ago
Created attachment 275697 [details] [diff] [review]
Patch 2

What Neil has discovered (see comment #12) was a bug and not a feature. New groups should be displayed until a new refresh of the current list is made.

To do so now the hostinfo.dat (with the current date) is only written if there is a complete new downloaded list:

+  if (!mGetOnlyNew && !mHostInfoLoaded)
+  {
+    rv = WriteHostInfoFile();
+    NS_ENSURE_SUCCESS(rv,rv);
+  }
Attachment #275349 - Attachment is obsolete: true
Attachment #275697 - Flags: superreview?(bienvenu)
Attachment #275697 - Flags: review?(neil)

Updated

10 years ago
Attachment #275352 - Attachment is obsolete: true

Updated

10 years ago
Attachment #275697 - Flags: superreview?(bienvenu) → superreview+

Comment 16

10 years ago
Comment on attachment 275697 [details] [diff] [review]
Patch 2

I still don't like the UI for this though.
Attachment #275697 - Flags: review?(neil) → review+

Comment 17

10 years ago
Landed on trunk.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED

Comment 18

10 years ago
Can we please get an l10n comment for
<!ENTITY currentListTab.accesskey     "L">

It may not be immediately obvious to a localizer that the chosen letter here must match two different strings in another file.

Comment 19

10 years ago
Actually, that's a bug. Hasse, please file a new bug for that, blocking this one.

Updated

10 years ago
Depends on: 392720

Comment 20

10 years ago
Thanks much for this "feature" seems to work fine in:
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a8pre) Gecko/2007081804 Thunderbird/3.0a1pre ID:2007081804
One thing though, what ever happened to the message count column in the subscribe dialog. The only way you can see "activity" for a newsgroup is to subscrbe to it.
Or am I missing a hidden pref.

Comment 21

10 years ago
> One thing though, what ever happened to the message count column in the
> subscribe dialog.

It has never been implemented yet, see bug 38906.

Comment 22

10 years ago
Was there a reason to make it a new tab, instead of a button (like comment #12 suggests) or similar?

Comment 23

10 years ago
> Was there a reason to make it a new tab, instead of a button 
> (like comment #12 suggests) or similar?

Sure: a button would just be awkward. 
And NS4 had a tab, too. ;-)

Markus and I talked about the alternatives before (tab, stateful aka radio button, checkbox) and different tabs are just more clear.
They avoid the "why don't I see any groups on my server?" problem best, imo.

Comment 24

10 years ago
Maybe I'm just not getting what the "New" tab is supposed to show, but currently it seems to show all groups, just like the "Current Group List" tab. Is that intended or should it just show "newly added" groups (which would at least make some sense). This was for news.mozilla.org

Not that the whole Subscribe dialog is all that intuitive... The Subscribe/Unsubscribe buttons seem superfluous as we have the checkboxes + ok, and the Refresh button obviously doesn't fetch "new" groups from the server, so I have no idea what it actually does. 

Comment 25

10 years ago
> Maybe I'm just not getting what the "New" tab is supposed to show, but
> currently it seems to show all groups, just like the "Current Group List" tab.
> Is that intended or should it just show "newly added" groups (which would at
> least make some sense). This was for news.mozilla.org

The list should show all groups added since you last did a refresh of your group list. That date is stored in the "lastgroupdate" line of your server's hostinfo.dat file. 
(We probably should show that date in the UI, I'll file a new bug for that.)

Try hitting 'refresh' on the list tab, your "lastgroupdate" line may be invalid.

Comment 26

10 years ago
> (We probably should show that date in the UI, I'll file a new bug for that.)

That's already part of bug 339981.

Updated

9 years ago
Component: MailNews: Subscribe → MailNews: Message Display
QA Contact: mail → search
You need to log in before you can comment on or make changes to this bug.