If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

M3 Windows icons

RESOLVED FIXED in Firefox 3 beta4

Status

()

Firefox
Theme
P1
normal
RESOLVED FIXED
10 years ago
7 years ago

People

(Reporter: u88484, Assigned: reed)

Tracking

({polish})

Trunk
Firefox 3 beta4
x86
Windows XP
polish
Points:
---
Dependency tree / graph
Bug Flags:
blocking-firefox3 +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(9 attachments, 5 obsolete attachments)

(Reporter)

Description

10 years ago
The large icons landed but what about the small icons?  Need consistency and not have two different sets and styles for large/small icons.
Flags: blocking-firefox3?
They are going to land in the next drop of icons, but not before beta 3.
(Assignee)

Updated

10 years ago
Duplicate of this bug: 414840

Comment 3

10 years ago
fixed ?

https://bugzilla.mozilla.org/show_bug.cgi?id=413806#c26


BTW, Blocks shoud be 413806 ?
(Reporter)

Comment 4

10 years ago
(In reply to comment #3)
> fixed ?
> 
> https://bugzilla.mozilla.org/show_bug.cgi?id=413806#c26
> 
> 
> BTW, Blocks shoud be 413806 ?
> 

Nope, it only changed the home button.  The rest will be after beta 3
Blocks: 413806
No longer blocks: 411725

Updated

10 years ago
Blocks: 405605
No longer blocks: 413806
Assignee: nobody → faaborg
Flags: blocking-firefox3? → blocking-firefox3+
Target Milestone: --- → Firefox 3
Summary: Need small icons for the new theme → Land next revision of M2 Windows Icons
Adapting this bug to cover all of the revised windows icons coming in, which includes the small icons for the toolbar.

Comment 6

10 years ago
Alex: Will this bug also cover the Chrome overriding required to display Vista Icons on Vista OS (and XP Icons on XP)? Or should we file a separate bug for that?
That should be a different bug, I filed bug 416531

Updated

10 years ago
Duplicate of this bug: 416565
Created attachment 303735 [details]
New Luna toolbar icons (checked in)

Please land asap.
Created attachment 303736 [details]
New areo toolbar icons (checked in)

please land asap
Reed: please check in these two new toolbar files as soon as you can.
Keywords: checkin-needed
(Assignee)

Updated

10 years ago
Component: Toolbars → Theme
QA Contact: toolbars → theme
Summary: Land next revision of M2 Windows Icons → M3 Windows icons
Target Milestone: Firefox 3 → Firefox 3 beta4
(Assignee)

Comment 12

10 years ago
Checking in browser/themes/winstripe/browser/Toolbar-aero.png;
/cvsroot/mozilla/browser/themes/winstripe/browser/Toolbar-aero.png,v  <--  Toolbar-aero.png
new revision: 1.2; previous revision: 1.1
done
Checking in browser/themes/winstripe/browser/Toolbar.png;
/cvsroot/mozilla/browser/themes/winstripe/browser/Toolbar.png,v  <--  Toolbar.png
new revision: 1.8; previous revision: 1.7
done
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
(Assignee)

Updated

10 years ago
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Updated

10 years ago
Status: REOPENED → ASSIGNED
Attachment #303735 - Attachment description: New Luna toolbar icons → New Luna toolbar icons (checked in)
Attachment #303736 - Attachment description: New areo toolbar icons → New areo toolbar icons (checked in)

Comment 13

10 years ago
The new Downloads icon is a pixel lower in the hover state than in the enabled state - is this intended?

Comment 14

10 years ago
I noticed that the new unhovered look of the keyhole icons don't have the jaggies anymore, but on hover state it still does. Are there any plans to change this?
>The new Downloads icon is a pixel lower in the hover state than in the enabled
>state - is this intended?

no, we will need to fix that.

>I noticed that the new unhovered look of the keyhole icons don't have the
>jaggies anymore, but on hover state it still does. Are there any plans to
>change this?

We landed the new normal state quickly to get it in, the other states will be fixed in the next update to the file.
Depends on: 419311
Target Milestone: Firefox 3 beta4 → Firefox 3
(Assignee)

Updated

10 years ago
Priority: -- → P3
Target Milestone: Firefox 3 → Firefox 3 beta4
Priority: P3 → P1
Attachment #303735 - Attachment is obsolete: true
Attachment #303736 - Attachment is obsolete: true
(Assignee)

Updated

10 years ago
Blocks: 419760
Alex is almost done with a large, omnibus set of png changes for this, which he'll point to as a zip file. They have my blanket approval for landing in beta 4.
Here is the file, this includes all updated windows icons in both the luna and aero style: http://people.mozilla.com/~faaborg/files/granParadisoUI/icons/windowsBeta4Icons.zip

few, 11 minutes before freeze... please land at your earliest convenience :)
Keywords: checkin-needed
(Assignee)

Comment 18

10 years ago
(In reply to comment #17)
> Here is the file, this includes all updated windows icons in both the luna and
> aero style:
> http://people.mozilla.com/~faaborg/files/granParadisoUI/icons/windowsBeta4Icons.zip

So, things are really weird in that zip... weird file names, strange new files, different orientation of things, etc. I'm going to wait until I speak to you about some of this first before landing this. If we need to clobber during the middle of the day for the new icons, we can do that.
Are you talking about the .DS_Store and other no-extension filenames? Those are OSX hidden files which get automagically added to the ZIP when using OSX. Safe to ignore them. If you'd like me to provide a ZIP version without them I would be happy to oblige.
Also, the CSS changes required for the toolbars are in bug 419760
Reed: I'll be in the office pretty soon to correct any problems with the zip, sorry about the .DS_Store files.

>strange new files, different orientation of things

There are a few cases where I am landing new files that I want us to transition to after these land (go button, secure, secure broken, livemark folder, livemark item).  The idea was that after we transition to the simpler files, we can remove the old ones from trunk, like the 2 livemark item icons that collectively contain 16 Web feed icons for no reason:

http://mxr.mozilla.org/seamonkey/source/browser/themes/winstripe/browser/livemark-item.png
http://mxr.mozilla.org/seamonkey/source/browser/themes/winstripe/browser/livemark-item-rtl.png
It would be good if we could, in addition to for Reed's edification, also list those planned changes here FTR so we can file the appropriate spinoff bugs.

I think one of Reed and Gavin's concerns was, though, that some files required by the manifests were missing.
(Assignee)

Comment 23

10 years ago
(In reply to comment #21)
> Reed: I'll be in the office pretty soon to correct any problems with the zip,
> sorry about the .DS_Store files.

.DS_Store files aren't a problem at all. I ignore them.

> >strange new files, different orientation of things
> 
> There are a few cases where I am landing new files that I want us to transition
> to after these land (go button, secure, secure broken, livemark folder,
> livemark item).  The idea was that after we transition to the simpler files, we
> can remove the old ones from trunk, like the 2 livemark item icons that
> collectively contain 16 Web feed icons for no reason:
> 
> http://mxr.mozilla.org/seamonkey/source/browser/themes/winstripe/browser/livemark-item.png
> http://mxr.mozilla.org/seamonkey/source/browser/themes/winstripe/browser/livemark-item-rtl.png

Ah ha! See, that's what I needed and was mostly getting confused by...
(Assignee)

Comment 24

10 years ago
So, if we're ready to transition to them now, we should do the CSS changes and do them now, so as to keep the same names for all themes. It gets very confusing when different file names are used for the same thing across the themes.
And if we're doing that, we should keep in mind the chrome override work in bug 416531
(Assignee)

Updated

10 years ago
Depends on: 416531
Ok, I'm going to put together a list of files that we would like to have css for, and I'll post it momentarily. This will allow us to keep all of the existing file names.
The following files will require CSS changes:

--------------------------
Go-arrow.png
Go-arrow-rtl.png

Top row is normal, bottom row is hover.
--------------------------
livemark-folder.png
now only one state
--------------------------
livemark-item.png
now only one state
--------------------------
Security-broken.png
now only one state
--------------------------
blacklist_large.png (in mozilla/ toolkit/ themes/ winstripe/ global/ icons/ )
larger image, now 64x64.  I let johnath know and he said it wouldn't be a problem, but including in the list since it is different from the image it is replacing.
--------------------------

The following files should no longer exist:

page-livemarks.png (instead use feeds/feedIcon16.png)
page-livemarks-aero.png (instead use feeds/feedIcon16-aero.png)

livemark-folder-rtl.png (use livemark-folder.png for RTL)
livemark-item-rtl.png (use livemark-item.png for RTL)
Here is an updated zip of the Windows icons for beta 4: http://people.mozilla.com/~faaborg/files/granParadisoUI/icons/windowsBeta4Icons_i2.zip
(Assignee)

Comment 29

10 years ago
Created attachment 306453 [details] [diff] [review]
wip

Go-arrow stuff is most likely wrong.

/browser/components/feeds/content/subscribe.xhtml,

    * line 46 -- ><xul:menuitem id="liveBookmarksMenuItem" label="&feedLiveBookmarks;" class="menuitem-iconic" image="chrome://browser/skin/page-livemarks.png" selected="true"

need to figure out what to do about that page-livemarks.png...
(Assignee)

Comment 30

10 years ago
Just for the record, landing all this is blocked by bug 416531 / bug 419319.
(Assignee)

Comment 31

10 years ago
Created attachment 306633 [details] [diff] [review]
patch - v1

We're going to duplicate the feed icon to make life easier.

go-arrow changes contributed by Ryan.
Attachment #306453 - Attachment is obsolete: true
Attachment #306633 - Flags: review?(rflint)
(Assignee)

Comment 32

10 years ago
Created attachment 306637 [details] [diff] [review]
patch - v1.1

I had this right the first time. Ryan confused me. :(
Attachment #306633 - Attachment is obsolete: true
Attachment #306637 - Flags: review?(rflint)
Attachment #306633 - Flags: review?(rflint)
Comment on attachment 306637 [details] [diff] [review]
patch - v1.1

Lies!
Attachment #306637 - Flags: review?(rflint) → review+
Comment on attachment 306637 [details] [diff] [review]
patch - v1.1

a1.9b4=beltzner, needs to land with bug 414389
Attachment #306637 - Flags: approval1.9b4+
er, uh, with bug 19760 ;)
(Assignee)

Comment 36

10 years ago
Created attachment 306652 [details] [diff] [review]
patch - v2

More changes I noticed as I was preparing to land.
Attachment #306637 - Attachment is obsolete: true
Attachment #306652 - Flags: review?(gavin.sharp)
Attachment #306652 - Flags: review?(gavin.sharp) → review+
Comment on attachment 306652 [details] [diff] [review]
patch - v2

>Index: browser/themes/winstripe/browser/browser.css

> .bookmark-item[container][livemark] { 
>   list-style-image: url("chrome://browser/skin/livemark-folder.png");

Need -moz-image-region: auto; here.
(Assignee)

Comment 38

10 years ago
RCS file: /cvsroot/mozilla/browser/themes/winstripe/browser/Go-arrow-aero.png,v
done
Checking in browser/themes/winstripe/browser/Go-arrow-aero.png;
/cvsroot/mozilla/browser/themes/winstripe/browser/Go-arrow-aero.png,v  <--  Go-arrow-aero.png
initial revision: 1.1
done
RCS file: /cvsroot/mozilla/browser/themes/winstripe/browser/Go-arrow-rtl-aero.png,v
done
Checking in browser/themes/winstripe/browser/Go-arrow-rtl-aero.png;
/cvsroot/mozilla/browser/themes/winstripe/browser/Go-arrow-rtl-aero.png,v  <--  Go-arrow-rtl-aero.png
initial revision: 1.1
done
Checking in browser/themes/winstripe/browser/Go-arrow-rtl.png;
/cvsroot/mozilla/browser/themes/winstripe/browser/Go-arrow-rtl.png,v  <--  Go-arrow-rtl.png
new revision: 1.4; previous revision: 1.3
done
Checking in browser/themes/winstripe/browser/Go-arrow.png;
/cvsroot/mozilla/browser/themes/winstripe/browser/Go-arrow.png,v  <--  Go-arrow.png
new revision: 1.4; previous revision: 1.3
done
RCS file: /cvsroot/mozilla/browser/themes/winstripe/browser/Secure-aero.png,v
done
Checking in browser/themes/winstripe/browser/Secure-aero.png;
/cvsroot/mozilla/browser/themes/winstripe/browser/Secure-aero.png,v  <--  Secure-aero.png
initial revision: 1.1
done
Checking in browser/themes/winstripe/browser/Secure.png;
/cvsroot/mozilla/browser/themes/winstripe/browser/Secure.png,v  <--  Secure.png
new revision: 1.5; previous revision: 1.4
done
RCS file: /cvsroot/mozilla/browser/themes/winstripe/browser/Secure24-aero.png,v
done
Checking in browser/themes/winstripe/browser/Secure24-aero.png;
/cvsroot/mozilla/browser/themes/winstripe/browser/Secure24-aero.png,v  <--  Secure24-aero.png
initial revision: 1.1
done
RCS file: /cvsroot/mozilla/browser/themes/winstripe/browser/Secure24.png,v
done
Checking in browser/themes/winstripe/browser/Secure24.png;
/cvsroot/mozilla/browser/themes/winstripe/browser/Secure24.png,v  <--  Secure24.png
initial revision: 1.1
done
RCS file: /cvsroot/mozilla/browser/themes/winstripe/browser/Security-broken-aero.png,v
done
Checking in browser/themes/winstripe/browser/Security-broken-aero.png;
/cvsroot/mozilla/browser/themes/winstripe/browser/Security-broken-aero.png,v  <--  Security-broken-aero.png
initial revision: 1.1
done
Checking in browser/themes/winstripe/browser/Security-broken.png;
/cvsroot/mozilla/browser/themes/winstripe/browser/Security-broken.png,v  <--  Security-broken.png
new revision: 1.5; previous revision: 1.4
done
Checking in browser/themes/winstripe/browser/Toolbar-aero.png;
/cvsroot/mozilla/browser/themes/winstripe/browser/Toolbar-aero.png,v  <--  Toolbar-aero.png
new revision: 1.3; previous revision: 1.2
done
RCS file: /cvsroot/mozilla/browser/themes/winstripe/browser/Toolbar-small-aero.png,v
done
Checking in browser/themes/winstripe/browser/Toolbar-small-aero.png;
/cvsroot/mozilla/browser/themes/winstripe/browser/Toolbar-small-aero.png,v  <--  Toolbar-small-aero.png
initial revision: 1.1
done
Checking in browser/themes/winstripe/browser/Toolbar-small.png;
/cvsroot/mozilla/browser/themes/winstripe/browser/Toolbar-small.png,v  <--  Toolbar-small.png
new revision: 1.8; previous revision: 1.7
done
Checking in browser/themes/winstripe/browser/Toolbar.png;
/cvsroot/mozilla/browser/themes/winstripe/browser/Toolbar.png,v  <--  Toolbar.png
new revision: 1.9; previous revision: 1.8
done
Checking in browser/themes/winstripe/browser/identity-aero.png;
/cvsroot/mozilla/browser/themes/winstripe/browser/identity-aero.png,v  <--  identity-aero.png
new revision: 1.2; previous revision: 1.1
done
Checking in browser/themes/winstripe/browser/identity.png;
/cvsroot/mozilla/browser/themes/winstripe/browser/identity.png,v  <--  identity.png
new revision: 1.3; previous revision: 1.2
done
Checking in browser/themes/winstripe/browser/jar.mn;
/cvsroot/mozilla/browser/themes/winstripe/browser/jar.mn,v  <--  jar.mn
new revision: 1.74; previous revision: 1.73
done
RCS file: /cvsroot/mozilla/browser/themes/winstripe/browser/livemark-folder-aero.png,v
done
Checking in browser/themes/winstripe/browser/livemark-folder-aero.png;
/cvsroot/mozilla/browser/themes/winstripe/browser/livemark-folder-aero.png,v  <--  livemark-folder-aero.png
initial revision: 1.1
done
Removing browser/themes/winstripe/browser/livemark-folder-rtl.png;
/cvsroot/mozilla/browser/themes/winstripe/browser/livemark-folder-rtl.png,v  <--  livemark-folder-rtl.png
new revision: delete; previous revision: 1.2
done
Checking in browser/themes/winstripe/browser/livemark-folder.png;
/cvsroot/mozilla/browser/themes/winstripe/browser/livemark-folder.png,v  <--  livemark-folder.png
new revision: 1.3; previous revision: 1.2
done
RCS file: /cvsroot/mozilla/browser/themes/winstripe/browser/livemark-item-aero.png,v
done
Checking in browser/themes/winstripe/browser/livemark-item-aero.png;
/cvsroot/mozilla/browser/themes/winstripe/browser/livemark-item-aero.png,v  <--  livemark-item-aero.png
initial revision: 1.1
done
Removing browser/themes/winstripe/browser/livemark-item-rtl.png;
/cvsroot/mozilla/browser/themes/winstripe/browser/livemark-item-rtl.png,v  <--  livemark-item-rtl.png
new revision: delete; previous revision: 1.3
done
Checking in browser/themes/winstripe/browser/livemark-item.png;
/cvsroot/mozilla/browser/themes/winstripe/browser/livemark-item.png,v  <--  livemark-item.png
new revision: 1.4; previous revision: 1.3
done
RCS file: /cvsroot/mozilla/browser/themes/winstripe/browser/menu-back-aero.png,v
done
Checking in browser/themes/winstripe/browser/menu-back-aero.png;
/cvsroot/mozilla/browser/themes/winstripe/browser/menu-back-aero.png,v  <--  menu-back-aero.png
initial revision: 1.1
done
RCS file: /cvsroot/mozilla/browser/themes/winstripe/browser/menu-back.png,v
done
Checking in browser/themes/winstripe/browser/menu-back.png;
/cvsroot/mozilla/browser/themes/winstripe/browser/menu-back.png,v  <--  menu-back.png
initial revision: 1.1
done
RCS file: /cvsroot/mozilla/browser/themes/winstripe/browser/menu-forward-aero.png,v
done
Checking in browser/themes/winstripe/browser/menu-forward-aero.png;
/cvsroot/mozilla/browser/themes/winstripe/browser/menu-forward-aero.png,v  <--  menu-forward-aero.png
initial revision: 1.1
done
RCS file: /cvsroot/mozilla/browser/themes/winstripe/browser/menu-forward.png,v
done
Checking in browser/themes/winstripe/browser/menu-forward.png;
/cvsroot/mozilla/browser/themes/winstripe/browser/menu-forward.png,v  <--  menu-forward.png
initial revision: 1.1
done
Removing browser/themes/winstripe/browser/page-livemarks-aero.png;
/cvsroot/mozilla/browser/themes/winstripe/browser/page-livemarks-aero.png,v  <--  page-livemarks-aero.png
new revision: delete; previous revision: 1.1
done
Removing browser/themes/winstripe/browser/page-livemarks.png;
/cvsroot/mozilla/browser/themes/winstripe/browser/page-livemarks.png,v  <--  page-livemarks.png
new revision: delete; previous revision: 1.4
done
Checking in browser/themes/winstripe/browser/feeds/feedIcon16-aero.png;
/cvsroot/mozilla/browser/themes/winstripe/browser/feeds/feedIcon16-aero.png,v  <--  feedIcon16-aero.png
new revision: 1.2; previous revision: 1.1
done
Checking in browser/themes/winstripe/browser/feeds/feedIcon16.png;
/cvsroot/mozilla/browser/themes/winstripe/browser/feeds/feedIcon16.png,v  <--  feedIcon16.png
new revision: 1.4; previous revision: 1.3
done
RCS file: /cvsroot/mozilla/browser/themes/winstripe/browser/places/collapse-aero.png,v
done
Checking in browser/themes/winstripe/browser/places/collapse-aero.png;
/cvsroot/mozilla/browser/themes/winstripe/browser/places/collapse-aero.png,v  <--  collapse-aero.png
initial revision: 1.1
done
RCS file: /cvsroot/mozilla/browser/themes/winstripe/browser/places/collapse.png,v
done
Checking in browser/themes/winstripe/browser/places/collapse.png;
/cvsroot/mozilla/browser/themes/winstripe/browser/places/collapse.png,v  <--  collapse.png
initial revision: 1.1
done
RCS file: /cvsroot/mozilla/browser/themes/winstripe/browser/places/expand-aero.png,v
done
Checking in browser/themes/winstripe/browser/places/expand-aero.png;
/cvsroot/mozilla/browser/themes/winstripe/browser/places/expand-aero.png,v  <--  expand-aero.png
initial revision: 1.1
done
RCS file: /cvsroot/mozilla/browser/themes/winstripe/browser/places/expand.png,v
done
Checking in browser/themes/winstripe/browser/places/expand.png;
/cvsroot/mozilla/browser/themes/winstripe/browser/places/expand.png,v  <--  expand.png
initial revision: 1.1
done
RCS file: /cvsroot/mozilla/browser/themes/winstripe/browser/places/history-aero.png,v
done
Checking in browser/themes/winstripe/browser/places/history-aero.png;
/cvsroot/mozilla/browser/themes/winstripe/browser/places/history-aero.png,v  <--  history-aero.png
initial revision: 1.1
done
RCS file: /cvsroot/mozilla/browser/themes/winstripe/browser/places/history.png,v
done
Checking in browser/themes/winstripe/browser/places/history.png;
/cvsroot/mozilla/browser/themes/winstripe/browser/places/history.png,v  <--  history.png
initial revision: 1.1
done
RCS file: /cvsroot/mozilla/browser/themes/winstripe/browser/places/importAndBackup-aero.png,v
done
Checking in browser/themes/winstripe/browser/places/importAndBackup-aero.png;
/cvsroot/mozilla/browser/themes/winstripe/browser/places/importAndBackup-aero.png,v  <--  importAndBackup-aero.png
initial revision: 1.1
done
RCS file: /cvsroot/mozilla/browser/themes/winstripe/browser/places/importAndBackup.png,v
done
Checking in browser/themes/winstripe/browser/places/importAndBackup.png;
/cvsroot/mozilla/browser/themes/winstripe/browser/places/importAndBackup.png,v  <--  importAndBackup.png
initial revision: 1.1
done
RCS file: /cvsroot/mozilla/browser/themes/winstripe/browser/places/minus-aero.png,v
done
Checking in browser/themes/winstripe/browser/places/minus-aero.png;
/cvsroot/mozilla/browser/themes/winstripe/browser/places/minus-aero.png,v  <--  minus-aero.png
initial revision: 1.1
done
RCS file: /cvsroot/mozilla/browser/themes/winstripe/browser/places/minus.png,v
done
Checking in browser/themes/winstripe/browser/places/minus.png;
/cvsroot/mozilla/browser/themes/winstripe/browser/places/minus.png,v  <--  minus.png
initial revision: 1.1
done
Checking in browser/themes/winstripe/browser/places/pageStarred-aero.png;
/cvsroot/mozilla/browser/themes/winstripe/browser/places/pageStarred-aero.png,v  <--  pageStarred-aero.png
new revision: 1.2; previous revision: 1.1
done
Checking in browser/themes/winstripe/browser/places/pageStarred.png;
/cvsroot/mozilla/browser/themes/winstripe/browser/places/pageStarred.png,v  <--  pageStarred.png
new revision: 1.3; previous revision: 1.2
done
RCS file: /cvsroot/mozilla/browser/themes/winstripe/browser/places/plus-aero.png,v
done
Checking in browser/themes/winstripe/browser/places/plus-aero.png;
/cvsroot/mozilla/browser/themes/winstripe/browser/places/plus-aero.png,v  <--  plus-aero.png
initial revision: 1.1
done
RCS file: /cvsroot/mozilla/browser/themes/winstripe/browser/places/plus.png,v
done
Checking in browser/themes/winstripe/browser/places/plus.png;
/cvsroot/mozilla/browser/themes/winstripe/browser/places/plus.png,v  <--  plus.png
initial revision: 1.1
done
Checking in browser/themes/winstripe/browser/places/starPage-aero.png;
/cvsroot/mozilla/browser/themes/winstripe/browser/places/starPage-aero.png,v  <--  starPage-aero.png
new revision: 1.2; previous revision: 1.1
done
Checking in browser/themes/winstripe/browser/places/starPage.png;
/cvsroot/mozilla/browser/themes/winstripe/browser/places/starPage.png,v  <--  starPage.png
new revision: 1.5; previous revision: 1.4
done
RCS file: /cvsroot/mozilla/browser/themes/winstripe/browser/places/starred48-aero.png,v
done
Checking in browser/themes/winstripe/browser/places/starred48-aero.png;
/cvsroot/mozilla/browser/themes/winstripe/browser/places/starred48-aero.png,v  <--  starred48-aero.png
initial revision: 1.1
done
Checking in browser/themes/winstripe/browser/places/starred48.png;
/cvsroot/mozilla/browser/themes/winstripe/browser/places/starred48.png,v  <--  starred48.png
new revision: 1.2; previous revision: 1.1
done
Checking in browser/themes/winstripe/browser/preferences/Options-aero.png;
/cvsroot/mozilla/browser/themes/winstripe/browser/preferences/Options-aero.png,v  <--  Options-aero.png
new revision: 1.2; previous revision: 1.1
done
Checking in browser/themes/winstripe/browser/preferences/Options.png;
/cvsroot/mozilla/browser/themes/winstripe/browser/preferences/Options.png,v  <--  Options.png
new revision: 1.9; previous revision: 1.8
done
Checking in browser/themes/winstripe/browser/preferences/plugin-aero.png;
/cvsroot/mozilla/browser/themes/winstripe/browser/preferences/plugin-aero.png,v  <--  plugin-aero.png
new revision: 1.2; previous revision: 1.1
done
Checking in browser/themes/winstripe/browser/preferences/plugin.png;
/cvsroot/mozilla/browser/themes/winstripe/browser/preferences/plugin.png,v  <--  plugin.png
new revision: 1.4; previous revision: 1.3
done
Checking in toolkit/themes/winstripe/global/jar.mn;
/cvsroot/mozilla/toolkit/themes/winstripe/global/jar.mn,v  <--  jar.mn
new revision: 1.44; previous revision: 1.43
done
RCS file: /cvsroot/mozilla/toolkit/themes/winstripe/global/icons/blacklist_favicon-aero.png,v
done
Checking in toolkit/themes/winstripe/global/icons/blacklist_favicon-aero.png;
/cvsroot/mozilla/toolkit/themes/winstripe/global/icons/blacklist_favicon-aero.png,v  <--  blacklist_favicon-aero.png
initial revision: 1.1
done
Checking in toolkit/themes/winstripe/global/icons/blacklist_favicon.png;
/cvsroot/mozilla/toolkit/themes/winstripe/global/icons/blacklist_favicon.png,v  <--  blacklist_favicon.png
new revision: 1.2; previous revision: 1.1
done
RCS file: /cvsroot/mozilla/toolkit/themes/winstripe/global/icons/blacklist_large-aero.png,v
done
Checking in toolkit/themes/winstripe/global/icons/blacklist_large-aero.png;
/cvsroot/mozilla/toolkit/themes/winstripe/global/icons/blacklist_large-aero.png,v  <--  blacklist_large-aero.png
initial revision: 1.1
done
Checking in toolkit/themes/winstripe/global/icons/blacklist_large.png;
/cvsroot/mozilla/toolkit/themes/winstripe/global/icons/blacklist_large.png,v  <--  blacklist_large.png
new revision: 1.2; previous revision: 1.1
done
Checking in toolkit/themes/winstripe/mozapps/jar.mn;
/cvsroot/mozilla/toolkit/themes/winstripe/mozapps/jar.mn,v  <--  jar.mn
new revision: 1.27; previous revision: 1.26
done
Checking in toolkit/themes/winstripe/mozapps/downloads/buttons-aero.png;
/cvsroot/mozilla/toolkit/themes/winstripe/mozapps/downloads/buttons-aero.png,v  <--  buttons-aero.png
new revision: 1.2; previous revision: 1.1
done
Checking in toolkit/themes/winstripe/mozapps/downloads/buttons.png;
/cvsroot/mozilla/toolkit/themes/winstripe/mozapps/downloads/buttons.png,v  <--  buttons.png
new revision: 1.4; previous revision: 1.3
done
Checking in toolkit/themes/winstripe/mozapps/downloads/downloadIcon-aero.png;
/cvsroot/mozilla/toolkit/themes/winstripe/mozapps/downloads/downloadIcon-aero.png,v  <--  downloadIcon-aero.png
new revision: 1.2; previous revision: 1.1
done
Checking in toolkit/themes/winstripe/mozapps/downloads/downloadIcon.png;
/cvsroot/mozilla/toolkit/themes/winstripe/mozapps/downloads/downloadIcon.png,v  <--  downloadIcon.png
new revision: 1.5; previous revision: 1.4
done
RCS file: /cvsroot/mozilla/toolkit/themes/winstripe/mozapps/extensions/extensionIcons-aero.png,v
done
Checking in toolkit/themes/winstripe/mozapps/extensions/extensionIcons-aero.png;
/cvsroot/mozilla/toolkit/themes/winstripe/mozapps/extensions/extensionIcons-aero.png,v  <--  extensionIcons-aero.png
initial revision: 1.1
done
Checking in toolkit/themes/winstripe/mozapps/extensions/extensionIcons.png;
/cvsroot/mozilla/toolkit/themes/winstripe/mozapps/extensions/extensionIcons.png,v  <--  extensionIcons.png
new revision: 1.2; previous revision: 1.1
done
RCS file: /cvsroot/mozilla/toolkit/themes/winstripe/mozapps/extensions/ratings-aero.png,v
done
Checking in toolkit/themes/winstripe/mozapps/extensions/ratings-aero.png;
/cvsroot/mozilla/toolkit/themes/winstripe/mozapps/extensions/ratings-aero.png,v  <--  ratings-aero.png
initial revision: 1.1
done
Checking in toolkit/themes/winstripe/mozapps/extensions/ratings.png;
/cvsroot/mozilla/toolkit/themes/winstripe/mozapps/extensions/ratings.png,v  <--  ratings.png
new revision: 1.2; previous revision: 1.1
done
RCS file: /cvsroot/mozilla/toolkit/themes/winstripe/mozapps/extensions/themeGeneric-aero.png,v
done
Checking in toolkit/themes/winstripe/mozapps/extensions/themeGeneric-aero.png;
/cvsroot/mozilla/toolkit/themes/winstripe/mozapps/extensions/themeGeneric-aero.png,v  <--  themeGeneric-aero.png
initial revision: 1.1
done
Checking in toolkit/themes/winstripe/mozapps/extensions/themeGeneric.png;
/cvsroot/mozilla/toolkit/themes/winstripe/mozapps/extensions/themeGeneric.png,v  <--  themeGeneric.png
new revision: 1.4; previous revision: 1.3
done
RCS file: /cvsroot/mozilla/toolkit/themes/winstripe/mozapps/extensions/viewButtons-aero.png,v
done
Checking in toolkit/themes/winstripe/mozapps/extensions/viewButtons-aero.png;
/cvsroot/mozilla/toolkit/themes/winstripe/mozapps/extensions/viewButtons-aero.png,v  <--  viewButtons-aero.png
initial revision: 1.1
done
Checking in toolkit/themes/winstripe/mozapps/extensions/viewButtons.png;
/cvsroot/mozilla/toolkit/themes/winstripe/mozapps/extensions/viewButtons.png,v  <--  viewButtons.png
new revision: 1.6; previous revision: 1.5
done
RCS file: /cvsroot/mozilla/toolkit/themes/winstripe/mozapps/passwordmgr/key-aero.png,v
done
Checking in toolkit/themes/winstripe/mozapps/passwordmgr/key-aero.png;
/cvsroot/mozilla/toolkit/themes/winstripe/mozapps/passwordmgr/key-aero.png,v  <--  key-aero.png
initial revision: 1.1
done
Checking in toolkit/themes/winstripe/mozapps/passwordmgr/key.png;
/cvsroot/mozilla/toolkit/themes/winstripe/mozapps/passwordmgr/key.png,v  <--  key.png
new revision: 1.2; previous revision: 1.1
done
RCS file: /cvsroot/mozilla/toolkit/themes/winstripe/mozapps/plugins/pluginGeneric-aero.png,v
done
Checking in toolkit/themes/winstripe/mozapps/plugins/pluginGeneric-aero.png;
/cvsroot/mozilla/toolkit/themes/winstripe/mozapps/plugins/pluginGeneric-aero.png,v  <--  pluginGeneric-aero.png
initial revision: 1.1
done
Checking in toolkit/themes/winstripe/mozapps/plugins/pluginGeneric.png;
/cvsroot/mozilla/toolkit/themes/winstripe/mozapps/plugins/pluginGeneric.png,v  <--  pluginGeneric.png
new revision: 1.3; previous revision: 1.2
done
RCS file: /cvsroot/mozilla/toolkit/themes/winstripe/mozapps/xpinstall/xpinstallItemGeneric-aero.png,v
done
Checking in toolkit/themes/winstripe/mozapps/xpinstall/xpinstallItemGeneric-aero.png;
/cvsroot/mozilla/toolkit/themes/winstripe/mozapps/xpinstall/xpinstallItemGeneric-aero.png,v  <--  xpinstallItemGeneric-aero.png
initial revision: 1.1
done
Checking in toolkit/themes/winstripe/mozapps/xpinstall/xpinstallItemGeneric.png;
/cvsroot/mozilla/toolkit/themes/winstripe/mozapps/xpinstall/xpinstallItemGeneric.png,v  <--  xpinstallItemGeneric.png
new revision: 1.4; previous revision: 1.3
done
Keywords: checkin-needed
(Assignee)

Comment 39

10 years ago
Checking in browser/themes/winstripe/browser/browser.css;
/cvsroot/mozilla/browser/themes/winstripe/browser/browser.css,v  <--  browser.css
new revision: 1.181; previous revision: 1.180
done
Status: ASSIGNED → RESOLVED
Last Resolved: 10 years ago10 years ago
Resolution: --- → FIXED
Depends on: 420427

Comment 40

10 years ago
Created attachment 306676 [details]
screenshot

no "viewButtons-aero.png" on VISTA

Comment 41

10 years ago
Created attachment 306686 [details]
screenshot

favicon and forward/back arrow on back/forward drop-down history does not replace.

Comment 42

10 years ago
Recommended add-on star ratings look like chopped-up stars. At least on Vista (my only testbed right now.) Keep it up, looking good!
(In reply to comment #42)
> Recommended add-on star ratings look like chopped-up stars. At least on Vista
> (my only testbed right now.) Keep it up, looking good!

Same on XP Classic (top half of stars is missing)

Comment 44

10 years ago
(In reply to comment #43)
> (In reply to comment #42)
> > Recommended add-on star ratings look like chopped-up stars. At least on Vista
> > (my only testbed right now.) Keep it up, looking good!
> 
> Same on XP Classic (top half of stars is missing)
> 

already listed in "Depends on", bug 420427

Comment 45

10 years ago
(In reply to comment #40)
> Created an attachment (id=306676) [details]
> screenshot
> 
> no "viewButtons-aero.png" on VISTA
> 

and more,
downloads/buttons-aero.png
downloads/downloadIcon-aero.png

mozilla/browser/themes/winstripe/browser/places/***.png

need other checkins for these?
(Reporter)

Comment 46

10 years ago
The RSS icon is ugly as hell, why not just stick with the orange icon that everybody recognizes.  The star icon looks much better though!
I agree with Kurt. 

Also, the 'new tab' button is still unrecognizable.
(Reporter)

Updated

10 years ago
Depends on: 420515
(In reply to comment #41)
> Created an attachment (id=306686) [details]
> screenshot
> 
> favicon and forward/back arrow on back/forward drop-down history does not
> replace.

reed: ping?
Created attachment 306796 [details]
RSS icons

There was a small mix up with the following files:

livemark-item.png (should look like a page with an RSS glyph, used for the items on live bookmarks)

page-livemarks.png (should be identical to feeds/feedicon16.png, orange square with white glyph)
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 50

10 years ago
(In reply to comment #48)
> reed: ping?

I will get back to this bug as soon as I've finished bug 419319. Please have patience. :)
Dão: we landed these two new icons for use in the back/forward drop down menu:

http://mxr.mozilla.org/seamonkey/source/browser/themes/winstripe/browser/menu-back.png

http://mxr.mozilla.org/seamonkey/source/browser/themes/winstripe/browser/menu-forward.png
(In reply to comment #51)
> Dão: we landed these two new icons for use in the back/forward drop down menu:

Yes, but browser.css references them wrongly. The !important flag from before is actually needed.

Btw, given that blue is the most common highlight color, aren't these icons a little bit too blue? Won't they fade away into the background?
Assignee: faaborg → reed
Status: REOPENED → NEW
(Assignee)

Comment 53

10 years ago
Created attachment 306826 [details] [diff] [review]
Fix RSS icon, AMO ratings, menu-(back|forward), and livemark items - v1
Attachment #306826 - Flags: review?(gavin.sharp)
Attachment #306826 - Flags: review?(gavin.sharp) → review+
Comment on attachment 306826 [details] [diff] [review]
Fix RSS icon, AMO ratings, menu-(back|forward), and livemark items - v1

a=shaver
Attachment #306826 - Flags: approval1.9b4+
(Assignee)

Comment 55

10 years ago
Checking in browser/themes/winstripe/browser/browser.css;
/cvsroot/mozilla/browser/themes/winstripe/browser/browser.css,v  <--  browser.css
new revision: 1.183; previous revision: 1.182
done
Checking in toolkit/themes/winstripe/mozapps/extensions/extensions.css;
/cvsroot/mozilla/toolkit/themes/winstripe/mozapps/extensions/extensions.css,v  <--  extensions.css
new revision: 1.45; previous revision: 1.44
done
Status: NEW → RESOLVED
Last Resolved: 10 years ago10 years ago
Resolution: --- → FIXED

Comment 56

10 years ago
Created attachment 306839 [details]
Library screenshot

20080301_2200_firefox-3.0b4pre.en-US.win32.zip

how about "Import and Backup" icon ? (both XP and Vista)
and ohers (minus, plus, ...) ?
(Assignee)

Comment 57

10 years ago
(In reply to comment #56)
> Created an attachment (id=306839) [details]
> Library screenshot
...
> how about "Import and Backup" icon ? (both XP and Vista)
> and ohers (minus, plus, ...) ?

I purposely didn't do those in this bug because they are going to require a ton of CSS work to match what pinstripe already has, etc, so I considered them low-priority. Would you please file a bug about that, make it blocking this bug, and CC me and faaborg on it? Thanks!
(In reply to comment #52)
> Btw, given that blue is the most common highlight color, aren't these icons a
> little bit too blue? Won't they fade away into the background?

Agree with that.  It really would be good to have more contrast in the
_moz-menuactive state.  Filed Bug 420546.
 

Updated

10 years ago
Depends on: 420551

Comment 59

10 years ago
(In reply to comment #57)
> (In reply to comment #56)
> > Created an attachment (id=306839) [details] [details]
> > Library screenshot
> ...
> > how about "Import and Backup" icon ? (both XP and Vista)
> > and ohers (minus, plus, ...) ?
> 
> I purposely didn't do those in this bug because they are going to require a ton
> of CSS work to match what pinstripe already has, etc, so I considered them
> low-priority. Would you please file a bug about that, make it blocking this
> bug, and CC me and faaborg on it? Thanks!
> 

filed, bug 420551
No longer depends on: 420551

Updated

10 years ago
Depends on: 420551
(Assignee)

Updated

10 years ago
Depends on: 420555

Updated

10 years ago
Depends on: 420546
Is the Go icon expected to get an hover state? If not, why do the icons contain two identical states?
IMHO last RSS icon (http://mxr.mozilla.org/seamonkey/source/browser/themes/winstripe/browser/livemark-item.png) is very ugly ;(
I hope you'll change it soon.
(In reply to comment #61)
> IMHO last RSS icon
> (http://mxr.mozilla.org/seamonkey/source/browser/themes/winstripe/browser/livemark-item.png)
> is very ugly ;(
> I hope you'll change it soon.
> 
It's already fixed see comment 53
(In reply to comment #62)
> (In reply to comment #61)
> > IMHO last RSS icon
> > (http://mxr.mozilla.org/seamonkey/source/browser/themes/winstripe/browser/livemark-item.png)
> > is very ugly ;(
> > I hope you'll change it soon.
> > 
> It's already fixed see comment 53

It's not. The patch in comment 53 doesn't modify any icons.

I too wonder why a page in a livemark folder needs a special icon. The folder itself already has a special one. For the individual pages, the generic page icon would probably be fine.

Comment 64

10 years ago
Created attachment 306866 [details]
RSS icons screenshot

20080301_2200_firefox-3.0b4pre.en-US.win32.zip

Comment 65

10 years ago
Created attachment 306867 [details]
RSS icon (in locationbar)
(In reply to comment #63)
> (In reply to comment #62)
> > (In reply to comment #61)
> > > IMHO last RSS icon
> > > (http://mxr.mozilla.org/seamonkey/source/browser/themes/winstripe/browser/livemark-item.png)
> > > is very ugly ;(
> > > I hope you'll change it soon.
> > > 
> > It's already fixed see comment 53
> 
> It's not. The patch in comment 53 doesn't modify any icons.
> 
> I too wonder why a page in a livemark folder needs a special icon. The folder
> itself already has a special one. For the individual pages, the generic page
> icon would probably be fine.
> 
I think he talked about the rss feed icon located in the location bar, 'cause http://mxr.mozilla.org/seamonkey/source/browser/themes/winstripe/browser/livemark-item.png was in the location bar before reed fix it.

Comment 67

10 years ago
Stop button in vista small icon set has a 1px line on the right side of the X.

Comment 68

10 years ago
Refresh button in vista small icon set has a few extraneous pixels above and below the leftmost portion of the circle

Comment 69

10 years ago
#67 and #68 are caused by the icons in Aero\browser\Toolbar-small.png being too cramped, they are in each others space.
I have a question about the Areo 'Downloads' icon.
Shouldn't the green down-arrow be blue to match the rest of theme? (I.e. The reload and stop icons are blue.)

If so, what about the green plus symbol (+) in 'New Tab' and 'New Window' and the arrows in 'Copy' and 'Paste'?
>Btw, given that blue is the most common highlight color, aren't these icons a
>little bit too blue? Won't they fade away into the background?

Yes, we need to fix that.

>Is the Go icon expected to get an hover state? If not, why do the icons contain
>two identical states?

It is expected to get a hover state.

Comment 72

10 years ago
The back/forwards list, shows back/forwards icons in blue on hover.  This is on XP with green back/forwards.  So not only can you not make the icons out, they should be green.  Thought worth noting here though happy to submit a new bug.
>The back/forwards list, shows back/forwards icons in blue on hover.

Yeah, we will have this fixed in the next major icon drop.  Kind of a dumb mistake on my part for not catching it before they landed.

Comment 74

10 years ago
(In reply to comment #71)
> >Btw, given that blue is the most common highlight color, aren't these icons a
> >little bit too blue? Won't they fade away into the background?
> 
> Yes, we need to fix that.

Will the icons for Vista stay the same? To me, the contrast is fine and they look great against the light blue highlighting.
>Will the icons for Vista stay the same? To me, the contrast is fine and they
>look great against the light blue highlighting.

Probably, there is still an issue using the classic windows theme on Vista, but we do have a white glow outside of the icon which helps.
http://mxr.mozilla.org/seamonkey/source/toolkit/themes/winstripe/mozapps/downloads/downloads.css#57
buttons.png
http://mxr.mozilla.org/seamonkey/source/toolkit/themes/winstripe/mozapps/downloads/buttons.png

I feel this:
56 .pause[disabled="true"] {
57   -moz-image-region: rect(16px, 48px, 32px, 32px);
58 }
Created attachment 308213 [details]
Addons buttons

While playing around, I noticed that there are some problems with buttons in the addons manager. The two rows seem to overlap a bit, and the shadow from one spills into the next.

Comment 78

10 years ago
Firefox should support standards and use the standard RSS icon!

Please, fix this!
(Assignee)

Updated

10 years ago
No longer depends on: 420551
(Assignee)

Updated

10 years ago
Depends on: 424286
Depends on: 414698
You need to log in before you can comment on or make changes to this bug.