Last Comment Bug 426026 - Back/forward buttons disappear when moving from 1.8 to 1.9 if they've been moved
: Back/forward buttons disappear when moving from 1.8 to 1.9 if they've been moved
Status: RESOLVED FIXED
[MU+]
: fixed1.9.0.2
Product: Firefox
Classification: Client Software
Component: Toolbars and Customization (show other bugs)
: 3.0 Branch
: All All
-- minor with 2 votes (vote)
: Firefox 3.1a1
Assigned To: Dão Gottwald [:dao]
:
: :Gijs (away until Feb 27)
Mentors:
: 426696 428619 428663 428681 428753 430194 433737 434129 434507 434910 437577 439073 439662 439799 (view as bug list)
Depends on: 452057
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-30 02:18 PDT by [:Cww]
Modified: 2009-10-23 08:50 PDT (History)
32 users (show)
mbeltzner: blocking‑firefox3-
mbeltzner: wanted‑firefox3+
samuel.sidler+old: blocking1.9.0.2+
samuel.sidler+old: wanted1.9.0.x+
dao+bmo: in‑testsuite-
mozillamarcia.knous: in‑litmus+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
handle the menu and personal toolbars as well (2.28 KB, patch)
2008-07-14 03:26 PDT, Dão Gottwald [:dao]
gavin.sharp: review+
samuel.sidler+old: approval1.9.0.2+
Details | Diff | Splinter Review

Description User image [:Cww] 2008-03-30 02:18:09 PDT
This is a followup bug based on my comment here: https://bugzilla.mozilla.org/show_bug.cgi?id=417421#c29

Following on from bug 417421 it doesn't patch the case as follows:

I have all my navigation buttons in my menu toolbar... so I have everything in one line, address bar, search bar, menu.  Moving from .13 to Minefield still makes the back/forward buttons disappear.  Doubly annoying because they don't show up in Toolbars>Customize, they get dumped in the (hidden) navigation toolbar.

Having it set up correctly in Minefield and then moving to 2.0.0.13 still makes the back/forward buttons disappear.

I would expect that Firefox 3 would figure out where the back button is and put the megabutton there even if it's not on the navigation toolbar and that 2.0.0.13 would look for the megabutton and put both the back and forward buttons where it is.

It's a minor issue but I can see people who customize their toolbars being minorly annoyed/confused after upgrading to 3 if it's in the final.

Anyhow by way of providing details, below are excerpts from my localstore.rdf after performing a series of steps.

1. Start with a fresh 2.0.0.13 profile.  Move buttons to menubar, hide navigation toolbar.

<RDF:Description RDF:about="chrome://browser/content/browser.xul#toolbar-menubar"
                   iconsize="small"
                   currentset="back-button,forward-button,stop-button,reload-button,home-button,menubar-items,urlbar-container,spring,search-container,throbber-box" />
<RDF:Description RDF:about="chrome://browser/content/browser.xul#nav-bar"
                   iconsize="small"
                   currentset="__empty"
                   collapsed="true" />

2. Open in Minefield, see that the back/forward buttons are "missing" (they're actually in the navigation toolbar).  Don't make any changes or touch anything, just close.
<RDF:Description RDF:about="chrome://browser/content/browser.xul#toolbar-menubar"
                   iconsize="small"
                   currentset="back-button,forward-button,stop-button,reload-button,home-button,menubar-items,urlbar-container,spring,search-container,throbber-box" />
<RDF:Description RDF:about="chrome://browser/content/browser.xul#nav-bar"
                   iconsize="small"
                   collapsed="true"
                   currentset="unified-back-forward-button,__empty" />

3. Make changes in Minefield to put the buttons where they should be.
<RDF:Description RDF:about="chrome://browser/content/browser.xul#toolbar-menubar"
                   iconsize="small"
                   currentset="unified-back-forward-button,stop-button,reload-button,home-button,menubar-items,urlbar-container,spring,search-container,throbber-box" />
<RDF:Description RDF:about="chrome://browser/content/browser.xul#nav-bar"
                   iconsize="small"
                   currentset="__empty"
                   collapsed="true" />

4. Open in 2.0.0.13 and see that the back/forward buttons are missing.


You can probably see what's going on from there.
Comment 1 User image Andy Behrens 2008-04-05 15:24:31 PDT
I agree, this could be quite confusing to users who have moved the buttons to another toolbar and hidden the navigation bar.

Anoother (possibly simpler) solution would simply be to reset the navigation bar state to "visible" when upgrading from FF2 to FF3.
Comment 2 User image Mike Beltzner [:beltzner, not reading bugmail] 2008-04-09 09:46:43 PDT
This will not block the final release of Firefox 3. Any patch will need unit tests in order to be approved.
Comment 3 User image Matthias Versen [:Matti] 2008-04-11 20:22:17 PDT
*** Bug 426696 has been marked as a duplicate of this bug. ***
Comment 4 User image Matthias Versen [:Matti] 2008-04-11 20:22:27 PDT
*** Bug 428619 has been marked as a duplicate of this bug. ***
Comment 5 User image Matthias Versen [:Matti] 2008-04-12 09:56:45 PDT
*** Bug 428681 has been marked as a duplicate of this bug. ***
Comment 6 User image Matthias Versen [:Matti] 2008-04-16 12:10:18 PDT
*** Bug 428753 has been marked as a duplicate of this bug. ***
Comment 7 User image Damian Shaw [Quan] 2008-04-21 20:40:42 PDT
*** Bug 430194 has been marked as a duplicate of this bug. ***
Comment 8 User image Stephen Donner [:stephend] 2008-04-25 02:05:01 PDT
*** Bug 428663 has been marked as a duplicate of this bug. ***
Comment 9 User image [:Cww] 2008-05-14 10:55:04 PDT
*** Bug 433737 has been marked as a duplicate of this bug. ***
Comment 10 User image [:Cww] 2008-05-16 22:55:04 PDT
*** Bug 434129 has been marked as a duplicate of this bug. ***
Comment 11 User image Kai Liu 2008-05-20 18:55:56 PDT
*** Bug 434910 has been marked as a duplicate of this bug. ***
Comment 12 User image Alistair Nieuwoudt 2008-05-20 21:57:49 PDT
I was using the latest version of Firefox 2, when I installed the Beta for Firefox 3 (last Beta before RC1). After using Firefox 3 for a day or so, I accidentally opened Firefox 2. The Forward and Back buttons disappeared. I'd never moved the buttons as the topic of this bug suggests. They were in their default spot, until they vanished. Now in both versions of Firefox I have no Forward or Back buttons. I've since uninstalled Firefox 2 and reinstalled Firefox 3. The buttons are still missing.
When Firefox 3 final is released, will the problem be fixed? And how can I fix the problem manually until then? I fully accept the consequences of using Beta software. :)
Comment 13 User image Barry Keown 2008-05-21 01:18:27 PDT
I had the same issue as described in comment#12.
Sort it by running Mozilla Firefox (Safe Mode) from your Start Menu, and selecting the 'reset toolbars' option.
Comment 14 User image Christen 2008-05-21 08:37:34 PDT
Another way to fix the problem in comment 12 is:
View->Toolbars->Customize... in the non-safe form
If it's the same problem I had (it starts out the same way mine did), the forward/back buttons should be in the "customize toolbar" box that pops up.  Just drag-and-drop them back to where you want them to be.  Or, if you don't want to drag-and-drop, hit the "Restore Default Set" button on the customize toolbar box.  That should put your arrows back where they belong.  Yay Beta!

Hope this helps!
-Christen
Comment 15 User image Sylvain Pasche 2008-06-13 11:42:29 PDT
*** Bug 439073 has been marked as a duplicate of this bug. ***
Comment 16 User image Kai Liu 2008-06-17 12:29:32 PDT
*** Bug 439662 has been marked as a duplicate of this bug. ***
Comment 17 User image Kai Liu 2008-06-17 12:30:03 PDT
*** Bug 434507 has been marked as a duplicate of this bug. ***
Comment 18 User image Kai Liu 2008-06-17 19:34:00 PDT
*** Bug 439799 has been marked as a duplicate of this bug. ***
Comment 19 User image Danny 2008-06-17 21:08:35 PDT
my problem is that they straight up aren't there. they were in 2.0.0.14 and in 3.0 beta 2 but not in 3.0

weird?
Comment 20 User image VanillaMozilla 2008-06-23 08:55:40 PDT
A bump in priority might be in order, while there are still relatively few version 3 users.  Since it happens only after update to 3, if it's not fixed fairly soon you might as well WONTFIX it.
Comment 21 User image Danny 2008-06-23 11:21:54 PDT
i found the solution to this problem.

since most of the comments i was getting back were more like discussion and less like help i decided to look for them myself. i tried resetting the navigation and such but it came down to this simple of procedure:

view > toolbar > customize

and they were right there. just had to click and drag them to where i wanted them

this didn't happen because i customized the toolbar. i left everything default since i first got FF
Comment 22 User image Samuel Sidler (old account; do not CC) 2008-07-13 23:53:36 PDT
I vaguely recall fixing something like this on the 1.8 branch a release or two ago. Can someone confirm this issue still exists?
Comment 23 User image Radek 'sysKin' Czyz 2008-07-14 01:40:02 PDT
This is definitely a new thing Samuel - the unified keyhole button appears in Navigation Toolbar even if that toolbar is hidden and even if original back and forward were somewhere else.
Comment 24 User image Dão Gottwald [:dao] 2008-07-14 03:22:49 PDT
(In reply to comment #22)
> I vaguely recall fixing something like this on the 1.8 branch a release or two
> ago. Can someone confirm this issue still exists?

You probably mean bug 417421.
This one is a special case (comment 23) that our migration code doesn't handle.
Comment 25 User image Dão Gottwald [:dao] 2008-07-14 03:26:18 PDT
Created attachment 329419 [details] [diff] [review]
handle the menu and personal toolbars as well

might be a good idea to fix this before we roll out major updates
Comment 27 User image Samuel Sidler (old account; do not CC) 2008-07-20 23:22:58 PDT
Can we get a test here before landing on 1.9.0? A major update Litmus test would be acceptable but an automated test would be even better.
Comment 28 User image Dão Gottwald [:dao] 2008-07-21 00:34:30 PDT
Marcia, can we get a major update Litmus test for this? It should cover moving the back button somewhere in the menu, navigation or bookmarks toolbar on Firefox 2 and then running Firefox 3.x for the first time with that profile.
Comment 29 User image Marcia Knous [:marcia - use ni] 2008-07-22 11:17:59 PDT
https://litmus.mozilla.org/show_test.cgi?id=5889 added to Litmus, to the 2.0->3 major update portion.
Comment 30 User image Samuel Sidler (old account; do not CC) 2008-07-22 11:23:15 PDT
Comment on attachment 329419 [details] [diff] [review]
handle the menu and personal toolbars as well

Approved for 1.9.0.2. Please land in CVS. a=ss
Comment 31 User image Mike Connor [:mconnor] 2008-08-14 12:17:55 PDT
checked into CVS.
Comment 32 User image Henrik Skupin (:whimboo) [away 02/18 - 02/27] 2008-08-24 04:26:27 PDT
Dao, what about custom toolbars? Placing the back/forward buttons onto such ones they still disappear with the latest nightly builds. Should we reopen this bug or shall I file a new one?
Comment 33 User image :Gavin Sharp [email: gavin@gavinsharp.com] 2008-08-24 18:33:11 PDT
(In reply to comment #32)
> Should we reopen this bug or shall I file a new one?

The answer to that question is "file a new bug" in 99% of cases (including this one) :)
Comment 34 User image Simon Bünzli 2008-08-30 19:09:07 PDT
*** Bug 437577 has been marked as a duplicate of this bug. ***
Comment 35 User image Matěj Cepl 2009-10-23 08:39:01 PDT
Could this have anything to do with https://bugzilla.redhat.com/show_bug.cgi?id=530466 ? (not that I would be able to reproduce it)?
Comment 36 User image Dão Gottwald [:dao] 2009-10-23 08:50:12 PDT
It shouldn't, this bug is fixed.

Note You need to log in before you can comment on or make changes to this bug.