The default bug view has changed. See this FAQ.

should be possible to move/copy address cards to different address books

RESOLVED FIXED

Status

MailNews Core
Address Book
P2
enhancement
RESOLVED FIXED
17 years ago
5 years ago

People

(Reporter: André Langhorst, Assigned: standard8)

Tracking

(Depends on: 1 bug, 4 keywords)

Trunk
access, fixed-seamonkey1.1a, fixed1.8.1, verified1.8.1.3
Dependency tree / graph
Bug Flags:
blocking1.3a -

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: relnote-seamonkey1.1)

Attachments

(4 attachments, 6 obsolete attachments)

3.15 KB, patch
Bienvenu
: review+
Bienvenu
: superreview+
Scott MacGregor
: approval-branch-1.8.1+
Details | Diff | Splinter Review
10.95 KB, patch
standard8
: review+
Bienvenu
: superreview+
Scott MacGregor
: approval-branch-1.8.1+
Details | Diff | Splinter Review
13.81 KB, patch
Details | Diff | Splinter Review
26.46 KB, patch
Details | Diff | Splinter Review
(Reporter)

Description

17 years ago
It should be possible to move and copy once created addressbook cards to other
address books

Updated

17 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows NT → All
Hardware: PC → All
Summary: should be possible to move/cope address cards to different address books → [RFE]should be possible to move/copy address cards to different address books

Comment 1

17 years ago
esther - do we already have a bug on this?
QA Contact: lchiang → esther

Comment 2

17 years ago
This may already exist as a feature bug.  Candice?
Assignee: hangas → chuang
(Reporter)

Comment 3

17 years ago
don´t know if it´s a DUP, but copying already seems to work, I´m not sure,
dragging should be equal with moving and dragging with pressend <ctrl> key
should copy entríes

Comment 4

17 years ago
Target M17.
Target Milestone: --- → M17

Comment 5

17 years ago
copying already works as mentioned.  moving rest of bug to future.
Target Milestone: M17 → Future

Updated

17 years ago
Status: NEW → ASSIGNED

Updated

17 years ago
Blocks: 56821

Updated

17 years ago
QA Contact: esther → pmock

Comment 6

16 years ago
Assign it to myself..
QA Contact: pmock → fenella
(Reporter)

Comment 7

16 years ago
adjusting severity due to initially mixed up "enh" and [rfe]
Severity: enhancement → normal
Summary: [RFE]should be possible to move/copy address cards to different address books → [RFE] should be possible to move/copy address cards to different address books

Updated

16 years ago
QA Contact: fenella → nbaca

Comment 8

16 years ago
reassigning to cavin
Assignee: chuang → cavin
Status: ASSIGNED → NEW
*** Bug 108437 has been marked as a duplicate of this bug. ***
*** Bug 109489 has been marked as a duplicate of this bug. ***

Comment 11

16 years ago
Trunk build 2001-12-13-03:WinMe
In the Address Book window I do not see a choice to move or copy addresses. The
Edit menu does not display move/copy and there is no contextual menu for move/copy.

Jen, The Address Book spec's Edit menu shows an Edit|Copy menu item but does not
have a Move option. Maybe the spec should be updated for accessibility reasons?
Keywords: access

Comment 12

16 years ago
AB Edit menu should have:

Undo --- Ctrl+Z
Redo ---Ctrl-Y (Cmd+Shift-Z mac)
---------------------
Cut --- Ctrl+X
Copy --- Ctrl+C
Paste --- Ctrl+V
Delete --- Del
----------------------
Select All --- Ctrl+A
----------------------
<Card/Address Book/Directory> Properties... --- Ctrl+I
Preferences...

If a card is selected, users should be able to select the menu items to Copy and 
Paste an AB entry from one AB to another.

A DnD from a Local AB to another is a move. A Ctrl+DnD is a Copy. A DnD or 
Ctrl+DnD from an LDAP Dir to a Local AB is always a Copy since a Move is not 
allowed. A DnD from a Local AB to an LDAP Dir is not allowed.

Comment 13

16 years ago
Marking nsbeta1 for accessbility reasons so that there is a copy menu item.
Currently you have to use the mouse to d&d to copy a card/list.
Keywords: nsbeta1

Updated

16 years ago
Whiteboard: nab-copy,nab-move

Updated

15 years ago
Status: NEW → ASSIGNED
Keywords: nsbeta1 → nsbeta1+
Priority: P3 → P2
Target Milestone: Future → ---

Comment 14

15 years ago
Is this really a nsbeta1+, P2? If yes, then we need to try and schedule it for
the MachV release.

Updated

15 years ago
Blocks: 122274
Keywords: nsbeta1+ → nsbeta1-
No longer blocks: 122274

Comment 15

15 years ago
*** Bug 124230 has been marked as a duplicate of this bug. ***

Comment 16

15 years ago
*** Bug 112766 has been marked as a duplicate of this bug. ***

Comment 17

15 years ago
A remark on comment #13

I can drag and drop cards, but I cannot drag and drop lists.
To be more precise, when I d&d a list, the copy at its destination is an empty
card (even though the destination address book contains the emails listed in the
list.)

Moz 1.0 release and 1.1a (2002061504) for i686 Linux

Comment 18

15 years ago
I have just noticed that my problem in comment 17 is mentioned in
comment 3 of Bug 41590 (dated 6/6/2000!)

Comment 19

15 years ago
Marking nsbeta1. There should be an Edit|Copy and an Edit|Move menu option for
accessibility reasons.
Keywords: nsbeta1- → nsbeta1

Comment 20

15 years ago
[RFE] is deprecated in favor of severity: enhancement.  They have the same meaning.
Severity: normal → enhancement

Comment 21

15 years ago
> A DnD from a Local AB to another is a move. A Ctrl+DnD is a Copy.

Actually, (for me at least) they're both a Copy.  The mouse pointer changes as
appropriate (the presence/absence of the "+" part next to the arrow), but they
both end up doing a Copy nevertheless.

Summary: [RFE] should be possible to move/copy address cards to different address books → should be possible to move/copy address cards to different address books

Comment 22

15 years ago
*** Bug 179916 has been marked as a duplicate of this bug. ***

Comment 23

15 years ago
We should do what is said in comment 12, and I can still reproduce comment 21 in
build 20021126 on win32 and linux build 20021128

Also bug 56821 insn't an entire dup, but once this bug is fixed 56821 is fixed
too at the same time.
Flags: blocking1.3a?

Updated

15 years ago
Blocks: 150632

Updated

15 years ago
Flags: blocking1.3a? → blocking1.3a-

Updated

15 years ago
Keywords: nsbeta1 → nsbeta1+

Comment 24

15 years ago
(On Windows 2000 moz 1.2.1)  I just tried to cut all my cards from the collected
address book and paste to another address book.  Then I tried dragging.  Since
the old ones did not go away in either case, I assumed it didnt work, and didnt
even look in the new address book.  The fact that the Edit/Cut+Past+Copy menu
items are greyed out doesnt help this impression any either.  I know this is a
bit repetitive, but this is horribly un-intuitive behavior, certainly a more
severe user interface issue than just an enhancement.  If I hadnt looked thru
bugzilla, I would have given up.

I would add a request that the cut operation should be made to work either by
greying out the cut cards until they are pasted (as when moving files in
Explorer) or simply by having the cards disappear after cutting.  A move, but in
two steps, just like every other Windows app allows.

Comment 25

15 years ago
*** Bug 56821 has been marked as a duplicate of this bug. ***

Updated

14 years ago
No longer blocks: 56821

Comment 26

14 years ago
Edit->Undo,Redo,Cut,Copy,Paste still disabled in Moz1.3b@Win32.
I disagree with the 'enhancement' severity of this bug.

Comment 27

14 years ago
I agree on the fact that this isn't just an enhanced. Its a severe bug and it
has been in there for simply too long now. Without these options its almost
impossible to properly manage ones address-book. I don't know what the
target-milestone is but I suggest it should be 1.5alpha.

Comment 28

14 years ago
Note that when dragging a card to another address book, if you press CTRL, the
"+" icon appears next to the mouse pointer indicating copy.  This would suggest
that without the CTRL, one would expect MOVE, but that copies too.  From Windows
conventions, you might expect SHIFT+DRAG to be MOVE, but that also does a COPY.
 Seems like the code is half there since CTRL pops up the + icon, just need to
make the default behavior be to MOVE.

Comment 29

14 years ago
*** Bug 197954 has been marked as a duplicate of this bug. ***

Comment 30

14 years ago
*** Bug 207012 has been marked as a duplicate of this bug. ***

Updated

14 years ago
Blocks: 118769

Comment 31

14 years ago
*** Bug 217902 has been marked as a duplicate of this bug. ***

Comment 32

13 years ago
*** Bug 226940 has been marked as a duplicate of this bug. ***

Comment 33

13 years ago
Having a right-click-option to send a contact card via email would be great,
too. Or even better: drag contact card on another to do that! (open new message
to that one and inserting it)

Comment 34

13 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7a) Gecko/20040202

Curious about status as this one is rather old and the bug in comment #21 still
exists (moving or copying address book entries *always copies* even though icon
appropriately changes between move and copy upon holding down Ctrl key while
dragging).

Comment 35

13 years ago
*** Bug 246477 has been marked as a duplicate of this bug. ***

Comment 36

13 years ago
*** Bug 251681 has been marked as a duplicate of this bug. ***

Updated

13 years ago
Assignee: cavin → sspitzer
Status: ASSIGNED → NEW
QA Contact: nbaca

Comment 37

13 years ago
I have been waiting release after a release for a fix for this bug. Because of
this I don't have any control over my adress books, they are just various
jumbles of duplicated adresses.
seems like it should be a trivial fix -:)

Updated

13 years ago
Keywords: helpwanted

Updated

13 years ago
Blocks: 250394
(Assignee)

Comment 39

13 years ago
Created attachment 165788 [details] [diff] [review]
Fix for DND Move/Copy bug

This patch provides a fix to allow the move/copy functions to work properly
when using drag and drop for cards.
(Assignee)

Updated

13 years ago
Attachment #165788 - Flags: review?(neil.parkwaycc.co.uk)
(Assignee)

Comment 40

13 years ago
Comment on attachment 165788 [details] [diff] [review]
Fix for DND Move/Copy bug

Sorry for the spam, cancelling review as this patch may give us more problems
as it breaks dnd to a list (you can't move a card to a list - only copy it)
Attachment #165788 - Flags: review?(neil.parkwaycc.co.uk)
Product: Browser → Seamonkey
(Assignee)

Comment 41

13 years ago
Created attachment 168563 [details] [diff] [review]
Fix for DND Move/Copy bug v2

This patch provides a better fix for DND Move/Copy. It deals with the issue of
moving mail lists correct (copy not allowed as that = duplicates) as well as
the copying/moving of cards.

Note that when dragging to a mail list, the action is forced to be a copy as a)
the cards would be lost if it is a move, as they should exist in a directory,
and b) the default drag action is move, so it'd be a bit annoying if we
prompted the user all the time.

Mailing List drag and drop is actually bug 42879 and part of this patch was
taken from the old patch on that bug by Sean Gao.
(Assignee)

Updated

13 years ago
Assignee: sspitzer → mark
Attachment #165788 - Attachment is obsolete: true
Status: NEW → ASSIGNED
(Assignee)

Updated

13 years ago
Attachment #168563 - Flags: review?(neil.parkwaycc.co.uk)
(Assignee)

Updated

13 years ago
Blocks: 42879

Comment 42

12 years ago
*** Bug 272991 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 43

12 years ago
Comment on attachment 168563 [details] [diff] [review]
Fix for DND Move/Copy bug v2

Due to other changes this patch now bitrots. Going to add an updated version.
Attachment #168563 - Attachment is obsolete: true
Attachment #168563 - Flags: review?(neil.parkwaycc.co.uk)
(Assignee)

Comment 44

12 years ago
Created attachment 171343 [details] [diff] [review]
Fix for DND Move/Copy bug v3

Revised version that fixes bitrot - still only will fix the dnd in address
book, not the copy & paste menu items.
(Assignee)

Updated

12 years ago
Attachment #171343 - Flags: review?(bienvenu)

Updated

12 years ago
Attachment #171343 - Flags: review?(bienvenu) → review+
(Assignee)

Updated

12 years ago
Attachment #171343 - Flags: superreview?(mscott)
(Assignee)

Updated

12 years ago
Target Milestone: --- → mozilla1.8beta
(Assignee)

Comment 45

12 years ago
Created attachment 172084 [details] [diff] [review]
Thunderbird DND Move/Copy Additional Patch

This is an additional patch that we need to stop thunderbird breaking. It just
applies the same changes to the thunderbird addressbook.properties as the Fix
DND Move/Copy v3 patch does to mailnews.

These patches will need to be applied to the tree together.
Attachment #172084 - Flags: superreview?(mscott)
Attachment #172084 - Flags: review?(bienvenu)

Updated

12 years ago
Attachment #172084 - Flags: review?(bienvenu) → review+
(Assignee)

Comment 46

12 years ago
Scott any chance of an sr of this dnd fix(es) for address book before 1.8b
branch? I don't think it can be classed as a release blocker, but it's a long
awaited fix for both mailnews and thunderbird that would be good to get in.

Comment 47

12 years ago
Comment on attachment 171343 [details] [diff] [review]
Fix for DND Move/Copy bug v3

A drop operation should never result in a prompt after the drop.

The code should just not allow the drop if the selection contains a mailing
list. 

I'd suggest modifing the method for reporting if a drag is enabled to say no 
if the drag items include a mailing list. 

Then remove all the code and the string bundle change for the prompt that got
added. Otherwise the code looked good.
Attachment #171343 - Flags: superreview?(mscott) → superreview-
(Assignee)

Comment 48

12 years ago
Comment on attachment 172084 [details] [diff] [review]
Thunderbird DND Move/Copy Additional Patch

Clearing extra request, as I'll be wrapping the two patches into one with
scott's latest comments.
Attachment #172084 - Attachment is obsolete: true
Attachment #172084 - Flags: superreview?(mscott)
(Assignee)

Comment 49

12 years ago
On reassessing this bug, found two others that I think really should be fixed
before finishing this one. Adding dependencies.
Depends on: 134590, 152133
Target Milestone: mozilla1.8beta → Future

Comment 50

12 years ago
Still present in TB 1.0 build 20041206 for what it is worth.

Comment 51

12 years ago
Sorry for the second message to anyone that is cced, but I do not know what to
do with the attached patch. I went to download it and I don't really know how to
install it. Is there a help section about installing patched somewhere or can
some one explain it to me.

Thanks.
(Assignee)

Updated

12 years ago
No longer blocks: 150632
(Assignee)

Updated

12 years ago
Depends on: 302086
(Assignee)

Updated

12 years ago
Component: Address Book → MailNews: Address Book
Product: Mozilla Application Suite → Core
Target Milestone: Future → ---
(Assignee)

Updated

12 years ago
No longer blocks: 250394
(Assignee)

Comment 52

12 years ago
*** Bug 250394 has been marked as a duplicate of this bug. ***
(Assignee)

Updated

12 years ago
Blocks: 242517
(Assignee)

Comment 53

11 years ago
*** Bug 320985 has been marked as a duplicate of this bug. ***
(Assignee)

Updated

11 years ago
Blocks: 320169
(Assignee)

Updated

11 years ago
Depends on: 336241
(Assignee)

Comment 54

11 years ago
Created attachment 220535 [details] [diff] [review]
Part 1. Only allow copy from read-only directories (checked in, trun + branch).

This patch will change the UI so that only copying is allowed from read-only (e.g. ldap) directories, and only copying or moving are allowed from read-write directories. This is the first part of a series of dnd patches.

It really needs bug 336241 (check if drop is allowed when modifier keys change) fixing before it can go into a proper release, however I don't see a problem with fixing it on trunk in the meantime.
Attachment #171343 - Attachment is obsolete: true
Attachment #220535 - Flags: superreview?(bienvenu)
Attachment #220535 - Flags: review?(bienvenu)

Comment 55

11 years ago
Comment on attachment 220535 [details] [diff] [review]
Part 1. Only allow copy from read-only directories (checked in, trun + branch).

thx, Mark.
Attachment #220535 - Flags: superreview?(bienvenu)
Attachment #220535 - Flags: superreview+
Attachment #220535 - Flags: review?(bienvenu)
Attachment #220535 - Flags: review+
(Assignee)

Updated

11 years ago
Keywords: helpwanted
(Assignee)

Updated

11 years ago
Attachment #220535 - Attachment description: Part 1. Only allow copy from read-only directories. → Part 1. Only allow copy from read-only directories (checked in).
(Assignee)

Comment 56

11 years ago
Created attachment 221344 [details] [diff] [review]
Part 2. Implement the main dnd functionality properly (diff -w)

I think this is now ready for review. I've done various testing on the items mentioned in the comments for canDrop and I think it is all at least behaving sensibly, but its also time to get some more eyes on it.

The only thing I would like to be able to do is default to copy when dragging, however I can't find a way to do that at the moment, so I'm going to follow it up on the newsgroups. However, this patch still improves the current situation a lot.

The non diff -w version is coming up in a moment.
Attachment #221344 - Flags: review?(neil)
(Assignee)

Comment 57

11 years ago
Created attachment 221345 [details] [diff] [review]
Part 2. Implement the main dnd functionality properly (normal patch)

Comment 58

11 years ago
I think we should default to move when dragging. After all the whole point is to have only one entry per person/email address/whatever.

Comment 59

11 years ago
Comment on attachment 221344 [details] [diff] [review]
Part 2. Implement the main dnd functionality properly (diff -w)

>+      if (selectedRows == "")
Nit: if (!selectedRows)

>+    if (srcURI.split(targetURI) != srcURI)
That's probably the wrong test, since what you really want to know is if the targetURI begins with srcURI.

>+      if (dataObj)
>+        dataObj = dataObj.value.QueryInterface(Components.interfaces.nsISupportsString);
>+      else
>+        continue;
Nit: if (!dataObj) and no else. Or possibly if (!(dataObj instanceof ...))
Attachment #221344 - Flags: review?(neil) → review+
(Assignee)

Comment 60

11 years ago
Comment on attachment 220535 [details] [diff] [review]
Part 1. Only allow copy from read-only directories (checked in, trun + branch).

Requesting 1.8 approval on the first part of this dnd patch. It's been on trunk for a while now and will go in at the same time as the already approved patch on bug 336241.
Attachment #220535 - Flags: approval-branch-1.8.1?(mscott)

Updated

11 years ago
Attachment #220535 - Flags: approval-branch-1.8.1?(mscott) → approval-branch-1.8.1+
(Assignee)

Updated

11 years ago
Keywords: fixed-seamonkey1.1a, fixed1.8.1
Whiteboard: nab-copy,nab-move → fixed1.8.1 and fixed-seamonkey1.1a only apply to Part 1.
(Assignee)

Updated

11 years ago
Attachment #220535 - Attachment description: Part 1. Only allow copy from read-only directories (checked in). → Part 1. Only allow copy from read-only directories (checked in, trun + branch).
(Assignee)

Comment 61

11 years ago
Created attachment 222803 [details] [diff] [review]
Part 2 v2. Implement the main dnd functionality properly (diff -w)

Updated patch to address Neil's comment, carrying forward his r+, requesting sr
Attachment #221344 - Attachment is obsolete: true
Attachment #222803 - Flags: superreview?(bienvenu)
Attachment #222803 - Flags: review+
(Assignee)

Comment 62

11 years ago
Created attachment 222804 [details] [diff] [review]
Part 2 v2. Implement the main dnd functionality properly (normal patch, checked in trunk + branch)

Normal version of Part 2 v2
Attachment #222803 - Attachment is obsolete: true
Attachment #222803 - Flags: superreview?(bienvenu)
(Assignee)

Comment 63

11 years ago
Comment on attachment 221345 [details] [diff] [review]
Part 2. Implement the main dnd functionality properly (normal patch)

Sorry for spam, obsolete the correct patch...
Attachment #221345 - Attachment is obsolete: true
(Assignee)

Comment 64

11 years ago
Comment on attachment 222803 [details] [diff] [review]
Part 2 v2. Implement the main dnd functionality properly (diff -w)

...re-requesting superreview on the correct patch.
Attachment #222803 - Attachment is obsolete: false
Attachment #222803 - Flags: superreview?(bienvenu)

Updated

11 years ago
Attachment #222803 - Flags: superreview?(bienvenu) → superreview+
(Assignee)

Comment 65

11 years ago
Comment on attachment 222804 [details] [diff] [review]
Part 2 v2. Implement the main dnd functionality properly (normal patch, checked in trunk + branch)

Checked in on trunk. I'll leave it there for a few days, and then request branch approval, should be in time for SeaMonkey 1.1a/Thunderbird 2.0a
Attachment #222804 - Attachment description: Part 2 v2. Implement the main dnd functionality properly (normal patch) → Part 2 v2. Implement the main dnd functionality properly (normal patch, checked in trunk)
(Assignee)

Comment 66

11 years ago
Marking as fixed. I'll request branch approval in a few days once its had time to soak on trunk.
Status: ASSIGNED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED
(Assignee)

Comment 67

11 years ago
Comment on attachment 222803 [details] [diff] [review]
Part 2 v2. Implement the main dnd functionality properly (diff -w)

How about getting this in in time for Thunderbird 2.0a/SeaMonkey 1.1a when the branch reopens?

Implements much better drag and drop functionality in address book.
Attachment #222803 - Flags: approval-branch-1.8.1?(mscott)

Comment 68

11 years ago
Comment on attachment 222803 [details] [diff] [review]
Part 2 v2. Implement the main dnd functionality properly (diff -w)

sounds good to me. The branch is closed for anything that effects Firefox. mail changes are still fine.
Attachment #222803 - Flags: approval-branch-1.8.1?(mscott) → approval-branch-1.8.1+
(Assignee)

Comment 69

11 years ago
Comment on attachment 222804 [details] [diff] [review]
Part 2 v2. Implement the main dnd functionality properly (normal patch, checked in trunk + branch)

Part 2 also checked into the branch.
Attachment #222804 - Attachment description: Part 2 v2. Implement the main dnd functionality properly (normal patch, checked in trunk) → Part 2 v2. Implement the main dnd functionality properly (normal patch, checked in trunk + branch)
(Assignee)

Updated

11 years ago
Whiteboard: fixed1.8.1 and fixed-seamonkey1.1a only apply to Part 1.

Comment 70

11 years ago
I assume this only fixes drag and drop and not moving/copying and pasting using the edit menu/keyboard? I filed Bug 339227 only a few days ago, which concerns the latter case. If it does fix edit menu copy/cut/paste (I have checked Thunderbird 2alpha1 20060527 and it does not appear to fix this), then Bug 339227 is a duplicate with apologies.
(Assignee)

Comment 71

11 years ago
*** Bug 347904 has been marked as a duplicate of this bug. ***
(Assignee)

Updated

10 years ago
Duplicate of this bug: 365453
(Assignee)

Comment 73

10 years ago
I think this needs a relnote for the SeaMonkey 1.1 release at least, something along the lines of:

It is now possible to move or copy cards between address books.

Cards can only be copied to mailing lists, so you need to use ctrl key whilst dragging to copy the card to the mailing list.

When dragging cards between address books, the default action is move,
use ctrl to copy instead.
Keywords: relnote
Whiteboard: relnote-seamonkey1.1
verified fixed 1.8.1.3 Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.8.1.3) Gecko/20070326 Thunderbird/2.0.0.0 Mnenhy/0.7.5.0 ID:2007032620
Keywords: verified1.8.1.3
Product: Core → MailNews Core
(Assignee)

Updated

5 years ago
Keywords: relnote

Comment 75

5 years ago
Created attachment 658908 [details] [diff] [review]
patch test
You need to log in before you can comment on or make changes to this bug.