Closed Bug 432016 Opened 13 years ago Closed 11 years ago

Modern theme lacks icons/etc files from Toolkit/Winstripe/Classic "global" theme

Categories

(SeaMonkey :: Themes, defect)

defect
Not set
major

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 465924

People

(Reporter: sgautherie, Unassigned)

Details

(Keywords: modern)

See bug 431955 comment 3:
{{
Robert Kaiser   2008-05-02 19:13:56 PDT

You're right in that Modern misses the icon, just like it does miss a number of
other things on trunk, as nobody did really maintain it to keep up with the
default theme and the toolkit change on trunk.
}}

Bug 416219 is probably a part of the same "issue".

***

From what I understand:

<classic.jar> is a merge of
</suite/themes/classic/jar.mn>
</toolkit/themes/winstripe/global/jar.mn>
</toolkit/themes/winstripe/help/jar.mn>
</toolkit/themes/winstripe/mozapps/jar.mn>

<modern.jar> is built from only
</suite/themes/modern/jar.mn>
which contains a few lines like
{{
  skin/modern/global/icons/autoscroll.png                          (/toolkit/themes/winstripe/global/icons/autoscroll.png)
}}
which refers to Winstripe.

***

In the example noticed in bug 431955,
we would need to port bug 429282 to SM
<http://bonsai.mozilla.org/cvsblame.cgi?file=/mozilla/toolkit/themes/winstripe/global/jar.mn&rev=1.58&mark=136#134>

How should this be done ?
*Port/Add more |/toolkit/themes/winstripe/*| lines ?
*Port "all" of them or only "selected" ones ?
*...
First we will need graphics consistent with the modern theme. Modern is supposed to look identical no matter what platform i.e. does not follow OS theme or HIG at all.
(In reply to comment #1)
> First we will need graphics consistent with the modern theme. Modern is

"I" am not the one who can create new images.
But wouldn't it be better (for the time being) to use the Winstripe images than miss the images ?

> supposed to look identical no matter what platform i.e. does not follow OS
> theme or HIG at all.

Using Winstripe images, without its "aero" part should achieve this.
> 
> From what I understand:
> 
> <classic.jar> is a merge of
> </suite/themes/classic/jar.mn>
> </toolkit/themes/winstripe/global/jar.mn>
> </toolkit/themes/winstripe/help/jar.mn>
> </toolkit/themes/winstripe/mozapps/jar.mn>

</toolkit/themes/*stripe/> - it depends on what platform you use what *stripe files you get.

By the way Bug 428227 has the spring.gif graphic and jar.mn patch for modern, waiting for r/sr
Blocks: 428227
Moving to Core->Themes (see http://www.gerv.net/temp/bmo-reorg.html and Bug 334962)
Assignee: general → nobody
Component: General → Themes
Product: Mozilla Application Suite → Core
QA Contact: general → themes
> and Bug 334962
Err I meant Bug 334964
No longer blocks: 428227
Depends on: 428227
Product: Core → SeaMonkey
Someone with sufficient rights please add bug 448909 to the Depends On list so that everyone can see that <video> controls will only work in Modern when this bug is fixed.
Blocks: 456757
> Someone with sufficient rights please add bug 448909 to the Depends On list so

The new Modern tracking bug (Bug 456757). Please file a new bug on this and make it depend on bug 456757.
I'm a little bit confused by this bug, maybe it's the title. If you include a bunch of files from toolkit/themes/winstripe/global/ the only effect you'll get is that the theming will be identical to Winstripe. But that is not the intention here, right?
> But that is not the intention here, right?

Right. I'll probably spin off a bug from bug 456757 to track /global/ as part of the Modernize Modern drive and dup this to that (since there are too many confusing comments here).
(In reply to comment #8)
> > Someone with sufficient rights please add bug 448909 to the Depends On list so
> 
> The new Modern tracking bug (Bug 456757). Please file a new bug on this and
> make it depend on bug 456757.

Done: Bug 458246.
Blocks: 493022
No longer blocks: 416219
Depends on: 512254
No longer depends on: 429282
No longer blocks: 493022
Work is being done in Bug 465924 and all the patches are there. =>DUPLICATE
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 465924
No longer blocks: 456757
No longer depends on: 428227, 512254
You need to log in before you can comment on or make changes to this bug.