Extra language packs installed from ftp.mozilla.org don't get updated

RESOLVED DUPLICATE of bug 485617

Status

enhancement
P5
normal
RESOLVED DUPLICATE of bug 485617
11 years ago
4 years ago

People

(Reporter: nONoNonO, Unassigned)

Tracking

unspecified
Future
x86
Windows XP
Dependency tree / graph

Details

()

This bug relates to both bug 336372 and bug 313453.
Bug 336372 describes that language packs aren't updated and this is fixed for language packs that are hosted on AMO by bug 313453, but this only partially solved bug 336372.

There are also official language packs available from ftp.

I think AMO has all the information to also check for updates for these language packs, since the filename can be derived from %APP%, %VERSION%, %OS% and %LOCALE%: ftp://ftp.mozilla.com/pub/%APP%/releases/%VERSION%/%OS%/xpi/%LOCALE%.xpi

Maybe the only (vital?) thing missing is the extension ID or GUID, but this would only be a problem if there are also unofficial language packs out there that might get updated by an official one after upgrading you application.

Alternatively, AMO or the localization teams could provide all the official language packs on their site. Because bug 313453 is solved, this would help all language packs getting updated.

Pro of this alternative: The extra language packs get easier to find (no need to download them from ftp anymore) (for example for Firefox from https://addons.mozilla.org/en-US/firefox/browse/type:3)

Con: All language packs hosted on AMO should also be maintained om AMO by the editors or localization teams.
Steps to reproduce (copied and updated a bit from bug 336372):
1. Install Firefox 3.0 en-US from ftp://ftp.mozilla.org/pub/mozilla.org/firefox/releases/3.0/win32/en-US/Firefox%20Setup%203.0.exe
2. Add dutch or german language pack from ftp://ftp.mozilla.org/pub/mozilla.org/firefox/releases/3.0/win32/xpi/
3. Update Firefox to the latest version

Result:
Installed language pack is disabled and marked as not compatible and no updates are found.

Expected result:
Update for language pack is automatically found and installed.
Problem occurs also on Mac OS X
On Linux the problem doesn't appear if you are updating via a distribution repository (1 Firefox rpm, 1 Firefox language pack rpm)
Duplicate of this bug: 457569
Depends on: 464484
These are an automated part of the build process and new ones are generated with each release but there is no path to upgrade them.  

Since it sounds like people use them I don't think we should discontinue them.  I think we should add them to AMO and give them a GUID (which would allow them to update themselves).

Since they are automated it makes this more difficult.  I filed bug 464484 to provide a writable API.
No longer depends on: 464484
Depends on: 464483
Depends on: 485617
This is a long ways away
Severity: normal → enhancement
Depends on: 464484
Priority: -- → P5
Target Milestone: --- → Future
Duplicate of this bug: 657599
Where are the 4.0.1 language packs anyway?  4.0.1 disabled the two 4.0 language packs I have for use with the "quick locale switcher" extension, and I don't find the languages I'm interested in (en-GB, en-US, de-ALL - one of those is covered by the installed Firefox).  For TB this is and for FF 3.x this used to be a relatively simple manual procedure.
frank: The 4.0.1 language packs can be found here
ftp://ftp.mozilla.org/pub/firefox/releases/4.0.1/win32/xpi/

I see en-GB and en-US there but only de, not de-ALL
(In reply to comment #8)
> I see en-GB and en-US there but only de, not de-ALL

de-ALL is an invalid language tag, which is why such a langpack doesn't exist. :)

"de" already means "generic" German, no need to add anything to it.
Thanks for publishing the 4.0.1 language packs.  If it's not only me: it would be nice to have new public language packs whenever a new stable version disables old language packs.  Ignore the "de-ALL" detail, it's a Google i18n term for "any de", and one "de" should suffice for the purposes of any UI (but note that de-CH has no "szlig" = ß).
I would like to add this to the Thunderbird Papercuts list, as it is still the same: when Tb updates, it first says that it checks but then does not find any of the updated locales on the ftp server.
yes this will be really nice, some dev's need the availability for other locales to check their add-ons and it's not helpful to download all needed locale for every new thunderbird/firefox major by manually
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 485617
only confirmation - works on TB 17.x on Mac OS X
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.