Closed Bug 47760 Opened 22 years ago Closed 21 years ago

body text color persists longer than stylesheet that set it [AltSS]

Categories

(Core :: CSS Parsing and Computation, defect, P3)

x86
Linux
defect

Tracking

()

VERIFIED FIXED
mozilla0.9.9

People

(Reporter: dbaron, Assigned: dbaron)

References

()

Details

(Keywords: css1)

The text color of the BODY, set in CSS, is persisting even when the stylesheet
that set that color is no longer applied.  This problem occurs in our
alternate-stylesheet selection, and probably also occurs for dynamic
content-side switching of stylesheets (or perhaps style rules too...).

STEPS TO REPRODUCE:
 1) load http://www.people.fas.harvard.edu/~dbaron/
 2) select View | Use Stylesheet | None
 3) select View | Use Stylesheet | Plain
 4) select View | Use Stylesheet | None

EXPECTED RESULTS:
 1) text white on green
 2) text black on gray (or user default)
 3) text black on white
 4) text black on gray (or user default)

ACTUAL RESULTS:
 1) text white on green
 2) text white on gray <== THE BUG
 3) text black on white
 4) text black on gray (or user default)

BUGGY ON:
 * Linux mozilla opt build of 2000-08-05, 08:00 PDT.
I wonder if this could have something to do with nsHTMLStyleSheetImpl... it
doesn't seem like the body fixup rule.  Any ideas?
*** Bug 47736 has been marked as a duplicate of this bug. ***
I think I found a bug, which depends on this: If I use two stylesheets, where
one imports the other, the imported style is ignored. See bug 52105.
*** Bug 55937 has been marked as a duplicate of this bug. ***
Bug 55937 contained a nice little testcase. I wrote there: We need to remove the 
BodyFixupRule when we switch from an alternate stylesheet to 'none' or to another 
alternate stylesheet.
*** Bug 64815 has been marked as a duplicate of this bug. ***
(marking alternate style sheet bugs for easy tracking...)
Summary: body text color persists longer than stylesheet that set it → body text color persists longer than stylesheet that set it [ASS]
Summary: body text color persists longer than stylesheet that set it [ASS] → body text color persists longer than stylesheet that set it [AltSS]
Blocks: html4.01
Keywords: css1, mozilla1.0
*** Bug 66554 has been marked as a duplicate of this bug. ***
Netscape's standard compliance QA team reorganised itself once again, so taking 
remaining non-tables style bugs. Sorry about the spam. I tried to get this done 
directly at the database level, but apparently that is "not easy because of the 
shadow db", "plus it screws up the audit trail", so no can do...
QA Contact: chrisd → ian
Pierre: How would we go about removing the BodyFixupRule on a stylesheet change?
*** Bug 82446 has been marked as a duplicate of this bug. ***
Using build 2001060604 on Win2k (SP2)

I had posted a testcase in bug 82446 which showed the body text disappearing
into the white background after the style sheet was switched to none
(originally, the styles said color: white; background: black; and when swithed
to none, it would revert to defaults color: black; background: white;) because
the white text didn't switch to html.css' defaults (which is what this bug is
about).

http://bugzilla.mozilla.org/showattachment.cgi?attach_id=35929

However, now I am see that switching to "none" doesn't do anything to the styles
whatsoever.  It doesn't even turn the background to white.  This is something
pretty new.

Jake
This is bad because i have seen where text becomes unreadable on style switches.

My personal start page on my computer has multiple stylesheets and there are
more than just text color properties that do not reset... david's pages are too
basic ;-). With pages with more complex layout, mozilla does not reset other css
properties... like background-images...

Should I file a separate report for this issue and others?
Cool, most stuff in my testcase is working... at least the background is 
changing correctly.  This was fixed in bug 88681.  

http://bugzilla.mozilla.org/showattachment.cgi?attach_id=35929

any chance this bug will get fixed too???

Jake

Looks like http://www.libpr0n.com/ is hampered by this bug.

Try switching the stylesheet to "none".  Notice how most of the actual 
information on the page is hidden because it is left as white text on a white 
background.  The background changes quite nicely, but the text fails to make 
the change back to its default color black.


This bug needs to be fixed in order to support the viewing of basic content 
without style.  The document content is the most important thing about a 
document and it ought to be able to be viewed without styling.  

Can this please get some priority?  Maybe milestone 0.9.4?

Jake
Status: NEW → ASSIGNED
Target Milestone: --- → mozilla0.9.9
This seems fixed by my checkin of bug 116161 yesterday.  I think it was due to
misuse of the HTMLDocumentColorRule.
Assignee: pierre → dbaron
Status: ASSIGNED → NEW
Depends on: 116161
marking fixed
Status: NEW → RESOLVED
Closed: 21 years ago
Resolution: --- → FIXED
This bug is fixed .... verifying.
However, bug 133219 is still open for the crash seen on http://www.libpr0n.com 
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.