If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Customize toolbar should have button for "Archive"

RESOLVED FIXED in Thunderbird 3.0rc1

Status

Thunderbird
Toolbars and Tabs
--
enhancement
RESOLVED FIXED
9 years ago
7 years ago

People

(Reporter: Tristan Young, Assigned: Magnus Melin)

Tracking

({icon})

Trunk
Thunderbird 3.0rc1
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments, 4 obsolete attachments)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b2) Gecko/20081201 Firefox/3.1b2 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b3pre) Gecko/20090223 Thunderbird/3.0b2

When customizing the toolbars, there are buttons for "Reply", "Junk", "Delete", etc, but nothing for "Archive".  It seems to have been missed.

There is a button available directly above the message in the message preview pane, and full-window message view.  Since the other buttons like "Junk" have been made available for customizing toolbars, it makes sense to also offer "Archive" for completeness.  This way, we can hide the message preview pane, and still have the ability to send messages to archive.

Reproducible: Always

Steps to Reproduce:
1. Use Thunderbird v3 b2
2. Hide the preview pane (F8)
3. Select a message, and click the "Archive" button in the upper toolbar.  Wait, you can't!  It's not there :)




I like the archive feature.  I haven't played with it much, but it will come in real handy. I can't wait for the official release version of Thunderbird v3, so I can start using this feature on my work computer.

Comment 1

9 years ago
Other ways to activate the the "Archive" function is to use Message > Archive from the menu, or to hit the 'A' keyboard shortcut (the latter pending change to a two-key shortcut per bug 476590). Thus, it is nevertheless possible to perform the archive function despite the header pane not being visible.

However, there is a clear inconsistency with other functions for which buttons are provided in the header pane and where corresponding toolbar buttons exist. Thus, adding a toolbar icon at least to the "Customize" palette would be more consequently applying that scheme.

Confirming for the missing toolbar button.
Status: UNCONFIRMED → NEW
Component: Mail Window Front End → Toolbars and Tabs
Ever confirmed: true
OS: Windows XP → All
QA Contact: front-end → toolbars-tabs
Hardware: x86 → All
Version: unspecified → Trunk
(Assignee)

Updated

9 years ago
Keywords: icon

Updated

9 years ago
Duplicate of this bug: 489164
Created attachment 376891 [details]
folder icon by Lapo

Here is the icon for the toolbar
Created attachment 376895 [details]
modified mail-toolbar, big size
Attachment #376891 - Attachment is obsolete: true
Created attachment 376896 [details]
modified mail-toolbar, small size
(Assignee)

Updated

8 years ago
Assignee: nobody → mkmelin+mozilla
Duplicate of this bug: 503883
(Assignee)

Updated

8 years ago
Depends on: 506011

Comment 7

8 years ago
No archive icon in the toolbar customization for Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.4pre) Gecko/20090914 Shredder/3.0b4pre yet, despite bug 506011 comment #7. Thus, yet needs to be done for XP at least.
hm, the css is there, so maybe some code is missing?

from primaryToolbar.css in trunk:
#button-archive {
  -moz-image-region: rect(0px 480px 24px 456px);
}

#button-archive:hover {
  -moz-image-region: rect(24px 480px 48px 456px);
}

#button-archive[disabled] {
  -moz-image-region: rect(48px 480px 72px 456px) !important;
}
(Assignee)

Comment 9

8 years ago
Created attachment 401706 [details] [diff] [review]
proposed fix

For qute the css was already there, however, the mac main toolbar images are still missing an archive icon (this patch assumes one is added at the end of the image list)

Andreas, know if the mac toolbar is being updated somewhere?
Attachment #376895 - Attachment is obsolete: true
Attachment #376896 - Attachment is obsolete: true
(Assignee)

Updated

8 years ago
Target Milestone: --- → Thunderbird 3.0rc1
(Assignee)

Updated

8 years ago
Status: NEW → ASSIGNED
Whiteboard: [has pach, need mac toolbar to have archive icon]
Created attachment 402323 [details] [diff] [review]
pinstripe toolbar icon patch
Attachment #402323 - Flags: ui-review?(clarkbw)
Attachment #402323 - Flags: review?(mkmelin+mozilla)
(Assignee)

Comment 11

8 years ago
Comment on attachment 402323 [details] [diff] [review]
pinstripe toolbar icon patch

Images looks good to me.
Attachment #402323 - Flags: review?(mkmelin+mozilla) → review+
(Assignee)

Comment 12

8 years ago
Created attachment 402386 [details] [diff] [review]
proposed fix, v2

Patch including the new mac toolbar images. Thanks a lot for those Andreas!
Attachment #401706 - Attachment is obsolete: true
Attachment #402386 - Flags: ui-review?(clarkbw)
Attachment #402386 - Flags: review?(philringnalda)
(Assignee)

Updated

8 years ago
Whiteboard: [has pach, need mac toolbar to have archive icon] → [has l10n impact] [has pach for review]
Comment on attachment 402323 [details] [diff] [review]
pinstripe toolbar icon patch

looks good
Attachment #402323 - Flags: ui-review?(clarkbw) → ui-review+
Comment on attachment 402386 [details] [diff] [review]
proposed fix, v2

I think "Archive selected messages" is a fine tooltip but we've used the singluar "message" for all the other tooltips (forward, delete, file) so it's probably best to keep consistent.  ui-r+ with that.
Attachment #402386 - Flags: ui-review?(clarkbw) → ui-review+
Comment on attachment 402386 [details] [diff] [review]
proposed fix, v2

Purty, do it!

Junk, Mark, and Tag are all plural, and I can't get the File tooltip to show at all, but I'm strongly disinclined to argue with anyone who has an opinion either way, much less with clarkbw :)
Attachment #402386 - Flags: review?(philringnalda)
Attachment #402386 - Flags: review+
Attachment #402386 - Flags: approval-thunderbird3+
(Assignee)

Comment 16

8 years ago
changeset:   3921:7c2eb92dd7ba
http://hg.mozilla.org/comm-central/rev/7c2eb92dd7ba

->FIXED

We decided on irc the goal should be plural - filed bug 518905 to make them consistent.
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
Summary: Customize toolbar missing button for "Archive" → Customize toolbar should have button for "Archive"
Whiteboard: [has l10n impact] [has pach for review]
Depends on: 531829
You need to log in before you can comment on or make changes to this bug.