Closed Bug 487003 Opened 11 years ago Closed 10 years ago

wrong favicon still frequent in Firefox 3.5 and 3.6

Categories

(Firefox :: Bookmarks & History, defect, major)

3.5 Branch
defect
Not set
major

Tracking

()

VERIFIED FIXED
Firefox 3.7a3

People

(Reporter: david, Unassigned)

References

Details

(Whiteboard: [redirect issues should have been solved by bug 542943])

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b3) Gecko/20090305 Firefox/3.1b3 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b3) Gecko/20090305 Firefox/3.1b3 (.NET CLR 3.5.30729)

Bookmarks toolbsr frequently gets correct favicon replaced by wrong favicon.  This seems to be somehow connected to loading several pages at once in different tabs/windows, where the favicon of a page that is loaded replaces the favicon of an existing bookmark (that was visited at or near the same time) in the toolbar.

Reproducible: Sometimes




This is a continuation of bug 411966.
Severity: normal → major
please report a set of steps to reproduce your problem and list of sites where you see it.
It happens at random and affects all sites.  I click on a link in my bookmark toolbar and around the same time visit another website in a different tab or window.  The favicon for the existing toolbar link gets replaced by the favicon for the other site.  This seems to happen equally often to any link I have bookmarked.
could also be your database is corrupt, you should try to open places.sqlite with a third party sqlite manager/browser and try executing "PRAGMA integrity_check" query.
you could use sqlite browser to execute the query
http://sourceforge.net/projects/sqlitebrowser/
This happens to me frequently too, very annoying.
sqlite browser is
a) Unavailable on many platforms that firefox is available for.
b) Isn't something you should expect an end-user to run.

Additionally, this is a continuation of Bug 411966 not a new bug. That bug was closed, incorrectly in my opinion, because a 'Fix was applied', testing showed that 'Fix' did what it was supposed to. But the incorrect behaviour still exists.

Why is this bug still marked Unconfirmed?
You can always download the SQLite Manager extension https://addons.mozilla.org/en-US/firefox/addon/5817
(In reply to comment #6)
> sqlite browser is
> a) Unavailable on many platforms that firefox is available for.
> b) Isn't something you should expect an end-user to run.
Fine, but we cannot read your computers mind, or yours for that matter, so until we get more data, we cannot fix this issue.  This is not a common issue.

> Additionally, this is a continuation of Bug 411966 not a new bug. That bug was
> closed, incorrectly in my opinion, because a 'Fix was applied', testing showed
> that 'Fix' did what it was supposed to. But the incorrect behaviour still
> exists.
We fixed an instance of the problem that we uncovered based on debugging discussed in the bug.  If you are seeing this, you have a different issue.
[url=https://bugzilla.mozilla.org/show_bug.cgi?id=411966]Bug 422966[/url] which I commented on here

[url=https://bugzilla.mozilla.org/show_bug.cgi?id=411966#c19]Comment #19[/url] From  Robert Janc   2008-04-20 08:25:18 PDT

has been solved. I've been running FF3.5b4 since it was released and have not seen the problem. Prior to that I could reproduce the problem at will.
Apparently, this is a common issue -  Bug 186532 , Bug 491103 , Bug 492259 , Bug 113430 , Bug 117895 , bug 250598  and so on...

The problem appears to be that favicon storage is very problematic.

Bug 120352 was an attempt at a tracking bug for all these problems, so that individual attempts on fixes wouldn't happen in isolation. But that hasn't appeared to been used.
I'm seeing this with FF 3.5b4 -- I've got several nameless bookmarks on my toolbar, and the one for Facebook often has a Yahoo favicon showing.  I'll try to check in the SQLite DB to see what's happening.
ben, that'd be great, thanks.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Duplicate of this bug: 491103
I ran PRAGMA integrity_check, opened Firefox again and I could reproduce the bug easily. For me, it happens even when I have one tab open. The bookmark is for my Yahoo! Mail. When I open a page belonging to usembassy.gov, Yahoo! icon is replaced with US Embassy icon.
I tried Huji's example in Comment 14 using FF3.5b3 on OSX 10.5.7 and could not reproduce it. The Yahoo icon never changed. Actually I have never seen this I switched to FF3.5b3 from FF3.0.x. NOTE: When I did see it in the past it almost always involved a Yahoo site like Yahoo weather.
(In reply to comment #15)
> Actually I have never seen this I switched to FF3.5b3 from FF3.0.x. NOTE: When
I did see it in the past it almost always involved a Yahoo site like Yahoo weather.

Same here
I can confirm the bug still persists on FF3.0.11. It happens at random, and there's no pattern to it whatsoever (at least none that I could figure out)
I have followed both this bug and Bug 411966 eagerly for about a year, when I started experiencing the issue described in the latter bug on a regular basis. I upgraded today to Firefox 3.5 in the hopes that it would resolve this bug, but sadly, the problem is persistent for me.

Details, and how to reproduce:

I am running Windows XP (latest service packs and updates applied), and have experienced this problem on all versions of Firefox 3, including version 3.5 which was released today. I never experienced it with previous (<3) versions of Firefox.

I have the Bookmarks Toolbar displayed. It has links to my start page, Google, and an intranet start page at work. My personal start page has links to some pages I read. When I click those links (usually I am middle-clicking on an HTML link to open in a new tab), sometimes the favicon displayed for one of the entries on my Bookmarks Toolbar changes to reflect the favicon for the newly opened, unrelated site.

For me, it seems to happen most frequently (probably over 90%) when opening http://www.svextra.com/blogs/gmsv/ and http://linuxtoday.com/. When opening http://www.google.com/, it happens sporadically. I find that the first and third Bookmark Toolbar entries seem most commonly erroneously replaced. These are not hard and fast rules (I find the problem occasionally on other sites). In every case, clicking on the Bookmarks Toolbar entry that has been erroneously changed forces a favicon reload, which fixes the problem.

Using Cygwin's sqlite3, I ran "PRAGMA integrity_check" on (profile)\Application Data\/Mozilla\Firefox\Profiles\(randomstring).default\places.sqlite while Firefox was closed; it returned a terse "ok" result.

Possibly related bugs:

I did some searching on bugs with "favicon" in their summaries and came up with Bug 118070, Bug 271359, Bug 461978, Bug 433299, and Bug 501396 which seem like they might be duplicates. I chose this bug because of its continuity with Bug 411966, which had a good description of the original problem.

Please let me know if screen shots, diagnostics, etc. would be useful. This seemingly trivial little behavior bugs me pretty disproportionately!
Duplicate of this bug: 501443
Duplicate of this bug: 501396
Duplicate of this bug: 502838
OS: Windows XP → All
Hardware: x86 → All
Summary: wrong favicon still frequent in Firefox 3.1 → wrong favicon still frequent in Firefox 3.5
Version: unspecified → 3.5 Branch
Hope this gets fixed soon - The only problem with Firefox 3.5 I've noticed so far..
Duplicate of this bug: 504789
I have been able to reproduce this bug on both of my computers.  One computer is running windows XP Pro; the other Windows Vista.
Steps to reproduce:
1)  go to www.google.com.  Add google bookmark to bookmarks toolbar.  The 'g' icon should appear.
2)  Go to http://mlb.mlb.com/index.jsp  Add this site to bookmark toolbar.
3)  Go to http://www.netflix.com.  Bookmark toolbar this site as well.
4)  Open new tab.  Go to google by using bookmark.  Navigate to MLB.com by using bookmark.  Watch google bookmark icon.  On my computers, it switches to MLB icon in a few seconds.
5)  Navigate back to google using bookmark.  It should switch back to proper icon in a few seconds.  
6)  Close Firefox, then reopen.  Go to google, then Netflix.  Similarly, the icon changes from google to netflix icon.  Icon changes back when navigating back to google.

As I said, this happens on both of my PC's.  I hope this helps you guys figure out the source of the bug.
I can also reproduce the favicon changing incorrectly in a specific case.   I have a Google bookmark on my toolbar.  When I go to the GNUCash website (gnucash.org), which is NOT a bookmark (I type it into the address bar), the Google bookmark's icon will change to the GNUCash icon.  This is fixed by visiting the google bookmark.
(In reply to comment #24)
I can't reproduce this.  Can you reproduce using those STR in a new profile?   Also, you didn't specify how you were navigating to those sites...opening them in a new tab, same tab, left click, middle click, ctrl click?
Duplicate of this bug: 511668
Exactly the same problem here, since one of the betas of Firefox 3. And still on Firefox 3.5. Quite annoying.

A screenshot here : https://bug511668.bugzilla.mozilla.org/attachment.cgi?id=395599
Concur.  The icon for Yahoo! in my Bookmarks Toolbar is OFTEN being replaced by the icon for some other site I recently opened -- whether it be the current Firefox session or the previous one.  The problem is not limited to Yahoo, but that's the one most frequently affected.  Other sites whose icons in the Bookmarks Toolbar are also being incorrectly replaced with those from other recently-open sites include Hotmail, Redfin, and even NOAA.  

Typically re-freshed to the correct icon after I open the site by clicking on it....but may take a minute to fix, even after the site has been opened in a fresh tab.

Typically (but not always) occurs when more than one tab was open.

Sometimes also occurs upon launching Firefox from scratch with only a signel default home page tab open.
I have a new piece of information. This bug appears to not manifest itself if private browsing mode is enabled. If I enter private browsing mode (I usually press Ctrl+Shift+P), then run the repro cases in comment #18, no incorrect icon updating is observed. Hope this helps in diagnosing the problem!
This was reported on April 5th and it's still out there?  Man...I could've learned C/C++/PERL/Gecko and everything else by now and fixed the bug....in fact, I think I'll go buy the OReilly books and get started.
(In reply to comment #31)
> This was reported on April 5th and it's still out there?  Man...I could've
> learned C/C++/PERL/Gecko and everything else by now and fixed the bug....in
> fact, I think I'll go buy the OReilly books and get started.
Have at it then.  This bug needs reliable steps to reproduce this issue.  Some people have provided steps but they seem to be the only people that can reproduce it with those steps.  No one has provided whatever it is that is actually causing this issue.  It could be as simple as one related bookmark between all of the users seeing this.
Make a bookmark to www.thedailyshow.com and to www.colbertnation.com in the bookmark bar. Switch between the two sites and watch them changing ...

The source of the pages don't show any reason, but the sites have the same IP. Could it be that it has to do with virtual servers that respond differently depending on given domain?
I was hoping this might fix this, but emptying the contents of the table moz_favicons in the places.sqlite file doesn't change this behavior.
Can anyone reproduce it with the domains I gave or any other domains with name-based virtual hosting (like many blogs)?
I tried but it didn't reproduce the bug. I'm still having the bug with Yahoo and one of the US Embassy web sites. I'm also having this problem with Google and GMail. The GMail icon changes to Google's when I make a search, and changes back when I check my email. This GMail/Google thing is new, and it wasn't like this two weeks ago. I don't think a change in IP or hosting information has taken place for GMail/Google recently, so I doubt shared IPs have anything to do with this bug. I've check that Yahoo/US Embassy pair too, and they are on different IPs.
I have this problem on both of my computers (home running Win 7, office running XP pro).  The profiles are not identical (I didn't copy the home profile and import to the office), but the bookmarks were imported at the office.  The problem isn't reliably reproducible, but I have noticed some things that might help.

First, it happens even when all of my plugins are disabled.

Second, the new icon does not always come from a bookmarked site.  I frequently get bookmark icons replaced with favicons from a site I've just visited.

Third, the new icon does not have to come from a site I've visited recently or have bookmarked.  On my office computer, I deleted a bookmark to break.com (imported from my home computer).  I don't believe I've ever visited the site on that computer, but even if I have, I occasionally purge all browser history. I'm not even sure where it's finding that link, but the icon frequently replaces one particular bookmark icon (for a link to ucomics.com).
I still see this bug in a brand new installation of Firefox 3.6b4 on Windows 7.  I have been trying to look for a pattern and I think it happens when the total number of open tabs gets too large.  When I have a relatively small number of tabs open (maybe less than 100 or so) I never see the bug.  When I get up to a couple hundred tabs it happens over and over and over again.  Is it possible that some data structure is overflowing?  Do other people who see this have a lot of tabs open?  Do you see the problem with just a few tabs open?
Could this be related to the weak hash function used for the cache and in other places? 

see: bug 290032, others
(In reply to comment #39)
> Could this be related to the weak hash function used for the cache and in other
> places?
> see: bug 290032, others

If i read comments in that bug correctly, hashtable implementation uses chaining on collisions, so it should not cause us problems afaict.
In case this helps, my favicons frequently get mixed up when I use "Clear Recent History" to clear the browsing history.  If I visit Site A and Site B in the same session and then clear the history, the bookmark for A sometimes gets the favicon of B or vice versa.  I'm using 3.6 beta 5, but it's been happening for a long time, at least since 3.0.
Yahoo appears to have gotten around the previous fix preventing tracking through use of the favicon. I am running XP Pro, XP, and Linux, in addition to NoScript, and I have the issue on all machines. going to yahoo logging in and checking mail, logging out (NO scripts allowed during process) then visiting another site will reproduce the issue. If I clear private data after logout, the problem will not occur. This is not a global issue (of the 15 favicons I have) but limited to yahoo. I have experimented with adding other "suspect" sites and none of them has done it either.
i can confirm this bug occurs on both osx & windows xp with firefox 3.6. usual suspect is the yahoo!mail icon & it gets replaced with various & sundry, most recently with the apple.com icon. it's not just yahoo!mail, however; other bookmarks also randomly misplace their actual favicon with something else.
I confirm this bug in Firefox 3.6 Linux. My compilation is Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.2) Gecko/20100121 Namoroka/3.6.
bug 542943 will probably fix this.
Depends on: 542943
Summary: wrong favicon still frequent in Firefox 3.5 → wrong favicon still frequent in Firefox 3.5 and 3.6
most of the internal causes for this should now be fixed, clearly old favicons could still be bad assigned, and we can't do much about that.

So remaining known reasons could be:
- real database corruption (something along bug 506905)
- old icons badly associated

If anyone has further steps to reproduce this thing after bug 542943 has been fixed, we will need any decent steps to reproduce.
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
Whiteboard: [redirect issues should have been solved by bug 542943]
Target Milestone: --- → Firefox 3.7a3
Duplicate of this bug: 553379
Duplicate of this bug: 547988
All:

Well, I'm sorry to report this error JUST OCCURRED to me again.  I'm using WinXP and Firefox 3.6.9.

The favicon for Hotmail on my Firefox bookmarks toolbar(lc2.law13.hotmail.passport.com/cgi-bin/login) was changed during my visit to two sites in succession.  The first was www.mediamonkey.com and the second was www.magic-tagger.com 

The hotmail favicon became the icon for mediamonkey and then magic tagger!  

Quickly reverted to the correct hotmail icon after I clicked on it to visit the hotmail site immediately after the incident.
(In reply to comment #49)
> All:
> 
> Well, I'm sorry to report this error JUST OCCURRED to me again.  I'm using
> WinXP and Firefox 3.6.9.

bug 542943 was fixed in FX 4, so I'm not surprised at all, you should reproduce with the latest beta to file a valid bug.
Sorry...I misunderstood the "RESOLVED FIXED" status for a bug to mean fixed in the current RELEASE build, and not a Beta or unreleased version.

A thousand pardons.
(In reply to comment #51)
> Sorry...I misunderstood the "RESOLVED FIXED" status for a bug to mean fixed in
> the current RELEASE build, and not a Beta or unreleased version.
> 
> A thousand pardons.

P.S.  Looking forward to FX 4 when I can finally not see this two year old bug anymore.
Duplicate of this bug: 605301
Duplicate of this bug: 608505
Duplicate of this bug: 544229
Verified on: 
Build identifier: Mozilla/5.0 (Windows NT 6.1; rv:2.2a1pre) Gecko/20110404 Firefox/4.2a1pre
Status: RESOLVED → VERIFIED
In my case, I have an incorrect favicon for a site that has no favicon. I followed all directions and can successfully rid my bookmarks toolbar of the favicon. However, when I visit the site again all is OK the first time but the second time I visit the site an incorrect favicon appears. The site is: http://dx.doi.org/
You need to log in before you can comment on or make changes to this bug.