Displaying a feed message (web page mode) that uses script to redirect a different url results in passing the url to the default browser.

REOPENED
Unassigned

Status

REOPENED
10 years ago
23 days ago

People

(Reporter: johannes.petereit, Unassigned)

Tracking

({privacy})

unspecified
privacy
Bug Flags:
wanted-thunderbird +

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9.1.3) Gecko/20090824 Firefox/3.5.3 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9.1.4pre) Gecko/20090915 Thunderbird/3.0b4

Whenever attempting to display a feed-post from a blog which uses the followers gadget from google friend connect the default webbrowser pops up and opens the given error url in a new tab. Not tested on other google friend connect gadgets, but will PROBABLY be reproducable on any other google friend gadget.

Reproducible: Always

Steps to Reproduce:
1. add a rss feed using the google friend connect "followers" widget to the mozilla rss reader (e.g. http://diaryofagraphicsprogrammer.blogspot.com/feeds/posts/default <-- NOT MY BLOG, NOT POSTED FOR ADVERTISING PURPOSES)
2. Click on a post
Actual Results:  
Default browser pops up displaying the following url in a new tab:
http://ps.friendconnect.gmodules.com/ps/ifr
The post clicked on however is displayed by thunderbird. Only the google friend connect gadget is deactivated.

Expected Results:  
No browser popping up and displaying some error page? o.O

Disabling these gadgets would be the fastest solutions, nobody needs them in a rss feed anyway.
(Reporter)

Updated

10 years ago
Summary: Displaying a Blog feed that uses a Google friend connect followers gadget yields in browser opening given error page. → Displaying a Blog feed that uses a Google friend connect followers gadget yields in browser opening an error page.
Duplicate of this bug: 538884
confirming with Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1.7) Gecko/20100111 Thunderbird/3.0.1 using the url feed provided in bug 538883
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: blocking-thunderbird3.1?

Comment 3

9 years ago
doubt we'd block on this, unless there are content policy issues here. Standard8?
blocking-thunderbird3.1: --- → ?
Flags: blocking-thunderbird3.1?
Whiteboard: [needs input Standard8]
(In reply to comment #3)
> doubt we'd block on this, unless there are content policy issues here.
> Standard8?

I think this is more a case of popup blocking than content policy - I suspect there's some js (which is allowed in feeds) or something calling an appropriate function (e.g. window.open) and we're just then handing it off to the browser.

Digging into what Firefox do for popup blocking may lead to a solution here.
Assignee: nobody → bugzilla
We're resetting the blocking flag for 3.1 on this bug and instead setting the wanted-thunderbird+ flag. We have too many blocking-3.1 bugs, to the point where it doesn't mean much, and managing the list is making it hard to actually work on closing bugs, which helps no one.

Thunderbird 3.1's primary purpose is to allow us to offer a prompted major update to Thunderbird 2 users, to ensure their continued ability to safely use Thunderbird.  Thunderbird 2 is built on an outdated version of Gecko, and our long-term ability to maintain the users' safety for Thunderbird 2 users is limited.

If you think this bug meets the requirements below, please renominate with a detailed explanation of how it meets the following two criteria, and we will reconsider.  To qualify, this bug must either:

a) make the upgrade experience from TB2 very painful for a large number of users

or

b) be a new, reproducible, severe quality issue (eg dataloss, frequent crashes)

Just because this bug doesn't block TB3.1 doesn't mean it can't or won't make the release.  Once they're done with their blockers (if any), we encourage developers to keep working on non-blocking bugs, and to try to land them as early in the cycle as possible, as non-blocking bugs will become increasingly difficult to land in the later stages of the cycle.
blocking-thunderbird3.1: ? → ---
Flags: wanted-thunderbird+

Comment 6

9 years ago
Confirming with Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1.9) Gecko/20100430 Fedora/3.0.4-2.fc12 Thunderbird/3.0.4 using feed http://calvinisticcartoons.blogspot.com/feeds/posts/default

Comment 7

9 years ago
Workaround:  after setting javascript.enabled to false I've not seen any  friendconnect pop-ups.
Duplicate of this bug: 565266
Duplicate of this bug: 544013
Duplicate of this bug: 576577

Comment 11

9 years ago
This is an incredibly annoying behavior. would be nice to see this one dealt with.

Comment 12

9 years ago
Funnily enough I was just thinking the same thing as I closed down the 10 tabs that had been opened in Firefox after catching up with a few blogs. Not only is the problem annoying, it's clearly a data leak too and one that could presumably be used to track certain eleemnts via a different browser profile, with different cookies etc. I'm quite surprised that it's not been fixed yet :(
Keywords: privacy
Whiteboard: [needs input Standard8]
Google announced that they are retiring Google Friends Connect at the end of 2011, or so my search shows. (I know nothing about this, just evaluating as a papercut nomination).
Assignee: mbanner → nobody

Updated

6 years ago
Duplicate of this bug: 838018
This is quite annoying. I think it's not related to blocked popups, as firefox doesn't show any popups to be blocked. 

A test case is Linus' blog http://torvalds-family.blogspot.com/feeds/posts/default - use show as web page. 

Loading it in a 3pane content tab doesn't show the problem... this works:
Components.classes['@mozilla.org/appshell/window-mediator;1'].getService(Components.interfaces.nsIWindowMediator).getMostRecentWindow("mail:3pane").document.getElementById("tabmail").openTab("contentTab", {contentPage: "http://torvalds-family.blogspot.fi/2009/05/more-reading.html"});
OS: Windows XP → All
Hardware: x86 → All

Comment 16

6 years ago
(I think) I've cured - well blocked - this, on The Verge RSS feed currently using AdBlockPlus to block the element containing the add-to Twit/Face/etc buttons. 

theverge.com##.social-media-column.clearfix.instapaper_ignore.entry-unrelated 

I'm currently testing on other RSS feeds

Comment 17

6 years ago
I have the same problem with this feed: http://feeds.feedburner.com/Rue89Strasbourg?format=xml

Comment 18

6 years ago
setting pref javascript.enabled will stop this, but may affect the display of the page.  dupe to bug 545596 since it has a wip patch.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 545596

Comment 19

6 years ago
this is actually not strictly due to a popup open, as per comment 15.  it is a redirect to a different url.  script trying to open a popup window could lead to the same effect though, an attempt to open the url in the default browser.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Summary: Displaying a Blog feed that uses a Google friend connect followers gadget yields in browser opening an error page. → Displaying a feed message (web page mode) that uses script to redirect a different url results in passing the url to the default browser.

Comment 20

6 years ago
so what's happening is the google code here:
http://www.google.com/friendconnect/script/friendconnect.js
is creating an iframe in the loaded page and doing a GET to
http://xxxx-opensocial.googleusercontent.com/gadgets/...

prior to Tb fully handling http content in a more browser like manner, a solution that works well is blocking that script with AdblockPlus.

Comment 21

6 years ago
I've read the Mozilla Bug reports and while everybody talks about it, NOTHING is being done about it.

I canned one newsfeed because of it, and 3 weeks after going to some other feed, it's started up again.

This is a ONE pixel .GIF image that I, for the life of me, cannot see as being useful.  What purpose would it serve to open my browser just to display 1 pixel??????  Couple that with it being on an HTTPS link.  Why?????

This should be a relatively easy fix....  Just BLOCK IT from going out from TBird.

SOMEBODY PLEASE DO SOMETHING.

Updated

4 years ago
Duplicate of this bug: 1093634

Updated

4 years ago
Duplicate of this bug: 1159396

Updated

3 years ago
Duplicate of this bug: 1244172

Updated

3 years ago
Duplicate of this bug: 1277308

Updated

3 years ago
Duplicate of this bug: 545596

Comment 28

a year ago
Yeah, some helpful soul in thunderbird.support suggested an ad blocker. I settled on uBlock Origin, even though the author does not want to support Thunderbird (he is very busy supporting browsers) someone else did some work on the AddOn and it kinda works in TB. This bug has been reported here 6 times so far, that means lots of people are affected (very few will open a bug).

Updated

a year ago
Duplicate of this bug: 1434479

Updated

3 months ago
Duplicate of this bug: 1517957

Comment 31

2 months ago

Good news, webextensions have progressed enough in Tb for the uBO author to begin work for 65+ compatibility, and there is partial functionality.

https://github.com/gorhill/uBlock/commit/305cd4db1c8fb93a5d032fb3a09ededd9bbdc240

Updated

23 days ago
Duplicate of this bug: 1530593
You need to log in before you can comment on or make changes to this bug.