Closed Bug 53505 Opened 24 years ago Closed 21 years ago

Command+~ (tilde) to switch between windows

Categories

(Core :: DOM: UI Events & Focus Handling, enhancement, P3)

PowerPC
All
enhancement

Tracking

()

RESOLVED WONTFIX
Future

People

(Reporter: mpt, Assigned: timeless)

References

Details

(Keywords: helpwanted, platform-parity)

Windows uses Alt+(Shift+)Tab(+Tab(+...)) to switch between windows a user has 
open, in stack order (rather than cycle order). As far as I know, window managers 
on X usually do this too.

Mac OS has no such global keyboard shortcut for switching between windows. What 
it does have is Cmd+(Shift+)Tab for switching between *applications*, in cycle 
order.

It is therefore up to each individual application to implement means for 
switching between the windows of that application. For example, IE 5 has Cmd+~ (a
non-internationalization-safe shortcut) for switching between windows in cycle 
order. BBEdit, meanwhile, has Cmd+Ctrl+/ for switching between windows in cycle 
order, and Cmd+Option+/ for switching between windows in stack order (actually, 
only to switch between the frontmost two windows).

I suggest that on Mac OS, Mozilla should have Option+(Shift+)Tab(+Tab(+...)) to 
switch between open windows in stack order. This would give a nice linear 
progression, on an ordinary Mac keyboard
|
| [control ][option ][cmd  ][     -- space bar --     ][cmd  ][option ][control ]
|,
between:
       Tab = switch between controls in the current pane
  Ctrl+Tab = switch between panes    in the current window (bug 30864)
Option+Tab = switch between windows  in the current app
   Cmd+Tab = switch between apps     on Mac OS.
Sending to Lake for comment.
Assignee: hangas → lake
Communicator 4.7.x added this functionality with Command-` - other apps use the 
same method (modifier + punctuation). Might want to stick with that (at least in 
the beginning).
Please stop sending bugs to various UI/UE people for comment, especially if 
they aren't going to.  Matthew proposed a very clear idea, and now it needs to 
be on the plate of an engineer who might implement it.
Assignee: lake → don
Component: User Interface: Design Feedback → Keyboard Navigation
QA Contact: mpt → sairuh
er..really reassigning to an engineer who might do it ;)
Assignee: don → ben
adding pchen for some mac help
Blocks: 72334
brade, this is the bug I told you about earlier.
I'll take this bug and see how feasible this is; Ben has a lot on his plate
right now.
Assignee: ben → brade
Keywords: pp
Target Milestone: --- → mozilla0.9.1
Target Milestone: mozilla0.9.1 → mozilla0.9.2
Keywords: helpwanted
Target Milestone: mozilla0.9.2 → mozilla1.0
No longer blocks: 72334
*** Bug 72334 has been marked as a duplicate of this bug. ***
Perhaps this should be coordinated with Bug 79450.
That bug doesn't need to be coordinated w/ this one, but once this feature is 
implemented someone should alert the other bug so an optional patch that won't 
be checked in could be provided for people to use while they wait for real 
keyboard configurability.
Are you guys aware that you can cycle through browser windows using "Ctrl-1" on
Windows and "Cmd-1" on the Mac?  (Note that this is the number "1" and not a
lowercase "L".)  This doesn't work for mail/news windows, it only cycles through
browser windows.  

I submitted this same comment to Bug 79450.  
Bugs targeted at mozilla1.0 without the mozilla1.0 keyword moved to mozilla1.0.1 
(you can query for this string to delete spam or retrieve the list of bugs I've 
moved)
Target Milestone: mozilla1.0 → mozilla1.0.1
*** Bug 118992 has been marked as a duplicate of this bug. ***
This bug probably existed before OS X was common, but just to point out, HIG for
Mac OS X states Command-` should be used to cycle windows.  In fact, in Cocoa
apps, the OS provides this functionality for you unless you override it.
*** Bug 140880 has been marked as a duplicate of this bug. ***
I appreciate that Option+Tab is really the more logical shortcut.

However, many other apps use the not-so-logical Command+~ shortcut. The
most notable among these is IE whose users we want to convert to Moz.

Would it be possible for *both* Option+Tab and Command+~ to work? I mean
let Option+Tab be the official shortcut, but for those who accidentally
press Command+~ it should still do what they expect.
I second the request to enable command-` to switch between windows, and
command-option-` should switch between the frontmost 2 windows.
*** Bug 141856 has been marked as a duplicate of this bug. ***
*** Bug 142550 has been marked as a duplicate of this bug. ***
Status: NEW → ASSIGNED
Target Milestone: mozilla1.0.1 → Future
I think that Mozilla should follow the OS's standard of Command-` for cycling
mozilla windows.  It's pretty standard for all apps now in OS X. I can't
remember all the different commands for cycling individual apps, I always try
command-` and if that doesn't work, I usually assume it's not implemented.
*** Bug 153123 has been marked as a duplicate of this bug. ***
this is supported automatically on MacOS X
Status: ASSIGNED → RESOLVED
Closed: 22 years ago
Resolution: --- → WONTFIX
It's not automatically supported by OS X -- that's apparently what bug 140492
is for.  But what does that have to do with Mac OS 8.5?  mpt, comments?  (If
mozilla.org no longer cares about Mac OS <=9, please just say so.)
agreed: a resolution about OSY based on OSX is unacceptable.
fwiw nscp doesn't care much about Mac OS Classic, so if you want this fixed you
should find someone to work on it. All things considered, i suspect that you
could probably fix this bug if you tried.
Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---
I have no plans to fix this issue (which is why I indicated WONTFIX).
Reassign to timeless since he reopened bug.
Assignee: brade → timeless
Status: REOPENED → NEW
Since I filed this bug, Apple have decreed the standard to be Command+~. 
Updating summary.
Summary: [Mac] Option+Tab to switch between windows → Command+~ (tilde) to switch between windows
*** Bug 140492 has been marked as a duplicate of this bug. ***
FWIW --

(Apparently the OS X version of this bug was duped to this, for some reason,
so it should have been OS = Mac OS + Mac OS X, but now:)

On a recent Mozilla + Mac OS X 10.2, command-~ does indeed cycle through
Mozilla windows.  Since this also works for other applications where it didn't
before, I suspect Apple just made it the default everywhere.

So now it really is a Mac OS 8.5 only bug.  (Or rather, Mac OS <= 10.1.5.)
Since it now works in Mac OS X (build 2003041108, 10.2.5), and System 7/8/9
isn't supported anymore, should we close this bug ? I know it doesn't work in
Mac OS X 10.1, and not everyone has upgraded to 10.2. But why should we try to
implement smtg which already works *for free* in a current OS.
This bug is targeted at a Mac classic platform/OS, which is no longer supported
by mozilla.org. Please re-target it to another platform/OS if this bug applies
there as well or resolve this bug.

I will resolve this bug as WONTFIX in four weeks if no action has been taken.
To filter this and similar messages out, please filter for "mac_cla_reorg".
setting OS to All since this affects some OSX versions.
Resolving this as WONTFIX since the OS that are most affected aren't actively
supported by mozilla effort.
Status: NEW → RESOLVED
Closed: 22 years ago21 years ago
OS: Mac System 8.5 → All
Resolution: --- → WONTFIX
This bug has surfaced again as bug 238062
Component: Keyboard: Navigation → User events and focus handling
You need to log in before you can comment on or make changes to this bug.