Closed Bug 580878 Opened 12 years ago Closed 12 years ago

Remove/reduce tabcandy-specific Utility code which rewraps native interfaces

Categories

(Firefox Graveyard :: Panorama, defect, P1)

defect

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: mitcho, Unassigned)

References

Details

(Whiteboard: tracked)

As per Gavin's recommendation on #574217, we should use less or no utility functions which rewrap native Firefox interfaces. Marked P1 because it could help with getting on trunk.

I'm of the belief that utility functions aren't always bad... so to get this party started, I propose a rule of thumb that if a helper/Utils function isn't used in more than X places in the tabcandy code, it should be thrown out and that logic be placed inline where the function is (was) used.

I will begin the discussion by proposing X = 3. Discuss!

(And yes there's also #574219 but the scope of that ticket is unclear to me so I thought I'd create another, more focused one.)
Depends on: 580870
Depends on: 580900
Depends on: 580901
Depends on: 580905
Depends on: 580937
Depends on: 580952
Depends on: 581052
Depends on: 581286
Depends on: 581612
Duplicate of this bug: 574219
All descendant bugs are resolved fixed now, so I'm closing this. Go team!
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → FIXED
Mass moving all Tab Candy bugs from Mozilla Labs to Firefox::Tab Candy.  Filter the bugmail spam with "tabcandymassmove".
Product: Mozilla Labs → Firefox
Target Milestone: -- → ---
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.