Last Comment Bug 594441 - Drag to move tabs and groups between windows while in Panorama
: Drag to move tabs and groups between windows while in Panorama
Status: RESOLVED WONTFIX
:
Product: Firefox Graveyard
Classification: Graveyard
Component: Panorama (show other bugs)
: Trunk
: All All
: -- enhancement
: Future
Assigned To: Nobody; OK to take it and work on it
:
:
Mentors:
: 620624 624149 626158 626261 644430 648763 648932 659901 911507 1042856 (view as bug list)
Depends on:
Blocks: 638188
  Show dependency treegraph
 
Reported: 2010-09-08 10:21 PDT by Ethan Sisson
Modified: 2016-04-12 14:00 PDT (History)
32 users (show)
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description Ethan Sisson 2010-09-08 10:21:17 PDT
User-Agent:       Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0b5) Gecko/20100101 Firefox/4.0b5
Build Identifier: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0b5) Gecko/20100101 Firefox/4.0b5

If I try to move pages from a window in Panorama view to another window, I cannot drag the page outside of it's window.

Additionally, If I try to move a tab from the tabstrip in one window into Panorama view in another window, I cannot drop the tab into Panorama.

I would expect to be able to drag pages from one window to any other window regardless of the view of any of the windows.

Reproducible: Always
Comment 1 Michael Yoshitaka Erlewine [:mitcho] 2010-09-16 18:38:51 PDT
Punting to the future, as we have hit fx4.0 feature freeze.
Comment 2 Tracy Walker [:tracy] 2010-10-14 11:10:53 PDT
I believe this would depend on bug 578512. Is there a better tracking bug for all-windows?
Comment 3 Ian Gilman [:iangilman] 2010-10-15 09:39:22 PDT
(In reply to comment #2)
> I believe this would depend on bug 578512. Is there a better tracking bug for
> all-windows?

Bug 578512 is our main bug for the "all windows" feature, which would allow one to move tabs from window to window by dragging tab thumbnails from group to group within a single Panorama window. 

This bug, on the other hand, seems to be requesting the ability to drag a tab thumbnail out of one Panorama window and into the tab strip of another browser window, and vice-versa. I would say this is a complimentary feature.
Comment 4 Michael Yoshitaka Erlewine [:mitcho] 2011-01-15 20:01:41 PST
*** Bug 624149 has been marked as a duplicate of this bug. ***
Comment 5 Michael Yoshitaka Erlewine [:mitcho] 2011-01-15 20:02:09 PST
*** Bug 620624 has been marked as a duplicate of this bug. ***
Comment 6 Michael Yoshitaka Erlewine [:mitcho] 2011-01-15 20:02:35 PST
*** Bug 626158 has been marked as a duplicate of this bug. ***
Comment 7 Michael 2011-01-15 20:09:06 PST
It would be really useful to be able to drag both tabs and tab groups between windows, and also to be able to make them appear in specific windows or all windows.  (Think OS X's Spaces.)  This is different from showing the in all windows in Panorama.  ie. You might have a gmail tab that always appears in every browser window, or a tab group that appears in all windows in Panorama, while other tabs and groups remain bound to a specific window.
Comment 8 Michael Yoshitaka Erlewine [:mitcho] 2011-01-16 14:02:26 PST
*** Bug 626261 has been marked as a duplicate of this bug. ***
Comment 9 George Carstoiu 2011-03-24 02:00:32 PDT
*** Bug 644430 has been marked as a duplicate of this bug. ***
Comment 10 Thomas Ahlblom 2011-04-11 08:35:34 PDT
*** Bug 648763 has been marked as a duplicate of this bug. ***
Comment 11 Frank Yan (:fryn) 2011-04-11 11:21:59 PDT
*** Bug 648932 has been marked as a duplicate of this bug. ***
Comment 12 Frank Yan (:fryn) 2011-04-11 11:23:07 PDT
Re-posting my comment from duplicate bug 648932:

The pseudo-mime-type that we use for tabs is a constant called TAB_DROP_TYPE.
Perhaps, dropping URLs should be handled as well, but that could be split into
a separate bug.
Comment 13 Dietrich Ayala (:dietrich) 2011-05-26 03:23:12 PDT
*** Bug 659901 has been marked as a duplicate of this bug. ***
Comment 14 - 2011-11-11 06:05:54 PST
Dislike to see that NOBODY cares about what's supposed to be the default behavior. Users will riot if same thing happens to old school "regular windows" drag tab out action but not to the "fancy panorama" tabs... Simply double standards...

It's simply because of including buggy and not-so-tested addons to the "default" Firefox. Multiplied with the "versioning game" of browsers, Firefox ""8"" ??? I don't think so; Firefox slowly but steadily digs its grave. Uncared bugs, alienated/defunct addons because of version race, etc etc...

Simply; from version "5" to version "8" this bug still stands unattended...
Comment 15 Paul [pwd] 2012-02-19 08:28:42 PST
I was just about to post regarding the ability to move tab groups between windows but it seems this covers it.
Comment 16 Tim Taubert [:ttaubert] 2013-06-14 10:58:45 PDT
We're not going to address this with Panorama being slated for removal.
Comment 17 Roman 2013-06-15 03:47:32 PDT
Bug for Panorama removal: bug 836758
Comment 18 Samium Gromoff 2013-09-03 09:31:43 PDT
How this functionality[1] is going to be covered then?

--
1. Cross-window movement of tab groups
Comment 19 [:Aleksej] 2014-07-28 10:31:18 PDT
*** Bug 1042856 has been marked as a duplicate of this bug. ***
Comment 20 YF (Yang) 2014-09-11 04:55:09 PDT
*** Bug 911507 has been marked as a duplicate of this bug. ***
Comment 21 miriam L 2015-04-12 11:03:50 PDT
(In reply to Samium Gromoff from comment #18)
> How this functionality[1] is going to be covered then?
> 
> --
> 1. Cross-window movement of tab groups
Comment 22 Tim Taubert [:ttaubert] 2015-04-15 02:29:12 PDT
It's not going to be covered. We're not planning to implement this, sorry.
Comment 23 Vittorio Giovara 2015-04-15 02:35:39 PDT
(In reply to Tim Taubert [:ttaubert] from comment #22)
> It's not going to be covered. We're not planning to implement this, sorry.

Can you explain why? Panorama is one of the characteristic features that Firefox has with respect to other browsers, so it's a pity that it's not being developed further.
Comment 24 Eyal Kalderon 2015-04-26 21:33:04 PDT
(In reply to Tim Taubert [:ttaubert] from comment #22)
> It's not going to be covered. We're not planning to implement this, sorry.

I would like to know as well. I am a frequent Panorama user who would love to have this feature.

Note You need to log in before you can comment on or make changes to this bug.