Status

()

Firefox
Toolbars and Customization
--
major
RESOLVED INVALID
8 years ago
6 years ago

People

(Reporter: Thomas Andersen, Unassigned)

Tracking

Trunk
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0b7pre) Gecko/20101005 Firefox/4.0b7pre
Build Identifier: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0b7pre) Gecko/20101005 Firefox/4.0b7pre

After installing this build, the status bar (bottom which eg. shows request/response activities) is gone. 
I am not sure if it is me, shouldn't this be an option in the View menu?
If I choose Menu: View - Toolbars - Add-on bar the status bar is sometimes displayed and somtimes just a flat grey stripe


Reproducible: Sometimes

Steps to Reproduce:
1. Install the build mentioned in this form Build Identifier field.
2. Run the build.
Actual Results:  
I can not see the status bar. I guess it is off by default, but I expected a menu item in the View menu to turn it on. I can turn it on by choosing Menu: View - Toolbars - Add-on, but this seems a bit misleading.



Expected Results:  
A View menu item that turns the status bar display on and off.
There is no more status bar, it is only the addons bar now. The addon bar is not the status bar.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INVALID
Version: unspecified → Trunk

Updated

8 years ago
Duplicate of this bug: 604945

Comment 3

8 years ago
How then can we see what is loading and the https lock? The loading information is vital to me since I'm on dial-up and that way I can see when a page is done or hung etc., etc.. To eliminate the status bar is, in my opinion, a VERY BAD idea.

Comment 5

8 years ago
Ok, I understand about the lock/color relationship.

Using an extension to fix the missing status bar is only a TEMPORARY fix since at some time in the future the extension will stop being updated by the author and FireFox will come out with a new version that won't load the extension because of the version number.

For me, at least, this bar is crucial. Can't it be put back in FireFox? What is to be gained by removing it?

Updated

8 years ago
Duplicate of this bug: 605451

Comment 7

8 years ago
I agree with Cliff. The statusbar is an important part of the UI. I also posted a bug relate to this which has been marked as a duplicate of this one.

The title of this bug report is misleading.. it isn't unstable.. it is no longer there.

Showing the links on hover is one of the main ways I decide whether a link is valid or whether it is going to take me to a spam/phishing site. However, eventually I noticed that the URL on hover is now being (unexpectedly) displayed in the main URL bar at the top.. although it took me a long time to notice it up there, and I haven't got used to looking up there yet.

Cliff, did you see notice it in the URL bar yet?

Comment 8

8 years ago
Richard, I did notice it and that isn't my main concern. My concern is to know what is loading so I can tell if it is hung or not and also when it is finished.When using dial up, sometimes sites just stop loading if it has taken too long and there is no way to know without seeing what is going on in the loading process. Without any progress indicator also there was no way to tell if how far along a page was in the loading process.

Updated

8 years ago
OS: Mac OS X → All
Summary: Status bar display is unstable → Status bar is gone

Updated

8 years ago
Duplicate of this bug: 612221

Updated

8 years ago
Duplicate of this bug: 612273

Comment 11

8 years ago
The extension (https://addons.mozilla.org/en-US/firefox/addon/235283/) doesn't work for me.

Updated

8 years ago
Duplicate of this bug: 612620

Updated

8 years ago
Duplicate of this bug: 613625

Comment 14

8 years ago
Installing extensions to restore original critical functionality? What really needs to be fixed is replacing the people who allow these thoughtless changes to Firefox in the first place. The whole point of Firefox was to have a customizable version of the Mozilla browser. Part of design is consistency so at most the "new and improved" feature should have been an opt-in option ONLY.

Additionally the animation is completely thoughtless as well (as is the full screen transition animation) as it wastes time, is slow, and appears unresponsive.

Also since English is a top-to-bottom language you view objects with their status below. Header/paragraph, picture/name, link/status. At best there should be an option to adjust the vertical position of the status bar with it being at the bottom by default since part of GOOD design is about consistency.

All the changes the to status bar were completely unwarranted, unwanted, and executed in the worst possible way. The changes are all the worst possible design one could come up with: inconsistency of position with older versions and other browsers, unresponsive due to animation, waste of resources: animation, unintuitive: appears in the opposite direction we have all been looking towards for YEARS. Newer is not automatically better.

Who exactly is responsible for letting these kinds of disasters afflict Firefox because clearly those people aren't USING the browser!

Comment 15

8 years ago
Hear, hear!!! Please restore the status bar as it originally was. If you want for some strange reason not to have it there then make it a selectable item for those of us who see it as essential. Using extensions to fix it is NOT acceptable as I explained in my comment #5 as well as has been well stated in the comment above.

Comment 16

8 years ago
And to add to this discussion...
Removing the status bar is, IMHO, a disaster of an idea.

The "add-in" to replace this functionality gives the appearance that Moz devs are pushing core functionality onto the user. The available add-in only partially does what the status bar fulfilled before (e.g. doesn't show Sync status).

Many add-ons use the status bar to convey information to the user. Users have come to rely on this information. If we're looking for justification, search the feedback users are giving. There is more negatives than positives with users complaining about the absence of what they consider 'core functionality'.

Bring back the status bar please!!!!

Comment 17

8 years ago
(In reply to comment #14)
> Who exactly is responsible for letting these kinds of disasters afflict 
> Firefox because clearly those people aren't USING the browser!

http://jboriss.wordpress.com/2010/04/29/removing-firefoxs-status-bar-and-rehousing-add-on-icons-part-1-of-2/

(In reply to comment #16)
> search the feedback users are giving. There is more negatives than positives
> with users complaining about the absence of what they consider 'core 
> functionality'.

http://input.stage.mozilla.com/en-US/search/?q=status+bar&product=firefox&version=&date_start=11%2F10%2F2010&date_end=11%2F17%2F2010

Comment 18

8 years ago
@comment 17 First link: is to a dev's blog. He states the rationale for removing the status bar. It makes sense his line of reasoning. The original premise of removal was speed/code optimization. However, in parts 2 of 2 and 3 of 2 (yes, the author revisited the subject he hoped we wouldn't have to), the author points out that he has no idea how to resolve the use of add-ons that required chucks of real estate on the status-bar without affecting other functionality (e.g. bookmarks, tabs, search bar, et al). This discussion from early 2010 leaves the whole idea of removing the status bar in doubt.  I contend that those arguments of removing the status bar are invalidated by the user need for feed back from add-ons.

@comment 17 Second link: The problem with statistics is that they can be mis-interpreted if one is not aware of how the information was derived. The numbers can tell you exactly what you want to hear or don't want to know. 

The second link brings up a search of the FF4b feedback page showing almost 2k comments (~88% negative) _but only_ for a one week period in the middle of November. If we change the search date values to last 30 days (month of November basically), the number of comments mentioning the status bar shows ~2900 (again ~88% negative) with the peak number of comments occurring 10 Nov (FF4b7 announced?). And this is only for English language search (what is the Deutsch/Espagnol/Francaise equivalent for Status bar?).

Point is...people are complaining. Can we have our status bar back, please?

Updated

8 years ago
Duplicate of this bug: 621249

Comment 20

8 years ago
I am adding this to this bug to prevent filing a new one.  This is not resolved in my opinion.  I am also suggesting what the proper functionality SHOULD have been at the bottom of this message.

Lost functionality / issues:

- ability to see what elements of a web site are loading as the page processes. Frequently I hit pages that won't load and in FF3 I can see by the status bar that it's the Ad provider or something that is causing the delay. That capability, to monitor progress, has been lost completely in the new UI.

- inability to compare the current URL to the target URL. Sounds silly and as a developer perhaps I am in the rare few, but with the new URL preview overlaying the current URL this becomes impossible

- the add-on bar has a close button... right above the Start Menu button in Windows. I have accidentally closed the Add on bar more times than I can count. Placing a close button right beside one of the most frequently clicked UI elements in the leading OS is bad planning.

- making users install add-ons to bring back lost functionality isn't a good idea. I see that 35,000+ people have already downloaded the Status-4-Evar extension. This is for a Beta release? Doesn't that seem pretty high when all the extension does is replicate a piece of standard UI that has been removed? For a Beta user crowd? Once this goes GA I can only image that number will be FAR higher.

- lack of control over alignment. The Add-on bar, due to its lack of a status label, moves all the extensions to the left end of the bar. In Windows all status information is generally in the lower right. This breaks the overall flow of what the user expects. I agree that the old status bar forced everything to the right and thus there was no alignment control but A. this is a more natural default based on the system tray location, and B.. my suggestion below would have given the user proper control.


There was such a simple way to implement this and not leave existing users in the dark:

- leave the status bar as it was, default off if desired, even control it through the tool bars menu.

- make the 'status text/progress/preview' label removable (drag it in and out like every other tool bar feature). Default it to the classic position, and note that it can be dragged out.

- use the visibility of the status label at the bottom as a flag to disable/enable the URL preview at the top. If the status label is placed anywhere, then turn off the URL bar preview.

That is how this should have been done IMO.

Comment 21

7 years ago
Bring back the status bar please!!!!

target url must be where it was - in status bar at bottom.

url and target url in location bar is useless
(Reporter)

Comment 22

7 years ago
The reason I was reacting to not having a status bar is/was that I can not see the HTTP activity and link info when mousing over hyperlinks and mailto links. 
It may be an old habit but I find it convenient to have some indication of what is going on. Browsers has had this feature since pre Y2K

These issues seems to have been solved in RC1 (probably in previous beta releases to) by displaying the activity info in a tool tip like thing at the bottom left corner of the document. I find the solution for displaying activity satisfying.

Comment 23

7 years ago
I too am satisfied with the solution included in Beta 11, Beta 12, and RC1. I reacted because unlike most of you who live in the US, I don't have a very fast Internet connection in the Philippines. When loading is stalled, I can see in the status bar exactly what was causing the delay.

Now the status seems to have been returned, and this "bug" seems "fixed" for me even if it is marked Invalid. I suggest changing its status to Fixed.
Duplicate of this bug: 645061

Comment 25

7 years ago
I am definitely NOT satisfied with the provided pseudo-solution consisting of a nearly invisible tooltip that moves around depending on my cursor movement and a cruelly-designed toolbar whose main part (80% ?) is filled with some kind of unlabeled text-field and does not even align icons correctly.
And I still can't see, why the statusbar had to be removed completely instead of switching it off by default and letting the users decide, whether they want it.

By the way: to prevent people from opening more and more bug-reports on this, you may consider filing this bug under "Firefox/4.0" instead of "Firefox/Trunk" ...

My further reasons have been explained in Bug 645061.
Duplicate of this bug: 647999

Updated

7 years ago
Duplicate of this bug: 658204

Comment 28

7 years ago
I am dismayed that such a unilateral decision could be made by what I would call a junior software developer. I have found that if you tell customers no frequently enough, THEY GO ELSEWHERE. To ignore this FACT is fool hardy.

Is there no guidance committee for Firefox? Can developers just make this kind of decision with total DISREGARD for a customer base?

George...

Resolved? invalid? What a load of ****! Resolved due to laziness is more like it or perhaps stupidity.
George, before posting anymore comments, I would recommend you read
https://bugzilla.mozilla.org/page.cgi?id=etiquette.html. Points 1.1 and 1.2 may be of interest to you

Comment 30

7 years ago
I find George R. Goffe's comments spot-on as well as did 88% of the overwhelming negative feedback which Mozilla still went ahead against. Firefox exists because of the community and it's needs, not because of corporate Mozilla's agendas. Point 1.1 is invalid in this case, his view represents the majority position of which Mozilla employees are not only ignoring though trying to stifle.

Secondly point 1.2 does not apply either as Mozilla employees have actively worked AGAINST allowing others to work on the bugs by suggesting valid bugs are invalid or forcibly deciding they won't be fixed.

If anything Mozilla employees are going against point 1.3 by refusing to allow the community to better the product.

I encourage others to privately contact me if they are aware of Mozilla intentionally preventing other bugs from being fixed such as the Go Button in example.

Comment 31

7 years ago
Tyler,

I apologize to you and everyone, if I have ruffled anyone's feathers but my bug (658204) which was closed as RESOLVED DUPLICATE of this bug. This is a completely valid bug in my opinion. The little popup that replaced the status bar in question partially obscures content from youtube.com.

You can check my posting history for Firefox, Seamonkey, Fedora, GCC AND a rather large number of other open source software projects. ALL my posts have been uniformly polite and constructive. I have attempted to further the cause of Open Software whenever possible by reporting bugs and recommending fixes and a continued willingness to do testing of fixes.

I KNOW that developers are not required to do what I say so I do not try to direct them, only provide constructive feedback and criticism if that's indicated.

George...

Comment 32

7 years ago
George,

I don't think you have anything to apologize for. The way people are treated in this special case here is calling for much harsher criticism then yours. If you only beat around the bush trying not to confront anybody how will they ever understand that what they do is wrong? There is only such a small part of Firefox-users filing bugs here. The overwhelming majority just gets frustrated without anyone ever noticing before it is too late. So it is on us to make enough noise to compensate for all the rest of users out there.

And I said and keep saying: this is a major feature that is broken here. And "install a plugin" is not a solution. Nor is "we asked some few selected users and they said, we don't need this feature anymore" a good way to decide in a community-driven software-development. And the reasons given in one of the articles above are quite laughable - if it weren't so sad that decisions are actually made on such a base.

André

Updated

7 years ago
Duplicate of this bug: 712304
Duplicate of this bug: 746931

Comment 35

6 years ago
Please reopen this bug as it obviously isn't resolved.
You need to log in before you can comment on or make changes to this bug.