Closed Bug 621857 Opened 11 years ago Closed 10 years ago

Aero Theme broken after changing to classic theme and back to Aero

Categories

(Core :: Widget: Win32, defect)

All
Windows 7
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 607251

People

(Reporter: FeuerFliege, Unassigned)

References

Details

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b9pre) Gecko/20101228 Firefox/4.0b9pre
Build Identifier: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b9pre) Gecko/20101228 Firefox/4.0b9pre

After changing to classic theme and back to aero theme titlebar, app-button and the windows minimize, maximize and close buttons are broken. It seems like aero and basic theme are mixed.
It doesn’t affect all open firefox windows.



Reproducible: Sometimes

Steps to Reproduce:
1. Have aero theme selected
2. Open some Firefox windows
3. Change theme to windows classic
4. Change back to windows areo
Actual Results:  
Titlebar, app-button and windows minimize, maximize and close buttons are broken. It seems like aero and basic theme are mixed.

Expected Results:  
100% aero without errors.
Component: Theme → Widget: Win32
Product: Firefox → Core
QA Contact: theme → win32
I think you need 2 or more windows to trigger the bug. I cannot reproduce it with a single window.
Duplicate of this bug: 624235
I realised that it can be reproduced in a single window if you repeatedly change theme from Windows aero to windows classic. and further more if when the bug occur, if you open a new window, the panorama button is at the wrong position(but other error of the bug is not present).
Is this a duplicate of bug 607251? Is it still a problem in latest nightly builds or Firefox 4 beta 10?
It was a little difficult to provoke the bug this time (some open windows and about 20 theme changes), but it still happens.

Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b10pre) Gecko/20110125 Firefox/4.0b10pre
Built from http://hg.mozilla.org/mozilla-central/rev/1fc29746701e
Duplicate of this bug: 635896
As AndreiD specified in bug 635896, this issue occurs when the option "Use hardware acceleration when available" is checked -> hardware acceleration problem.
Hardware: x86_64 → All
I've to say, that exactly happens to me, BUT, not when I change between Classic/Aero... 

It happens only when I've this program open in parallel with Firefox... 

http://k.min.us/jjNyY6.png

At the begining, when I hover on Windows Caption Button while in Aero Mode, I can see the over those button, the Classic's theme too... 

Check some screenshots...

This while I'm with Aero Theme: http://k.min.us/jjNwQy.png

And: http://k.min.us/jjRFo6.png

http://k.min.us/jjRDgy.png

I hope it will help you... I've a personal "userChrome" but as I can see, additional people have the problem too. The program isn't windows native designed. Maybe it helps too.

Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b13pre) Gecko/20110308 Firefox/4.0b13pre

Win7 x64 SP1

All HWA true. D3D10.
Duplicate of this bug: 641790
Duplicate of this bug: 648238
Duplicate of this bug: 650233
Reproducible on:
Mozilla/5.0 (Windows NT 6.1; rv:5.0a2) Gecko/20110417 Firefox/5.0a2

Is this the same issue as in bug as 607251? 
Considering duping this one since that one is already set on New.
OS: Windows 7 → All
in reply to comment 13 -> this may be a dupe of bug 607251
OS: All → Windows 7
Status: UNCONFIRMED → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 607251
You need to log in before you can comment on or make changes to this bug.