Last Comment Bug 633113 - Lotus iNotes 8.5.2 / Domino Web Access (DWA) do not work after updating to Firefox 4; now that support for remote XUL is turned off by default
: Lotus iNotes 8.5.2 / Domino Web Access (DWA) do not work after updating to Fi...
Status: RESOLVED FIXED
[See comment 15 and comment 26]
: relnote
Product: Tech Evangelism
Classification: Other
Component: Desktop (show other bugs)
: unspecified
: All All
: -- normal with 1 vote (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
: 628264 636089 642330 643757 643785 644039 644111 647793 654367 (view as bug list)
Depends on:
Blocks: kill-remote-xul
  Show dependency treegraph
 
Reported: 2011-02-10 00:45 PST by Amrendra
Modified: 2014-09-14 23:35 PDT (History)
21 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description Amrendra 2011-02-10 00:45:53 PST
User-Agent:       Mozilla/5.0 (Windows NT 5.1; rv:2.0b11) Gecko/20100101 Firefox/4.0b11
Build Identifier: Mozilla/5.0 (Windows NT 5.1; rv:2.0b11) Gecko/20100101 Firefox/4.0b11

Message:	uncaught exception: [Exception... "Component returned failure code: 0x80040111 (NS_ERROR_NOT_AVAILABLE) [nsIDOMHTMLDocument.createElementNS]"  nsresult: "0x80040111 (NS_ERROR_NOT_AVAILABLE)"  location: "JS frame :: https://indelm01.tcs.com/iNotes/Forms8.nsf/iNotes/Proxy/?OpenDocument&Form=s_JSViewList&l=en&gz&CR&MX&TS=20080801T161647,90Z&charset=ISO-8859-1 :: CyB :: line 6"  data: no]
URL:	https://indelm01.tcs.com/mail/mail1/227356.nsf/iNotes/Mail/?OpenDocument&KIC&UNH=nhrfechkibbgfungsr8pesijias&F8

Call Stack:
Sorry, not yet implemented
Date:	Thu Feb 10 2011 14:05:58 GMT+0530 (India Standard Time)
UserAgent:	Mozilla/5.0 (Windows NT 5.1; rv:2.0b11) Gecko/20100101 Firefox/4.0b11
Canonical UserName:


Reproducible: Always
Comment 1 Markus Nohr 2011-03-07 01:23:40 PST
It's also in Firefox 4.0b12

Domino Release 8.5.2 (Linux for Intel)
$HaikuForm - 401
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b12) Gecko/20100101 Firefox/4.0b12

07.03.2011 10:06:28AM Aufgrund eines aufgetretenen Problems ist der aktuelle Vorgang möglicherweise fehlgeschlagen.
07.03.2011 10:06:28AM uncaught exception: [Exception... "Component returned failure code: 0x80040111 (NS_ERROR_NOT_AVAILABLE) [nsIDOMHTMLDocument.createElementNS]"  nsresult: "0x80040111 (NS_ERROR_NOT_AVAILABLE)"  location: "JS frame :: https://inotes.piazzablu.com/iNotes/Forms85.nsf/iNotes/Proxy/?OpenDocument&Form=l_StdPageOperations_Gecko&l=de&gz&CR&MX&TS=20100811T081528,46Z&charset=UTF-8&PresetFields=s_FullmailView;1,s_FullListViewVirtual;1,s_mailView;1,s_Base;1,s_FullInit;1 :: CyB :: line 15"  data: no]
07.03.2011 10:06:28AM : 0
Comment 2 Josh 2011-03-07 08:19:25 PST
Same error for OSX for FF 4.0b12
Shouldnt we call this confirmed?

Domino Release 8.5.2 (Windows NT/Intel)
$HaikuForm - 401
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0b12) Gecko/20100101 Firefox/4.0b12

03/07/2011 09:56:58AM A problem has occurred which may have caused the current operation to fail.
03/07/2011 09:56:58AM uncaught exception: [Exception... "Component returned failure code: 0x80040111 (NS_ERROR_NOT_AVAILABLE) [nsIDOMHTMLDocument.createElementNS]"  nsresult: "0x80040111 (NS_ERROR_NOT_AVAILABLE)"  location: "JS frame :: https://unmcnotes02.unmc.edu/iNotes/Forms85.nsf/iNotes/Proxy/?OpenDocument&Form=l_StdPageOperations_Gecko&l=en&gz&CR&MX&TS=20100811T081528,46Z&charset=ISO-8859-1&PresetFields=s_FullmailView;1,s_FullListViewVirtual;1,s_mailView;1,s_Base;1,s_FullInit;1 :: CyB :: line 15"  data: no]
03/07/2011 09:56:58AM : 0
03/07/2011 09:56:58AM A problem has occurred which may have caused the current operation to fail.
03/07/2011 09:56:58AM this.eN is null
03/07/2011 09:56:58AM https://unmcnotes02.unmc.edu/iNotes/Forms85.nsf/iNotes/Proxy/?OpenDocument&Form=l_StdPageOperations_Gecko&l=en&gz&CR&MX&TS=20100811T081528,46Z&charset=ISO-8859-1&PresetFields=s_FullmailView;1,s_FullListViewVirtual;1,s_mailView;1,s_Base;1,s_FullInit;1: 14
03/07/2011 10:15:12AM A problem has occurred which may have caused the current operation to fail.
03/07/2011 10:15:12AM uncaught exception: [Exception... "Component returned failure code: 0x80040111 (NS_ERROR_NOT_AVAILABLE) [nsIDOMHTMLDocument.createElementNS]"  nsresult: "0x80040111 (NS_ERROR_NOT_AVAILABLE)"  location: "JS frame :: https://unmcnotes02.unmc.edu/iNotes/Forms85.nsf/iNotes/Proxy/?OpenDocument&Form=l_StdPageOperations_Gecko&l=en&gz&CR&MX&TS=20100811T081528,46Z&charset=ISO-8859-1&PresetFields=s_FullmailView;1,s_FullListViewVirtual;1,s_mailView;1,s_Base;1,s_FullInit;1 :: CyB :: line 15"  data: no]
03/07/2011 10:15:12AM : 0
03/07/2011 10:16:16AM A problem has occurred which may have caused the current operation to fail.
03/07/2011 10:16:16AM uncaught exception: [Exception... "Component returned failure code: 0x80040111 (NS_ERROR_NOT_AVAILABLE) [nsIDOMHTMLDocument.createElementNS]"  nsresult: "0x80040111 (NS_ERROR_NOT_AVAILABLE)"  location: "JS frame :: https://unmcnotes02.unmc.edu/iNotes/Forms85.nsf/iNotes/Proxy/?OpenDocument&Form=l_StdPageOperations_Gecko&l=en&gz&CR&MX&TS=20100811T081528,46Z&charset=ISO-8859-1&PresetFields=s_FullmailView;1,s_FullListViewVirtual;1,s_mailView;1,s_Base;1,s_FullInit;1 :: CyB :: line 15"  data: no]
03/07/2011 10:16:16AM : 0
Comment 3 Ed Morley [:emorley] 2011-03-23 04:31:01 PDT
*** Bug 643785 has been marked as a duplicate of this bug. ***
Comment 4 Ed Morley [:emorley] 2011-03-23 04:36:02 PDT
Occurs in Fx 4 final.

From the bug that's just been duped against this:
(Bug 643785 comment 0)
> Build Identifier: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0) Gecko/20100101
> Firefox/4.0
> 
> When using Lotus iNotes 8.5.2 FP 1 in Full Mode for a user, the following error
> appears when clicking on the Inbox, Drafts, Sent Items folders. Similarly for
> Contacts, (but NOT for Calendar):
> 
> 03/22/2011 04:24:20PM A problem has occurred which may have caused the current
> operation to fail.
> 03/22/2011 04:24:20PM uncaught exception: [Exception... "Component returned
> failure code: 0x80040111 (NS_ERROR_NOT_AVAILABLE)
> [nsIDOMHTMLDocument.createElementNS]"  nsresult: "0x80040111
> (NS_ERROR_NOT_AVAILABLE)"  location: "JS frame ::
> http://mila-notes.mila-irl.lan/iNotes/Forms85.nsf/iNotes/Proxy/?OpenDocument&Form=l_StdPageOperations_Gecko&l=en&gz&CR&MX&TS=20101020T153425,75Z&charset=ISO-8859-1&PresetFields=s_FullmailView;1,s_FullListViewVirtual;1,s_mailView;1,s_Base;1,s_FullInit;1
> :: CyB :: line 15"  data: no]
> 03/22/2011 04:24:20PM : 0
> 
> Problem is not as extensive when iNotes Lite Mode is used, as in the error does
> not appear until a new email is created and it starts looking up the TO: fild
> name to autocomplete it from the address book/directory, in which the following
> error occurs:
> 
> 03/22/2011 04:33:17PM A problem has occurred which may have caused the current
> operation to fail.
> 03/22/2011 04:33:17PM FKS is null
> 03/22/2011 04:33:17PM
> http://mila-notes.mila-irl.lan/iNotes/Forms85.nsf/iNotes/Proxy/?OpenDocument&Form=l_StdPageOperations_Gecko&l=en&gz&CR&MX&TS=20101020T153425,75Z&charset=ISO-8859-1&PresetFields=s_stdedit;1:
> 8
> 03/22/2011 04:33:18PM A problem has occurred which may have caused the current
> operation to fail.
> 03/22/2011 04:33:18PM FKS is null
> 03/22/2011 04:33:18PM
> http://mila-notes.mila-irl.lan/iNotes/Forms85.nsf/iNotes/Proxy/?OpenDocument&Form=l_StdPageOperations_Gecko&l=en&gz&CR&MX&TS=20101020T153425,75Z&charset=ISO-8859-1&PresetFields=s_stdedit;1:
> 8
> 
> 
> iNotes details:
> 
> IBM Lotus iNotes 8.5.2    Build 401.3    October 20, 2010
> 
> Reproducible: Always
> 
> Steps to Reproduce:
> 1. Open
> http://mila-notes.mila-irl.lan/mail/klawlor.nsf/iNotes/Mail/?OpenDocument&ui=inotes_full
> 2. Click on Sent Items folder.
> 3. Click on Inbox.
> Actual Results:  
> In Full Mode, no emails are listed, but in Lite Mode all emails are listed.
> Also, the error does not appear when switch between folders in Lite Mode, but
> it does appear when entering a To: field email address on looking up the email.
> 
> Expected Results:  
> I would have expected all emails to be lists, and an error with the Lotus
> iNotes Console NOT appear.
Comment 5 Ed Morley [:emorley] 2011-03-23 04:58:12 PDT
jonas, am I correct in thinking this is fallout from bug 546857? If so, wasn't bug 623482 supposed to mean a more usable error message is shown rather than the exception?

Marking new given all the confirmations and to make sure bugmail gets sent. No idea what component this should be in (Core::XUL if the exception shouldn't be shown; or else TE if it's expected, perhaps?).

CCing Morinaka from IBM, given bug 546857 comment 189, if you are not the correct contact, please advise as to who else can be CC'd - thanks. Morinaka, is iNotes still using XUL? If so, is there a support article on lotus.com support that people can be pointed to explaining the need to whitelist?
Comment 6 Boris Zbarsky [:bz] 2011-03-23 06:10:30 PDT
Bug 623482 made it so that when loading a page with the XUL MIME type there's an error page.  It doesn't affect createElementNS with the XUL namespace.
Comment 7 Mounir Lamouri (:mounir) 2011-03-23 09:03:36 PDT
(In reply to comment #6)
> Bug 623482 made it so that when loading a page with the XUL MIME type there's
> an error page.  It doesn't affect createElementNS with the XUL namespace.

FWIW, in bug 623482, there is a patch to show a warning with an arrow panel in that case.
Comment 8 Jonas Sicking (:sicking) No longer reading bugmail consistently 2011-03-23 14:20:02 PDT
It was decided in bug 623482 that we did not need error messages for the DOM case. See comment bug 623482 comment 30 to 58 approximately.

Either way this bug is WONTFIX. I.e. we're not planning on stopping to throw from createElementNS when a XUL node is created.

If someone thinks a warning message should be displayed, please file a separate bug specifically on that.
Comment 9 Josh 2011-03-23 14:24:39 PDT
So does that mean to access my school email, I need to just use another browser cause Mozilla wont fix this issue? Im not sure what to make of "WONTFIX" and some of the technical terms here as I'm kinda new at this bug contributing thing...

Thanks!
Comment 10 Mounir Lamouri (:mounir) 2011-03-23 14:26:47 PDT
(In reply to comment #9)
> So does that mean to access my school email, I need to just use another browser
> cause Mozilla wont fix this issue? Im not sure what to make of "WONTFIX" and
> some of the technical terms here as I'm kinda new at this bug contributing
> thing...
> 
> Thanks!

You can whitelist a website with this extension:
https://addons.mozilla.org/en-US/firefox/addon/remote-xul-manager/
Comment 11 Ed Morley [:emorley] 2011-03-23 14:29:35 PDT
Would it make sense to now turn this into an open TE bug, that we'll at least be able to point users to that wonder why iNotes have stopped working?
Comment 12 Josh 2011-03-23 14:32:55 PDT
Thanks Mounir, whitelisting with the addon worked. Whitelisting the domain of "www.unmcnotes02.unmc.edu" alone didnt fix it, I had to whitelist the url once I had logged in: "https://unmcnotes02.unmc.edu/mail%5Cstudents%5Cmy.name.nsf" where my.name was my actual name. Hope this helps, thanks again!
Comment 13 Jonas Sicking (:sicking) No longer reading bugmail consistently 2011-03-23 14:35:36 PDT
You probably needed to whitelist https://unmcnotes02.unmc.edu/

(note the protocol)
Comment 14 Stephen Hogan 2011-03-24 03:23:20 PDT
From what I can tell, the remote-xul-manager actually ignores the protocols and just handles the server name. Even if you add http://<servername>/mail/<user>.nsf, it truncates the whitelist entry into just <servername>.

I am using it now and it works fine for Full-Mode iNotes in FF4 final build.

Thank goodness.
Comment 15 Ed Morley [:emorley] 2011-03-24 05:33:51 PDT
Given that this bug is going to receive more and more traffic, I'm going to turn this into a TE bug per comment 11, so that:
(a) people know this is something Lotus need to sort out
(b) it shows up in the default quicksearch results (which are for status "---" only).

For people arriving at this bug:

(1) Remote XUL support was turned off by default for Firefox 4 beta 5 onwards (in bug 546857) for security reasons. For why, see:
- http://blog.mozilla.com/addons/2010/07/21/compatibility-for-firefox-4-time-to-get-started/ 
- http://groups.google.com/group/mozilla.dev.platform/browse_thread/thread/3279e68d8966da36

(2) To work around this you need to whitelist your iNotes domain(s) using: https://addons.mozilla.org/firefox/addon/remote-xul-manager/ This addon also includes a generator tool that creates an extension installer with a predefined whitelist, to aid people installing to multiple machines. See comment 12, comment 14 above and also http://www-10.lotus.com/ldd/nd85forum.nsf/7756aedc25e6d81285256324005ac76c/70917e98d832a1be8525785d003a64c4?OpenDocument for advice on what to whitelist. 

(3) Long term IBM/Lotus need to:
- Create proper documentation for this on their support site.
- Switch away from XUL given that bug 546857 _implies_ that XUL support will be dropped completely in the future (turning off by default was for transitioning only, from what I could tell after skim reading 250+ comments).

If users of iNotes can reply to the support thread open on the Lotus support site, it may help expedite a solution (or at least better documentation/an FAQ on their side):
http://www-10.lotus.com/ldd/nd85forum.nsf/5f27803bba85d8e285256bf10054620d/56ec114bc7c5c7218525785c004591c0?OpenDocument
Comment 16 Ed Morley [:emorley] 2011-03-24 08:28:31 PDT
Apparently iNotes used to be known as Domino Web Access, adding to title to try and prevent yet more dupes.

Is this issue worth adding to Fx4 relnotes?
Comment 17 Ed Morley [:emorley] 2011-03-24 08:30:36 PDT
*** Bug 642330 has been marked as a duplicate of this bug. ***
Comment 18 Ed Morley [:emorley] 2011-03-24 08:31:06 PDT
*** Bug 644111 has been marked as a duplicate of this bug. ***
Comment 19 Ed Morley [:emorley] 2011-03-24 08:31:32 PDT
*** Bug 644039 has been marked as a duplicate of this bug. ***
Comment 20 Boris Zbarsky [:bz] 2011-03-24 08:31:41 PDT
ccing Christian for the relnote question...  Let me know if I have the wrong guy!
Comment 21 Chris Lawson (gone) 2011-03-24 08:35:18 PDT
See also bug 448599 and bug 639411. Might it be worth opening a TE tracker on Lotus Domino Web Access problems?
Comment 22 Ed Morley [:emorley] 2011-03-24 08:37:28 PDT
*** Bug 636089 has been marked as a duplicate of this bug. ***
Comment 23 christian 2011-03-24 10:22:34 PDT
I'll add it...though not many people look at the known issues so it likely won't help. Also adding Cww so that support is aware.
Comment 24 Stephen Hogan 2011-03-25 03:13:15 PDT
(In reply to comment #16)
> Apparently iNotes used to be known as Domino Web Access, adding to title to try
> and prevent yet more dupes.
> 
> Is this issue worth adding to Fx4 relnotes?

It is also known by its acronym 'DWA' up to Lotus Domino/Notes release 7.x.
Comment 25 Stephen Hogan 2011-03-25 03:15:24 PDT
(In reply to comment #23)
> I'll add it...though not many people look at the known issues so it likely
> won't help. Also adding Cww so that support is aware.

Poor implementation by a sysadmin/IT mManager if they don't look at the "Known Issues" when deploying a new browser that is to access a critical system such as email... IMHO.
Comment 26 Stephen Hogan 2011-03-25 11:48:38 PDT
Confirmation from IBM that this issue will be fixed in Lotus iNotes 8.5.2 FP3:

https://www-304.ibm.com/support/docview.wss?mynp=OCSSULMR&mync=E&uid=swg21473999&myns=swglotus

They also recommend the "Remote XUL Manager" download.
Comment 27 Kouichiro Morinaka 2011-03-27 22:46:00 PDT
Also one another technote has been issued about Firerfox 4 support in Lotus iNotes.

https://www-304.ibm.com/support/docview.wss?uid=swg21474006

We are planning to remove XUL dependency in future releases as well.
Comment 28 Matthias Versen [:Matti] 2011-04-05 10:29:03 PDT
*** Bug 647793 has been marked as a duplicate of this bug. ***
Comment 29 Ed Morley [:emorley] 2011-05-23 11:41:09 PDT
*** Bug 643757 has been marked as a duplicate of this bug. ***
Comment 30 Asa Dotzler [:asa] 2013-04-11 16:11:30 PDT
*** Bug 628264 has been marked as a duplicate of this bug. ***
Comment 31 Asa Dotzler [:asa] 2013-04-11 16:11:44 PDT
*** Bug 654367 has been marked as a duplicate of this bug. ***
Comment 32 Karl Dubost :karlcow 2014-09-14 23:35:55 PDT
Thanks everyone. Following Comment #27

Note You need to log in before you can comment on or make changes to this bug.