Closed Bug 64371 Opened 22 years ago Closed 20 years ago

Support Microsoft Internet Keyboard hotkeys

Categories

(Core :: DOM: UI Events & Focus Handling, enhancement, P3)

x86
Windows 2000
enhancement

Tracking

()

VERIFIED DUPLICATE of bug 30431
mozilla1.2alpha

People

(Reporter: dave532, Assigned: aaronlev)

References

()

Details

(Keywords: access, helpwanted)

From bug 63748:
------- Additional Comments From Mike Pinkerton 2001-01-03 11:27 -------

here you go, hyatt. more windoze special key luvin'

-- 
So here's some more :)

A few days ago I get a new keyboard with these extra buttons on, there appears
to be a range of different MS keyboards with different sets of hotkeys, this one
is one of the cheaper ones but has the following Internet navigation hotkeys
Back, forward, stop, search, favourites, home and also a button to launch the
email client.

To quote from the above URL:
Microsoft keyboard Hot Keys work with programs that use the WM_APPCOMMAND API,
which is a standardized way for software to receive Hot Key commands. Many newer
programs are already using the WM_APPCOMMAND API, and more are in development.

** Note: these keys work in Netscape Navigator and IE, so it's a product parity
issue

** Possibly related bugs:
bug 30431 - support for intellimouse explorer back/forward buttons
bug 11057 - Simple MAPI support (does the email button launch the default MAPI
app? My guess is yes)
Adding keywords 4xp as this works in Netscape 4.x and mozilla1.2 as I don't
believe that it's important to be fixed by the 1.0 release. However I'm sure
people who buy these keyboards would like to see these keys work so if the fix
is simple it should be fixed but otherwise I think it could just wait
Keywords: 4xp, mozilla1.2
We can't use WM_APPCOMMAND, because it's only supported on Win2000 and WinME.  
See the requirements section of:

  http://msdn.microsoft.com/library/psdk/winui/mousinpt_8sbo.htm

There has to be a different way, since these keys work under Win95, 98, and NT4. 
 Maybe it just sends an (eg.) Alt+LeftArrow keypress...?
If IntelliType is installed it turns out that Win95 and up can use WM_APPCOMMAND
after all. (I would assume anyone on older operating systems using one of the
advanced keyboards/mice would have this installed anyways). From
http://msdn.microsoft.com/library/techart/wm_appcmd.htm (about 1/4 of the way
down the page):

4.0 WM_APPCOMMAND Requirements

Using Microsoft IntelliType Pro 1.0 or IntelliPoint 3.0 software enhances the
native WM_APPCOMMAND support found in Windows 2000. IntelliType Pro and
IntelliPoint emulate this enhanced WM_APPCOMMAND support on legacy Microsoft
operating systems.

With Microsoft IntelliType Pro:

Windows 2000: Version 1.0 enhanced support for Beta 3. Version 1.1 enhanced
support for final version of Windows 2000.
Windows NT4.0: Service Pack 3 and later support provided by IntelliType Pro 1.0+.
Windows 95/98: Support provided by IntelliType Pro 1.0+.
Windows CE: Unsupported.

With Microsoft IntelliPoint:

Windows 2000: Version 3.0 enhanced support for Beta 3. Version 3.01 enhanced
support for final version of Windows 2000.
Windows NT4.0: Service Pack 3 and later support provided by IntelliPoint 3.0+.
Windows 95/98: Support provided by IntelliPoint 3.0+.
Windows CE: Unsupported.
->xpapps
Component: XP Toolkit/Widgets → XP Apps
Whiteboard: helpwanted
really xpapps
Assignee: hyatt → pchen
QA Contact: jrgm → sairuh
shouldn't this go to keybd nav...?
Component: XP Apps → Keyboard Navigation
Severity: trivial → enhancement
Keywords: access, helpwanted
Whiteboard: helpwanted
*** Bug 80465 has been marked as a duplicate of this bug. ***
*** Bug 60851 has been marked as a duplicate of this bug. ***
Keywords: nsenterprise
I would really like to see this enhancement added, at the latest, by the 1.0
release.  I think that catering to these hooks in the OS is vital to creating a
high-profile browser.
Keywords: nsbeta1
nav triage team:

Marking p3, nsbeta1+, and mozilla0.9.5
Keywords: nsbeta1nsbeta1+
Priority: -- → P3
Target Milestone: --- → mozilla0.9.5
Removing nsenterprise nomination. 0.9.5 sounds right.
Keywords: nsenterprise
Mass-moving lower-priority 0.9.5 bugs off to 0.9.6 to make way for remaining
0.9.4/eMojo bugs, and MachV planning, performance and feature work. If you
disagree with any of these targets, please let me know.
Target Milestone: mozilla0.9.5 → mozilla0.9.6
pushing out to mozilla1.0 cause I ain't got time at the moment
Target Milestone: mozilla0.9.6 → mozilla1.0
nice to have but don't think it will get done for mozilla1.0, pushing out to
mozilla1.2
Target Milestone: mozilla1.0 → mozilla1.2
->default assignee
Assignee: pchen → aaronl
In bug 30431, m_kato added a patch that processes WM_APPCOMMAND.  This should
already take care of the Back and Forward buttons, and maybe more.  From what I
can glean from the patch, it should be pretty straight-forward to add most other
browser-related buttons in.

netdemon: would you agree?
Our key event model doesn't yet have any way of specifying these keys.  Marking
dependency.
Depends on: 13168
Also marking dependency on bug 30431, since there's code there to handle back,
forward, and probably more, once we get the keypress.
Depends on: 30431
Akkana, what if we added constants with names like:
DOM_VK_MOZ_BLAH?

Kind of like our -moz-blah css pseudo styles.
Depends on: 164421
Blocks: 164421
No longer depends on: 164421
Keywords: mozilla1.2mozilla1.3
*** Bug 172877 has been marked as a duplicate of this bug. ***
Looks like the fix for bug 30431 also got the Back, Forward, Stop, and Refresh
keys working.  Can someone confirm?  If so, this bug should be marked as a dupe
of 30431.
I confirm that my Microsoft Natural Keyboard Pro's hotkeys do work in Win2K
Mozilla, and have for awhile now.
Resolving as duplicate. 

If the back, stop, forward, or refresh keys are not working, then reopen.

*** This bug has been marked as a duplicate of 30431 ***
Status: NEW → RESOLVED
Closed: 20 years ago
Resolution: --- → DUPLICATE
v dup
Status: RESOLVED → VERIFIED
No longer blocks: 164421
Component: Keyboard: Navigation → User events and focus handling
You need to log in before you can comment on or make changes to this bug.