[tracker] add Elastic Search support to Socorro

RESOLVED FIXED in 51

Status

Socorro
General
P1
normal
RESOLVED FIXED
7 years ago
5 years ago

People

(Reporter: rhelmer, Assigned: adrian)

Tracking

Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [search])

(Reporter)

Description

7 years ago
Currently we use PostgreSQL for reports in the Socorro web UI, such as "Top Crashers", for example:

https://crash-stats.mozilla.com/topcrasher/byversion/Firefox/5.0a2

Behind the scenes, this uses the "top crash by signatures" table in PostgreSQL.

This bug is to track exploring Elastic Search to replace this (and other) reports, and also to investigate new features like faceted search.

Updated

7 years ago
Depends on: 656297

Updated

7 years ago
Depends on: 661598
(Reporter)

Updated

7 years ago
Depends on: 654567
(Reporter)

Updated

7 years ago
Target Milestone: --- → 2.0
(Reporter)

Updated

7 years ago
Depends on: 665225

Updated

7 years ago
Assignee: nobody → adrian
(Assignee)

Updated

7 years ago
Depends on: 669961, 669965
(Assignee)

Updated

7 years ago
No longer depends on: 673728

Updated

7 years ago
Depends on: 675712
(Assignee)

Updated

7 years ago
Depends on: 678096

Updated

7 years ago
Blocks: 652880
(Reporter)

Updated

7 years ago
Blocks: 710091
Component: Socorro → General
Product: Webtools → Socorro

Updated

6 years ago
Whiteboard: [search]
(Assignee)

Updated

6 years ago
Depends on: 733187
(Assignee)

Updated

6 years ago
Depends on: 733193
(Assignee)

Updated

6 years ago
Hardware: x86_64 → All
Target Milestone: 2.0 → 2.5.2
(Assignee)

Updated

6 years ago
Target Milestone: 2.5.2 → 2.5.3
(Assignee)

Updated

6 years ago
Target Milestone: 3 → 4
(Reporter)

Updated

6 years ago
Depends on: 673423
(Assignee)

Updated

6 years ago
Target Milestone: 4 → 5
(Assignee)

Updated

6 years ago
Blocks: 678096
No longer depends on: 678096
(Assignee)

Updated

6 years ago
Target Milestone: 5 → 6
(Assignee)

Updated

6 years ago
Target Milestone: 6 → 8

Updated

6 years ago
Duplicate of this bug: 465360

Updated

6 years ago
Target Milestone: 8 → 9
(Assignee)

Updated

6 years ago
Target Milestone: 9 → 10

Updated

6 years ago
Target Milestone: 10 → 11
(Assignee)

Updated

6 years ago
Target Milestone: 11 → 12
(Assignee)

Updated

6 years ago
Target Milestone: 12 → Future
(Assignee)

Updated

5 years ago
Summary: add Elastic Search support to Socorro [tracker] → [tracker] add Elastic Search support to Socorro
(Assignee)

Updated

5 years ago
Depends on: 797509
(Assignee)

Updated

5 years ago
Blocks: 678101
(Assignee)

Updated

5 years ago
Priority: -- → P1
(Assignee)

Updated

5 years ago
Depends on: 838746
(Assignee)

Updated

5 years ago
Depends on: 838747
(Assignee)

Updated

5 years ago
Depends on: 838897
(Assignee)

Updated

5 years ago
Depends on: 853031
(Assignee)

Updated

5 years ago
Depends on: 855298
(Assignee)

Updated

5 years ago
Target Milestone: Future → 41
(Assignee)

Comment 2

5 years ago
To test search with elasticsearch on production, here is what you can do: 

1. go to advanced search https://crash-stats.mozilla.com/query?advanced=1
2. run any search you want
3. once the results appear, add `&_force_api_impl=elasticsearch` at the end of the URL and reload
4. you should now get results coming directly from elasticsearch. One easy way of telling it does indeed come from ES is to verify that the number of results is lesser than 1,000
5. if you find a bug, please file! https://bugzilla.mozilla.org/enter_bug.cgi?product=Socorro&component=Middleware

Important note: at the moment, filtering by version is broken! A pull request is open to fix that, https://github.com/mozilla/socorro/pull/1199 (bug 838897)
(Assignee)

Comment 3

5 years ago
Other note: if you run a new search after having loaded a forced search, the new search won't be using elasticsearch and you will have to force it again by doing step 3.
(Assignee)

Updated

5 years ago
Depends on: 736488
(Assignee)

Updated

5 years ago
Depends on: 867120
(Assignee)

Updated

5 years ago
Depends on: 877175

Comment 4

5 years ago
retargeting this tracker for the future. not sure if its time to resolve it or not.
Flags: needinfo?(adrian)
Target Milestone: 41 → Future
(Assignee)

Comment 5

5 years ago
Let's mark this resolve when we have turned elasticsearch on the main production web app. Should happen when we turn the PHP app off.
Flags: needinfo?(adrian)
(Assignee)

Comment 6

5 years ago
The PHP app was switched off, the django app is on, elasticsearch is on!
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: Future → 51

Updated

5 years ago
Blocks: 889040
You need to log in before you can comment on or make changes to this bug.