Status

()

Core
General
--
enhancement
RESOLVED FIXED
6 years ago
5 years ago

People

(Reporter: marco, Assigned: marco)

Tracking

Trunk
mozilla11
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite -

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [iOS])

Attachments

(2 attachments, 2 obsolete attachments)

(Assignee)

Description

6 years ago
Remove libreg as its last use was in the Seamonkey Profile Migrator, that is being removed too (see bug 679016).
(Assignee)

Updated

6 years ago
Assignee: nobody → mar.castelluccio
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
(Assignee)

Updated

6 years ago
Depends on: 674014
(Assignee)

Updated

6 years ago
Blocks: 457262
(Assignee)

Updated

6 years ago
Depends on: 679016
Whiteboard: [iOS]
(Assignee)

Comment 1

6 years ago
Created attachment 556006 [details] [diff] [review]
Part 1: Clean nsProfileMigrator

Cleaned nsProfileMigrator to remove the last (useless) use of libreg.
Attachment #556006 - Flags: review?(gavin.sharp)
(Assignee)

Comment 2

6 years ago
Gavin, if you are too busy for the review, could you assign it to someone else?
Comment on attachment 556006 [details] [diff] [review]
Part 1: Clean nsProfileMigrator

This looks OK to me, but I don't really know the history of this stuff offhand (or when we stopped using it), so perhaps bsmedberg should sign off.
Attachment #556006 - Flags: review?(gavin.sharp) → review?(benjamin)
Comment on attachment 556006 [details] [diff] [review]
Part 1: Clean nsProfileMigrator

This code exists to import the profile list from Firefox <0.9.2 to Firefox >=0.9.3. I think it can go now.
Attachment #556006 - Flags: review?(benjamin) → review+
(Assignee)

Comment 5

6 years ago
Created attachment 560489 [details] [diff] [review]
Part 2: Remove libreg

The Part 1 patch could be checked-in in the meantime.
This patch instead removes libreg and libreg references in the makefiles.
Attachment #560489 - Flags: review?(gavin.sharp)
Attachment #560489 - Flags: review?(gavin.sharp) → review?(khuey)
Comment on attachment 560489 [details] [diff] [review]
Part 2: Remove libreg

Kill it with fire!
Attachment #560489 - Flags: review?(khuey) → review+
(Assignee)

Updated

6 years ago
Keywords: checkin-needed

Updated

6 years ago
Flags: in-testsuite-
https://hg.mozilla.org/integration/mozilla-inbound/rev/81a7f5489ebc
https://hg.mozilla.org/integration/mozilla-inbound/rev/971ed890c27d
Target Milestone: --- → mozilla9

Updated

6 years ago
Keywords: checkin-needed

Comment 8

6 years ago
https://hg.mozilla.org/mozilla-central/rev/81a7f5489ebc
https://hg.mozilla.org/mozilla-central/rev/971ed890c27d
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Version: unspecified → Trunk

Comment 9

6 years ago
Callek asked me to back this out of m-c, since it's burning comm-central, but that the c-c change will be landing shortly after the aurora uplift & then this can re-land straight after :-) 

https://hg.mozilla.org/mozilla-central/rev/183d0e60d82c
https://hg.mozilla.org/mozilla-central/rev/c722928d8b69

(Bug #s and dependencies to follow)
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Whiteboard: [iOS] → [iOS] [waiting for c-c changes]
Target Milestone: mozilla9 → ---
(In reply to Ed Morley [:edmorley] from comment #9)
> Callek asked me to back this out of m-c, since it's burning comm-central,
> but that the c-c change will be landing shortly after the aurora uplift &
> then this can re-land straight after :-) 
> 
> https://hg.mozilla.org/mozilla-central/rev/183d0e60d82c
> https://hg.mozilla.org/mozilla-central/rev/c722928d8b69
> 
> (Bug #s and dependencies to follow)

To be clear, I'm not exactly blocking on comm-central here, just wanting either the comm-central fix in hand, or the aurora uplift to have happened. So comm doesn't have to deal with this fallout during and after merge-day. (I'll file bug within 24 hours, likely less)
Depends on: 689120

Updated

6 years ago
Depends on: 689437
Can we re-land this, or are we waiting on the c-c bugs to get fixed?
(Assignee)

Comment 12

6 years ago
Created attachment 580644 [details] [diff] [review]
Part 1: Clean nsProfileMigrator v2

Patch unbitrotted.
Attachment #556006 - Attachment is obsolete: true

Updated

6 years ago
Blocks: 709193
(Assignee)

Comment 13

6 years ago
Created attachment 580646 [details] [diff] [review]
Part 2: Remove libreg v2

Patch unbitrotted.
I've also done a small change in "/browser/components/build/Makefile.in". Could you check it?
Attachment #560489 - Attachment is obsolete: true
(Assignee)

Comment 14

6 years ago
After the change in the latest patch has been checked, the patches could be checked-in.
Minor makefile change looks fine to me, it's a no-op and this has had r+ already, so should be fine to push as long as try comes up green. (Prior discussions with Callek on IRC + comment 10 + the urgency of bug 709193, means that this doesn't need to be blocked by the c-c changes).

https://tbpl.mozilla.org/?tree=Try&rev=e1b435a80f0d

Really hoping this + the other things we're trying in bug 709193 help the PGO situation.
Whiteboard: [iOS] [waiting for c-c changes] → [iOS]
https://hg.mozilla.org/integration/mozilla-inbound/rev/b9d0984bdd95
https://hg.mozilla.org/integration/mozilla-inbound/rev/f5578fdc50ef

\o/
Target Milestone: --- → mozilla11
https://hg.mozilla.org/mozilla-central/rev/b9d0984bdd95
https://hg.mozilla.org/mozilla-central/rev/f5578fdc50ef
Status: REOPENED → RESOLVED
Last Resolved: 6 years ago6 years ago
Resolution: --- → FIXED

Updated

6 years ago
Duplicate of this bug: 465662

Updated

6 years ago
Blocks: 303657

Updated

6 years ago
Blocks: 352003

Updated

5 years ago
Blocks: 750661

Updated

5 years ago
No longer blocks: 750661
You need to log in before you can comment on or make changes to this bug.