Last Comment Bug 713852 - Fix strange tab appearance due to change in border-image behaviour
: Fix strange tab appearance due to change in border-image behaviour
Status: RESOLVED FIXED
:
Product: Thunderbird
Classification: Client Software
Component: Toolbars and Tabs (show other bugs)
: Trunk
: x86 Linux
: -- normal (vote)
: Thunderbird 13.0
Assigned To: Richard Marti (:Paenglab)
:
Mentors:
: 734630 735002 749891 750043 750617 750720 751063 751473 752645 754870 (view as bug list)
Depends on: 763394
Blocks: 497995 735108
  Show dependency treegraph
 
Reported: 2011-12-28 06:36 PST by Mike Conley (:mconley) - (Needinfo me!)
Modified: 2012-06-11 00:45 PDT (History)
16 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
fixed
fixed


Attachments
Screenshot of problem (15.20 KB, image/png)
2011-12-28 08:16 PST, Mike Conley (:mconley) - (Needinfo me!)
no flags Details
Fix the border-image definitions (3.21 KB, patch)
2011-12-28 12:10 PST, Richard Marti (:Paenglab)
mconley: ui‑review-
Details | Diff | Splinter Review
Fix the border-image definitions v2 (3.58 KB, patch)
2011-12-29 08:40 PST, Richard Marti (:Paenglab)
mconley: review+
mconley: ui‑review+
Details | Diff | Splinter Review
Patch for backout in aurora (2.81 KB, patch)
2012-03-09 14:35 PST, Richard Marti (:Paenglab)
mconley: review+
standard8: approval‑comm‑aurora+
standard8: approval‑comm‑beta+
Details | Diff | Splinter Review

Description Mike Conley (:mconley) - (Needinfo me!) 2011-12-28 06:36:38 PST
Protz sent me this bug report over email, saying that the tab icon looks a bit off.  He linked to this screenshot (which I'm currently unable to view): http://jonathan.protzenko.free.fr/shutter/Selection_001.png. 

He then mentioned that adding padding-left: 5px to the <tab> itself fixes the issue nicely.
Comment 1 Mike Conley (:mconley) - (Needinfo me!) 2011-12-28 08:16:15 PST
Created attachment 584576 [details]
Screenshot of problem
Comment 2 Blake Winton (:bwinton) (:☕️) 2011-12-28 08:21:54 PST
See also http://dl.dropbox.com/u/2301433/Screenshots/ThatsNotRight.png on Mac (as reported on Twitter…  ;)

(Cc-ing Paenglab, cause he does excellent theme work.)

Later,
Blake.
Comment 3 Richard Marti (:Paenglab) 2011-12-28 12:10:03 PST
Created attachment 584609 [details] [diff] [review]
Fix the border-image definitions

This is a fallout of Bug 497995. This patch follows the changes in this bug plus tries to better align the tab-icons with the tab-text.
Comment 4 Mike Conley (:mconley) - (Needinfo me!) 2011-12-28 14:00:46 PST
Comment on attachment 584609 [details] [diff] [review]
Fix the border-image definitions

Richard:

This fixes up the appearance of the tabs nicely!  Great work!

One thing I've noticed is that when hovering non-selected tabs, the background colour of the hovered tab changes but the border stays the same colour, giving it a weird box-y look.  Any way to fix that here?

Thanks,

-Mike
Comment 5 Mike Conley (:mconley) - (Needinfo me!) 2011-12-28 14:01:11 PST
Oh, I should mention - Noticed the above appearance on OSX.
Comment 6 Richard Marti (:Paenglab) 2011-12-29 08:40:27 PST
Created attachment 584762 [details] [diff] [review]
Fix the border-image definitions v2

Sorry missed the hover definition under Mac.
Comment 7 Mike Conley (:mconley) - (Needinfo me!) 2011-12-29 11:29:37 PST
Comment on attachment 584762 [details] [diff] [review]
Fix the border-image definitions v2

Review of attachment 584762 [details] [diff] [review]:
-----------------------------------------------------------------

The code looks good to me, and so far looks good on OSX, Windows 7 Aero Glass and Basic, and GNOME.  Going to check Windows XP next.
Comment 8 Mike Conley (:mconley) - (Needinfo me!) 2011-12-29 12:24:28 PST
Comment on attachment 584762 [details] [diff] [review]
Fix the border-image definitions v2

Looks good to me - thanks Paenglab, looks good.
Comment 9 Mike Conley (:mconley) - (Needinfo me!) 2011-12-29 12:44:23 PST
Checked in to comm-central as http://hg.mozilla.org/comm-central/rev/4c03954be2d1

Removing tracking for TB 11, because I don't think the border-image changes landed in Mozilla 11.
Comment 10 Richard Marti (:Paenglab) 2012-03-09 14:35:56 PST
Created attachment 604537 [details] [diff] [review]
Patch for backout in aurora

Patch for backout in aurora. Not tested, but should work because only the border-image definitions are changed to the old notation.
Comment 11 Mike Conley (:mconley) - (Needinfo me!) 2012-03-10 09:40:22 PST
Comment on attachment 604537 [details] [diff] [review]
Patch for backout in aurora

This looks good to me.

We'll want to apply this backout only to comm-aurora.
Comment 12 wvsrk1lx 2012-03-12 04:30:49 PDT
*** Bug 734630 has been marked as a duplicate of this bug. ***
Comment 13 Mark Banner (:standard8) 2012-03-12 13:13:42 PDT
Comment on attachment 604537 [details] [diff] [review]
Patch for backout in aurora

[Triage Comment]
a=me for backout.
Comment 14 Mike Conley (:mconley) - (Needinfo me!) 2012-03-12 13:19:18 PDT
Backed out of comm-aurora:  http://hg.mozilla.org/releases/comm-aurora/rev/dc97cb1e9c00
Comment 15 Richard Marti (:Paenglab) 2012-03-12 14:31:49 PDT
*** Bug 735002 has been marked as a duplicate of this bug. ***
Comment 16 Mark Banner (:standard8) 2012-03-13 05:01:39 PDT
So this is now "fixed" in 13, but due to the backout, marking as fixed in 12 to keep flag comparisons happy.
Comment 17 Mike Conley (:mconley) - (Needinfo me!) 2012-04-27 06:51:13 PDT
Bug 497995 got backed out last minute for 13, so we're going to have to do the same backout here.

Going to see if Paenglab's patch applies to beta.
Comment 18 Mike Conley (:mconley) - (Needinfo me!) 2012-04-27 08:39:48 PDT
Comment on attachment 604537 [details] [diff] [review]
Patch for backout in aurora

Due to the backout of bug 497955 on beta (13), this patch will need to be applied there.
Comment 19 Jim Porter (:squib) 2012-04-27 22:54:26 PDT
*** Bug 749891 has been marked as a duplicate of this bug. ***
Comment 20 Mark Banner (:standard8) 2012-04-30 01:44:54 PDT
*** Bug 750043 has been marked as a duplicate of this bug. ***
Comment 21 Mike Conley (:mconley) - (Needinfo me!) 2012-04-30 06:30:51 PDT
Backed out of comm-beta (TB 13) as http://hg.mozilla.org/releases/comm-beta/rev/028c8a8a8beb.

As in https://bugzilla.mozilla.org/show_bug.cgi?id=713852#c16, marking as fixed in 13 to keep flag comparisons happy.
Comment 22 Mark Banner (:standard8) 2012-05-01 01:31:52 PDT
*** Bug 750617 has been marked as a duplicate of this bug. ***
Comment 23 Mark Banner (:standard8) 2012-05-01 07:45:27 PDT
*** Bug 750720 has been marked as a duplicate of this bug. ***
Comment 24 Mark Banner (:standard8) 2012-05-02 01:00:48 PDT
*** Bug 751063 has been marked as a duplicate of this bug. ***
Comment 25 Mark Banner (:standard8) 2012-05-02 23:27:32 PDT
*** Bug 751473 has been marked as a duplicate of this bug. ***
Comment 26 Richard Marti (:Paenglab) 2012-05-07 13:11:19 PDT
*** Bug 752645 has been marked as a duplicate of this bug. ***
Comment 27 Mike Conley (:mconley) - (Needinfo me!) 2012-05-16 07:53:39 PDT
*** Bug 754870 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.