Last Comment Bug 714281 - Show the all tabs button only when the tab strip overflows
: Show the all tabs button only when the tab strip overflows
Status: RESOLVED FIXED
: ux-minimalism
Product: Firefox
Classification: Client Software
Component: Tabbed Browser (show other bugs)
: Trunk
: All All
: -- normal (vote)
: Firefox 12
Assigned To: Dão Gottwald [:dao]
:
: Dão Gottwald [:dao]
Mentors:
Depends on: 1153751 716271 928011
Blocks: 607226 702005 714594
  Show dependency treegraph
 
Reported: 2011-12-30 07:39 PST by Dão Gottwald [:dao]
Modified: 2015-04-20 06:34 PDT (History)
12 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch (901 bytes, patch)
2011-12-31 03:33 PST, Dão Gottwald [:dao]
fryn: feedback-
Details | Diff | Splinter Review
patch v2 (3.46 KB, patch)
2012-01-02 01:59 PST, Dão Gottwald [:dao]
mak77: review+
limi: ui‑review+
fryn: feedback+
Details | Diff | Splinter Review

Description Dão Gottwald [:dao] 2011-12-30 07:39:53 PST
bug 626854 spin-off
Comment 1 Dão Gottwald [:dao] 2011-12-31 03:33:28 PST
Created attachment 585123 [details] [diff] [review]
patch

Frank, I don't see how this could cause the scrollbox to "continously toggle between overflow and underflow." Is this still a concern here?
Comment 2 Frank Yan (:fryn) 2011-12-31 08:23:32 PST
Comment on attachment 585123 [details] [diff] [review]
patch

(In reply to Dão Gottwald [:dao] from comment #1)
> Frank, I don't see how this could cause the scrollbox to "continously toggle
> between overflow and underflow." Is this still a concern here?

I cannot reproduce the problem with this patch.

This patch regresses the feature of bug 465086. We need a bit more to address that, e.g. something like replacing the _usingClosingTabsSpacer *property* with a locked attribute and adding the following to the stylesheet:
#tabbrowser-tabs[locked]:not([overflow="true"]) ~ #alltabs-button {
+  visibility: hidden;
+}

`visibility: hidden;` conveniently also blocks pointer events.

Thanks for taking on this bug.
Comment 3 Frank Yan (:fryn) 2011-12-31 08:25:04 PST
That should've been:
#tabbrowser-tabs[locked]:not([overflow="true"]) ~ #alltabs-button {
  visibility: hidden;
}

Ignore the pluses. (Copy-paste fail.)
Comment 4 Dão Gottwald [:dao] 2012-01-02 01:59:53 PST
Created attachment 585262 [details] [diff] [review]
patch v2

"locked" seems too vague, so I didn't use that.
Comment 5 Frank Yan (:fryn) 2012-01-02 07:23:54 PST
Comment on attachment 585262 [details] [diff] [review]
patch v2

Looks good!
Comment 6 Marco Bonardo [::mak] 2012-01-03 06:22:47 PST
IIRC, the panorama button is hidden till it's used first time, and the alltabs menuitem for it is the only accessible (in the sense of visible) hook to open Panorama.
Do we still do that hiding-by-default? If so, the question is whether we consider Panorama a useful feature to be discoverable when tabs don't overflow.
Comment 7 Dão Gottwald [:dao] 2012-01-03 07:27:39 PST
(In reply to Marco Bonardo [:mak] from comment #6)
> IIRC, the panorama button is hidden till it's used first time, and the
> alltabs menuitem for it is the only accessible (in the sense of visible)
> hook to open Panorama.
> Do we still do that hiding-by-default?

Yes.

> If so, the question is whether we
> consider Panorama a useful feature to be discoverable when tabs don't
> overflow.

See bug 626854 comment 14... Panorama is mostly useful for users with so many tabs that they become hard to handle on a single tab strip. "Many tabs" more or less implies overflow, so I think this is still covered well enough.
Comment 8 Marco Bonardo [::mak] 2012-01-03 09:09:18 PST
Comment on attachment 585262 [details] [diff] [review]
patch v2

Review of attachment 585262 [details] [diff] [review]:
-----------------------------------------------------------------

::: browser/base/content/browser.css
@@ +22,5 @@
>  }
>  
> +#tabbrowser-tabs:not([overflow="true"])[using-closing-tabs-spacer] ~ #alltabs-button {
> +  visibility: hidden;
> +}

So, I assume the hidden override is added to avoid the flicker. A brief comment above it may clarify the reason to future generations
Comment 9 Alex Limi (:limi) — Firefox UX Team 2012-01-03 14:26:10 PST
Comment on attachment 585262 [details] [diff] [review]
patch v2

Yes, please. :)
Comment 10 Frank Yan (:fryn) 2012-01-03 14:40:29 PST
(In reply to Marco Bonardo [:mak] from comment #8)
> So, I assume the hidden override is added to avoid the flicker. A brief
> comment above it may clarify the reason to future generations

It's not to avoid flicker. It's to maintain the correct amount of temporary space needed for the next tab's close button to be positioned under the cursor, so we don't regress bug 465086. Still, a comment would indeed clarify this. I'd like to push this now, since I have dependent changes that need unbitrotting, so I'll add a comment when doing that.

Thanks for the review. :)
Comment 11 Dão Gottwald [:dao] 2012-01-04 01:46:35 PST
https://hg.mozilla.org/integration/fx-team/rev/50c9e7757aa5
Comment 12 Tim Taubert [:ttaubert] 2012-01-05 01:40:54 PST
https://hg.mozilla.org/mozilla-central/rev/50c9e7757aa5
Comment 13 Thomas Stache 2012-01-06 00:57:05 PST
Errrm, where is "Tabs from other computers" accessible now? I can't find it on Windows now (without unhiding the old menu bar).
Comment 14 Dão Gottwald [:dao] 2012-01-07 12:26:36 PST
(In reply to Thomas Stache from comment #13)
> Errrm, where is "Tabs from other computers" accessible now? I can't find it
> on Windows now (without unhiding the old menu bar).

filed bug 716271
Comment 15 Thomas Stache 2012-01-07 13:33:40 PST
Thanks Dão, I was sure this was only an oversight...
Comment 16 Cameron McCormack (:heycam) 2012-01-12 15:40:58 PST
Sorry to be a UI complainer, but is there a way I can override this for myself?  I have a user style sheet that prevents tab strip overflow and has no minimum tab width.  When the tabs get a bit small, I like being able to use the menu to find a tab.  Thanks!
Comment 17 John Drinkwater (:beta) 2012-02-16 09:16:50 PST
(In reply to Cameron McCormack (:heycam) from comment #16)
> Sorry to be a UI complainer, but is there a way I can override this for
> myself?  I have a user style sheet that prevents tab strip overflow and has
> no minimum tab width.  When the tabs get a bit small, I like being able to
> use the menu to find a tab.  Thanks!

I shrink tabs to favicons and use(d) the dropdown to find articles if I want to jump to a specific tab; not even sure why the change is needed, just move the icon into the customise window…

You can get it back by setting this in your userChrome/Stylish
#tabbrowser-tabs ~ #alltabs-button { visibility: visible #important; }
Comment 18 Richard 2012-04-04 03:32:38 PDT
Personally I wish it was left or at minimum placed in the "Customize Toolbar" selection like the "Tab Groups" is. I preferred List All Tabs since it gave me quick access to both the "Tabs from other computers" and "Tab Groups" but also allowing for view of a list.
Comment 19 Jo Hermans 2012-04-20 17:11:10 PDT
Note that this means that the panorama button is not available unless you add it manually in the customize window, or if you know the keyboard shortcut.

Contradicts <http://support.mozilla.org/en-US/kb/what-are-tab-groups>
Comment 20 al_9x 2012-04-20 18:01:01 PDT
(In reply to John Drinkwater (:beta) from comment #17)
> 
> You can get it back by setting this in your userChrome/Stylish
> #tabbrowser-tabs ~ #alltabs-button { visibility: visible #important; }

  #tabbrowser-tabs ~ #alltabs-button { visibility: visible !important; }
Comment 21 John Drinkwater (:beta) 2012-04-29 13:17:21 PDT
(In reply to al_9x from comment #20)
> (In reply to John Drinkwater (:beta) from comment #17)
> > #tabbrowser-tabs ~ #alltabs-button { visibility: visible #important; }
> 
>   #tabbrowser-tabs ~ #alltabs-button { visibility: visible !important; }

Oops, my bad. Honest typo I swear :)
Comment 22 hamiglorr 2012-06-18 13:18:07 PDT
Well, for me this problem isn't fixed or resolved!

I'm using Firefox on an iMac with OS X 10.5.8. Until a week or two ago, when I clicked on the "Windows" menu at the top of my screen, it would show me a list of all the tabs I had open, but this handy helper suddenly stopped.  Now, when I click on "Windows" it only shows me the open windows.  I just upgraded to Firefox 13.0.1, but the list of all open tabs is still not working.  Is this the Mac version of the missing "List All Tabs" button?  I tried using the "Permanent List-all-tabs Button" add-on, but it didn't do anything, presumably because I'm using a Mac.  Is there any way I can get back my handy list of all open tabs??

Note You need to log in before you can comment on or make changes to this bug.