Closed Bug 716412 Opened 10 years ago Closed 2 years ago

compact dialog prompt: unchecking "Always ask me before compacting folders automatically" fails to change or keep mail.purge.ask preference to false

Categories

(MailNews Core :: Backend, defect)

defect
Not set
normal

Tracking

(thunderbird_esr52 wontfix, thunderbird_esr60 affected, thunderbird62 wontfix, thunderbird63 affected)

RESOLVED FIXED
Thunderbird 70.0
Tracking Status
thunderbird_esr52 --- wontfix
thunderbird_esr60 --- affected
thunderbird62 --- wontfix
thunderbird63 --- affected

People

(Reporter: wsmwk, Assigned: aceman)

References

(Blocks 1 open bug)

Details

(Keywords: ux-control, Whiteboard: [gs])

User Story

https://support.mozilla.org/en-US/questions/1228592
https://support.mozilla.org/en-US/questions/1231098

Attachments

(6 files, 2 obsolete files)

"Always ask me before compacting folders automatically" doesn't always work / stick

There are many examples of this in gsfn - the most recent is http://getsatisfaction.com/mozilla_messaging/topics/compct_folder [sic]

Some have been collected under the tag http://getsatisfaction.com/mozilla_messaging/tags/compactask  - for example http://getsatisfaction.com/mozilla_messaging/topics/please_stop_asking_me_if_i_want_to_compact_folders ....

though many failed to disable the ask prompt because of hangs or crashes following the reporter's click of the prompt as in http://getsatisfaction.com/mozilla_messaging/topics/compacting_files -- which is a different bug (fixed I think/hope)
mail.purge.ask preference
Summary: "Always ask me before compacting folders automatically" doesn't always work / stick to stop the compact dialog prompt → "Always ask me before compacting folders automatically" doesn't always work / stick to stop the compact dialog prompt to change mail.purge.ask preference
Whiteboard: [gs]
The first of your links probably has a typo.

But I do not understand what is requested here. Does the dialog not save the preference to not ask again?
(that was a sucky summary)

correct. across multiple releases there are cases where user unchecks the setting, click OK, but they continue to get prompted.  But I don't have a handy test case for you. ANd when I encounter one in the support forum I have them go into config editor and change the pref.

Do you need a failing testcase to troubleshoot this?
Summary: "Always ask me before compacting folders automatically" doesn't always work / stick to stop the compact dialog prompt to change mail.purge.ask preference → compact dialog prompt: unchecking "Always ask me before compacting folders automatically" fails to change or keep mail.purge.ask preference to false
I can't see the problem. The pref is saved for me when TB exits.

I don't think there is an OK button. I see a Cancel and Compact button.
I've been brainwashed to think, "OK" button :(

two examples
- http://getsatisfaction.com/mozilla_messaging/topics/compact_folders_nag
- http://getsatisfaction.com/mozilla_messaging/topics/compct_folders [sic] i was missing an "s" earlier
it is unknown what triggers/causes this. possibilities?
1. mail.purge.ask preference "changed" via uncheck and clicking compact, but something after compact caused prefs.js to not change
2. only happens on some type of folder?
3. only happens on startup or some other type of event?
4. can it happen if user kills tbird before compact completes or if compact silently fails?

if #1 occurs, pretty sure it doesn't happen for everyone because there are people who report it never gets set.
If I understand Tb's behaviour on mail.purge.ask correctly, Tb does do next only.
(1) Read mail.purge.ask setting upon restart only.
(2) If mail.purge.ask=true upon restart,
(2-1) Show dialog before start of auto-compact.
(2-2) When "Do it automatically..." is checked at dialog by user,
      never shows dialog any more, and stores mail.purge.ask=false in prefs.js.
(3) If mail.purge.ask=false upon restart, never shows dialog.

So, manual change from mail.purge.ask=false to mail.purge.ask=true won't become effective until restart. And, manual change from mail.purge.ask=true toail.purge.ask=false can do nothing while Tb is running. Checking of "Do it automatically..." at dialog is still needed, until restart of Tb is executed.

Wayne, please distinguish (a) manual change of mail.purge.ask=true/false via Config Editor case(as for mail.purge.ask=true/false, it's similar to prefs.js editing while Tb is running), and (b) actual disabling of dialog via dialog case, please.
And in (b), check difference between "Compact" case and "Cancel" case, please. When "Cancel", checking of "Do it ..." may also be canceled.
You may be right WADA. I also toggled the pref manually in about:config and got inconsistent results. I'll try again with this info.
FYI.
Enabling/disabling of "Always ask me before compacting folders automatically" was orginally done by UI for it, and mail.purge.ask merely holded current status and was read upon restart only.
Current Tb's behaviour is simply a result by "removing the UI and only putting disabling part in dialog".
can we crowdsource this issue? Given our numerous compact issues, and the fact that I/we have ignored this issue for a long time, I'd like to see this resolved for TB17. (yeah, that's ambitious - but maybe we can convince Mark to take it)

bug 469050 would also be nice, but we've missed the localization boat for TB17.


> read upon restart only.

Can we inspect the code? If that IS the code then it must be fixed.  (hard to tell via UI without bug 469050 :( )

But if it's not read upon restart only - which I think is true - then there is a bug. AFAIK know there are people for whom unchecking "ask" doesn't work. 


And, a different bug, I think changing the option and then clicking cancel doesn't affect the option.  so we should change the code so it does. Or the dialog should somehow to reflect that it doesn't.  See screen shot.
Keywords: ux-control
Attached image compact ask dialog
I wonder if the sense of checked+"Always ask..." (which seems like negative logic) shouldn't be changed to unchecked + "Don't ask ..."


Regarding ask working or not, it seems (I'm not certain) that the frequency is way down for people unchecking the box and reporting that the prompt doesn't go away. Anyway, I'm collecting examples at https://getsatisfaction.com/mozilla_messaging/tags/compactaskfail
Looking at the code putting up the dialog
http://mxr.mozilla.org/comm-central/source/mailnews/base/util/nsMsgDBFolder.cpp#1883 (this is the only place that uses the mail.purge.ask pref) I do not see any obvious problem. It seems to properly check the pref.
1. if it is true, it shows the dialog
1-1. if the user unchecks the "always ask", it is saved as 'false' but ONLY WHEN THE "Compact" BUTTON IS PRESSED. If Cancel us pressed compact is aborted, but the pref is NOT saved, so it stays at true.
2. if it is false, no dialog is shown, so there is no way to set it to true (only via about:config).

I that what you all see?
Attached patch patch for TB17Splinter Review
Wayne's proposal in screenshot can't be done right now, because ConfirmEx() does not allow such fancy design. I've prepared a quick fix for TB17 in that it saves the pref regardless of which button is clicked. The Cancel button is also renamed to No so that is does not imply it is just a plain dismissal of the dialog without any changes saved. This is similar to the solution in bug 476426.

For TB18 I'll prepare a better patch with string improvements.
Assignee: nobody → acelists
Status: NEW → ASSIGNED
Attachment #668911 - Flags: ui-review?(bwinton)
OS: Windows Vista → All
Hardware: x86 → All
Thanks for the patch. I am somewhat undecided if I like the pref being set if it is unchecked and the user clicks no - because most users frankly don't know what compact is for, and we default to autocompact so that users will get the benefit of having their folders compacted.  Put another way, if they select No, then, do they also know that they should be doing manual compacts?  Worst case, they uncheck the option, click No, and never compact again.  It may or may not lead to performance issues. They can't hit a 4GB barrier any more (depending on OS), which is good.

OTOH, always saving/changing the pref is exactly what the UI conveys.
So, I like it, with minor reservations.

I took another spin through getsatisfaction. Except for the two recent postings [1], whose meaning is still unclear, I can't find any postings that 100% confirm that the pref isn't being saved when unchecked.

[1] did it not honor unchecking?
https://getsatisfaction.com/mozilla_messaging/topics/compact_file_message_turn_off  
https://getsatisfaction.com/mozilla_messaging/topics/compact_folders_message-13wqn3
Whiteboard: [gs] → [gs][no l10n impact]
Wayne, I am not sure I understand what you say.
If you say the default setting is to Compact, but Ask before it.
So when the dialog comes up, the Ask is always set. If the user unticks it and it gets saved, then the dialog never comes up again, but compaction will still happen silently automatically in the future. The only difference between the two buttons is that on NO compaction does not happen now, but will happen silently in an hour. On pressing Compact it will be done immediately.

If the pref is unset the dialog never comes up so they can never tick it to set it. Only via about:config.

Ideally the dialog would have both prefs exposed (Compact and Ask), but that would need a rewrite in XUL and produce a dialog similar to the System integration one ("Set Tb as default client for"). Or having 4 buttons fro all combinations (like "Don't compact now, but ask later", "Don't compact now and never without asking", "Compact now, but ask in the future too", "Compact now and never ask").

So what is the problem?
Or instead of 4 buttons we can properly explain in the dialog what those 2 buttons actually do and that to disable compact you must visit preferences.
I'll get to comment 15 in due course - although I will be very happy to be preempted by others responses.


What I want to mention is three things:
1. If we can get rid of the ask part of dialog we might be better off, and if the pref is still wanted then expose it in preferences where we have more room to convey what it does. Which leads me to...
2. I'm not keen about the wording "save disk space", which no doubt most users fixate on thinking this is some sort of option like compression. Indeed...
3. iirc one or more localizations translate "compact" to "compress"

Finally, one goal of Bug 286888 is to make this bug obsolete
In the proper patch we can expand the wording to convey what compact really means.
(Can I get a set of steps to reproduce?  I'm having a hard time trying to figure out how to test this change.  Or, heck, write a Mozmill test, and I can do that manually. ;)
Flags: needinfo?(acelists)
Comment on attachment 668911 [details] [diff] [review]
patch for TB17

It does seem weird that "Cancel" would make an action occur.  But I see how someone would want to not sync, and not be asked again, and not want another button for that, and there's currently no way to reflect that in the UI.  We could add another button, but that's also not great.

The ideal solution, I think, to to make the dialog go away entirely, but I hear there a few compact bugs we want to fix first, so in the meantime, ui-r=me, based on the description of the behaviour.  (But _please_ add tests, so that the reviewer can make sure this actually does what it says without having to wait an hour for it to trigger on its own… ;)

Thanks,
Blake.
Attachment #668911 - Flags: ui-review?(bwinton) → ui-review+
You can trigger it just by restarting TB and deleting some big message :)

Yes, Cancel should not trigger an action, that is why I rename it to No.

But waiting on a test causes a bug to not get fixed :)
Flags: needinfo?(acelists)
Attachment #668911 - Flags: review?(neil)
And landing patches without tests causes regressions and makes it really hard for other people to fix things in the future.  :(
Comment on attachment 668911 [details] [diff] [review]
patch for TB17

I realise that the strings suck, but I don't think changing the behaviour of the dialog is a good idea.
Attachment #668911 - Flags: review?(neil)
wow, I thought we had fixed this. Did we land a different bug else to make the user experience less bad?
Flags: needinfo?(acelists)
I don't know, but the patch here didn't land.
So now when we do not need a quick fix for TB17 and probably not TB24, we can fix it properly:) Any suggestions? I'll check if we can get more buttons into that dialog that do the needed actions.
Flags: needinfo?(acelists)
Duplicate of this bug: 1486694
Duplicate of this bug: 1484083
probably a good time to revisit this, in the wake of bug 1157256. Ideally, I'd like to have this for 60.2 release

Once we have a fix, we will want explicit testing from users who have recently reported bugs (dupes) and support requests (I think I have a couple), because I am not certain they are all have the same root cause.
So what is the proposal on what to do?
My changes were rejected.
So what is the proper solution?
Also if wanted for 60.2, there can't be string changes again.
Flags: needinfo?(vseerror)
(In reply to :aceman from comment #29)
> So what is the proposal on what to do?
> My changes were rejected.
> So what is the proper solution?
> Also if wanted for 60.2, there can't be string changes again.

If we cannot make progress on the whole package, then perhaps for now we file and fix a new bug that we keep prompting until restart.


(In reply to neil@parkwaycc.co.uk from comment #23)
> Comment on attachment 668911 [details] [diff] [review]
> patch for TB17
> 
> I realise that the strings suck, but I don't think changing the behaviour of
> the dialog is a good idea.

What then is the solution to resolving the conflict - because clearly there is a behavior problem in the eyes of the user?  Or are you saying the string changes ARE the solution?
Flags: needinfo?(vseerror) → needinfo?(neil)
See Also: → 469050, 1488309
In the dialogue box I see, there is a conflict of defacto requirements, as in:

In a normal modal dialogue box:

	the Cancel button is expected to "abandon all".  I.E. Close the dialogue and have no other impact.
	the OK button is supposed to do the promised action according to the configuration displayed.

The is a conflict here because the presentation has two actions that are independent.

	Action 1:	Compact the folders
	Action 2:	Change the configuration (I.E. ask/don't ask me again)

What some people want is Action 2 but not Action 1, which does not fit the defacto behaviour.

A solution picks one of: adding a button, splitting into two dialogues, doing the Action 2 when the Cancel button is clicked, or ...

Of course, not making changes is also an option. However, many people have no interest in compacting anymore. Space is cheap.
(In reply to Simon from comment #31)

> However, many people have no interest in compacting anymore. Space is cheap.

Deleted messages are not gone until compacting occurs.  I think there is a greater responsibility to the user to actually remove what they think is gone.  While the concept of compaction (perhaps it needs a new name) is about incomprehensible to users and explaining it leaves them thinking about Zip for some reason.  They do expect their deleted mail to be gone when they empty the trash.

Personally I do not see the point of effort on compaction.  I think efforts would be better spent on the mbox replacement.  Then compaction can be consigned to the darkness of history.
^ what Matt said.  I empty my own trash bin.  I even check it first in case I've tossed something recyclable.
I've been digging into the history of compact, and perhaps coming to the conclusion that we should just *remove* this dialog - but not without making a few other changes first.  More later about the history and a rationale for removing the dialog, but if someone else has thoughts about removing, or not removing, I'd be interested to hear it.
(In reply to Wayne Mery (:wsmwk) from comment #34)
> if someone else has thoughts about removing, or not removing, I'd be interested to hear it.

The less said to the user the better.  But the habit of the UI to basically lock up while a compact occurs makes silently doing it more difficult,  but preferable.

(In reply to Wayne Mery (:wsmwk) from comment #34)

I've been digging into the history of compact, and perhaps coming to the
conclusion that we should just remove this dialog - but not without making
a few other changes first. More later about the history and a rationale for
removing the dialog

Did the more slip through the cracks Wayne? I really think we should be moving this bug forward if we can.

Flags: needinfo?(vseerror)

I think if the buttons were Yes/No then it would be much more logical for the checkbox to be remembered in both cases.

(In reply to Magnus Melin [:mkmelin] from comment #37)

I think if the buttons were Yes/No then it would be much more logical for the checkbox to be remembered in both cases.

Seems sensible. So I think the path forward is to revisit the patch in that light, then get a new UI review (despite having UI+ already), otherwise we are stuck waiting for Neil or his twin to reply to comment 30 which doesn't seem likely to happen.

(In reply to Matt from comment #36)

(In reply to Wayne Mery (:wsmwk) from comment #34)

I've been digging into the history of compact, and perhaps coming to the
conclusion that we should just remove this dialog - but not without making
a few other changes first. More later about the history and a rationale for
removing the dialog

Did the more slip through the cracks Wayne? I really think we should be moving this bug forward if we can.

More like a chasm. :)

So, the history goes back to David's bug 198936 comment 5 thirteen years ago, which cites many of the compact bugs which cause users grief and the reason why this PITA dialog still exists. It also states that even back then they would have liked to get rid of this dialog.

Flags: needinfo?(vseerror) → needinfo?(acelists)
See Also: → 198936
See Also: → 1529254

(Let's not pretend Neil will respond)

Perhaps Alessandro can bring fresh perspective

The current wording is
"Do you wish to compact all local and offline folders to save disk space? This will save about NN.N MB. Always ask before compacting folders automatically"

This was fine when 10 years ago in the age of small disks when perhaps the emphasis of this dialog was to tell the user they could save disk space. IMO saving space should no longer be the primary reason for the dialog, and space savings should be deemphasized or complete removed from the dialog. (ref: comment 17 and comment 31)

Comment 32 mentions the key points IMO - a) that users confuse "Thunderbird compact" with "file compression" and b) that they are don't know (but perhaps should not need to care) that compact is really about removing already deleted messages. And further, that the dialog is triggered by the disk space threshold set in advanced options.

The wording we choose and buttons we offer should also encourage the user to disable prompting. (Assuming we don't just bite the bullet and change to not prompt by default - bug 286888)

Bug 1488309 comment 6 is also relevant - "Compact Folders" dialog box can be alarming - should clearly indicate Thunderbird the requesting application. In fact before I looked at that bug I was thinking that a compete rewording of the $%@(*# dialog could be a big step forward.

Flags: needinfo?(neil) → needinfo?(alessandro)

Hi Wayne, thanks for pulling me into this.

If I get the point, I think I mostly agree with you regarding the rewording the dialog triggered by the disk space threshold.
Since the main outcome of this dialog is to basically empty the trash, why don't we use something a bit more generic and clear for the user?

Having a better styled dialog with the info (question mark?) icon, so it's blue and not a scary orange, with the following copy:

  • Title: It's time to free up some space
  • Body: You reached the disk space threshold, do you want Thunderbird to empty your trash and clean up previously deleted messages?
  • Buttons: Edit Preferences (aligned to the left), Cancel and Proceed (aligned to the right)

Obviously, the wording can be improved since English is not my first language and I'm sure it can be written way better, but that would be the direction I'd like to suggest. Emphasis on cleaning and deleting old messages, while communicating the reason for the dialog to appear, and allowing the user to proceed or edit the preferences, or ignore it completely.
No mention of "compacting" or "compressing" since it's not accurate and those are a bit of scary words for regular users.

Thoughts?

Flags: needinfo?(alessandro)

Thanks for the suggestion. Attached is my weak attempt at mock up based on your suggestion and avoids the technical terms purge and compact. And obviously I'm not a UI guy, so this is no attempt at colors, alignment and other niceties. One correction to my own work, I think "You reached the deleted messages disk space threshold." is more clear.

If we do "edit preferences" then we need to add a checkbox in options > advanced > disk space and have it default to not prompt (unchecked) with some wording like "Don't automatically free disk space". And maybe get rid of the word compact there as we..

Flags: needinfo?(acelists)
Attachment #9067217 - Flags: feedback?(alessandro)
Attachment #9067217 - Flags: feedback?(acelists)

Hmm, this fails to address the issue that some users DO want to keep being bothered by the dialog. (yes)

Possibility - default to not ask only for new users, and change "edit preferences" to something like "edit prompting preference". (which is unfortunately vague / not direct enough that some users won't understand they don't need to keep getting prompted.

Comment on attachment 9067217 [details]
Space dialog like so.png

It seems clear to me, but of course a native English speaker should give a better feedback.
The word `purge` is still used in this screenshot, didn't we want to get rid of it?

One quick thing is that the buttons should all be aligned in the same bottom container:

```
[Edit Preferences]                      [Cancel] [Proceed]
```
Attachment #9067217 - Flags: feedback?(alessandro) → feedback+

Yeah, that should be "remove deleted messages" not purge

(In reply to Wayne Mery (:wsmwk) from comment #42)

Hmm, this fails to address the issue that some users DO want to keep being bothered by the dialog. (yes)

Possibility - default to not ask only for new users, and change "edit preferences" to something like "edit prompting preference". (which is unfortunately vague / not direct enough that some users won't understand they don't need to keep getting prompted.

We could add an un-ckecked checkbox that says "Stop reminding me and Automatically perform a clean up when reaching the disk space threshold".
Or something like that.

Comment on attachment 9067217 [details]
Space dialog like so.png

Adding Matt for both English and support perspective
Attachment #9067217 - Flags: feedback?(unicorn.consulting)

I think we have an issue in that most users have no idea what a "disk space" threshold is or why they would want to recover disk space. I think we should also specify what folder we are going to remove the previously deleted messages from.

Most support topics that talk about compacting in other than data loss terms sound befuddled as to why we would be obsessing about 1 or 2 mb of space they have 600gb or in many cases most of 2Tb free, so the conversation starts with what is wrong with you people obsessing about such a piddly amount of recovered disk space. As the dialog is already wordy. I suggest we look at is in a more explanatory manner.

"Thunderbird does not remove messages from a folder what you delete them. It simply marks them as deleted. Complete the deletion process now and remove (number of deleted messages in the folder) deleted messages from the (insert folder name here)" that optionally could add "Do this in future without notifying me"

Personally I would like to offer round robin and offer to recover the messages that are about to be removed. Or at least offer to "show me some of what will be removed" and show the 10 oldest from and subjects. While the terminology we us is frightening there is no escaping the fact we are actually permanently and irrevocably removing user data, hidden or not.

There is nothing like having 2 or 3 year old messages suddenly reappear that you thought were deleted to demonstrate the issue and it is not disk space and never has been.

I would just like to migrate to maildir so we can forget this stuff really. Until then I think explain and suppress the notice where possible.

(In reply to Matt from comment #47)

I thing we have an issue here in that most users have no idea what a "disk space" threshold is or why they would want to recover disk space.

True. It is however one way to entice users to say "yes" (because everyone likes to save disk space), and at the same time avoid technical jargon.

I think we should also specify what folder we are going to remove the previously deleted messages from.

This is not realistic. The current algorithm totals across all folders only disk space, it does not enumerate numbers of messages nor folder names.

Most support topics that talk about compacting in other than data loss terms sound befuddled as to why we would be obsessing about 1 or 2 mb of space they have 600gb or in many cases most of 2Tb free, so the conversation starts with what is wrong with you people obsessing about such a piddly amount of recovered disk space.

Along those lines, after 8 years we're long overdue for an increase via Bug 1462666 - increase default autocompact threshold "mail.purge_threshhold"

As the dialog is already wordy. I suggest we look at is in a more explanatory manner.

Fair enough. Attached is a shorter example based on your wording below.

"Thunderbird does not remove messages from a folder what you delete them. It simply marks them as deleted. Complete the deletion process now and remove (number of deleted messages in the folder) deleted messages from the (insert folder name here)" that optionally could add "Do this in future without notifying me"

Attachment #9067294 - Flags: feedback?(unicorn.consulting)
Attachment #9067294 - Flags: feedback?(alessandro)
Blocks: 1543430

Two things...

I think you became vou. Looks like I did it :)

The other is more one I struggle with. As soon as we say remove they think we a taking something away. I do not say this lightly. But perhaps a "more information ...." link to a SUMO article that offer the wordy explanation in two paragraphs might be the best result.. And not the clunker I wrote years ago. I is really terrible and always was. Smething like the attachment perhaps.

Possibly in the give compact some love we could look at Bug 1260698. That has now been around for years and still pops up in support. If we don't have time to fix it, perhaps we could change the dialog.

Duplicate of this bug: 1488309
Comment on attachment 9067294 [details]
Space dialog like so v2.png

I like the wording, I think it's clear enough.
Any reasons why the `Edit Preferences` button was removed.

Again, I'd suggest to align the buttons in this way
```
[Edit Preferences]                      [Cancel] [Proceed]
```
Just to keep it in mind, you don't need to do it in the mock-up, but just as a reminder for when the dialog gets updated.
Attachment #9067294 - Flags: feedback?(alessandro) → feedback+
Assignee: acelists → alessandro

The buttons will be aligned properly if you call dialog->ConfirmEx() as it is now. I assume nobody is proposing to convert this to a full XUL-driven dialog. Then, I'm not sure how you would implement the "Edit preferences" button. ConfirmEx() just tells you which button was clicked. You would have to implement the call to open Preferences tab in the C++ code following it.

Comment on attachment 9067294 [details]
Space dialog like so v2.png

Looks good to me.  Just noticed that Outlook calls it "purging recoverable deleted items."
Attachment #9067294 - Flags: feedback?(unicorn.consulting) → feedback+
Comment on attachment 9067217 [details]
Space dialog like so.png

I do not like the reference to freeing disk space.  It was important 20 years ago,  it is confusing to general users now to have terabytes free.
Attachment #9067217 - Flags: feedback?(unicorn.consulting) → feedback-

So let's go with attachment 9067294 [details]. Two issues I see:

  1. "Remove automatically and do not ask me." needs a correction like "Remove deletions automatically and do not ask me."
  2. I hope users don't think this is about emptying trash - because it isn't, and they still should empty trash. (It would frankly be nice if we did this automatically for users, like gmail.)

OK, I'm starting on this one.
Like aceman correctly pointed out, using the ConfirmEx() doesn't allow us to add an extra "Edit preferences" button.
I wouldn't mind turning this into a standalone xhtml dialog, as it's really small and it will give us the flexibility we need.
What do you guys think?

I'm fine as long as it says the box belongs to Thunderbird.

So, to quickly recap, the new string for the message will be:
"It is time for all the messages you have deleted to be removed from disk. Thunderbird can do this automatically without asking you, using the checkbox below."

And the checkbox should be:
"Remove deletions automatically and do not ask me."

I'm reassigning this to aceman since it involves a bit C++ to fix the preference not saved properly, as I'm awful with C++.

Assignee: alessandro → acelists

Ok, what would the buttons be labeled?
Currently they are "Compact now" and "Cancel".
Also, the checkbox currently says "Always ask me before compacting". So you propose to invert the meaning of the checkbox?

The premise was that it seems users are clicking the "Cancel" button, but still expect the checkbox value to be saved. That is unusual as Cancel usually means aborting the proposed action without any persistent state.

In your proposal, the dialog would come up with the checkbox unticked (as TB is asking everytime).
1.User ticking it and clicking "Compact now" is a clear case, the pref is stored and TB never asks again.
2.User NOT ticking it and clicking "Compact now" is OK, the pref is NOT changed and TB asks again when something is there to compact.
3.User NOT ticking it and clicking "Cancel" is clear, no compaction is done but TB asks again later.
4.User ticking it and clicking "Cancel" is the problem case. No compaction is done NOW, but at a later time should it ask again (pref not saved) or should it actually compact without asking (pref was saved)? What would be the sense in just postponing the compact by an hour or so?

Flags: needinfo?(alessandro)

(In reply to :aceman from comment #59)

Ok, what would the buttons be labeled?
Currently they are "Compact now" and "Cancel".

We should change it to "Proceed" as suggested by Wayne, in order to communicate the fact that we're not only proceeding with the compacting action, but also with the checkbox option, if checked.

Also, the checkbox currently says "Always ask me before compacting". So you propose to invert the meaning of the checkbox?
In your proposal, the dialog would come up with the checkbox unticked (as TB is asking everytime).

Correct, an opt-in option is better in this case.

4.User ticking it and clicking "Cancel" is the problem case. No compaction is done NOW, but at a later time should it ask again (pref not saved) or should it actually compact without asking (pref was saved)? What would be the sense in just postponing the compact by an hour or so?

We should leave it that way as it wouldn't make sense to update an option when the user dismisses the dialog. It goes against the expected behavior.
Inverting the meaning and functionality of the checkbox like we're doing (having it unchecked by default), and changing the confirmation button to "Proceed", will help the user understand that they need to confirm the dialog in order to trigger the compact and save the decided option.

Flags: needinfo?(alessandro)

Ok.
Your new text does not contain the "This will save about X MB". Are we sure to remove that estimate? That would undo half of bug 749099.

Whiteboard: [gs][no l10n impact] → [gs]
Flags: needinfo?(alessandro)

(In reply to :aceman from comment #61)

Ok.
Your new text does not contain the "This will save about X MB". Are we sure to remove that estimate? That would undo half of bug 749099.

That would be unfortunate only because it can be an indication of whether compact is working correctly or not - for example Bug 1260698 - Compact folders - shows wrong estimated and compacted size. Compacts too often.

However, I think part of the idea of this bug is to simply the dialog messaging. So perhaps we should do as a followup Bug 469050 - Compacting operation should be shown on Activity Manager window" and include the values there? (Perhaps it could even provide starting and ending values?)

I think we should leave the estimate, as I'm sure we'll have many complaints if we remove it.
At the end, we're asking users to trigger an action, and we should give them all the proper info.

The message could be updated to something like this:
"It is time for all the messages you have deleted to be removed from disk. This operation will save about X MB. Thunderbird can do this automatically without asking you, using the checkbox below."

We're still simplifying this dialog by changing the checkbox status and string.

I also agree with Wayne, setting bug 469050 as a follow up would be good.

Flags: needinfo?(alessandro)
Attached patch 716412.patch (obsolete) — Splinter Review

OK, let's try that.

Attachment #9076355 - Flags: ui-review?(alessandro)
Comment on attachment 9076355 [details] [diff] [review]
716412.patch

Review of attachment 9076355 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good to me.
ui-r+
Attachment #9076355 - Flags: ui-review?(alessandro) → ui-review+
Comment on attachment 9076355 [details] [diff] [review]
716412.patch

Review of attachment 9076355 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks.
Attachment #9076355 - Flags: review?(jorgk)
Attachment #9076355 - Flags: review?(frgrahl)
Comment on attachment 9076355 [details] [diff] [review]
716412.patch

> +autoCompactAllFoldersMsg=It is time for all the messages you have deleted to be removed from disk. This operation will save about %S. Thunderbird can do this automatically without asking you, using the checkbox below.

It is Thunderbird for both products. How about &brandShorterName or &brandFullName if you don't want to just display "Daily" in local builds? Would make it generic and SeaMonkey has both strings too.

> +autoCompactNeverAskCheckbox=Remove deletions automatically and do not ask me.

Both messages sound a little too technical for me. Probably how I would write them myself :)

Maybe 
> +autoCompactAllFoldersMsg=It is time for all the messages you have deleted to be removed from disk. This operation will save about %S. Check the box below to if you want &brandShorterName to do this from now on without asking you.
> +autoCompactNeverAskCheckbox=Remove deleted messages automatically and do not ask me again.

SeaMonkey is still broken so can't test right now but patch looks otherwise good and jorgk should spot any problems. 

r+ with at least Thunderbird changed to SeaMonkey in the suite strings.
Attachment #9076355 - Flags: review?(frgrahl) → review+

This is mostly about the new strings, right? They are horrible.

+# LOCALIZATION NOTE(autoCompactAllFoldersMsg): %S is the compaction gain.
You should say ... compaction gain in MB or GB or something. What's the unit? Percent?

+autoCompactAllFoldersMsg=It is time for all the messages you have deleted to be removed from disk. This operation will save about %S.
Hmm, are we lowering ourselves to smart app level informal talk now? Hey mate, it's about time to pull up your zip? We don't know whether it's time. All we know is that there will be a saving and we're offering that.

Thunderbird can do this automatically without asking you, using the checkbox below.
Hilarious. Thunderbird will remove the deleted messages using a checkbox. Wow, I thought we use tons of C++ code in the backend. You wanted to say something like: TB will do this automatically without asking you if you click the checkbox below. But then, the box has a label, so it's pretty obvious.

+autoCompactNeverAskCheckbox=Remove deletions automatically and do not ask me.
Now, what exactly is a "deletion"? Above you were going to remove deleted messages. Now you're also remove other deletions? Like deleted tags, contacts, accounts, whatever. Very confusing.

Comment on attachment 9076355 [details] [diff] [review]
716412.patch

The wording is really bad.
Attachment #9076355 - Flags: review?(jorgk) → review-

And something else. Typically the action we're doing here is purging. Why not use that word?

(In reply to Jorg K (GMT+2) from comment #70)

And something else. Typically the action we're doing here is purging. Why not use that word?

Because part of the point of this bug / change is to remove jargon and technical terminology - things the average user wouldn't and shouldn't need to understand. (But if purge must be used, it should be in addition to the other text already added)

So we are stuck again. What now? :)

(In reply to Frank-Rainer Grahl (:frg) from comment #67)

r+ with at least Thunderbird changed to SeaMonkey in the suite strings.

Yeah sorry, of course the hard-coded Thunderbird needs to be fixed.

Thanks for the thoughts - easily addressed based on chat today with aleca

(In reply to Jorg K (GMT+2) from comment #68)

This is mostly about the new strings, right? They are horrible.

+# LOCALIZATION NOTE(autoCompactAllFoldersMsg): %S is the compaction gain.
You should say ... compaction gain in MB or GB or something. What's the unit? Percent?

I see MB, but is it always?

+autoCompactAllFoldersMsg=It is time for all the messages you have deleted to be removed from disk. This operation will save about %S.
Hmm, are we lowering ourselves to smart app level informal talk now? Hey mate, it's about time to pull up your zip? We don't know whether it's time. All we know is that there will be a saving and we're offering that.

Correct - that's it. No further change.

Thunderbird can do this automatically without asking you, using the checkbox below.
Hilarious. Thunderbird will remove the deleted messages using a checkbox. Wow, I thought we use tons of C++ code in the backend. You wanted to say something like: TB will do this automatically without asking you if you click the checkbox below. But then, the box has a label, so it's pretty obvious.

Regardless, users have been confused. So to be absolutely clear to them, this should stay.

+autoCompactNeverAskCheckbox=Remove deletions automatically and do not ask me.
Now, what exactly is a "deletion"? Above you were going to remove deleted messages. Now you're also remove other deletions? Like deleted tags, contacts, accounts, whatever. Very confusing.

Includes folder deletions, but let's keep the clarification simple as Remove message deletions automatically and do not ask me.

Over to aceman ...

Flags: needinfo?(acelists)

(In reply to Wayne Mery (:wsmwk) from comment #73)

+# LOCALIZATION NOTE(autoCompactAllFoldersMsg): %S is the compaction gain.
You should say ... compaction gain in MB or GB or something. What's the unit? Percent?
I see MB, but is it always?

It actually varies, it can be in KB, MB, GB depending on how much we save. Also the unit will be part of the %S replacement.

Flags: needinfo?(acelists)
Attached patch 716412.patch v1.1 (obsolete) — Splinter Review
Attachment #9076355 - Attachment is obsolete: true
Attachment #9077202 - Flags: review?(jorgk)
Comment on attachment 9077202 [details] [diff] [review]
716412.patch v1.1

Review of attachment 9077202 [details] [diff] [review]:
-----------------------------------------------------------------

I'm not sure why you're presenting the same wording again and expect a different outcome this time.

::: mail/locales/en-US/chrome/messenger/messenger.properties
@@ +72,5 @@
>  # LOCALIZATION NOTE(compactingDone): %1$S is the compaction gain.
>  compactingDone=Done compacting (approx. %1$S saved).
>  autoCompactAllFoldersTitle=Compact Folders
> +# LOCALIZATION NOTE(autoCompactAllFoldersMsg): %1$S will be replaced by size gain of the compaction (including the unit), %2$S will be replaced by application name
> +autoCompactAllFoldersMsg=It is time for all the messages you have deleted to be removed from disk. This operation will save about %1$S. %2$S can do this automatically without asking you, using the checkbox below.

Please change this.
"TB can do this automatically without asking you, using the checkbox below."

No, TB doesn't do the compaction automatically using a checkbox. Please check the grammar of the sentence. "using" specifies the method by which an action is carried out. He crossed the ocean using a wooden paddle.

TB can do this automatically without asking you if you select that option below ... or words to that effect.
Attachment #9077202 - Flags: review?(jorgk)

OK, so if it's still not clear what I want, I repeat it:

It is time for all the messages you have deleted to be removed from disk. This operation will save about %1$S.
That's OK, but I find the tone sloppy. I'd prefer:
Messages you have deleted can be purged from disk. This operation will save about %1$S of disk space.

%2$S can do this automatically without asking you, using the checkbox below.
This grammatically wrong. I suggest:
TB can do this automatically without asking you if you select that option below.

I like Jorg's suggestion, but with a couple of small changes.

"The messages you have deleted can be purged from disk. This operation will save about %1$S of disk space."
add The at the beginning of the sentence

"Select the option below to let TB do this automatically without asking you."
flips the sentence to start with the action

Short and to the point.
Thoughts?

Thanks. SGTM

Perfect.

Attachment #9077202 - Attachment is obsolete: true
Attachment #9077527 - Flags: review?(jorgk)
Comment on attachment 9077527 [details] [diff] [review]
716412.patch v1.2

Brilliant. I agree that the old message wasn't so helpful, but the new strings have well and truly missed the boat.
Attachment #9077527 - Flags: review?(jorgk) → review+

Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/a08e9c097cd2
Reword the Compact Folders dialog. ui-r=aleca, r=jorgk,frg

Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 70.0
Attachment #9067217 - Flags: feedback?(acelists)

Thanks. Looks good. Was busy with paid work in the last 2 days so a bit silient here.

Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/1e23f4af08b6
Follow-up: Reformat. rs=reformat
Duplicate of this bug: 1595685
Duplicate of this bug: 1604584
Duplicate of this bug: 1607994
Blocks: 1607994

I'm not at all clear what it is supposed to do. Originally, I thought this message would pop up when several folders contained 'marked as deleted' and hidden emails and the Threshold set in Options/Preferences had been reached. The compacting process would compact all folders to clean up files of all previously deleted items. But obviously I was wrong and this is a message I've just not ever seen and has nothing to do with the compacting threshold option.

However, I have a user in Support Forum who is complainting about the Trash folder being emptied and no option on pop up to never ask again. That user compacts folders on a regular basis, so it clearly is not related to compacting. The user keeps losing emails from Trash if they click on 'Proceed' and clicking on 'Cancel' merely gets repeated popups.

Is this pop-up talking about auto compact folders to regain space or talking about 'Empty the Trash' AND compact all folders symultaneouly or only 'Emptying the Trash' and compact only the 'Trash'?
'Purge from disk' is not the kind of language general users understand. It does not make it clear that the users will lose emails nor where those purged emails will be deleted from nor what parameter decides what gets deleted.

Users have chosen settings in Account Settings whether they want messages deleted in the 'Disc Space' section and whether they want the 'Trash' emptied on exit. This pop up seems to override the user expectation.

Compact is a word Thunderbird users are familiar with and there are loads of Help info in Articles and those you can google to explain what it entails. But 'purge' means 'remove', so implies it removes emails and the user finds that rather intimidating and scary as they are unsure what will occur if they click on 'Proceed'.

I would appreciate some clarity on what exactly occurs when they click on 'Proceed' and also would like to know how to stop that pop up assuming the user does not want TB to do anything automatically.
Will mail.purge.ask=false via Config Editor stop this request ?
Is there a an easy option in 'Options/Preferences' to switch it off?
Why is there no option in the pop-up to 'never ask again' ?
Thanks.

Plenty of people in the Support forum are very wary and confused by 'Messages you have deleted can be purged from disk. '
They understand messages they have deleted are in the Trash/deleted folder. So believe this pop up -'Proceed' will basically Empty the TRash.
They are distressed that this pops up repeatedly and there seems to be no option to say 'No and stop asking me'.
This is largely due to a complete misunderstand and seems very confusing to those who do compact manually to see this message. Although it is possible they do not compact 'Drafts' and this is causing the pop up.
Either way can we please use the words 'compact all folders' as this is understood and easy to explain by directing users to the Support Help Article on compacting.
see bug 1678856

I agree with Anje completely. It should be possible to disable this message. I don't want to delete anything automatically and this message drives me crazy.

(In reply to Sławek from comment #91)

I agree with Anje completely. It should be possible to disable this message. I don't want to delete anything automatically and this message drives me crazy.

So you want to loose your data then? This process is a required housekeeping function. Personally, I think the answer is to simply not put out any information and just do it. Especially as I have spent years listening to comments like this that even after reading a lot of information on the subject apparently miss the point and still insist they don't want to delete anything.

The point is you already did the deletion or you would not get the message and the cleanup is required now. The message is about cleaning up the storage files, not actually about deleting messages as such. The deletions mentioned could have occurred through a move.

All the issues regarding this pop up have nothing to do with the action it will perform - which is necessary, but everything to do with the wording used. There are load of people who are not compacting because the wording is being misunderstood. 'Purge from disk' is just not required. The pop up merely needs to say something like "The Threshold has been reached as per settings in Options/Preferences and your folders need to be compacted. Please click on 'Proceed' to compact now. Do not exit thunderbird whilst compacting is being done."
Currently, people believe the emails they have deleted which are in the Trash are about to be purged/removed from the Trash and from the disk and from the server. It is consuming much time in the Support forum and in the long run people will not compact folders which may lead to data loss and result in unhappy people in the Support Forum requiring help and consuming Support forum helpers time.

Please look again at the wording used to stop all this unnecessary misunderstanding and time wasting.

This bug is done. Let's move the action to other bugs.

That said, throughout the years, this dialog has always caused user stress and misunderstanding, regardless of wording, in part because it typically happens exactly when the user has just deleted or moved a message (sometimes many)? Hmm, why is Thunderbird prompting me now, is something wrong? This is why the wording was changed in this bug - starting with comment 41 and ending up with comment 78. You won't see many bugs with more comments, so even though it still might not be stellar wording, clearly this change wasn't a quick knee jerk, seat of the pants rewording. So I suggest you read this entire first before moving this to bug 1678856 (it has more information than 1677751).

But the more effective solution IMO is to not present the dialog at all. Compact is "normal maintenance" (perhaps that should be part of the wording?), and normal maintenance should be done automatically by the software, not manually by the user, aka bug 286888 together with bug 469050.

Blocks: 1678856
No longer blocks: 1607994
See Also: → 1607994, 286888

(In reply to Matt from comment #92)

(In reply to Sławek from comment #91)

I agree with Anje completely. It should be possible to disable this message. I don't want to delete anything automatically and this message drives me crazy.

The message is about cleaning up the storage files, not actually about deleting messages as such.

Well, it should SAY THAT then!

THAT is what THIS BUG is about. (As far as I can tell.)

Restrict Comments: true
You need to log in before you can comment on or make changes to this bug.