Need to implement support for minimum window size.

RESOLVED DUPLICATE of bug 357725

Status

--
major
RESOLVED DUPLICATE of bug 357725
18 years ago
10 years ago

People

(Reporter: mozilla, Unassigned)

Tracking

Trunk
Future
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
Somehow, I managed to get a mozilla window to be two pixels wide. Besides being
almost impossible to see, it was impossible to get mozilla browser windows back
to sane sizes again. By hacking the localstore.rdf file, I reset the window to a
sane size and was able to resize it, however, Mozilla enforce a minimum sane
size on windows so that it is possible to manipulate them.

Comment 1

18 years ago
what version of mozilla are you using? sounds like a localstore.rdf corruption issue
(Reporter)

Comment 2

18 years ago
Fizzilla 0.8.1. The localstore.rdf file looked fine other than the messed-up 
window size. Shouldn't matter anyways; sanity checks still ought to be performed 
where feasable.

Comment 3

18 years ago
over to pinkerton for a look.
Assignee: asa → pinkerton
Status: UNCONFIRMED → NEW
Component: Browser-General → XP Apps
Ever confirmed: true
-> danm
Assignee: pinkerton → danm

Comment 5

18 years ago
should check to ensure windows fit in the current monitor(s) region too.
Target Milestone: --- → mozilla0.9.2

Comment 6

18 years ago
*** Bug 79005 has been marked as a duplicate of this bug. ***

Updated

18 years ago
Depends on: 79005

Comment 7

18 years ago
Clarifying summary to avoid dups.  We need to ensure that windows cannot be
opened or resized to the point that they cease to function as windows.  User
must always be able to recover from resizing by resizing back.  Note that some
platforms (e.g., Mac OS) may have guidelines for minimal window size that are
more restricive than this.  IMO, it would be good if we could facilitate
compliance with these guidelines (i.e., do the 'right thing' by default) without
overly restricting applications on other platforms 
Summary: Window too small, can't resize → Need to implement support for minimum window size.

Comment 8

18 years ago
*** Bug 79005 has been marked as a duplicate of this bug. ***

Updated

18 years ago
Whiteboard: OSX

Comment 9

17 years ago
*** Bug 79884 has been marked as a duplicate of this bug. ***

Updated

17 years ago
Target Milestone: mozilla0.9.2 → mozilla1.0

Comment 10

17 years ago
Is this OS X specific?  I don't think it is

Comment 11

17 years ago
*** Bug 106925 has been marked as a duplicate of this bug. ***

Comment 12

17 years ago
Bug 79005 and bug 79884 are both OS: All.
Modifying platform/OS



OS: MacOS X → All
Hardware: Macintosh → All

Updated

17 years ago
Whiteboard: OSX

Comment 13

17 years ago
Bugs targeted at mozilla1.0 without the mozilla1.0 keyword moved to mozilla1.0.1 
(you can query for this string to delete spam or retrieve the list of bugs I've 
moved)
Target Milestone: mozilla1.0 → mozilla1.0.1

Updated

17 years ago
Target Milestone: mozilla1.0.1 → ---

Updated

17 years ago
Target Milestone: --- → Future

Updated

17 years ago
Keywords: mozilla1.0, oeone

Updated

16 years ago
Blocks: 109150

Comment 14

16 years ago
Bug 176320 has all the documentation about the summary of this bug.

One problem about minimal window sizes is that previous documentation provided 2
different ways specifying minimal sizes, where complying with/in one way could
allow to disrespect the other way. With 100px as minimal value for inner*
properties and with 100px as a minimal value for outer* properties, the obvious
problem, even happening in NS 4.x, is that a perfectly valid value for, say,
outerHeight could create a window where its innerHeight value would be under
100px... because of many requested toolbars, e.g.:

window.open(strURL, "",
"outerWidth=400,outerHeight=130,menubar,toolbar,personalbar,status"); 

will definitively create a short window where the innerHeight will not comply
with the minimum of 100px.

Same phenomenon with resizeTo(): parameters of this method could be meeting the
requested minimal values of outer* and, at the same time, violate the minimal
values of inner*. But the code never checks for this and never makes corrective
adjustements to comply with both ways.

resizeTo(400,130);
will resize such window to under minimal innerHeight value and, at the same
time, above minimal outerHeight values.

I explained in comment #5 of bug 176320 that there should be only 1 way of
defining the minimal size values of a popup window: with inner* properties, so
that there would be no conflict, no contradictory behavior, no awkward incoherence.

One last example:
window.open(strURL, "", "outerWidth=300,outerHeight=200,status");
will render a popup with a statusbar but the security padlock icon won't be
visible nor accessible *in any normal way* and the window resizing grippy won't
be visible nor reachable. Absence of menubar, scrollbars, resizability makes the
window frustrating to use.
Updating severity to major - when this happens (2x2 window size in
localstore.rdf) a typical user can't use Mozilla anymore (they don't know to go
whack localstore.rdf).

I haven't seen this myself in quite a while, but there was a recent complaint on
the newsgroup:
http://groups.google.com/groups?dq=&hl=en&lr=lang_en&ie=UTF-8&safe=off&selm=SQska.105769%24OV.209172%40rwcrnsc54

Removing circular dependency on bug 79005.
Severity: normal → major
No longer depends on: 79005
Product: Core → Mozilla Application Suite

Updated

14 years ago
Assignee: danm.moz → nobody

Updated

13 years ago
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 357725
No longer blocks: 306681
You need to log in before you can comment on or make changes to this bug.