Last Comment Bug 756881 - New tab thumbnails not displayed (or old images displayed) for Facebook, Twitter (sites using Cache-Control no-store)
: New tab thumbnails not displayed (or old images displayed) for Facebook, Twit...
Status: VERIFIED FIXED
: regression
Product: Firefox
Classification: Client Software
Component: Tabbed Browser (show other bugs)
: Trunk
: All All
: P1 major with 17 votes (vote)
: Firefox 25
Assigned To: Mark Hammond [:markh]
:
: Dão Gottwald [:dao]
Mentors:
: 760773 763174 766898 768969 770480 783772 812160 830770 853696 (view as bug list)
Depends on: 870100
Blocks: 754608
  Show dependency treegraph
 
Reported: 2012-05-20 10:28 PDT by Michael
Modified: 2016-02-09 09:40 PST (History)
56 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
-
affected
-


Attachments
Possible Solution: Screenshot (830.81 KB, image/png)
2012-07-24 13:05 PDT, Koolaid.Junkie
no flags Details

Description Michael 2012-05-20 10:28:22 PDT
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:15.0) Gecko/15.0 Firefox/15.0a1
Build ID: 20120519030527

Steps to reproduce:

Click on "open new tab" icon on tab bar.


Actual results:

9 frequently viewed pages are displayed, but the thumbnails for some of them do not refresh properly.  In particular, the thumbnails for Facebook pages never refresh when accessed through the appropriate thumbnail.  Thumbnails for other pages appear to refresh properly.  Previously, the correct page thumbnails for Facebook were displayed.


Expected results:

The thumbnail updates to display the most recent page viewed, including for Facebook.
Comment 1 Jo Hermans 2012-05-20 12:10:35 PDT
That's because of the fix for bug 754608 - if the page uses the "Cache-Control: no-store" header (Facebook does), the thumbnail isn't updated. That means that you keep using the old one.

Note that currently we're not deleting thumbnails (bug 754671), the old thumbnail will stay around unless you destroy the thumbnails folder in your profile.

I noticed that if you delete the thumbnails folder, you will get a grey rectangle instead of the thumbnail. Facebook will never have a thumbnail if it uses no-store on all its pages. That's even worse than showing the old content.
Comment 2 Michael 2012-05-20 12:29:36 PDT
Is there a way to force thumbnail regeneration?  I had tried deleting the tabs in question, along with subsequent ones, in order to try to force it to regenerate, but now no new thumbnails show up for any site that I removed from the thumbnail list.
Comment 3 omeringen 2012-06-02 14:15:47 PDT
*** Bug 760773 has been marked as a duplicate of this bug. ***
Comment 4 Jim Jeffery not reading bug-mail 1/2/11 2012-06-09 03:58:40 PDT
*** Bug 763174 has been marked as a duplicate of this bug. ***
Comment 5 Ekanan Ketunuti 2012-06-21 08:37:08 PDT
*** Bug 766898 has been marked as a duplicate of this bug. ***
Comment 6 Ekanan Ketunuti 2012-06-27 18:47:53 PDT
*** Bug 768969 has been marked as a duplicate of this bug. ***
Comment 7 Michael Lefevre 2012-07-14 05:27:05 PDT
I realise it's probably too late to do anything, but the fix for bug 754608 went into the last beta, so this is an issue for 14 as well.
Comment 8 Michael Lefevre 2012-07-14 05:34:40 PDT
*** Bug 770480 has been marked as a duplicate of this bug. ***
Comment 9 Alex Keybl [:akeybl] 2012-07-16 07:00:06 PDT
No need to track for FF14, we won't be taking a forward fix here for an intermittent screenshotting issue.

Tim - are you the right person to look at this for FF15? It'll be on Beta as of today, so it's really important that we move on a fix here asap.
Comment 10 Tim Taubert [:ttaubert] 2012-07-16 07:06:50 PDT
(In reply to Alex Keybl [:akeybl] from comment #9)
> Tim - are you the right person to look at this for FF15? It'll be on Beta as
> of today, so it's really important that we move on a fix here asap.

Fixing this is really hard. Starting with Fx 14, we'll not capture pages that send a 'Cache-Control: no-store' header because of privacy implications - bug 754608.

Now, there are lots of sites that use it to disable caching because they probably want no stale content and want to keep control over the displayed content. OTOH there are banking sites that send it for security reasons. There is no way to distinguish between those two.

There was thread on dev.planning about this with no real conclusion either:

https://groups.google.com/forum/#!searchin/mozilla.dev.planning/thumbnail/mozilla.dev.planning/enlr8-0CfXw/lf0P_3n5sYwJ
Comment 11 Alex Keybl [:akeybl] 2012-07-16 07:14:53 PDT
(In reply to Tim Taubert [:ttaubert] from comment #10)
> (In reply to Alex Keybl [:akeybl] from comment #9)
> > Tim - are you the right person to look at this for FF15? It'll be on Beta as
> > of today, so it's really important that we move on a fix here asap.
> 
> Fixing this is really hard. Starting with Fx 14, we'll not capture pages
> that send a 'Cache-Control: no-store' header because of privacy implications
> - bug 754608.
> 
> Now, there are lots of sites that use it to disable caching because they
> probably want no stale content and want to keep control over the displayed
> content. OTOH there are banking sites that send it for security reasons.
> There is no way to distinguish between those two.
> 
> There was thread on dev.planning about this with no real conclusion either:
> 
> https://groups.google.com/forum/#!searchin/mozilla.dev.planning/thumbnail/
> mozilla.dev.planning/enlr8-0CfXw/lf0P_3n5sYwJ

Are we still exploring options? Or are you suggesting we wontfix and let the product team know so that they can try deal with the implications?
Comment 12 Tim Taubert [:ttaubert] 2012-07-16 07:23:30 PDT
(In reply to Alex Keybl [:akeybl] from comment #11)
> Are we still exploring options? Or are you suggesting we wontfix and let the
> product team know so that they can try deal with the implications?

We're not actively exploring options but I think we should. Other browsers just don't seem to care about what screenshots they take so there's no behavior to adopt for us and we need to come up with *something*.

There's also bug 725189 which covers a similar problem. I'm sure a lot of people don't care about screenshots being taken while logged into facebook or similar, but some do.
Comment 13 Oz 2012-07-16 09:32:17 PDT
It is true that some websites do not generate thumbnails because they can reveal private information or this is a issue? (if it is a issue I have it on facebook, thepiratebay and abovetopsecret websites)


However what kind of private information you can see in that small thumbnails? :)
Comment 14 Koolaid.Junkie 2012-07-24 12:37:11 PDT
Possible Solution: All user to select images to be shown in the Thumbnail Space. Maybe use the favicon, or allow storing of user-created images.

Why must the image displayed on the "New Tab" page be a screenshot of the site, specially when that screenshot shows old content. At least with the option for user to use their own image, no "privacy" issues will arise and there will be no "blank" thumbnails.
Comment 15 Koolaid.Junkie 2012-07-24 13:05:12 PDT
Created attachment 645447 [details]
Possible Solution: Screenshot

Allow user to set their own images for the thumbnail on the New Tab Page.
Comment 16 Oz 2012-07-24 13:47:49 PDT
The new tab thumbnails need some serious work:

-I have over 800mb of useless thumbnails from useless links. 
*fix - store thumbnails only for pined websites and automatically delete thumbnails older than 24h

-no thumbnails for sites using Cache-Control no-store
*fix - add pref to override the "security" feature, personally I don't see any privacy issue in a 427x341p thumbnail.
Comment 17 Jo Hermans 2012-07-24 14:26:36 PDT
(In reply to Oz from comment #16) 
> -I have over 800mb of useless thumbnails from useless links. 
> *fix - store thumbnails only for pined websites and automatically delete
> thumbnails older than 24h

bug 754671
Comment 18 Prasan 2012-07-26 18:08:24 PDT
Problem: Not all thumbnails are displayed

More: Its quite random and I'm not really able to pinpoint which pages don't display the thumbnails, Since I can't manually pin a website.
But of the few websites that I have pinned, I think the ones using https don't show up a thumbnails. 
I cannot confirm this because there aren't enough test pages and again I don't know how to manually set a page in there. 

Troubleshooting done:
I have cleared the cache. 
Restarted firefox multiple times.
Firefox is up to date


To sum it up : I think HTTPS pages don't get their thumbnails.
Comment 19 Prasan 2012-07-28 12:26:49 PDT
(In reply to prasanaik from comment #18)
> Problem: Not all thumbnails are displayed
> 
> More: Its quite random and I'm not really able to pinpoint which pages don't
> display the thumbnails, Since I can't manually pin a website.
> But of the few websites that I have pinned, I think the ones using https
> don't show up a thumbnails. 
> I cannot confirm this because there aren't enough test pages and again I
> don't know how to manually set a page in there. 
> 
> Troubleshooting done:
> I have cleared the cache. 
> Restarted firefox multiple times.
> Firefox is up to date
> 
> 
> To sum it up : I think HTTPS pages don't get their thumbnails.

A bit of an update. I don't think this has to do https. 
On the other hand, it might have to do with AJAX. 

I'm basing this on what I noticed:
Pages like twitter and Google Reader fail to load. 
I think its those pages that keep updating without an actual refresh using AJAX which leads to the thumbnail failing.
Comment 20 Alex Keybl [:akeybl] 2012-07-30 10:00:01 PDT
We're investigating what to do here in the longterm, but it's not a critical issue for shipping the feature in upcoming releases, so no need to track for 15. If a low-risk fix is found, we would consider uplift however.
Comment 21 henryfhchan 2012-08-15 22:32:10 PDT
Suggestion:
Cache thumbnails for Cache-Control: no-store if
(1) The user entered the URL explicitly into the browser
(2) The URL has a path of '/'.
Comment 22 Dave Herman [:dherman] 2012-08-16 11:32:32 PDT
This seems like a serious issue from the standpoint of just looking respectable. My new tabs have looked like this for a few weeks:

http://gyazo.com/6af13f20394299d19fef5f110fac1d61

[ You can track the timing pretty accurately since it clearly last took a snapshot of the famous Twitter downtime that happened on July 26th. :) ]

As pretty as Koolaid.Junkie's mockup is, I don't think wasting users' time asking them to specify thumbnails is viable. If we can't find a reasonably attractive (and privacy-respecting) thumbnail automatically, I'm afraid we need to reconsider the whole design of a thumbnails page. The screenshot I linked to is pretty embarrassing aesthetically.

Dave
Comment 23 Karel Jára 2012-08-16 14:47:30 PDT
I can confirm comment 22. I rather turned the whole new page off instead of looking at a set of grey rectangles. This should be resolved somehow.
Comment 24 :Gavin Sharp [email: gavin@gavinsharp.com] 2012-08-17 13:47:38 PDT
The grey rectangles are more likely to be issues with losing thumbnails in the file cache, which is fixed by bug 744388. That patch is currently scheduled to ship in Firefox 16.
Comment 25 Dão Gottwald [:dao] 2012-09-11 09:56:20 PDT
*** Bug 783772 has been marked as a duplicate of this bug. ***
Comment 26 Jonathan Protzenko [:protz] 2012-10-25 07:08:24 PDT
I'm running Aurora and, just like :dherman, I have mostly grey rectangles on my new tab page, so I don't think the issue is related to the file cache. I've made sure all my cache settings are set to default.
Comment 27 :Gavin Sharp [email: gavin@gavinsharp.com] 2012-10-26 14:52:37 PDT
The other major cause of blank thumbnails appearing on about:newtab is bug 756881.
Comment 28 :Gavin Sharp [email: gavin@gavinsharp.com] 2012-10-26 14:53:10 PDT
Er, which is this bug. But the point stands - this bug is not fixed :)
Comment 29 Dão Gottwald [:dao] 2012-11-15 06:49:27 PST
*** Bug 812160 has been marked as a duplicate of this bug. ***
Comment 30 Dão Gottwald [:dao] 2013-01-15 14:04:32 PST
*** Bug 830770 has been marked as a duplicate of this bug. ***
Comment 31 John Kitz 2013-01-16 02:39:33 PST
Please note the comments I entered in bug 830770 after it was mmarked as a duplicate of this one. Another example of a site which fails to result in a placeholder or thumbnail containing an image is http://casperflights.com/.
Comment 32 Madhava Enros [:madhava] 2013-02-19 14:17:39 PST
Can we just take a screenshot of the un-logged-in front page of sites that set this and use that? I think other browsers may do this.
Comment 33 Tim Taubert [:ttaubert] 2013-02-19 14:29:06 PST
(In reply to Madhava Enros [:madhava] from comment #32)
> Can we just take a screenshot of the un-logged-in front page of sites that
> set this and use that? I think other browsers may do this.

You just pretty much described the goal of bug 841495 :)
Comment 34 Michael Lefevre 2013-02-19 14:45:44 PST
I'm assuming that removing bug 841495 from the dependency list was accidental.
Comment 35 Oz 2013-03-03 08:48:18 PST
any news on this?
Comment 36 :Gavin Sharp [email: gavin@gavinsharp.com] 2013-03-03 12:41:25 PST
Bug 841495 is the proposed solution, work is progressing in that bug.
Comment 37 Paul Silaghi, QA [:pauly] 2013-04-02 05:56:42 PDT
*** Bug 853696 has been marked as a duplicate of this bug. ***
Comment 38 Marcin Wisnicki 2013-05-19 14:55:52 PDT
Consider showing favicon like Chrome.
Comment 39 Sid 2013-05-25 12:33:21 PDT
Is it supposed to be fixed now that patches in bug 841495 landed? My Nightly still doesn't capture thumbs for "no-store" websites.
Comment 40 Tim Taubert [:ttaubert] 2013-05-25 12:43:03 PDT
(In reply to Sid from comment #39)
> Is it supposed to be fixed now that patches in bug 841495 landed? My Nightly
> still doesn't capture thumbs for "no-store" websites.

No, bug 841495 just implemented the mechanism. We still need to fix a couple of follow-ups and implement a policy for when to use the new service (see bug 870100).
Comment 41 Daniel "warmth" Delgado 2013-06-03 04:22:54 PDT
Looking forward for this bug to be fixed. I see the screenshot as a possible solution but only temporarily like Opera does, I think a better PNG creation system must be done, not depending on Cache headers.
Comment 42 gbcox 2013-06-10 14:16:03 PDT
For those of you who are tired of waiting for a fix, a good workaround is this addon:
https://addons.mozilla.org/en-US/firefox/addon/new-tab-tools
Comment 43 Daniel "warmth" Delgado 2013-07-24 11:12:16 PDT
I can confirm that this has been fixed for the latest Nightly version. :D
Comment 44 :Gavin Sharp [email: gavin@gavinsharp.com] 2013-07-24 16:35:15 PDT
Fixed by bug 870100.
Comment 45 Alex Shilov 2014-03-11 22:06:47 PDT
I'm using Nightly 30, and this bug is not fixed. Thumbnails are not updated for days, even if i click them regularly.
Comment 46 Prasan 2014-03-11 22:13:40 PDT
This bug has indeed been fixed. The page thumbnails now source the login pages for websites like twitter etc. People commenting about the feature being a issue in Nightlies should try stable releases as they work perfectly well.
Comment 47 xanda 2014-07-20 12:19:02 PDT
This bug is not fixed and stable releases do not 'work perfectly well'.
We are using standard/stable release 30: thumbnails are not updated as described.
Comment 48 Matt Brubeck (:mbrubeck) 2014-07-25 07:29:16 PDT
For privacy reasons, Firefox does not save screenshots while you are logged in to sites like Facebook.  Instead, it shows a thumbnail of what a logged-out user sees instead.  This is the fix that was chosen for this bug.  It's a compromise between aesthetics and user privacy.  (Before this fix, there was no image displayed at all for Facebook, Twitter, etc.)

If you are seeing something other than the intended behavior, please file a new bug with a detailed description/screenshots of the issue you are seeing, so we can work on fixing it.  Thanks!
Comment 49 samarali 2015-10-30 10:12:35 PDT Comment hidden (spam)
Comment 50 pbhj 2016-02-09 09:40:29 PST
FYI there are several continuations of this bug - 949655, 1126487 at least.

Note You need to log in before you can comment on or make changes to this bug.