The default bug view has changed. See this FAQ.

Sorting in Bookmarks Management window should apply everywhere

VERIFIED FIXED in mozilla1.4final

Status

SeaMonkey
Bookmarks & History
P2
enhancement
VERIFIED FIXED
16 years ago
3 years ago

People

(Reporter: Viswanath Ramachandran, Assigned: janv)

Tracking

Trunk
mozilla1.4final
x86
All
Dependency tree / graph
Bug Flags:
blocking1.4a -

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [adt2] [UI])

(Reporter)

Description

16 years ago
When you do a Sort by attribute (Name, Location etc) in the bookmarks management 
window, that Sort should
- apply to the view in the bookmarks sidebar
- apply to the view in the bookmarks pulldown menu in Nav
- be persistent across sessions. 

I've verified that the first two do not happen, which is a bug.
(Reporter)

Updated

16 years ago
Keywords: nsbeta1
(Reporter)

Comment 1

16 years ago
nice to have, mozilla0.9.2 would be the right time to have it. 
Keywords: nsbeta1 → nsbeta1+
Priority: -- → P3
Target Milestone: --- → mozilla0.9.2

Comment 2

16 years ago
*** Bug 78230 has been marked as a duplicate of this bug. ***

Comment 3

16 years ago
nav triage team:

Ben, how much work is this?
On initial inspection, maybe 20-40 minutes start to finish. 
Status: NEW → ASSIGNED
(Reporter)

Comment 5

16 years ago
nav triage: on further review, not an rtm stopper. but if you can generate a 
patch, we shd take it among the nice-to-haves. Moving to m0.9.3 therefore.  
Target Milestone: mozilla0.9.2 → mozilla0.9.3

Comment 6

16 years ago
I aplogize in advance if this is not the right place to post this comment, but I
can not believe the bookmarks team does not consider this as a critical feature,
thus moving it to 0.9.2 and 0.9.3.

Now I *fully* appreciate the fact there are other issues to work on with
bookmarks, but IMHO, sorting is a critical function of managing your
bookmarks...and as such the inability to have things sorted alphabetically in
the menus, etc. is a fundamental flaw in the component...especially if Ben is
right in saying that it should take under an hour to implement this feature.  If
I knew how to code, I would gladly volunteer my services, but I have zero
programming knowledge.

Thank you
Actually I did some investigation of this the other day before it was moved out, 
and it'd probably take longer than I originally estimated to get just right.

-Ben
 "The Bookmarks Team" (and the "Defer Skin Switch until after restart Team" and 
the "Layout issues in random dialogs Team") 

Comment 8

16 years ago
nav triage team:

This is too big of a task to complete by mozilla0.9.3. Marking mozilla1.0
Target Milestone: mozilla0.9.3 → mozilla1.0

Comment 9

16 years ago
*** Bug 89047 has been marked as a duplicate of this bug. ***
Paul Chen is now taking Bookmarks bugs. For your convenience, you can filter 
email notifications caused by this by searching for 'ilikegoats'.

Assignee: ben → pchen
Status: ASSIGNED → NEW

Comment 11

16 years ago
*** Bug 106324 has been marked as a duplicate of this bug. ***

Comment 12

16 years ago
P2, moz097, blocks 102472. Estimated at one day.
Blocks: 102472
Priority: P3 → P2
Target Milestone: mozilla1.0 → mozilla0.9.7

Comment 13

16 years ago
*** Bug 111947 has been marked as a duplicate of this bug. ***

Comment 14

16 years ago
Moving to mozilla0.9.8
Target Milestone: mozilla0.9.7 → mozilla0.9.8

Comment 15

15 years ago
mass reassign of pchen bookmark bugs to ben
Assignee: pchen → ben

Comment 16

15 years ago
what are the chances this is gonna make 098?
-> .9.9
Status: NEW → ASSIGNED
Target Milestone: mozilla0.9.8 → mozilla0.9.9
Severity: normal → enhancement
Keywords: nsbeta1

Comment 18

15 years ago
nsbeta1+
Keywords: nsbeta1 → nsbeta1+
Depends on: 128815

Comment 19

15 years ago
Mass-moving remaining Nav team 0.99 bugs to 1.0.
Target Milestone: mozilla0.9.9 → mozilla1.0
This is all in except for the menu. Joe has a fix for the XUL Sort Service which
he needs to land so I can hook that part up. 
Whiteboard: Menu Sort: 1d.

Updated

15 years ago
Whiteboard: Menu Sort: 1d. → Menu Sort: 1d.[adt3]

Comment 21

15 years ago
*** Bug 133185 has been marked as a duplicate of this bug. ***

Comment 22

15 years ago
adding self to cc list

Comment 23

15 years ago
Ben, is this still waiting on work from Joe?  What bug does this depend on?
No, joe has landed. Completion of this bug is now possible. 

Comment 25

15 years ago
nsbeta1- per Nav triage team, ->1.0.1
Keywords: nsbeta1+ → nsbeta1-
Whiteboard: Menu Sort: 1d.[adt3] → Menu Sort: 1d.[
Target Milestone: mozilla1.0 → mozilla1.0.1

Comment 26

15 years ago
*** Bug 147177 has been marked as a duplicate of this bug. ***

Comment 27

15 years ago
Nominating for buffy.
Keywords: nsbeta1- → nsbeta1

Comment 28

15 years ago
Nav triage team: nsbeta1+/adt3
Keywords: nsbeta1 → nsbeta1+
Whiteboard: Menu Sort: 1d.[ → [adt2]

Comment 29

15 years ago
With Mozilla v1.1b build 2002072008, Win 98SE, & the view options set to "Sorted
by Name" A-Z the folders, sub-folders, & bookmarks show as sorted when examined
in the "Manage Bookmarks" mode but not in the regular use mode.  Thus
rendenering the sort rather useless.  I have about 4,000 bookmarks in about 50
folders & sub-folders all told.  BTW, sorting is better than in mozilla v1.0.  

Comment 30

15 years ago
*** Bug 158877 has been marked as a duplicate of this bug. ***

Comment 31

15 years ago
This *feature* or lack thereof, has kept me from a 100% Moz conversion for some 
time now. (I'm seriously anal about my bookmarks..so sue me)

Is there ANY idea of expected completion date or build for this feature?

Comment 32

15 years ago
*** Bug 41281 has been marked as a duplicate of this bug. ***

Comment 33

15 years ago
*** Bug 162888 has been marked as a duplicate of this bug. ***

Comment 34

15 years ago
*** Bug 167369 has been marked as a duplicate of this bug. ***

Comment 35

15 years ago
*** Bug 168499 has been marked as a duplicate of this bug. ***

Comment 36

15 years ago
*** Bug 168898 has been marked as a duplicate of this bug. ***

Comment 37

15 years ago
*** Bug 169604 has been marked as a duplicate of this bug. ***
-> Jan for Buffy. 
Assignee: ben → varga
Status: ASSIGNED → NEW

Comment 39

15 years ago
*** Bug 172526 has been marked as a duplicate of this bug. ***

Comment 40

15 years ago
*** Bug 173740 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 41

15 years ago
Hmm, this looks like it's already working.
Ben, what is the remaining issue, if any ?

Comment 42

15 years ago
In Mozilla 1.2a Mac OS 9, the bookmarks bug is still here, at least for me.
(Assignee)

Comment 43

15 years ago
Hmm, it works on Mac OS X.
When I click on a column in bookmark manager the same change is reflected in
sidebar.

Comment 44

15 years ago
Works in the sidebar but, does it still work in the drop down Bookmark 
selection on the Toolbar?
(Assignee)

Comment 45

15 years ago
Ok, so this is the remaining issue ?

Comment 46

15 years ago
As far as i can see, ordering by name bookmarks in the Bookmarks Manager only
changes order in that own window. Not elsewhere.
(Assignee)

Comment 47

15 years ago
Okey, Ben confirmed that the remaing issue is Bookmarks pulldown menu

Comment 48

15 years ago
There's also another strange behaviour: I bookmarked www.pchigh.ch and it did
not appear in the bookmarks until I removed the "-=".

Comment 49

15 years ago
*** Bug 176013 has been marked as a duplicate of this bug. ***

Comment 50

15 years ago
*** Bug 172715 has been marked as a duplicate of this bug. ***

Comment 51

15 years ago
Verified the bug on Windows XP version on 2002-11-25:
Windows XP Pro version 2002, all patches installed (NOT service packs)

Running Phoenix with the following about screen:
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.2b) Gecko/20021029 Phoenix/0.4

Again, while the bookmarks are sorted in the Manage Bookmarks screen, but when a
folder is added to the toolbar, the bookmarks contained within are not sorted.

Comment 52

15 years ago
*** Bug 185457 has been marked as a duplicate of this bug. ***

Comment 53

14 years ago
*** Bug 184621 has been marked as a duplicate of this bug. ***

Comment 54

14 years ago
This is a critical bug that we have had to live with for way too long!  It needs
to be fixed.

Comment 55

14 years ago
As Chris said back in July, this is stopping me from really migrating from IE -
can't beleive it's still not fixed. Would love to be the one to fix it, but
programming skills aren't up to it :(

Comment 56

14 years ago
Pardon my ignorance, but how do you sort bookmarks in IE?  I can see how to
rearrange them (D&Din IE 6), but not how to sort them.

Comment 57

14 years ago
Peter, in IE6, you basically can just 'sort by name' which performs an
alphabetical sorting on both folder AND individual bookmarks.
GRANTED, Moz/PX has a MUCH greater ability to sort bookmarks in various
ways.....this problem is that these 'sortings' aren't reflected as they should
be outside of the bookmark manager....but I digress.

If you haven't seen the 'sort by name' option, just right click anywhere in the
drop down list of bookmarks...look near the bottom of the list of the new window
that pops up....it should be there.  I think that the only reason it's even
available is becuase even IE simply ADDS bookmarks to the list in the order they
are created, ie, out of order.  The sort by name just puts them back in ABC
order...which is REALLY necessary when you're dealing with a LOT of bookmarks!!!

Comment 58

14 years ago
Not only the sorting in the pull down menu is missing. Things which we got used 
to from other programs are missing there too.
Simply grabbing an entry from the bookmark-pulldown and dragging it to a 
different location within the pulldown menu. right clicking there and have 
options like "edit bookmark" "delete" "cut/copy/paste" and "sort by Name/last 
visited" etc.
I know quite some people who say that the focus on such annoyances isnt that 
good since this bug is knows for years (literally) now, and still has a target 
milestone of 1.0.1.
I have to admit, I am not good enough to code at that level, or else I would try 
to change that.

Comment 59

14 years ago
"options like "edit bookmark" "delete" "cut/copy/paste" and "sort by Name/last 
visited" etc."

These other *abilities* actually make it so that I don't even have to go into
the IE bookmark manager very often.  These functions are EXTREMELY useful!

Comment 60

14 years ago
Thanks, but wow, right-clicking in a menu - they couldn't have buried that any
more if they had a shovel.  It isn't even available in the Favorites sidebar or
the Organize dialog.  

Comment 61

14 years ago
*shrug* i actually think you commented in another bug a while back where that
was mentioned. it was introduced with ie4 shell integration. the problem is that
the menus and the views don't relate and there's no clean ui to allow you to 
enforce sorting on the menu other than contextually.
(Assignee)

Updated

14 years ago
OS: Windows 98 → All
Target Milestone: mozilla1.0.1 → mozilla1.4alpha

Comment 62

14 years ago
Would be real nice if a developer showed some initiative and FIXED this bug.  We
need less talk and more action!

Comment 63

14 years ago
> Would be real nice if a developer showed some initiative and FIXED this bug.  We
> need less talk and more action!

A sentiment shared by all. So where's your patch?

Comment 64

14 years ago
Bookmark problems are the only thing stopping me making Mozilla my default 
browser. In IE6 bookmarks can be sorted by folder name, sub folder name, and 
link name. It is then possible to manually move specific 'important' links to 
the top of the hierarchy where they are prominent. It is also possible to move 
links to the top spot by prefixing them with a hash character # before sorting.

But if I import my links into Mozilla none of this is possible. They arrive out 
of order, and the contents of sub folders are randomly scrambled. # characters 
are ignored. And there is nothing I can do about it. I can't sort them and I 
can't move them manually.

It really is about time this problem was addressed.

Comment 65

14 years ago
This is extremely important to anyone who has more than a few bookmarks, and is
a real showstopper for anyone considering a move from IE.
I'd like to add my voice to those pleading for a solution!

Comment 66

14 years ago
Nigel and others who have commented, please make sure you register your vote if 
this bug is important to you. It is to me!

See "Vote for this bug" on this page.

Comment 67

14 years ago
Incredibly, this bug was "officially" opened in Bugzilla almost TWO YEARS ago
on: 2001-04-24 13:22.  Nice to see the developers "step up" to this request. 
Good thing this is NOT commercial software.  They'd all be fired by now.
(Assignee)

Updated

14 years ago
Blocks: 196756

Comment 68

14 years ago
*** Bug 196841 has been marked as a duplicate of this bug. ***

Updated

14 years ago
Flags: blocking1.4a?
(Assignee)

Comment 69

14 years ago
pushing to beta
Target Milestone: mozilla1.4alpha → mozilla1.4beta
(Assignee)

Updated

14 years ago
No longer blocks: 196756

Updated

14 years ago
Flags: blocking1.4a? → blocking1.4a-

Comment 70

14 years ago
*** Bug 200838 has been marked as a duplicate of this bug. ***
(Assignee)

Updated

14 years ago
Whiteboard: [adt2] → [adt2] [UI]
*** Bug 204718 has been marked as a duplicate of this bug. ***
(Assignee)

Updated

14 years ago
Status: NEW → ASSIGNED
Target Milestone: mozilla1.4beta → mozilla1.4final

Comment 72

14 years ago
There are various bugs about sorting bookmarks...

All of them have been reported for ages, and still nothing is changed in 1.4b

(except that now sorting works, but it's not flexible at all)

The best would be : 
- sort folder first, then files (which is not the current behaviour, sorting by
name for instance sorts everything by name, regardless its nature) : this is as
to match the win32, X and console traditionnal behaviour of displaying folders
before files
- beeing able to sort folders separatly, because for instance, I can like to
have forums/board bookmark by date, and other stuff by name...which is
impossible at the moment
- proper export of bookmarks : once exported by moz, and imported in IE, all
special characters like é è à etc.. (french, but in general all latin special
keys) are jammed...for instance, Société is written SociÃ(c)tÃ(c) ...must be
some kind of charset mismatch...
(Assignee)

Updated

14 years ago
Blocks: 205378

Comment 73

14 years ago
Fixed by 205378. Verified in both the 2003-05-23-09 Win32 and 2003-05-23-07
Macho trunk builds.
Status: ASSIGNED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED

Comment 74

14 years ago
Verified
Status: RESOLVED → VERIFIED

Comment 75

14 years ago
When I sort bookmarks in the manager, the changes are still not showing up in
the dropdown in the nav.

Are the changes made, only applied in Mozila and not in Firebird?

Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4b) Gecko/20030525 Mozilla
Firebird/0.6

Comment 76

14 years ago
*** Bug 205316 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 77

14 years ago
Yeah, it's only fixed in Mozilla due to lack of resources.
Pierre is still busy these days, anyone wanna make a patch for Firebird.
It should be easy using some bonsai/cvs/diff magic.
*** Bug 207912 has been marked as a duplicate of this bug. ***

Comment 79

14 years ago
If this is fixed in Moz shouldn't the product and target to Phoenix (fb) ?
(Assignee)

Comment 80

14 years ago
Please don't change the product, but feel free to file a similar bug for Firebird.
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.