Closed Bug 795665 Opened 9 years ago Closed 7 years ago

Use even more 2x images for HiDPI browser UI

Categories

(Firefox :: Theme, defect)

All
macOS
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1016548

People

(Reporter: fryn, Unassigned)

References

(Blocks 1 open bug, )

Details

Attachments

(1 file, 3 obsolete files)

We do not need to create and integrate HiDPI counterparts for every single image that we currently have in the tree, but we should try to do it for all the browser UI that we intend to support going forward.

We already completed a lot of this in bug 781327. This followup bug is for the remaining work. Any bugs that get filed for missing HiDPI images in our OS X theme should get duped to this bug.
Blocks: osx-hidpi
Depends on: 817366
No longer depends on: 781327
Summary: Provide HiDPI images for all the browser UI we intend to support on OS X → Use even more 2x images for HiDPI browser UI
Icons we still need:

- Large Notification Key
- Sync Promo
- Bookmark Panel Star
- Bookmark Menu Icon
- Sidebar Close
- Preference Pane Categories
  - Application Actions
  - Help
- Add-ons Manager icons
Depends on: 832553
No longer depends on: 832553
Depends on: 781327
No longer depends on: 817366
Duplicate of this bug: 834592
Some more icons we need:
- Icons in Tab View, as Reuben reported, though it's about as de-prioritized as fixing Tab View is.
Duplicate of this bug: 834591
Another icon we need:
- an HIDPI version of search-textbox.png for bookmarks with keywords (quicksearches), since Search.png is a different size and color.
We need a HiDPI version of the smooth scrolling image too.
…and a HiDPI version of the check mark used in our menus. Although that could probably be replaced with a ✓
Attached file HiDPI checkmark icon (obsolete) —
(In reply to Reuben Morais [:reuben] from comment #7)
> …and a HiDPI version of the check mark used in our menus. Although that
> could probably be replaced with a ✓

Nevermind the last part. Attached is the high resolution version of the checkmark icon that OS X uses.
(In reply to Reuben Morais [:reuben] from comment #7)
> …and a HiDPI version of the check mark used in our menus.

Nice find!

The code for that is here:
https://mxr.mozilla.org/mozilla-central/source/toolkit/themes/pinstripe/global/menu.css#171

The high-resolution checkmark icon needs to be converted from a PDF to a PNG containing the normal and hover states first.
- the little down arrow icon in the menu button next to the default button in arrow panels (panel-dropmarker.png)
- the flexible space and activity indicator in toolbar customization

I made this into an Etherpad, though it may be prone to vandalism:
https://etherpad.mozilla.org/even-more-hidpi

(In reply to Reuben Morais [:reuben] from comment #6)
> We need a HiDPI version of the smooth scrolling image too.

What is the smooth scrolling image?
(In reply to Frank Yan (:fryn) from comment #10)
> (In reply to Reuben Morais [:reuben] from comment #6)
> > We need a HiDPI version of the smooth scrolling image too.
> 
> What is the smooth scrolling image?

Oh, that's autoscroll, not smooth scroll.
Attached image HiDPI Checkmark icon
The white version doesn't exist in the OS X files, so I couldn't create the two state version of these images.
Attachment #715283 - Attachment is obsolete: true
Attached image Menu right arrow (obsolete) —
toolkit/themes/pinstripe/global/menu/menu-arrow.png
Attached image Menu right arrow, disabled (obsolete) —
toolkit/themes/pinstripe/global/menu/menu-arrow.png
Depends on: 845306
Attachment #717453 - Attachment is obsolete: true
Attachment #717454 - Attachment is obsolete: true
Depends on: 845516
Depends on: 848150
Depends on: 851953
Depends on: 881290
Here are some more that I've discovered in Firefox 29 for Mac...

The following in the bookmarks dropdown menu in the menu bar:
- folder icons for bookmarks (including smart folder icons)
- link icons for links without favicons 
- "Bookmarks toolbar" icon
- RSS folder icon
- the "get bookmark add-ons" icon

All of the above in the "Show All Bookmarks" pane as well as all the Toolbar icons in the bookmarks pane.

Icons in the Preferences Pane:
- All top icons
- (?) help button
- the action icons under Applications

All icons in the Add-ons manager.

Icons in the Preferences Pane, Add-ons manager and toolbar icons in the Bookmarks menubar dropdown.

The embedded window that appears for activating plugins (in particular the cross for closing it).
I've gone through the comments and bugs noted here, and I think everything is now covered by the bug 1021964 breakdown. Forward duping. Please file new bugs for any issues not covered there.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1021964
Crap. I meant bug 1016548.
Duplicate of bug: 1016548
You need to log in before you can comment on or make changes to this bug.