Closed Bug 1016548 Opened 6 years ago Closed 6 years ago

Breakdown: Finish OS X HiDPI support for Firefox front-end

Categories

(Tracking Graveyard :: Firefox Operations, defect)

All
macOS
defect
Not set
normal

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: Dolske, Assigned: Dolske)

References

(Depends on 10 open bugs, Blocks 1 open bug)

Details

(Whiteboard: p=5 s=33.1 [qa-])

HiDPI Retina displays on OS X are quite common. We previously did a lot of work in bug 781327 and bug 795665 to get things into a decent state, but a significant amount of work remains to be done. This bug is for determining the remaining scope of work we want to do to consider it effectively complete.
Flags: firefox-backlog+
Whiteboard: p=5 → p=5 [qa-]
Status: NEW → ASSIGNED
Whiteboard: p=5 [qa-] → p=5 s=it-32c-31a-30b.3 [qa-]
Depends on: 1021915
Depends on: 1021927
Depends on: 1021941
Depends on: 1021958
Depends on: 1021964
Depends on: 1021971
Depends on: 1021974
Depends on: 1021978
Depends on: 1021984
Depends on: 1021988
Depends on: 1022005
Depends on: hidpi-favicon-ui
Duplicate of this bug: 795665
As part of bug 1016556 we'll be figuring out how we want to deal with HiDPI in Windows, since it's more complicated (multiple zoom levels, instead of just 100% and 200%). I don't think that should block the remaining OS X Retina work, though... Most of it is just continuing the same techniques we've already done in previous bugs, so when/if the plan for Windows HiDPI changes how we do OS X HiDPI, we'd already need to update previous work. It's fairly simple and mechanical, so there shouldn't be much wasted effort.
Depends on: 1016405
Depends on: 1022039
Depends on: 1022041
Depends on: 1022044
Depends on: 1022051
Depends on: 1022060
Depends on: 881281
I recently landed full hdpi support in bug 837188
Depends on: 837188
Whiteboard: p=5 s=it-32c-31a-30b.3 [qa-] → p=5 s=33.1 [qa-]
Blocks: 1023517
Marking FIXED as breakdown is complete.
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Status: RESOLVED → VERIFIED
Depends on: 1041685
Product: Tracking → Tracking Graveyard
You need to log in before you can comment on or make changes to this bug.