Order of words reversed in Hebrew site on Mac

RESOLVED FIXED in mozilla0.9.8

Status

()

RESOLVED FIXED
18 years ago
5 years ago

People

(Reporter: smontagu, Assigned: ftang)

Tracking

({intl})

Trunk
mozilla0.9.8
PowerPC
Mac System 8.5
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(6 attachments)

(Reporter)

Description

18 years ago
I was sent the attached screen shots by ofer@yeda.co.il

Each word is displayed correctly, but the order of the words is reversed. 
For example the Hebrew equivalent of WHAT'S NEW, which should be rendered 

WEN S'TAHW

is rendered

S'TAHW WEN
(Reporter)

Comment 1

18 years ago
Created attachment 34289 [details]
screenshot from www.walla.co.il
(Reporter)

Comment 2

18 years ago
Created attachment 34290 [details]
screenshot from www.msn.co.il
(Reporter)

Comment 3

18 years ago
The first thing to try in fixing this is to port the IBMBIDI changes in 
gfx/src/windows/nsRenderingContextWin.cpp to 
gfx/src/mac/nsRenderingContextMac.cpp



(Assignee)

Comment 4

18 years ago
simon- Please attach nwe screen shot in GIF or JPEG. I somehow cannot view tiff. 
Also, could you attach the CORRECT screen shot here so I can compare if I write 
some new code. 
reassing to ftang
Assignee: nhotta → ftang
(Assignee)

Comment 5

18 years ago
mark it as assigned
Status: NEW → ASSIGNED
(Reporter)

Comment 6

18 years ago
Attaching new screenshots. For testing I suggest you use the Hebrew testpage 
that Mimi prepared for Andreas, which has text in Hebrew with images of the 
expected rendering.
(Reporter)

Comment 7

18 years ago
Created attachment 34529 [details]
screenshot of www.walla.co.il (gif)
(Reporter)

Comment 8

18 years ago
Created attachment 34530 [details]
screenshot of msn.co.il (gif)
(Reporter)

Comment 9

18 years ago
Created attachment 34531 [details]
expected results at www.walla.co.il
(Assignee)

Comment 10

18 years ago
I am confsued. Which screen shots are right, which are wrong ?
(Reporter)

Comment 11

18 years ago
WRONG:
  attachment 34529 [details] -- walla
  attachment 34530 [details] -- msn

RIGHT:
  attachment 34531 [details] -- walla

I didn't attach a RIGHT screenshot of www.msn.co.il, because the content of the 
site keeps changing.
(Assignee)

Comment 12

18 years ago
no time to work on mac arabic/hewbrew . move to future.
Target Milestone: --- → Future

Comment 13

18 years ago
Changing QA contact to giladehven@hotmail.com.

Changing component to "Bidi..." and adding intl keyword.
Component: Internationalization → BiDi Hebrew & Arabic
Keywords: intl
QA Contact: andreasb → giladehven

Comment 14

17 years ago
*** Bug 94633 has been marked as a duplicate of this bug. ***

Comment 15

17 years ago
*** Bug 93665 has been marked as a duplicate of this bug. ***

Comment 16

17 years ago
*** Bug 81943 has been marked as a duplicate of this bug. ***

Comment 17

17 years ago
*** Bug 81020 has been marked as a duplicate of this bug. ***

Comment 18

17 years ago
From dupe:
------- Additional Comments From Simon Montagu 2001-05-18 11:52 -------
What I was trying to say was that the Hebrew in your screenshot has been
ordered with base direction left-to-right instead of right-to-left. In
Windows when mRightToLeftText is true in nsRenderingContextWin.cpp we call
SetTextAlign with TA_RTLREADING, which sets the base direction for the
device context's native reordering to right-to-left. You have to find the
equivalent API for Mac and call it.
------- Additional Comments From Simon Montagu 2001-05-21 15:51 -------
What I meant was the base (paragraph) direction used when the platform invokes 
its own implementation of the Bidi algorithm. This is important, because it 
determines whether a logical text like

COPYRIGHT 2000 MICROSOFT

is rendered

TGHIRYPOC 2000 TFOSORCIM   <--- with LTR base direction

or

TFOSORCIM 2000 THGIRYPOC   <--- with RTL base direction

In Windows this is set by calling SetTextAlign with the flag TA_RTLREADING (by 
the way the comment in the source of nsRenderingContextWin.cpp is not 
synchronized with the code -- I'll file a separate bug on that).
OS: other → Mac System 8.5

Updated

17 years ago
Blocks: 95860

Comment 19

17 years ago
*** Bug 96305 has been marked as a duplicate of this bug. ***

Comment 20

17 years ago
Mass-move all BiDi Hebrew and Arabic qa to me, zach@zachlipton.com. 
Thank you Gilad for your service to this component, and best of luck to you 
in the future.

Sholom. 
QA Contact: giladehven → zach

Comment 21

17 years ago
*** Bug 108331 has been marked as a duplicate of this bug. ***

Comment 22

17 years ago
On system 10, I see this in some places but not others. not sure if this is 
the same bug? adding attachment

Comment 23

17 years ago
Created attachment 59664 [details]
Tapuz (logical) web sites on OS X. notice the order of the words where the arrows point
(Assignee)

Updated

17 years ago
Blocks: 115710
(Assignee)

Comment 24

17 years ago
probably could be fixed by bug 116976 and bug 116982
Depends on: 116976, 116982
(Assignee)

Updated

17 years ago
Target Milestone: Future → mozilla0.9.8
(Assignee)

Comment 25

17 years ago
I believe the following three patch should fix most mac os hewbrew problem

big endian issue in nsFrame.cpp
see latest patch in http://bugzilla.mozilla.org/show_bug.cgi?id=116976

big endian issue in nsBidiImp.cpp 
http://bugzilla.mozilla.org/attachment.cgi?id=62917&action=view

turn off hebrew reordering and do not report hint on mac gfx
http://bugzilla.mozilla.org/attachment.cgi?id=62920&action=view
(Assignee)

Comment 26

17 years ago
this should be fixed right now. If you see some speical case which are not
right. Please file seperate bug for the speical case and assign to smontagu first. 
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED
(Assignee)

Updated

17 years ago
Blocks: 104060
(Assignee)

Updated

17 years ago
No longer blocks: 104060

Updated

10 years ago
Component: Layout: BiDi Hebrew & Arabic → Layout: Text
QA Contact: zach → layout.fonts-and-text
You need to log in before you can comment on or make changes to this bug.