Closed Bug 82626 Opened 24 years ago Closed 22 years ago

Bad alignment of items in dropdown list

Categories

(Core :: Layout: Form Controls, defect)

defect
Not set
normal

Tracking

()

VERIFIED FIXED
Future

People

(Reporter: stevegca, Assigned: rods)

References

()

Details

Attachments

(2 files)

From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win 9x 4.90; en-US; rv:0.9+) Gecko/20010524
BuildID:    2001052404

In the page at http://www.netbank.com/login.htm the text for the items in the
dropdown list ("select one...", "banking", "brokerage" "credit card" and "safe
deposit box") are misaligned.  When selected, only the bottom half of the
letters display.

Reproducible: Always
Steps to Reproduce:
1. Go to http://www.netbank.com/login.htm
2. Look at the dropdown list
3.
Confirmed on Linux-Mandrake8, build 2001052411
I'm thinking this may have to do with the fact that the dropdown in question is
within a <p> element, which has the CSS declaration:
p {line-height:0px;}

??? I don't know why anyone would want a line-height of 0px, but to each their
own...

The behavior still doesn't make sense to me though.
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Summary: Bad alignment of items in dropdown list → [FIX]Bad alignment of items in dropdown list
Yes, that is it exactly. Somehow it must be inheriting that. If I add:
select {
line-height:1em ! important;
}
all is well.
Attached file reduced testcase
So the fix would be to add:

line-height:1em ! important;

to the forms.css file in the select rule.
bug 82265 talks about the same issue
Target Milestone: --- → mozilla0.9.2
This bug could potentially make selects unusable because you wouldn't be able to
read whats in them.

patch looks good.
r=kmcclusk@netscape.com
sr=hyatt
a= asa@mozilla.org for checkin to the trunk.
(on behalf of drivers)
fixed
Status: ASSIGNED → RESOLVED
Closed: 23 years ago
Resolution: --- → FIXED
Should we mark bug 79999 as a dupe of this one?
Look like a round-off error accumulates, probably a core layout thing.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Summary: [FIX]Bad alignment of items in dropdown list → Bad alignment of items in dropdown list
Status: REOPENED → ASSIGNED
this will have to wait
Target Milestone: mozilla0.9.2 → mozilla1.0
*** Bug 79999 has been marked as a duplicate of this bug. ***
*** Bug 70019 has been marked as a duplicate of this bug. ***
*** Bug 65187 has been marked as a duplicate of this bug. ***
*** Bug 90149 has been marked as a duplicate of this bug. ***
OS: Windows ME → All
Hardware: PC → All
Did somebody apply this patch again?  Cause this bug seems to be gone, but Bug
84928 has returned.  WinXPRC2/2001081403-trunk
oops looked at "fixed" testcase instead of real testcase, ignore my last comments
*** Bug 97100 has been marked as a duplicate of this bug. ***
*** Bug 105320 has been marked as a duplicate of this bug. ***
Moving to Future
Target Milestone: mozilla1.0 → Future
*** Bug 117960 has been marked as a duplicate of this bug. ***
*** Bug 126761 has been marked as a duplicate of this bug. ***
*** Bug 139303 has been marked as a duplicate of this bug. ***
*** Bug 143865 has been marked as a duplicate of this bug. ***
*** Bug 149815 has been marked as a duplicate of this bug. ***
*** Bug 150264 has been marked as a duplicate of this bug. ***
Can someone please have a look at this? 
With 2002112208 on Win2k it looks correct (both testcase and URL) and the last
'positive' comment is more than a year old.
This is fixed.  See bug 82265 for patch, discussion, etc.
Status: ASSIGNED → RESOLVED
Closed: 23 years ago22 years ago
Depends on: 82265
Resolution: --- → FIXED
verifying build 2003-02-05-11-trunk
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Creator:
Created:
Updated:
Size: