[tracker] Mozillians Profile Privacy Controls

VERIFIED FIXED

Status

VERIFIED FIXED
6 years ago
5 years ago

People

(Reporter: hoosteeno, Unassigned)

Tracking

Details

Initial Questions:

Project/Feature Name: Mozillians Profile Privacy Controls
Tracking  ID:
Description:
We have a Q1 goal to "Release privacy controls to allow Mozillians to have a public profile page and be recognized for their contributions."

To implement this goal we want to create a mechanism whereby registered users of Mozillians.org can make some fields in their Mozillians profile public. Doing so would make these profiles and the specified fields viewable by...
* non-vouched Mozillians
* not-logged-in internet visitors
* search engines and other crawlers


Additional Information:
https://wiki.mozilla.org/Mozillians/RoadMap#Phonebook

https://bugzilla.mozilla.org/show_bug.cgi?id=747524
Urgency: 2-4 weeks
Key Initiative: All
Release Date: 2013-03-28
Project Status: active
Mozilla Data: Yes
New or Change: Existing
Mozilla Project: Marketing Initiative
Mozilla Related: Mozillians.org and current/future API users of Mozillians.org.
Separate Party: No
Depends on: 843871

Comment 1

6 years ago
Justin - It looks like there were some errors generating the dependent bugs. I've filed a bug reporting the problem. Could you please open the needed bugs separately and mark them as blockers for this bug? Sorry for the inconvenience.

Legal: https://bugzilla.mozilla.org/enter_bug.cgi?product=Legal&format=legal
Data Safety Review: https://bugzilla.mozilla.org/enter_bug.cgi?product=Data%20Safety
Privacy-Technical Review: https://bugzilla.mozilla.org/enter_bug.cgi?product=Privacy, I think Product Review is the right component
Privacy-Policy Review: https://bugzilla.mozilla.org/enter_bug.cgi?product=Privacy, I think Privacy Policies is the right component
Depends on: 844266
Depends on: 844267
Depends on: 844269
Depends on: 844272
Duplicate of this bug: 842645
Blocks: 747524
Summary: Mozillians Profile Privacy Controls → [tracker] Mozillians Profile Privacy Controls
This feature is described in great detail here:

https://wiki.mozilla.org/Mozillians/Releases/Privacy_Controls
Group: mozilla-corporation-confidential
Depends on: 846026
Depends on: 846039
Depends on: 846049
Depends on: 846051

Updated

6 years ago
Depends on: 848964

Updated

6 years ago
Depends on: 848967

Updated

6 years ago
Depends on: 849018
Depends on: 850259
Depends on: 850351
Depends on: 850428
The new Mozillians privacy controls are in staging and tagged for a 3/28 release. 

https://mozillians.allizom.org/en-US/user/edit/
Launched and announced to the community!
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Bumping to verified \o/ privacy controls landed and have been in the wild for some time. People are happier and healthier now.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.