[B2G][Leo][Settings]Display: The brightness adjustment slider is unresponsive.

RESOLVED FIXED

Status

Firefox OS
Gaia::Settings
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: J Zimbrick, Assigned: gduan)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(blocking-b2g:leo+, b2g18 verified, b2g-v1.1hd fixed)

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Description:
 In the settings menu, the brightness adjustment slider is unresponsive.

Repro Steps:
1. Update Leo device to build 20130722070207.
2. Open the settings menu.
3. Scroll down to the Display option under the Personalization tab and tap it.
4. Uncheck Adjust Automatically under the display tab.
5. Attempt to slide the the brightness slider and observe that it is largely unresponsive.  It does not adjust with the user input, and most of the time does not react at all, but will sometimes seemingly randomly pick a different value.

Actual:
Brightness display slider is unresponsive.

Expected:
Brightness display slider reacts to user input.

Environmental Variables
Build ID: 20130722070207
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/68fb0a2e0114
Gaia: 41d10fb10be6916e6554eb440d9a97130ef23ce0
Platform Version: 18.1
RIL Version: 01.01.00.019.164 

Notes:
Repro frequency: 100% on 3 devices.
Q Analysts Team Priority: (Pri Levels: Pri 2

As far as regression windows, I change this setting on every build, this is the first time I've seen this sort of behavior with the brightness slider.
Can we get a specific regression window here?
blocking-b2g: --- → leo?
Keywords: regressionwindow-wanted
(Reporter)

Comment 2

4 years ago
Rolled back a few builds, the problem began on Sunday the 21st's build:

Environmental  Variables:
Build ID: 20130721230204
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/1dffc79bfac5
Gaia: 06d56e0efd1cb3bbed37fef6ee45233b86b3ae3b
Platform Version: 18.1
RIL Version: 01.01.00.019.164

Did not occur on the 20th's build.
(Reporter)

Comment 3

4 years ago
Exact regression window:

Last passing build:
Environmental  Variables:
Build ID: 20130721230204
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/1dffc79bfac5
Gaia: 06d56e0efd1cb3bbed37fef6ee45233b86b3ae3b
Platform Version: 18.1
RIL Version: 01.01.00.019.164

First breaking build:
Environmental  Variables:
Build ID: 20130721070210
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/1dffc79bfac5
Gaia: c4bdd3210864938b8ffd252c442ddcd442d09944
Platform Version: 18.1
RIL Version: 01.01.00.019.164
Keywords: regressionwindow-wanted
(Reporter)

Comment 4

4 years ago
Disregard comment 3, the build numbers were swapped.

Exact regression window:

Last passing build:
Environmental  Variables:
Build ID: 20130721070210
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/1dffc79bfac5
Gaia: c4bdd3210864938b8ffd252c442ddcd442d09944
Platform Version: 18.1
RIL Version: 01.01.00.019.164

First breaking build:
Environmental  Variables:
Build ID: 20130721230204
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/1dffc79bfac5
Gaia: 06d56e0efd1cb3bbed37fef6ee45233b86b3ae3b
Platform Version: 18.1
RIL Version: 01.01.00.019.164
Only one candidate here that likely caused this regression - bug 881727. That patch is huge, so it likely caused a regression like this.
Blocks: 881727

Comment 6

4 years ago
This bug also affects sliders "Ringer & Notifications" and "Alarm" under Settings>Sound
Also it can be related to bug 802208
Assignee: nobody → gduan
Created attachment 779569 [details]
PR TO MASTER

Add pointer-events: none to fix this bug
Attachment #779569 - Flags: review?(arthur.chen)
Comment on attachment 779569 [details]
PR TO MASTER

George, nice catch! r=me.

pointer-events was declared in switches.css: label:not([for]) input + span and removed after bug 881727 lands.
Attachment #779569 - Flags: review?(arthur.chen) → review+
master: https://github.com/mozilla-b2g/gaia/commit/8574aeec5cd13f0ed2460b51768599e26f722b28
Status: NEW → RESOLVED
Last Resolved: 4 years ago
status-b2g18: --- → affected
status-b2g-v1.1hd: --- → affected
Resolution: --- → FIXED

Updated

4 years ago
blocking-b2g: leo? → leo+
Duplicate of this bug: 897951
Duplicate of this bug: 888008
Duplicate of this bug: 899962
Duplicate of this bug: 899263
Uplifted 8574aeec5cd13f0ed2460b51768599e26f722b28 to:
v1-train: f386fd332f7c2415302101a65ac56cce6a6d7529
status-b2g18: affected → fixed

Comment 15

4 years ago
The issue does not seem to occur anymore on Leo V1.1 mozilla build.

Build ID: 20130801070210
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/aff662053ee8
Gaia: ddb922ed002e88d01f71199da32ff75911b455b2
Platform Version: 18.1
RIL Version: 01.01.00.019.172 

Verifying as Fixed in v1.1
status-b2g18: fixed → verified
Duplicate of this bug: 900809
Nominate for hd? as this is a duplicate of bug 901775.
blocking-b2g: leo+ → hd?
Duplicate of this bug: 901775
v1.1.0hd: f386fd332f7c2415302101a65ac56cce6a6d7529
status-b2g-v1.1hd: affected → fixed
Duplicate of this bug: 857121

Comment 21

4 years ago
This still occurs on Keon with the latest update (10th August)

Comment 22

4 years ago
Thanks for your help!
Verified on the V1.1.0 HD build with latest helix base image(0805).
Marked as "Verified"+"Fixed"

* Test build:(Mozilla-b2g18_v1_1_0_hd-helix/2013-08-15-04-22-01)
  + Mercurial-Information
    - Gecko revision="bd0864949c0f"
  + Git-information
    - Gaia revision="d04d2d3969e4366fabafe9659f9b2705b7879ac2"
It was leo+'ed after comment 9 and this already covers hd+ uplift. Correcting flag
blocking-b2g: hd? → leo+
You need to log in before you can comment on or make changes to this bug.