Closed Bug 881063 Opened 7 years ago Closed 6 years ago

[E.Me] Add Marketplace and Installed Apps to E.Me search results

Categories

(Firefox OS Graveyard :: Gaia::Everything.me, defect)

x86
macOS
defect
Not set

Tracking

(blocking-b2g:-)

RESOLVED FIXED
blocking-b2g -

People

(Reporter: ranbena, Assigned: ranbena)

References

Details

(Whiteboard: [systemsfe][1.3:p1])

Integrate Marketplace download suggestions and Installed apps into search results.
Assignee: nobody → ran
Blocks: 873167
Depends on: 879437
Depends on: 879342
Depends on: 881064
Summary: Add Marketplace Apps to E.Me search results → Add Marketplace and Installed Apps to E.Me search results
blocking-b2g: --- → leo?
This is a feature request after the June 10th deadline - which is way past when we can accept new features into 1.1. Please clarify the 1.1 need here.
Its too late in 1.1 to add a new feature request.If there is a disagreement here please explain the reasoning here and renominate it.
blocking-b2g: leo? → -
Hunting down the backup info. Thank you!
Depends on: 882881
From: 	Ran Ben Aharon <ran@everything.me>
Subject: Pre-release version
Date: 	June 13, 2013 1:23:28 PM PDT
 


As requested we have a pre-release version available for you guys to play around with.

It's on this branch. 
https://github.com/EverythingMe/gaia/tree/results 

Let me know what's the most convenient way to build it on your devices. If you'd like, I can video myself with some use cases.

Features you can test:
Installed apps - as you type in the search box, matching installed apps will appear. Matches are made by app name and by related categories.
Examples:
Type "se" -> "settings" app.
Type "ma" -> "E-mail" "Here maps" "Marketplace"..
Type "vacations" -> "Here Maps" 
Type "social" -> "Facebook" "Twitter" (if installed)
Click on "Games" -> "Chess" "Paddle Game" (if installed)
Clicking an installed app takes you straight to it.

Marketplace apps - only on exact searches (typing and clicking "return", clicking on suggestion, on shortcut, etc.) download suggestions will appear. Matches are made by exact app name match and by category (not yet implemented).
Examples:
Search for "calculator" -> 3 different "Calculator" apps appear.
Search for "stopwatch" -> 3 different "Stopwatch" apps appear.
Search for "tetris" -> 2 different "Tetris" apps appear.
Deduplication - already installed apps won't appear as a download suggestion.

Clicking on a marketplace app should take you to the app page in the marketplace app (but currently doesn't - see below).

Most of the time Marketplace apps are accompanied by Marketplace query search app. Clicking on it should take you to Marketplace search results for that query (but currently doesn't - see below)

Not yet implemented:
Searching categories (i.e "Games") should suggest marketplace / preinstalled apps. Should be available early next week.

Bugs we're aware of
Sometimes installed app show a default image.
Sometimes you have to search a term twice for marketplace apps to appear.
Sometimes app deduping doesn't work.
Clicking a marketplace app doesn't react. Opened a bug.Same bug prevents opening Marketplace app with search results.
Some regressions - layout and interaction bugs (progress indicator position, swipe down for bgimage, scrolling...)

From: 	Ran Ben Aharon <ran@everything.me>
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 910316
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
This bug is specific to Marketplace apps. 
Does 910316 include code to address marketplace apps appearing in E.Me search results?
Depends on: 925806
Depends on: 925815
Alias: Mrkt-E.Me
Alias: Mrkt-E.Me
Depends on: 875587
Depends on: 928996
Flags: needinfo?(ran)
Depends on: 905072
Depends on: 930593
Flags: needinfo?(ran)
Depends on: 937694
Whiteboard: [systemsfe][1.3:p2]
Whiteboard: [systemsfe][1.3:p2] → [systemsfe][1.3:p1]
Summary: Add Marketplace and Installed Apps to E.Me search results → [E.Me] Add Marketplace and Installed Apps to E.Me search results
No longer depends on: 937694
No longer depends on: 925815
Can this be closed out or are we waiting on the Marketplace server changes to verify?
Flags: needinfo?
(In reply to Peter Dolanjski [:pdol] from comment #7)
> Can this be closed out or are we waiting on the Marketplace server changes
> to verify?

Yeah - we can close this out & track the server side issues separately.
Status: REOPENED → RESOLVED
Closed: 6 years ago6 years ago
Flags: needinfo?
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.