Closed Bug 92763 Opened 23 years ago Closed 23 years ago

Add Windows XP as OS selection for entering/searching bugs

Categories

(Bugzilla :: Administration, task, P3)

2.13
All
Other

Tracking

()

RESOLVED FIXED
Bugzilla 2.16

People

(Reporter: grey, Assigned: ddkilzer)

References

Details

(Whiteboard: [metadata:os])

Attachments

(1 file)

Seing as how people (myself included) are using WinXP on a testing basis, and
that there is already a META bug for trackign WinXP/Mozilla bugs, it's time to
add WinXP as an OS selection. Make it easier to report/find bugs relating to Moz
on WinXP. Seeing as how it's going to be the Hot New Thing in the Windows world
come October (or there abouts, if it doesn't get further delayed) it'd s a good
idea for Mozilla to be as WinXP aware as possible.
Stupid me already forgot to add data. The WinXP meta tracking bug is Bug 67221
Depends on: 92597
Severity: normal → enhancement
Priority: -- → P3
Target Milestone: --- → Bugzilla 2.16
No longer depends on: 92597
Depends on: bz-enums
Is this a duplicate of bug 75778 "Add Windows XP to OS list"?
Whiteboard: [metadata:os]
no, it's not.  bug 75778 is a request for mozilla.org to put it on the list on
their installation.  This bug is about putting it on the default list in
Bugzilla.  (if we change the defaults, installations will still have to change
their own once Bugzilla is already installed, as we only write the defaults at
the initial install, and not on upgrades)
-> Bugzilla product
Component: Bugzilla → Administration
Product: Webtools → Bugzilla
Version: Bugzilla 2.13 → 2.13
this crazy bug is blocking me and i couldn't find it because someone used a very
silly summary.
Blocks: 107672
Summary: Add WinXP as OS selection for entering/searching bugs → Add Windows XP as OS selection for entering/searching bugs
As part of bug 107672 two lines were added two detect Windows XP.  These were
commented out as this bug isn't fixed yet. Also, bug 106993 may be a problem as
adding this to the part of checksetup.pl that generates localconfig won't add it
to existing installations.
We are currently trying to wrap up Bugzilla 2.16.  We are now close enough to
release time that anything that wasn't already ranked at P1 isn't going to make
the cut.  Thus this is being retargetted at 2.18.  If you strongly disagree with
this retargetting, please comment, however, be aware that we only have about 2
weeks left to review and test anything at this point, and we intend to devote
this time to the remaining bugs that were designated as release blockers.
Target Milestone: Bugzilla 2.16 → Bugzilla 2.18
arg. this is easy for anyone who knows the core to do, and it should just be done.
Target Milestone: Bugzilla 2.18 → Bugzilla 2.16
Attached patch Patch v.1Splinter Review
Adds 'Windows XP' enum to @opsys in checksetup.pl, uncomments
lines in enter_bug.cgi and fixes sample OS list box in
queryhelp.cgi.
Keywords: patch, review
Comment on attachment 78946 [details] [diff] [review]
Patch v.1

r=bbaetz - remmber this won't affect bmo, only the defaults for new
installations.
Attachment #78946 - Flags: review+
Comment on attachment 78946 [details] [diff] [review]
Patch v.1

r= justdave

Except I don't like us having a popup with the OSes hard-coded in
queryhelp.cgi...  if that's supposed to be context-sensitive, it should be
getting them the same way the bug form does.  But that's a different bug, what
you're doing here satisfies this one.
Attachment #78946 - Flags: review+
*** Bug 135666 has been marked as a duplicate of this bug. ***
checked in
Status: NEW → RESOLVED
Closed: 23 years ago
Resolution: --- → FIXED
In Comment #11 justdave is referring to Bug 108578 when
talking about fixing the hard-coded values in queryhelp.cgi.
*** Bug 150358 has been marked as a duplicate of this bug. ***
No longer depends on: bz-enums
Assignee: justdave → ddkilzer
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: