Closed Bug 93189 Opened 23 years ago Closed 21 years ago

Bookmark data persists when / after bookmark deleted, removed, and/or new bookmark created with the same name.

Categories

(SeaMonkey :: Bookmarks & History, defect, P5)

x86
Windows 2000
defect

Tracking

(Not tracked)

RESOLVED FIXED
Future

People

(Reporter: cplyon, Assigned: bugs)

References

Details

(Keywords: qawanted)

Using build 2001073103 on Win2K

Steps To Reproduce:
1- Go to "www.mozilla.org" (for example) add add it as a bookmark (any method 
is ok)
2- Rename that bookmark to "FUNKYTOWN" (for example)
3- Delete that bookmark
4- While still on the mozilla page, drag the URL icon (proxy icon) to your 
Personal Toolbar, Bookmarks sidebar, or Manage Bookmark window

Expected Results:
Bookmark should be named "mozilla.org" (the title of the page).

Actual Results:
The bookmark is named "FUNKYTOWN".  Any data for the deleted URL (comments, 
keyword) persists in this new bookmark.

If you use the Add Bookmark or File Bookmark option, the correct name is given.
Delete needs to be a little more aggressive about unhooking properties. 
Status: NEW → ASSIGNED
Target Milestone: --- → Future
Paul Chen is now taking Bookmarks bugs. For your convenience, you can filter 
email notifications caused by this by searching for 'ilikegoats'.

Assignee: ben → pchen
Status: ASSIGNED → NEW
Mass move Ben's bugs dumped on me marked future with p5 to get off my untriaged
radar. You can filter out this email by looking for "ironstomachaussie"
Priority: -- → P5
mass reassign of pchen bookmark bugs to ben
Assignee: pchen → ben
/me too: 2002052309 / Linux
steps to reproduce:

1.
open www.some-webpage.com in Mozilla

2.
"Add bookmark" with bookmark menu

3.
"Manage bookmark", klick new bookmark, rename it, then delete it

4.
do step 2 again

Result: new (2nd) bookmark has the name chosen in step 3
I think that this bug be marked a duplicate of Bug 51863.  Here's why:
- Look at the effect described by the original reporter, then read Bug 51863
Comment 79 (note especially part 3 in the middle section).  It is clear to me
that if it were not for the effects of 51863, the effect described in _this_
bug's original report would not be observable.  The problem reported in this bug
will be fixed if Bug 51863 is ever fixed, as I believe it should be.
- Even though this bug's effect is covered by 51863, there are other problems
resulting from "deleted bookmark data persisting"; but I think they're covered
by Bug 96789 and Bug 123679:  that deleted bookmarks' data still shows up in
bookmark searches.  Put fixes for the issue "Deleted bookmark data persists"
under one or both of those bugs.

The only reason I can see _not_ to mark this bug a duplicate of 51863 would be
if you think Bug 51863 is invalid.  If it were invalidated, then there would be
a general need to get rid of deleted bookmark data.  However, in that case,
there still needs to be some coordination between this bug and 96789/123679
(either marking duplications or marking dependencies), since it seems to me that
making it so "deleted bookmark data" no longer "persists" would also fix those
issues.
Just my $.02.
SPAM
I inverted two digits in that 51xxx bug.  The bug I refer to above is Bug 51683,
not 51863.  Sorry for the mixup.
*** Bug 149736 has been marked as a duplicate of this bug. ***
*** Bug 149736 has been marked as a duplicate of this bug. ***
As per bug 149736 which was marked a duplicate (just for clarification): 
Deleted bookmark data persists - period.  Even if the bookmark is not actually
renamed (but simply deleted), Mozilla will continue to check changes in the URL
site.  Renaming is not a necessary step for reproducibility.
*** Bug 164757 has been marked as a duplicate of this bug. ***
*** Bug 174052 has been marked as a duplicate of this bug. ***
Keywords: qawanted
Whiteboard: dupme (51683)
*** Bug 197629 has been marked as a duplicate of this bug. ***
This last duplicate (Bug 197629) is proof enough that this is NOT a duplicate of
bug 51683 or bug 123679, since this the effects of this bug are observable even
without creating a new bookmark of the same URL.
Whiteboard: dupme (51683)
Updating summary in an attempt to improve Bugzilla searches and reduce dupes.
Summary: Deleted bookmark data persists in new bookmark → Bookmark data persists when / after bookmark deleted, removed, and/or new bookmark created with the same name.
Chris and all people cc'd on this bug because they filed duplicates: 
Can anybody reproduce this? I just tried several times, but it may be
timing-dependant, so it would be nice if you tried as well.

I believe this was fixed in March 2003 by the big bookmarks rewrite.
> I believe this was fixed in March 2003 by the big bookmarks rewrite.
yup
Status: NEW → RESOLVED
Closed: 21 years ago
Resolution: --- → FIXED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.