Deleted bookmarks appear in search result window

RESOLVED FIXED

Status

RESOLVED FIXED
17 years ago
9 years ago

People

(Reporter: kasumi, Assigned: neil)

Tracking

Dependency tree / graph
Bug Flags:
blocking1.4.1 -
blocking1.5a -

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

17 years ago
tested 2002-02-04-11-trunk
OS = Win 98 JA 4.10.1998

1. Launch Navigator
2. Access to http://www.nfl.com/
3. Add this page to bookmark from toolbar or menubar
4. Delete this page from book mark
5. To search this page, select Manage bookmarks from toolbar or menubar
6. Select Edit/Find bookmarks or click Find in Sidebar/Bookmarks tab
7. Select "name" to first listbox, select "contains" to second listbox
   then type nfl to input box, click Find button
8. You will have deleted NFL.com in the search result window

Expected: deleted pages should not be searched.

Comment 1

17 years ago
Related to bug 93189 and/or bug 96789?
(Reporter)

Comment 2

17 years ago
No.
93189 seems like rename problem.
96789 is mentioning about imported pages.
This bug is regardless of rename nor import. 

Comment 3

17 years ago
According to bug 93189 comment #1, not all the bookmark data is removed when 
the bookmark is deleted.  Maybe this data is what Find picks up?

Bug 96789 is a problem identical to this one, dealing specifically to Imported 
IE Favorites.  Maybe bug 96789 is a specific example of a more general problem?
(Reporter)

Comment 4

17 years ago
>not all the bookmark data is removed when 
>the bookmark is deleted.  Maybe this data is what Find picks up?
I think so.

96789 is not good example because this is imported data.
We need to doubt about importing process.
Status: NEW → ASSIGNED
Priority: -- → P3
Target Milestone: --- → mozilla1.2

Comment 5

17 years ago
removing self from cc list

Updated

15 years ago
Flags: blocking1.5a?
Flags: blocking1.4.x?

Comment 6

15 years ago
Anybody still alive?. This bug is OLD, SERIOUS and should be "obvious".
While this would be nice to fix, I don't think we'd hold either the 1.4.x
release or the 1.5a release for it.

Adding dependency on bug 93189.
Depends on: 93189
Flags: blocking1.5a?
Flags: blocking1.5a-
Flags: blocking1.4.x?
Flags: blocking1.4.x-
Mass reassign of my non-Firefox bugs to ben_seamonkey@hotmail.com
Assignee: bugs → ben_seamonkey
Status: ASSIGNED → NEW
Product: Browser → Seamonkey

Updated

14 years ago
Blocks: 275249

Updated

13 years ago
Assignee: ben_seamonkey → p_ch
QA Contact: claudius → bookmarks
Target Milestone: mozilla1.2alpha → ---

Comment 9

13 years ago
Reassigning as per Bug #32644
Assignee: p_ch → nobody
this may have been fixed (in ff) by vlad's fix for #255255
Priority: P3 → --
Duplicate of this bug: 371742
[Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9.2a1pre) Gecko/20090715 SeaMonkey/2.1a1pre] (home, optim default) (W2Ksp4)
(http://hg.mozilla.org/mozilla-central/rev/d190d9b6ccd1
 +http://hg.mozilla.org/comm-central/rev/773809454cf2 + bug 503724 patch)
Keywords: 4xp
Blocks: 96789
Depends on: 255255
Flags: wanted-seamonkey2?
Whiteboard: [Port bug 255255!!?]
I ported bug 255255 and bug 301048 and have a patch locally. The good news is that the core of this bug is already fixed in what I have so far, the even better news is that in the end it will hopefully enable/fix delete/cut while in search mode as well. :-) It just needs a little more work. Stay tuned.
Assignee: nobody → jh
Status: NEW → ASSIGNED
Created attachment 389572 [details] [diff] [review]
proposed patch

For better comparison, this is the full diff of the patch from bug 255255:
<http://bonsai.mozilla.org/cvsview2.cgi?command=DIFF&subdir=mozilla%2Fbrowser%2Fcomponents%2Fbookmarks%2Fcontent%2FAttic&file=bookmarks.js&rev1=1.101&rev2=1.102&whitespace_mode=show&diff_mode=full>

This fixes/changes (Bookmark Manager and Bookmarks sidebar):
- bookmarks deleted in normal mode are also removed from Search mode view
- enables Delete and Cut (and their shortcuts) in Search mode

Test cases (Bookmark Manager and Bookmarks sidebar):
- create bookmark, verify it's visible in Search mode, delete it in normal mode, verify it's also gone in normal mode and Search mode
- create bookmark, verify it's visible in Search mode, delete it in Search mode, verify it's gone in Search mode and normal mode
- use cut instead of delete, then paste in normal or Search mode
- use Undo after delete or cut
Attachment #389572 - Flags: review?(neil)
Duplicate of this bug: 506208
(Assignee)

Comment 16

9 years ago
Comment on attachment 389572 [details] [diff] [review]
proposed patch

Sorry, I don't think this is the right way to fix this; strangely enough the hint came from the code that makes cut work in the Search view (which is a separate bug worth fixing) - the local search service needs to check that the search results have parents.
Attachment #389572 - Flags: review?(neil) → review-
(Assignee)

Comment 17

9 years ago
Created attachment 392713 [details] [diff] [review]
Proposed patch
Assignee: jh → neil
Attachment #389572 - Attachment is obsolete: true
Attachment #392713 - Flags: review?(iann_bugzilla)

Updated

9 years ago
Attachment #392713 - Flags: review?(iann_bugzilla) → review+
(Assignee)

Comment 18

9 years ago
Pushed changeset 29283536a639 to comm-central.
Status: ASSIGNED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED

Updated

9 years ago
No longer depends on: 255255
Hardware: x86 → All
Whiteboard: [Port bug 255255!!?]
I'll continue with the rest of what my patch fixed in bug 81893 (Delete/Cut) and bug 509029 (newline added when copying bookmark).
Depends on: 255255
Hardware: All → x86

Updated

9 years ago
Flags: wanted-seamonkey2?
You need to log in before you can comment on or make changes to this bug.