[COST CONTROL] Remove the `mindgap.js` module and filtering operations of historical data.

RESOLVED FIXED in 1.3 Sprint 5 - 11/22

Status

Firefox OS
Gaia::Cost Control
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: salva, Assigned: mai)

Tracking

unspecified
1.3 Sprint 5 - 11/22
x86_64
Linux
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

256 bytes, text/html
salva
: review+
Details
With the new Netowrk Statistics API, mindgap.js module is no longer required. It must be removed in order to fully unlock all the features provided by the new API.
blocking-b2g: --- → 1.3?
Blocks: 937251
(Assignee)

Updated

4 years ago
Assignee: nobody → mri

Updated

4 years ago
Target Milestone: --- → 1.3 Sprint 5 - 11/22
(Assignee)

Comment 1

4 years ago
Created attachment 832280 [details]
proposal patch v1

Please, could you review my code?
There is a pending issue: testing of the application with two different SIM cards
Attachment #832280 - Flags: review?(salva)
Comment on attachment 832280 [details]
proposal patch v1

See some comments on GitHub. It's going well but I want to discuss some aspects. Provide your opinion if you don't share the point of view of any of the comments.

When ready, ask for review again.

Thank you :mai!
Attachment #832280 - Flags: review?(salva)
(Assignee)

Comment 3

4 years ago
Comment on attachment 832280 [details]
proposal patch v1

Updated the code keeping in mind your comments
Attachment #832280 - Flags: review?
(Assignee)

Updated

4 years ago
Attachment #832280 - Flags: review? → review?(salva)
Comment on attachment 832280 [details]
proposal patch v1

Nice work with lots of improvements. I'm happy to see mindgap.js is gone!

Please don't merge until bug 937041 is in Mozilla Central.

Thank you :mai, a really good work!

NOTE: I made a little name fix and change `availableNetworks()` into `getAvailableNetworks()` because this is the ultimate name for the method.
Attachment #832280 - Flags: review?(salva) → review+
Depends on: 937041
Master: 445a9fb8deddd15e617f000ef208bddbedd28f0b
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Duplicate of this bug: 937247
already in master. clear flag
blocking-b2g: 1.3? → ---

Updated

4 years ago
Depends on: 941716
This just broke the utility tray entirely.

John - Can you back this out?
Flags: needinfo?(jhford)
Please, John, before remove this, let's see if we can solve this by providing a simple patch. Jason, when the bug 928325 broke the utility tray and this was reported in bug 939110, it was not backed out. I am not asking for a special treatment, but note these kind of things happens. Let's find a solution before taking light decisions.
Hi. Root cause found. Our fault, backing out:
d8b28cec6ef01c7b8e0440d5e4da033c486b0515

My apologies if the previous comment sounded rude. I only wanted to see what was more convenient: if a patch or another PR. Given the situation, it is better to make a backout: better to track one commit rather than two. :)
Status: RESOLVED → REOPENED
blocking-b2g: --- → 1.3?
Resolution: FIXED → ---
(Assignee)

Comment 11

4 years ago
Created attachment 8336727 [details]
v1.1
Attachment #832280 - Attachment is obsolete: true
Attachment #8336727 - Flags: review?(salva)

Updated

4 years ago
Flags: needinfo?(jhford)
Comment on attachment 8336727 [details]
v1.1

Added two harmless modifications in a couple of lines not affecting the behaviour but the code style.

Thanks for the fix, :mai!
Attachment #8336727 - Flags: review?(salva) → review+
Master: 84a0570132f6af235000f08ef02b6798cbfa2d0d
Status: REOPENED → RESOLVED
Last Resolved: 4 years ago4 years ago
Resolution: --- → FIXED
already in master v1.3. clear flag
blocking-b2g: 1.3? → ---
Depends on: 964502

Updated

4 years ago
No longer depends on: 964502
You need to log in before you can comment on or make changes to this bug.