Closed Bug 984797 Opened 6 years ago Closed 6 years ago

You cannot peek at notifications in the notifications panel

Categories

(Firefox OS Graveyard :: Gaia::System, defect)

defect
Not set

Tracking

(Not tracked)

VERIFIED FIXED
2.0 S6 (18july)

People

(Reporter: cwiiis, Assigned: cwiiis)

References

Details

(Whiteboard: [systemsfe][2.1-feature-qa+])

Attachments

(1 file, 2 obsolete files)

Because the notifications panel slides in as a whole, instead of revealing a fixed position panel, you cannot pull down on it to 'peek' at notifications and quickly slide it back up.
I believe this will be fixed by bug 968930.

Michael: Is it a dupe?
Flags: needinfo?(mhenretty)
Yup, this is definitely a valid concern/use case, and we will be addressing it with the notification rework done in bug 968930.
Status: NEW → RESOLVED
Closed: 6 years ago
Flags: needinfo?(mhenretty)
Resolution: --- → DUPLICATE
Duplicate of bug: 968930
I'm reopening this as the bottom-tray notifications aren't going to be implemented in 2.1 and this would still be nice.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Depends on: 1038781
I'm marking this for review now, as I think the method is sound and it works.

Unfortunately, a layout bug blocks this from landing as the performance once you have more than a couple of notifications is quite poor (see the blocking bug).
Attachment #8456256 - Flags: review?(etienne)
I've fixed the main layout bug that blocks this, so I think it's feasible to do this now. Here's an updated implementation based on UX feedback.
Assignee: nobody → chrislord.net
Attachment #8456256 - Attachment is obsolete: true
Status: REOPENED → ASSIGNED
Attachment #8456256 - Flags: review?(etienne)
Attachment #8456736 - Flags: ui-review?(rmacdonald)
Attachment #8456736 - Flags: review?(etienne)
Depends on: 1038185
Comment on attachment 8456736 [details] [review]
Implementation of a fixed-position utility tray v2

Wow this is beautiful :)

r=me with the grippy/placeHolder's height cached (we probably want to update the placeholder's one on resize).
The reflows on touchstart are driving me crazy :)

You might also want to investigate calling .preventDedault() on the touchevents to prevent the reflows from BrowserElementPanning.js but this can be done in a follow up.

Great work! I'll show my phone to Rob to make the ui-review quicker.
Attachment #8456736 - Flags: review?(etienne) → review+
(In reply to Etienne Segonzac (:etienne) from comment #6)
> Comment on attachment 8456736 [details] [review]
> Implementation of a fixed-position utility tray v2
> 
> Wow this is beautiful :)
> 
> r=me with the grippy/placeHolder's height cached (we probably want to update
> the placeholder's one on resize).
> The reflows on touchstart are driving me crazy :)
> 
> You might also want to investigate calling .preventDedault() on the
> touchevents to prevent the reflows from BrowserElementPanning.js but this
> can be done in a follow up.
> 
> Great work! I'll show my phone to Rob to make the ui-review quicker.

Thanks :) I've made the suggested changes (good call!) and am attempting to fix the marionette breakage.

I'll leave the preventDefault changes because I'm afraid of breaking something, but follow-up is a good idea.
Hi Chris,

Rob demoed this to me and the rest of the UX team this morning, and it looks great!  I approve. :)

Peter.
Fixed tests, merged to master: https://github.com/mozilla-b2g/gaia/commit/92dd8cc758614123a62376a56458259f4fd77a23
Status: ASSIGNED → RESOLVED
Closed: 6 years ago6 years ago
Resolution: --- → FIXED
Comment on attachment 8456736 [details] [review]
Implementation of a fixed-position utility tray v2

Marking ui-review+ per comment #8.
Attachment #8456736 - Flags: ui-review?(rmacdonald) → ui-review+
Damn, this is due to a weird layout bug that causes visibility:hidden flexbox children to have a 0x0 size - I thought I'd worked around it, but obviously not well enough.

If I can't find a better work-around, I think I'll just have to not use flexbox (which is a shame because it makes the css much simpler, but not the end of the world).

I'll sort this out tomorrow.
Actually, I'm just a massive idiot - there's no layout bug here, I messed up the CSS. Carrying r+/ui-r+
Attachment #8456736 - Attachment is obsolete: true
Attachment #8459147 - Flags: ui-review+
Attachment #8459147 - Flags: review+
I'm confident the change would have fixed the issue, merged to master: https://github.com/mozilla-b2g/gaia/commit/35f68cec4d813182591f1a474b15f5f58b7dc146

If I'm wrong, that's the last time I'll ever do that without waiting for travis.
Status: REOPENED → RESOLVED
Closed: 6 years ago6 years ago
Resolution: --- → FIXED
Is this to land in v2.0 branch as well ?
(In reply to William Dorffer [:schoewilliam] from comment #15)
> Is this to land in v2.0 branch as well ?

No, this is a 2.1 feature (there's also a notifications panel visual refresh, being worked on by gmarty)
Whiteboard: [systemsfe]
Target Milestone: --- → 2.0 S6 (18july)
Duplicate of this bug: 1041382
Flags: in-moztrap?(jsmith)
QA Contact: jsmith
Whiteboard: [systemsfe] → [systemsfe][2.1-feature-qa+]
Flags: in-moztrap?(jsmith) → in-moztrap?(mozbugs.retornam)
QA Contact: jsmith → mozbugs.retornam
Flags: in-moztrap?(mozbugs.retornam) → in-moztrap?(ashiue)
QA Contact: mozbugs.retornam → ashiue
Verified on
Gaia      de7235e41f36a23a31c5e47218473c0cc471b019
Gecko     https://hg.mozilla.org/mozilla-central/rev/149d3ce6e020
BuildID   20140819160208
Version   34.0a1
Status: RESOLVED → VERIFIED
No longer depends on: 1059864
Depends on: 1060118
Duplicate of this bug: 825645
Blocks: 1080349
You need to log in before you can comment on or make changes to this bug.