Closed Bug 99193 Opened 20 years ago Closed 7 years ago

In a thread, press Enter on the parent message and multiple actions occur

Categories

(MailNews Core :: Backend, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: nbaca, Unassigned)

References

(Blocks 1 open bug)

Details

Attachments

(2 files)

Branch build 2001-09-10-03: WinMe

I found this bug while investigating bug# 89702.

Overview: In threaded mode, single click onto a parent message, then press the
Enter key.

Actual Results: 
a.If the thread is collapsed then pressing the Enter key
- expands the thread
- opens the selected message in a stand alone window

b. If the thread is collapsed then pressing the Enter key
- collapses the thread
- opens the selected message in a stand alone window

c. If a child message is selected then the state of the thread remains (it
either remains collapsed or remains expanded) and the message appears in a stand
alone window.

Expected Results: In 4.7 pressing the Enter key only opens the message in a
stand alone window, which appears reasonable.

Additional Information: 
- Double clicking onto the parent message just opens it in a stand alone window.
Marking "nsbranch" based on kmurray's comments in bug# 89702.
Keywords: nsbranch
QA Contact: esther → olgam
Blocks: 99230
I'm assuming 6.1 had the same behavior? We haven't even started to look into
this yet so I'd assert that I wouldn't hold the release for this. however, I
hate to minus kmurray bugs =). So I'll let him over ride me if he really feels
this is important =).
Keywords: nsbranchnsbranch-
Target Milestone: --- → mozilla0.9.6
The reason this bug was filed is because we only half fixed bug 89702 (double
click on a top level thread works fine, but using Enter to open a standalone
message at top level still toggles open state). I wouldn't hold a release for
this either, but we should fix this (89702) in 0.9.5.
moving to 0.9.7 and reassigning to ssu.
Assignee: sspitzer → ssu
Keywords: nsbeta1
Target Milestone: mozilla0.9.6 → mozilla0.9.7
Blocks: 107067
Keywords: nsbranch-
Keywords: nsbeta1nsbeta1+
It looks like the fix is to prevent the key event to be picked up by the default
handler in outliner.xml.  The threadPane.js patch should do the trick, but it
doesn't seem to be working.

Another fix could be to patch outliner.xml to remove the default handlers in
question.  If this is done, I've noticed that it prevents the thread from
expanding/collapsing when simply hitting 'enter' on a selected message in the
thread pane.

It also has the same effect on the folder pane in that if 'enter' is pressed,
the folder (that contains subfolders) will not expand or collapse.  This is
consistent behavior with 4.x.

However, I don't know what the side effects of patching outliner.xml are.

I'll need to talk to hyatt about this.
Status: NEW → ASSIGNED
event.stopPropagation() is what you want I think.
event.stopPropagation() does not fix this problem, but I did notice that if
place this call as follows (just as a test case):

 function ThreadPaneKeyPress(event)
 {
     event.preventBubble();
     if (event.keyCode == 13)
     {
       ThreadPaneDoubleClick();
     }
 }

it does prevent the the Crtl-Q event from being processed.  Which leads me to
believe that the key event (wrt to toggling threads) is being processed either
in parallel or has been caught before entering ThreadPaneKeyPress().
Priority: -- → P2
Target Milestone: mozilla0.9.7 → mozilla0.9.8
Target Milestone: mozilla0.9.8 → mozilla0.9.9
No longer blocks: 107067
Target Milestone: mozilla0.9.9 → mozilla1.2
Discussed in 2/25 bug mtg w Mktng, PjM and Engineering.  Decision was to move to
1.2 and nsbeta minus this bug.
Blocks: 122274
Keywords: nsbeta1+nsbeta1-
*** Bug 135484 has been marked as a duplicate of this bug. ***
*** Bug 131086 has been marked as a duplicate of this bug. ***
I remove nsbeta1- keyword - it was for MachV.
Keywords: nsbeta1-
Now I add 'nsbeta1' keyword for Buffy. Sorry, it's faster to edit multiple bugs
at once than manually go to each and remove minus.
Keywords: nsbeta1
Mail triage team: nsbeta1-
Keywords: nsbeta1-
Keywords: nsbeta1
It is a strange thing that this (unsolved) bug bloks a (solved) bug such as
bug  	99230 0=)
Blocks: 236849
*** Bug 230942 has been marked as a duplicate of this bug. ***
This bug still exists in TBird 0.7, and seems to be languishing.

Any hope of getting this fixed by Aviary 1.0/SM 1.8?
Flags: blocking1.8a3?
Flags: blocking-aviary1.0RC1?
Flags: blocking1.8a3? → blocking1.8a3-
out of time for this on the aviary 1.0 change list that we are trying to crank
down on..  reassigning to default owner to get consideration for future releases
Assignee: ssu0262 → sspitzer
Status: ASSIGNED → NEW
Flags: blocking1.8a4?
Flags: blocking-aviary1.0PR?
Flags: blocking-aviary1.0PR-
QA Contact: olgam
Flags: blocking1.8a4?
Flags: blocking1.8a4-
Flags: blocking1.8a3-
Product: Browser → Seamonkey
Assignee: sspitzer → mail
Still present in "Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.12)
Gecko/20050915" and "Thunderbird version 1.5 Beta 2 (20051006)"
Duplicate of this bug: 281337
Duplicate of this bug: 263781
Duplicate of this bug: 278393
OS: Windows ME → All
Hardware: PC → All
Assignee: mail → nobody
Component: MailNews: Main Mail Window → MailNews: Backend
Priority: P2 → --
Product: Mozilla Application Suite → Core
QA Contact: backend
Target Milestone: mozilla1.2alpha → ---
Duplicate of this bug: 406775
Product: Core → MailNews Core
WFM. current nightly
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.