[meta] Low-res and slow painting issues when scrolling subframes in Fennec

RESOLVED FIXED in Firefox 31

Status

()

Firefox for Android
Graphics, Panning and Zooming
RESOLVED FIXED
3 years ago
11 months ago

People

(Reporter: kats, Assigned: kats)

Tracking

({meta})

unspecified
Firefox 31
All
Android
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox29 unaffected, firefox30 affected, firefox31 fixed)

Details

There are a number of bugs filed for low-res and slow painting issues in Fennec. These appear to be regressions from the recent tiling work for B2G, and need to be addressed. Filing this meta-bug to collect all the individual issues. I don't want to dupe them all because I'm not 100% sure they're all the same and there might be a few underlying bugs.

Updated

3 years ago
Blocks: 984430
Blocks: 995063
Most of the regressions here are part of Fx 30 how do we want to track this greater issue so that Fx 30 is acceptable? Right now I would be embarrassed to ship the current Aurora code as a Beta or Release.

Updated

3 years ago
Depends on: 997038

Updated

3 years ago
Blocks: 997038
No longer depends on: 997038
No longer blocks: 995063
Depends on: 997696
CC'ing snorp so he can keep an eye on it
Blocks: 986991
status-firefox29: --- → unaffected
status-firefox30: --- → affected
status-firefox31: --- → affected
relnote-firefox: --- → ?
No longer blocks: 995129
Blocks: 993473
Blocks: 995129
No longer blocks: 995129
Sorry, dependency relationships are confusing
Marking this fixed since all dependencies are fixed or on inbound.
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
status-firefox31: affected → fixed
Target Milestone: --- → Firefox 31
Since this has been fixed before beta I'm assuming it doesn't need to be relnote'd.
relnote-firefox: ? → ---
You need to log in before you can comment on or make changes to this bug.