too many tabs prevents vertical scrollbar from appearing

VERIFIED FIXED in mozilla1.0

Status

SeaMonkey
Tabbed Browser
VERIFIED FIXED
17 years ago
4 years ago

People

(Reporter: Quinn Yost (mythdraug), Assigned: David Hyatt)

Tracking

Trunk
mozilla1.0

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
Steps:
    1)  open more tabs than you have room to display
    2)  view a page that is longer than your window

Results:  Vertical scrollbar does not appear
Expected Result: Vertical scrollbar appears

Build:  2001092403 win32

Comment 1

17 years ago
Confirming with build 2001092503, win98. Marking as New
By bug 101730 changing OS and Platform to All
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows 2000 → All
Hardware: PC → All

Comment 2

17 years ago
*** Bug 101730 has been marked as a duplicate of this bug. ***

Comment 3

17 years ago
Moving to Tabbed Browser component
Component: XP Toolkit/Widgets → Tabbed Browser

Comment 4

17 years ago
*** Bug 102712 has been marked as a duplicate of this bug. ***

Comment 5

17 years ago
*** Bug 102827 has been marked as a duplicate of this bug. ***

Comment 6

17 years ago
*** Bug 103323 has been marked as a duplicate of this bug. ***

Comment 7

17 years ago
the little x to close tabs with is also pushed to the right, out of view
*** Bug 103408 has been marked as a duplicate of this bug. ***
(Assignee)

Updated

17 years ago
Status: NEW → ASSIGNED
Target Milestone: --- → mozilla1.0

Comment 9

17 years ago
*** Bug 103051 has been marked as a duplicate of this bug. ***

Comment 10

17 years ago
Possible root cause:

The page grows wider than the screen (which explains the loss of the
vertical scroll bar and the <x> close tab button).

i.e. Mozilla assumes the screen is as wide as <number of tabs>*<tab width> --
when that value exceeds the screen width it *still* increases so parts of the
page are no longer visible (and you can't horizontal scroll since mozilla
*thinks* the page is wider than it is!).

Pages that uses javascript to find the page width and then center the page
(e.g. http://www.newsunlimited.co.uk/ , create tabs until, say, twice
screen width) will be centered within the virtual screen space rather than
my LCDs.

Comment 11

17 years ago
Possible root cause:

The page grows wider than the screen (which explains the loss of the
vertical scroll bar and the <x> close tab button).

i.e. Mozilla assumes the screen is as wide as <number of tabs>*<tab width> --
when that value exceeds the screen width it *still* increases so parts of the
page are no longer visible (and you can't horizontal scroll since mozilla
*thinks* the page is wider than it is!).

Pages that uses javascript to find the page width and then center the page
(e.g. http://www.newsunlimited.co.uk/ , create tabs until, say, twice
screen width) will be centered within the virtual screen space rather than
my LCDs.

Comment 12

17 years ago
Offhand I'm not sure why but in the skin I designed all the tabs share the width
of the browser. If you create lots of tabs they just all get very narrow :-)

Comment 13

17 years ago
*** Bug 101475 has been marked as a duplicate of this bug. ***
I'd like to see this resolved by the creation of additional rows
of tabs as necessary, but making the tabs narrower would be better
than the current behavior.

Comment 15

17 years ago
*** Bug 106460 has been marked as a duplicate of this bug. ***

Comment 16

17 years ago
I suggest use of <arrowscroll orient="horizontal"> but this depends on bug
103723 which has a working patch allready posted, but noone has reviewed it yet :-(.
--mondo

Comment 17

17 years ago
*** Bug 106581 has been marked as a duplicate of this bug. ***

Comment 18

17 years ago
*** Bug 106614 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 19

17 years ago
The tabs now flex, and will shrink down as much as they can.  I believe this is
the ideal mechanism for the tabs, and that we should not spill over to multiple
rows.  An overflow mechanism may still be necessary, but for now, this system
should scale to a pretty large # of tabs.

Marking this bug fixed.  Feel free to open new bugs if you want some other
specific overflow mechanism.
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED
Nice job!  Works for me on 2001102503, Win95 OSR2.
I particularly like the extra size of tabs when there
are relatively few of them, lets me see more of the
title.  Good show.  

For reference, # of tabs that cause problems at various
resolutions (using Modern theme, if it matters):

  Window    Titles are     Layout
   Size     all "..."     Problems
 320x 200       8            11
 640x 480      19            22
 800x 600      24            27
1024x 768      30            35
1152x 864      34            39
1280x1024      38            43
1600x1200      47            54

Any number of tabs fewer than the numbers you
see there don't cause these problems.  

That's quite a few tabs at the high end, and on the
lower resolutions, giving up the extra row would be a
substantial loss too.  (At 320x200, it wouldn't leave
much room at all for page content; does anyone still
use quarter-screen browser windows at 640x480?) I'd
say, for now, suggest opening a separate window if more
tabs are needed.  If someone wants the ability to
scroll the tab bar or a spillover into additional rows
of tabs, file a separate RFE.  I thought I would want
this, but seeing how many tabs I can get without it, I
no longer care.  29 tabs (1024x768, part of each title
visible) should be quite enough for me, in any one
window, at any given time.  

Nit:  maybe the tab title should skip the ellipse
      ("...") if it would ammount to the whole 
      title of the tab and just show the first
      couple of characters with no ellipse?  
      That would pop the useful number of tabs
      out to just shy of the second column above.

Comment 21

17 years ago
See bug 106927
*** Bug 107164 has been marked as a duplicate of this bug. ***

Comment 23

17 years ago
*** Bug 109333 has been marked as a duplicate of this bug. ***
QA Contact: jrgm → sairuh
okay, i no longer see this happening *except* when i open enough tabs such that
the tab's close button is no longer visible --when that occurs, the vertical
scrollbar is gone. is that bug 106927, or another issue?
spoke w/hyatt, and what i'm seeing [comment 24] is indeed a symptom of bug 106927.

marking this one vrfy'd.
Status: RESOLVED → VERIFIED

Comment 26

16 years ago
why is this bug closed ?.
I have the problem still in current builds.
I am using win2k, yesterdays build(2002051508).

Comment 27

16 years ago
Please try to read a bug report before commenting. It is clearly noted 
that bug 106927 is still open.

Comment 28

16 years ago
Oops...
Sorry and Thanks.

Comment 29

16 years ago
*** Bug 169612 has been marked as a duplicate of this bug. ***
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.