Update Android SDK and build tools to 20

RESOLVED FIXED

Status

Release Engineering
Platform Support
RESOLVED FIXED
3 years ago
a month ago

People

(Reporter: wesj, Assigned: wesj)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

3 years ago
While fixing bug 1016529, I noticed sdk 20 is out now. We have a few features that need 19+ (stumbler and restricted profiles), and once we know an sdk works, we should keep ourselves up to date.

I have new found tool-tool powers that I seem to finally be able to use, so I can do this for releng if they're ok with it (with reviews going to them).
Bug 1030265 covers raising our target SDK version. We'll also want to do something like Bug 1024238 to die early for outdated tools.
Blocks: 1030265
OS: Linux → Android
Hardware: x86_64 → All
Summary: Updated android sdk to 20 → Update Android SDK and build tools to 20
Blocks: 1042715
(Assignee)

Comment 2

3 years ago
Created attachment 8461646 [details] [diff] [review]
Update manifests

I pushed this up to tooltool. Here are the manifest entries. Waiting on a try run https://tbpl.mozilla.org/?tree=Try&rev=291ace64c568
(Assignee)

Comment 3

3 years ago
And I didn't update the version code in mozconfig. Lets try again:
https://tbpl.mozilla.org/?tree=Try&rev=bf00cfc3dd30
(Assignee)

Comment 4

3 years ago
We're hitting strange errors in proguard. rnewman hinted that they may be due to jdk1.6 (at least, he's seen them with Java6).
Depends on: 1043023
That's bug 951968.
This can't come soon enough; just hit another thing that KitKat broke for which the fix is only available in 19+.

https://tbpl.mozilla.org/php/getParsedLog.php?id=45296026&tree=Fx-Team
Blocks: 1049217
(Assignee)

Comment 7

3 years ago
Trying again:
https://tbpl.mozilla.org/?tree=Try&rev=8a1c188388ec
(Assignee)

Comment 8

3 years ago
Whoops. Had to update mozconfig.common as well. Try again:
https://tbpl.mozilla.org/?tree=Try&rev=59f57d37778e
(Assignee)

Comment 9

3 years ago
I was apparently at a bad revision for that push. Pulled. Lets try again:
https://tbpl.mozilla.org/?tree=Try&rev=59f57d37778e
(Assignee)

Comment 10

3 years ago
Looked good. Landed on fx-team:
https://hg.mozilla.org/integration/fx-team/rev/b9fc8a08a0c2
Backed out in https://hg.mozilla.org/integration/fx-team/rev/9fa6759714ac under suspicion of causing various android failures in the following push.
https://tbpl.mozilla.org/php/getParsedLog.php?id=45973080&tree=Fx-Team
https://tbpl.mozilla.org/php/getParsedLog.php?id=45975386&tree=Fx-Team
https://tbpl.mozilla.org/php/getParsedLog.php?id=45976146&tree=Fx-Team
https://tbpl.mozilla.org/php/getParsedLog.php?id=45974436&tree=Fx-Team

Though nalexander thinks it's more likely Bug 1052276 that could be the cause of at least some of these.
Flags: needinfo?(wjohnston)
Relanded in https://hg.mozilla.org/integration/fx-team/rev/e0c877dfa4da since 1052276 seems more likely at this point.
Flags: needinfo?(wjohnston)
https://hg.mozilla.org/mozilla-central/rev/e0c877dfa4da
Assignee: nobody → wjohnston
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED

Updated

3 years ago
Depends on: 1062231
Blocks: 1084498
You need to log in before you can comment on or make changes to this bug.