The default bug view has changed. See this FAQ.

Migrate Android builds to TaskCluster

RESOLVED FIXED

Status

Taskcluster
Task Configuration
RESOLVED FIXED
2 years ago
19 hours ago

People

(Reporter: dustin, Assigned: coop)

Tracking

(Blocks: 2 bugs)

Details

(Whiteboard: [trello:https://trello.com/c/GbF1APrQ], URL)

Comment hidden (empty)
(Reporter)

Updated

2 years ago
Whiteboard: [trello:https://trello.com/c/GbF1APrQ]
(Reporter)

Comment 1

2 years ago
Overall plan here:
 * build a docker image for building Android using the tools in alder
 * build Android by hand in that docker image
 * upload docker image to quay.io and build Android in a custom-written task
 * autogenerate the task using the tools in alder
 * hook that task up to automation so it runs on checkin (maybe just invoking from buildbot?)
(Reporter)

Updated

2 years ago
Depends on: 1122598
(Reporter)

Updated

2 years ago
Depends on: 1125973

Updated

2 years ago
Blocks: 1122509
(Reporter)

Updated

2 years ago
See Also: → bug 1151557

Updated

2 years ago
Depends on: 1155349
See Also: → bug 1159700
(Reporter)

Updated

2 years ago
Depends on: 1164608
(Reporter)

Updated

2 years ago
Depends on: 1164611
(Reporter)

Updated

2 years ago
Depends on: 1164612
(Reporter)

Updated

2 years ago
Depends on: 1164614
(Reporter)

Updated

2 years ago
Depends on: 1164615
(Reporter)

Updated

2 years ago
Depends on: 1164617
(Reporter)

Updated

2 years ago
Depends on: 1164618
(Reporter)

Updated

2 years ago
Depends on: 1164623
(Reporter)

Updated

2 years ago
Depends on: 1164626
(Reporter)

Updated

2 years ago
Depends on: 1164914
Blocks: 1141248
(Reporter)

Updated

2 years ago
Depends on: 1168592
(Reporter)

Updated

2 years ago
Depends on: 1168612
(Reporter)

Updated

2 years ago
Depends on: 1169661
(Reporter)

Updated

2 years ago
Depends on: 1169652
(Reporter)

Updated

2 years ago
Depends on: 1169703
(Assignee)

Updated

2 years ago
Depends on: 1174206
(Reporter)

Updated

2 years ago
Duplicate of this bug: 1174206
(Reporter)

Updated

2 years ago
No longer depends on: 1164626
(Reporter)

Updated

2 years ago
No longer depends on: 1164617
(Reporter)

Updated

2 years ago
No longer depends on: 1164611
(Reporter)

Comment 3

2 years ago
This is just waiting on symbol uploads now.
(Reporter)

Comment 4

2 years ago
Let's ship this without symbol uploads.  Just waiting on bug 1206106 then.
Depends on: 1206106

Updated

2 years ago
Blocks: 1199720

Updated

2 years ago
Blocks: 1163084
(Reporter)

Updated

2 years ago
Status: NEW → RESOLVED
Last Resolved: 2 years ago
No longer depends on: 1164615
Resolution: --- → FIXED
(Assignee)

Updated

11 months ago
Assignee: dustin → jlund
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Updated

11 months ago
Component: RelOps → Task Configuration
Product: Infrastructure & Operations → Taskcluster
QA Contact: arich
Version: other → unspecified

Updated

11 months ago
Depends on: 1269003

Updated

10 months ago
Blocks: 1275344

Comment 5

10 months ago
falling behind on this. hope to have updates tomorrow.
(Assignee)

Updated

10 months ago
Blocks: 1277595
(Assignee)

Updated

10 months ago
Summary: [tracker] Drive Android builds out of taskcluster → Fennec opt build as Tier 2
(Assignee)

Updated

10 months ago
Summary: Fennec opt build as Tier 2 → [tracker] Drive Android builds out of taskcluster
(Assignee)

Updated

10 months ago
Depends on: 1277645
(Assignee)

Updated

10 months ago
No longer depends on: 1277645
(Assignee)

Updated

10 months ago
Depends on: 1277682

Updated

10 months ago
No longer blocks: 1277595

Updated

7 months ago
Depends on: 1298894

Updated

7 months ago
Depends on: 1298895
(Assignee)

Updated

4 months ago
Summary: [tracker] Drive Android builds out of taskcluster → [tracker] Migrate Android builds to TaskCluster
(Assignee)

Updated

4 months ago
Depends on: 1270544
(Assignee)

Updated

4 months ago
Summary: [tracker] Migrate Android builds to TaskCluster → Migrate Android builds to TaskCluster
(Assignee)

Updated

4 months ago
Assignee: jlund → coop
(Assignee)

Updated

19 hours ago
Status: REOPENED → RESOLVED
Last Resolved: 2 years ago19 hours ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.