Blank window in preferences/options window with Adblock Plus and Ghostery enabled

RESOLVED DUPLICATE of bug 1127744
(NeedInfo from)

Status

()

defect
RESOLVED DUPLICATE of bug 1127744
5 years ago
4 years ago

People

(Reporter: jkitch, Unassigned, NeedInfo)

Tracking

({qawanted, regression})

unspecified
x86_64
All
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox36-)

Details

Attachments

(2 attachments)

Posted image Screenshot
Now that in-content preferences have been disabled, the general panel of the options dialog is completely empty.

Even the help button is missing.

[Tracking Requested - why for this release]: Significant UI regression.
On further testing, only reproducible with both Ghostery 5.4.1 (everything blocked) and Adblock Plus 2.6.7 enabled.
Blocks: abp
Summary: General tab of options dialog blank in latest beta → Blank window in preferences/options window with Adblock Plus and Ghostery enabled
Here is what I did to reproduce (OS X 10.10.2):

* Installed latest Aurora nightly (37.0a2 2015-02-04) which apparently calls itself "Firefox Developer Edition."
* Went to about:config and changed browser.preferences.inContent to false.
* Installed Adblock Plus 2.6.7 and Ghostery 5.4.1.
* Opened preferences - all fine.
* Restarted browser and opened preferences again - General tab is empty. Other tabs work but switching from them to the General tab doesn't do anything.

The Error Console shows NS_ERROR_FAILURE coming from preferences.xml, document.loadOverlay() call in prefwindow.showPane() fails. After disabling and reenabling Adblock Plus (with browser restart after each) things work correctly again - there is probably some dependency on the load order here which is why I couldn't reproduce with my regular profile.
Unfortunately, I was unable to reproduce that issue again despite repeating the same steps multiple times, it seems to be some rather fragile race condition.
@jkitch: Judging by bug numbers, the two ranges you gave above have only three patches in common: bug 1088508, bug 1105525, bug 991923. Neither of these seems to touch code that might be related.
regression window is wrong.  trying to find a better one.
With a clone of an old, but actively used profile with a half dozen addons, the blank window can be observed by loading a bunch of tabs at once and trying to open the options window at the same time.

Assuming that the blank window is caused by the same issue, I have been able to reproduce it as far back as early in the 33.0a1 cycle (possibly earlier, since I stopped looking at that point).

Given that it is rare (in terms of nobody else noticing) and that there is an easy workaround in the event that a recent change has made it more likely to occur, I'm not sure this is significant enough to merit special attention or a rushed patch.  

Workaround: click on a different tab, close and reopen options and click back to the first.
Another attempt with the same profile and addons other than ghostery/adblock removed.

https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=c8288d0c7a15&tochange=62d33e3ba514

Now regression window, assuming I got it right this time.
Narrowed it down to one of the first patches in https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=cb0c1f1666f7&tochange=ba028f407ebf

Still observed with d54d7a3105b6
Not observed after backing out 01332e9ad851 (Bug 1021280)

This was a self built opt build with no PGO, which may have influenced things.

I'm not a Javascript expert, so I can't comment about which change in the Addon SDK uplift broke things.
Dave, Erik: Any ideas?
Flags: needinfo?(evold)
Flags: needinfo?(dtownsend)
(In reply to Wes Kocher (:KWierso) from comment #11)
> Dave, Erik: Any ideas?

I have no idea how https://hg.mozilla.org/mozilla-central/rev/01332e9ad851 could have caused this, I think there is a better chance that the Ghostery add-on which uses the sdk, and may interact with adblock plus, might have something to do with it.

Any ideas Pete?
Flags: needinfo?(evold) → needinfo?(pete)
It is quite late in the cycle, addons related and intermittent. we won't block the 36 release for this bug.
I've got no ideas here.
Flags: needinfo?(dtownsend)
Duplicate of this bug: 1083669
QA Whiteboard: [bugday-20150309]
OS: Windows 8.1 → All
Duplicate of this bug: 1139740
Duplicate of this bug: 1140540
Duplicate of this bug: 1140875
Posted image Ghostery on.jpg
Ghostery on --> blank page, Ghostery off --> all options available
Attachment #8576816 - Flags: approval-mozilla-release?
Attachment #8576816 - Flags: approval-mozilla-release?
Duplicate of this bug: 1142931
resource://firefox-at-ghostery-dot-com/ghostery/data/options.html
Flags: needinfo?(jkitch.bug)
It's not only the preferences dialog, is it? In my affected profiles, it's also the "profile-reset dialog" (see bug 1127744, dupe of this one?) and the "Clear Recent History" dialog.

Instead, I can type about:preferences in the URL bar and the dialog contents nicely show up.

So I think the problem is with non-browser window pop-ups of a certain type (or Ghostery's or Adblock's handling of them?), rather than with the contents of dialogs.
Actual Ghostery settings do not seem to matter.  The same behaviour was observed with everything unchecked.

Interesting console output from a self-built debug build:

[9272] WARNING: We should have hit the document element...: file c:\mozilla-central\layout\xul\BoxObject.cpp, line 183
[9272] ###!!! ASSERTION: forward references have already been resolved: 'Error',
 file c:\mozilla-central\dom\xul\XULDocument.cpp, line 1117

These errors do not appear with Ghostery disabled.
Flags: needinfo?(jkitch.bug)
Now that in-content preferences has shipped, this no longer occurs.

Marking as duplicate to bug 1127744.  As far as I can tell the other bug has the same cause and it still affects a shipping dialogue.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1127744
Did you have try to disable a multi-processing mode (e10s)
Options > General > Startup > "Enable multi-process Firefox Developper Edition"
Ghostery still does not work in SeaMonkey 2.39 (Firefox 42.0)
Please work on it and fix it.

Ghostery 5.4.9. (2015-11-05) blank Site for Settings
"resource://firefox-at-ghostery-dot-com/ghostery/data/options.html"

"resource://firefox-at-ghostery-dot-com/ghostery/data/" show all parts, but no way to select one.

Ghostery Favicon appears in the address bar, but no content. 

<!doctype html>
<!--
 * Ghostery for Firefox
 * http://www.ghostery.com/
 *
 * Copyright 2014 Ghostery, Inc. All rights reserved.
 * See https://www.ghostery.com/eula for license.
-->
<html>
<head>
<meta content="text/html;charset=utf-8" http-equiv="Content-Type">
<meta content="utf-8" http-equiv="encoding">
<meta name="viewport" content="user-scalable=no, width=device-width, minimum-scale=1, maximum-scale=1">
<link rel="icon" href="images/icon19.png">
<link href="lib/vendor/apprise/apprise.css" media="screen" rel="stylesheet" type="text/css">
<link href="lib/vendor/tipTip/tipTip.css" media="screen" rel="stylesheet" type="text/css">
<link href="css/page.css" media="screen" rel="stylesheet" type="text/css">
<link href="css/options.css" media="screen" rel="stylesheet" type="text/css">
<link href="css/browser.css" media="screen" rel="stylesheet" type="text/css">
</head>
<body>

<div id="content"></div>

</body>
</html>


-> (e10s)in SeaMonkey ??? Now way to enable / disable!
-> Disabling / Uninstall all other add-on had no effect.


My System:
Platform: x86 WinXp SP3
User-Agent: Mozilla/5.0 (Windows NT 5.1; rv:42.0) Gecko/20100101 Firefox/42.0 SeaMonkey/2.39
Build-Identifikator: 20151103191810
###################################


I do not know witch is the current/first bug posting. So I write it here, but please see also here:

Bug 1066223 - [e10s] Ghostery add-on's settings page doesn't work 
Bug 1187065 - [e10s] Ghostery addon does not show its resource:// pages (like options and walkthrough) in e10s 
https://addons.mozilla.org/en-US/firefox/addon/ghostery/reviews/741240/
(In reply to Cha0s from comment #32)
> Did you have try to disable a multi-processing mode (e10s)
> Options > General > Startup > "Enable multi-process Firefox Developper
> Edition"

Once multi-processing-mode is deactivated, Firefox restarts and the Ghostery Options Page then appears filled and functional. Multi-processing-mode enabled once more, and the Ghostery Options Page remains functional.
Multi-Processing-mode must be toggled twice.
You need to log in before you can comment on or make changes to this bug.