[userstory] Preset Device Choices

RESOLVED FIXED

Status

RESOLVED FIXED
4 years ago
8 months ago

People

(Reporter: jryans, Unassigned)

Tracking

(Depends on: 10 bugs, Blocks: 1 bug)

unspecified
Dependency tree / graph
Bug Flags:
qe-verify -

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [multiviewport] [userstory], URL)

User Story

User Story:

* As a web developer I am targeting a specific device like the iPhone 5s and I would like to be able to easily choose that device by name from a list such that I don't have to look up the screen size and enter the information manually.

Acceptance Criteria:

* Common devices available from a regularly maintained list
* Choosing a device change the viewport to match the constraints of the new device
* List of popular devices for initial display to users as target devices
* Way to customize the list of target devices

Notes:

*The entire device does not need to be available all at once, we may want an interface that allows you to choose a set of devices for a set of devices you intend to target.

We have the beginnings of a device database on github which is being used for the WebIDE:  https://github.com/jankeromnes/devices

Competition:

* Chrome offers a limited set of devices they build directly into Chrome releases.  Their device list is more mature than ours and offers slightly more information.  A side goal of ours is to work with Developer Services on a device list service that can crowd-source the information needed.

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Could have sworn there was a bug for this already...

Anyway, we should integrate the device catalog into the responsive mode preset list.

Updated

4 years ago
Assignee: nobody → ntim.bugs
Status: NEW → ASSIGNED
(Reporter)

Comment 1

4 years ago
I have local patch that implements this, but it's also based on top of a large patch set...

Anyway, you are welcome to give it a shot if you like!  I'll likely come back and land my version eventually if it's not done by then.

Comment 2

4 years ago
Created attachment 8626307 [details] [diff] [review]
WIP patch

This patch adds the functionality, but the command button no longer updates it's state. I guess the way we check for responsive mode state will probably need a refactor unless we don't use async initialization.

Updated

4 years ago
Assignee: ntim.bugs → nobody
Status: ASSIGNED → NEW
(Reporter)

Updated

4 years ago
Blocks: 1179734
(Reporter)

Updated

4 years ago
Blocks: 1184438
(Reporter)

Updated

3 years ago
Whiteboard: [devtools-ux]
User Story: (updated)
Flags: qe-verify-
Summary: Use device catalog in Responsive Mode → [userstory] Preset Device Choices
Whiteboard: [devtools-ux] → [multiviewport] [userstory]
Depends on: 1237873
User Story: (updated)
User Story: (updated)
(Reporter)

Updated

3 years ago
Depends on: 1241713
(Reporter)

Updated

3 years ago
Depends on: 1241714
(Reporter)

Updated

3 years ago
Depends on: 1241720
(Reporter)

Updated

3 years ago
Depends on: 1247290
(Reporter)

Updated

3 years ago
Depends on: 1247302
(Reporter)

Updated

3 years ago
Depends on: 1249295
(Reporter)

Updated

3 years ago
Depends on: 1254385
(Reporter)

Updated

3 years ago
Depends on: 1254386
(Reporter)

Updated

3 years ago
Depends on: 1254388
(Reporter)

Updated

3 years ago
Depends on: 1254390
(Reporter)

Updated

3 years ago
Depends on: 1254392
(Reporter)

Updated

3 years ago
Depends on: 1262829
Depends on: 1266414
Depends on: 1266417
(Reporter)

Updated

3 years ago
Depends on: 1269441
(Reporter)

Updated

3 years ago
Depends on: 1269739
(Reporter)

Updated

3 years ago
Depends on: 1269750
(Reporter)

Updated

3 years ago
Depends on: 1273584
(Reporter)

Updated

3 years ago
Depends on: 1266411
(Reporter)

Updated

3 years ago
Depends on: 1278909
Depends on: 1259132
(Reporter)

Updated

3 years ago
Depends on: 1284463
(Reporter)

Updated

3 years ago
Depends on: 1291263
(Reporter)

Updated

3 years ago
Depends on: 1297431
(Reporter)

Updated

3 years ago
Depends on: 1299450
(Reporter)

Updated

2 years ago
Depends on: 1302964
(Reporter)

Updated

2 years ago
Depends on: 1303699
(Reporter)

Updated

2 years ago
Depends on: 1309292
(Reporter)

Updated

2 years ago
Duplicate of this bug: 1029467
(Reporter)

Updated

2 years ago
No longer blocks: 1184438
(Reporter)

Updated

2 years ago
Depends on: 1325571
(Reporter)

Updated

2 years ago
Depends on: 1325124
(Reporter)

Updated

2 years ago
Depends on: 1325563
(Reporter)

Comment 5

2 years ago
I believe this feature is complete according to the user story in 52 and later.  We can track bugs and tweaks separately.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED

Updated

8 months ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.