Bookmark manager context menu needs "Open in New Tab" option

VERIFIED FIXED in mozilla1.4alpha

Status

P3
minor
VERIFIED FIXED
17 years ago
14 years ago

People

(Reporter: ewv, Assigned: janv)

Tracking

Trunk
mozilla1.4alpha
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [adt2])

(Reporter)

Description

17 years ago
From bookmark menu, go to book mark manager.

Right click on a bookmark. There is Open, Open in New Window, but no "Open in
new Tab".

This should be consistent with the link context menu.

Comment 1

17 years ago
I don't think the Bookmarks window should have `Open in New Window' in the 
first place, let alone `Open in New Tab'. `Open in New Window' implies that 
just doing a normal `Open' will open the bookmark in the Bookmarks window 
itself. Bookmarks should trigger the same pref as mail/news or non-Mozilla apps 
for whether external links open in new windows or existing windows; if you want 
to override that pref in particular situations, drag and drop into a new window 
or onto the tab bar.
(Reporter)

Comment 2

17 years ago
Didn't know about dragging into the tab bar. That's cool.

As far as what should appear, it should be neither or both.
*** Bug 118790 has been marked as a duplicate of this bug. ***

Comment 4

17 years ago
If Open in New Tab is added to the bookmarks menu it should also be added to the
personal toolbar menu (right-click over a folder in the PTM). If Open in New
Window is removed, it should also be taken off the PTM.

I'd prefer all three (Open, open in new window, open in new tab) as it's more
user friendly.

Comment 5

17 years ago
*** Bug 122068 has been marked as a duplicate of this bug. ***

Comment 6

17 years ago
*** Bug 122215 has been marked as a duplicate of this bug. ***

Comment 7

17 years ago
That's more a User Interface issue.
Status: NEW → ASSIGNED
Target Milestone: --- → Future

Comment 8

17 years ago
*** Bug 130219 has been marked as a duplicate of this bug. ***

Comment 9

17 years ago
*** Bug 131015 has been marked as a duplicate of this bug. ***

Comment 10

17 years ago
*** Bug 132960 has been marked as a duplicate of this bug. ***

Comment 11

17 years ago
My enhancement idea has been added to this "bug". It is to be able to r click on
a *folder* on the personal toolbar and choose to have it open all links
contained in the folder in a single tabbed window? And it would open them in the
order that the links are arranged in. It would display the first link while the
other links loaded in thier own tabs. The same option could perhaps be available
in the bookmarks if it's easy to implement. 

What better way to truely show the power of tabbed windows? I can see where this
concept would be a significant user feature unique to the Mozilla project,
showing off the already nice tab implementation. It would greatly speed the
everyday user's browsing experience.

I also very much support the original proposal of this "bug", which is to be
able to get "open in a new tab" in the R click of bookmarks and the personal
toolbar.

An eventual extension of this idea could be to assign a folder as a home page
link instead of a single link. 

http://bugzilla.mozilla.org/show_bug.cgi?id=132960

Comment 12

17 years ago
Please disregard my comments. I was incorrectly pointed this bug number. The
correct bug number for my issue is 119599. Sorry for any confusion.
http://bugzilla.mozilla.org/show_bug.cgi?id=119599

Comment 13

17 years ago
*** Bug 135886 has been marked as a duplicate of this bug. ***

Comment 14

17 years ago
*** Bug 141381 has been marked as a duplicate of this bug. ***
*** Bug 141680 has been marked as a duplicate of this bug. ***

Comment 16

17 years ago
*** Bug 147724 has been marked as a duplicate of this bug. ***

Comment 17

17 years ago
Has there been any indication that this 'feature' will be included in any
upcoming builds? It seems to have gone on the back burner, and yet, it's
probably one of the more sort after requests...

Comment 18

17 years ago
i don't want open in new tab, and if it takes removing open in new window to 
get this bug wontfixed, i will support that.

Indication? we're busy deciding what to do. nothing will happen to 
nightly or release binaries until:
1. a decision is made
2. if that decision is along the lines of the request, someone needs to write 
some code
3. someone would then need to find a reviewer who would have to positively r= 
the code
4. ... and a super reviewer to positively sr= the code
5. and then check it in (assuming the tree is open and not restricted) or find 
someone to check it in.

But hopefully this bug will die at step 1.
Whiteboard: DONTFIX

Comment 19

17 years ago
Bookmark context menu is different for bookmark folder and single bookmark, in
both menus is item 'Open in New Window', but it has different meaning. This is
IMHO confusing. Futhermore, community wanna have also 'Open in New Tab'. 

If we can differentiate actions 'open bookmark in new browser window', 'open
bookmark in new browser tab' and 'open bookmark folder in new bookmark manager
window', "Open in New Tab" menu item should be added and everybody will be happy.

Matthew: To your comment 1 - Bookmarks are integral part of browser, not
stand-alone application like mail/news. Bookmarks advance a leisure of browsing,
similarly as Tabbed Browsing does. So, there should be "Open in New Tab" menu item.
Blocks: 135841
*** Bug 154110 has been marked as a duplicate of this bug. ***

Comment 21

17 years ago
Nominating for buffy, a bunch of 7.0 users requested this.
Keywords: nsbeta1
Whiteboard: DONTFIX

Comment 22

17 years ago
Nav triage team: nsbeta1+/adt2
Keywords: nsbeta1 → nsbeta1+
Whiteboard: [adt2]

Comment 23

17 years ago
*** Bug 159039 has been marked as a duplicate of this bug. ***
Nominating for mozilla1.2.
Keywords: mozilla1.2

Comment 25

16 years ago
Yes. I support this the orignal "brainstormer," and first comment on this issue
except for removing any features (eg Removing `Open in New Tab'. `Open in New
Window' . It will be at least once feature that would seperate Netscape/Mozilla
from IE.


Well apparentenly  this is a "popular feature" everyone including me would like
to see.

Feature not in 
Mozilla 1.1
Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.1) Gecko/20020826

Comment 26

16 years ago
*** Bug 168193 has been marked as a duplicate of this bug. ***
*** Bug 176442 has been marked as a duplicate of this bug. ***

Comment 28

16 years ago
It would be nice if a middle-click in the bookmark-sidebar would open a link in
a new tab, in addition to the context menu (if option "middle click or control
click ..." is checked in preferences->navigator->tabbed browsing.

I'm missing this feature for a long time now.

Comment 29

16 years ago
Info:
We have an "open link in a new tab"  from mail preview (bug 181063)

So I think it is a little ourious to have ut not from the bookmarks and sidebar-
bokkmarks.

For me it would be very helful to have this function.


This wish is discussed in bug 16477, bug 114314, bug 116531, bug 117449

I think work on the bug should be concentrated in bug 117449, other bugs should
be colosed with DUP.

Comment 30

16 years ago
Drag & drop a link on the "new tab icon" in the tab bar nicely opens a new tab
with the bookmark.

However doing the same action with a bookmark folder throws a "NC is not a
registered protocol" alert dialog (Mozilla 1.2)

I would like the "Open in new tab" menu entry as well as the CTRL+click added to
Mozilla 1.3

Comment 31

16 years ago
*** Bug 183779 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 32

16 years ago
reassigning
Assignee: ben → varga
Status: ASSIGNED → NEW
(Assignee)

Updated

16 years ago
Target Milestone: Future → mozilla1.4beta
(Assignee)

Updated

16 years ago
Blocks: 196756

Comment 33

16 years ago
*** Bug 197971 has been marked as a duplicate of this bug. ***
(Assignee)

Updated

16 years ago
Priority: -- → P3
Target Milestone: mozilla1.4beta → mozilla1.4alpha

Comment 34

16 years ago
Now that we've got "Open in New Tab" added to the context menu in Mozilla Mail,
let's finish it off by having it in the Bookmarks section too. :)

(Assignee)

Comment 35

16 years ago
It's fixed on the bookmarks branch which should land soon.

Comment 36

16 years ago
Using the 2003-03-25-03 Macho (OS X) and 2003-03-25-04 Win32 trunk builds, the
"Open in New Tab" option appears in the contextual menu.

Comment 37

16 years ago
Confirming under XP.  So - this has now either been fixed by a checkin elsewhere
(that "bookmarks branch") or is a dupe of something else that's been fixed?

Comment 38

16 years ago
Fixed by bug 196756. Verified.

Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED

Comment 39

16 years ago
Verified.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.