Closed Bug 1190158 Opened 4 years ago Closed 4 years ago

[Browser app] Firefox Browser app on the main home screen

Categories

(Firefox OS Graveyard :: Gaia::TV, defect, P1)

ARM
Gonk (Firefox OS)
defect

Tracking

(feature-b2g:2.5+)

RESOLVED FIXED
FxOS-S6 (04Sep)
feature-b2g 2.5+

People

(Reporter: jocheng, Assigned: danhuang)

References

Details

(Whiteboard: [ft:conndevices])

Attachments

(2 files)

Browser app -

As a user, I would like to have my favorite Firefox browser on my TV and access it easily (on the main home screen)
feature-b2g: --- → 2.5+
Assignee: nobody → yliao
Depends on: 1125716
Blocks: 1156635
No longer blocks: 1156635
Depends on: 1156635
Status: NEW → ASSIGNED
Priority: -- → P1
Blocks: 1193702
No longer depends on: 1193702
Summary: [Landing page] Firefox Browser app on the main home screen → [Browser app] Firefox Browser app on the main home screen
Target Milestone: --- → FxOS-S6 (04Sep)
Blocks: 1198099
Depends on: 1198103
No longer depends on: 1198103
Depends on: 1198115
No longer depends on: 1198115
Depends on: 1198200
No longer depends on: 1198200
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Depends on: 1199563
No longer depends on: 1199563
Depends on: 1200078
No longer depends on: 1200078
Depends on: 1198097
Reopen because need to make browser app pin to home
Status: RESOLVED → REOPENED
Flags: needinfo?(yliao)
Resolution: FIXED → ---
Status: REOPENED → NEW
Comment on attachment 8655309 [details] [review]
[gaia] begeeben:1190158_firefox_browser_app_on > mozilla-b2g:master

This patch adds browser app to the smart home.
Flags: needinfo?(yliao)
Attachment #8655309 - Flags: review?(rexboy)
Status: NEW → ASSIGNED
Attachment #8655309 - Flags: review?(rexboy) → review-
Assignee: yliao → nobody
Status: ASSIGNED → NEW
Assignee: nobody → dhuang
Duplicate of this bug: 1193686
Comment on attachment 8656982 [details] [review]
[gaia] danhuang1202:1190158_browser_app_on_home_screen > mozilla-b2g:master

Please help me to review. I had added browser app in home deck. And add two type: isFillIcon and isEnableWave in default-cards.json. Thanks.
Attachment #8656982 - Flags: review?(rexboy)
Comment on attachment 8656982 [details] [review]
[gaia] danhuang1202:1190158_browser_app_on_home_screen > mozilla-b2g:master

r=me. Thank you!
Attachment #8656982 - Flags: review?(rexboy) → review+
Thanks for the review.
Merged into master: https://github.com/mozilla-b2g/gaia/pull/31690
Status: NEW → RESOLVED
Closed: 4 years ago4 years ago
Resolution: --- → FIXED
Hi Tori, 
Could you please take a look at the icon and the name? Thank you! :)
Flags: needinfo?(tchen)
After checked with Joe and Dan, the icon and name should be as below:

icon -> Dan will revise the icon to Firefox icon after it becomes official.
name -> stick on "browser", same as Firefox OS phone
Flags: needinfo?(tchen) → needinfo?(dhuang)
Hi Tori,
When you make gaia, you can type 'GAIA_DEVICE_TYPE=tv MOZILLA_OFFICIAL=1 make' in terminal.
This would build gaia with official version, and can use to check official icon in browser.
Flags: needinfo?(dhuang)
Depends on: 1217708
Depends on: 1233366
Depends on: 1233624
No longer depends on: 1233624
Depends on: 1233641
No longer depends on: 1233641
You need to log in before you can comment on or make changes to this bug.