Option to expand mailing list into addresses window

REOPENED
Unassigned

Status

--
enhancement
REOPENED
17 years ago
6 days ago

People

(Reporter: bam, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
It would be convenient to have a property attached to a list that would permit
it to expand the members into the composition window's address list.  This would
allow and individual member to be removed from the list prior to hitting SEND.

Updated

17 years ago
QA Contact: sheelar → nbaca

Updated

16 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
Product: MailNews → Core

Comment 1

14 years ago
*** Bug 147737 has been marked as a duplicate of this bug. ***

Comment 2

14 years ago
*** Bug 291035 has been marked as a duplicate of this bug. ***

Comment 3

13 years ago
*** Bug 332055 has been marked as a duplicate of this bug. ***

Updated

12 years ago
Duplicate of this bug: 369716

Updated

12 years ago
Assignee: ducarroz → nobody
QA Contact: nbaca → composition

Updated

12 years ago
Duplicate of this bug: 377814

Updated

11 years ago
Duplicate of this bug: 232205

Updated

11 years ago
Duplicate of this bug: 366988

Updated

11 years ago
Duplicate of this bug: 286064

Updated

11 years ago
Duplicate of this bug: 313842
(Assignee)

Updated

10 years ago
Product: Core → MailNews Core

Comment 10

10 years ago
	
Yes, exactly as does MS Ooutlook !

Regards
Summary: [RFE] Option to expand mailing list into addresses window → Option to expand mailing list into addresses window

Updated

10 years ago
Duplicate of this bug: 449551

Updated

10 years ago
Duplicate of this bug: 470664

Updated

10 years ago
Duplicate of this bug: 469127

Comment 14

10 years ago
This was a feature of Eudora Lite 11 years ago.  This is one of the reasons I still use Eudora Lite 3.0.6 for E-mail and only use Thunderbird for newsgroups.
Duplicate of this bug: 378531

Comment 16

10 years ago
(In reply to comment #15)
> *** Bug 378531 has been marked as a duplicate of this bug. ***
Please read the report again.
It is definitely not a duplicate of this bug!!!
It has nothing to do with sending Emails!
It has to do with the address book!
Clicking on a list in the left pane brings up the address cards for that list in the right pane. Highlighting one of these and deleting does not remove the card!!!!

Comment 17

9 years ago
Has any progress been made in providing this option. I for one could sure use it.

Comment 18

9 years ago
Workaround: 

1. Open Address Book
2. Select the mailing list in the left pane
3. Click Compose in the toolbar or Accel+M

The address area of the message compose window now lists all recipients one by one.
(Reporter)

Comment 19

9 years ago
Nice .. WFM!
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED

Comment 20

9 years ago
That's just a workaround though, reopening.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Comment 21

9 years ago
I don't see how this would help if you're trying to forward an E-mail and you want to edit/modify the addressee list prior to sending.

....Rob
(Reporter)

Comment 22

9 years ago
I take that back: DNWFM

I agree with Magnus and Bobbert. In fact what Bobbert pointed out was one of the first things I tried to do: forward an email to a list but remove a couple of recipients.  It is a no-go, I must type in the list name and in that case it does not get expanded.

Comment 23

9 years ago
(In reply to comment #0)
> It would be convenient to have a property attached to a list that would permit
> it to expand the members into the composition window's address list.  This would
> allow and individual member to be removed from the list prior to hitting SEND.

This has been one of the main blemishes in the pretty good 'Thunderbird'.
I have overcome this by creating various sender lists which include or exclude particular members for sending restricted circulation emails.
It's a great nuisance and very time consuming as well as wasteful of computer resources.
High time this was dealt with as it is a very simple software fix!

Comment 24

9 years ago
I am so very glad to see others recognizing the short-comings of Thunderbird and the need to modify an address list before forwarding/sending. Maybe now something will be done to resolve this problem. I have my fingers crossed!

Comment 25

9 years ago
Has this died on the development table? I for one would sure like to see it implemented. Thunderbird is a great product, but it could be so much better 
if this feature were added.

Comment 26

9 years ago
Is there any hope in hell of getting a resolution to this problem in my life time? I must admit that i'm astounded by the lack of interest in this very real problem.......yes problem, not enhancement. This problem is akin to building a $50,000 vehicle and not supplying a driving wheel! This is a basic function any E-mail server should be able to handle. Is my only option to find another mail server that has this function? I'm otherwise happy with Thunderbird!

Comment 27

8 years ago
Finally Paul B. Gallagher gived me a good working detour - GREAT - I don't know if we can close this bug, using this fact.
Here is the text we exchanges:
Paul B. Gallagher wrote: 
> Compose your message to a list and queue it using File | Send Later (CTRL-SHIFT-Enter). SeaMonkey will expand the list name to individual recipient names and addresses.

> Go to your Unsent Messages folder and open the message as new (CTRL-E). Delete the unwanted recipients, and send normally.

> Don't forget to delete the unedited version from your Unsent Messages folder. 
And i replied:
(My UnSent Message folder is named OutBox and is located under "Local Folder").
GREAT !!!! THANKS !!!!
You find it .... I had tried to do a "Save", it goes to the Draft folder BUT without the expansion of the recipients.

Comment 28

8 years ago
I have used this method several times.  It is just a workaround, however.  I believe that this issue should remain open, and a nice, time-saving method should be developed to address this.

Comment 29

8 years ago
This is a "working" work around......thank you. However, i agree with Mark, the issue should remain open........this is a lot of extra work to accomplish something that should be simple.

Updated

8 years ago
Duplicate of this bug: 602448

Comment 31

8 years ago
Is this the year this bug will be fixed??????

Comment 32

8 years ago
No, i think that it will never been fixed. however the detour given in Comment 27 IS PERFECT.
(In reply to comment #31)
> Is this the year this bug will be fixed??????

This is not currently a priority for Thunderbird developers, whoever would be welcome to attempt a fix for it, though I'd suggest trying it via an add-on first.

bobbert: Most of your comments on this bug are not helpful to getting the bug fixed. Please read the etiquette before making any more posts: https://bugzilla.mozilla.org/page.cgi?id=etiquette.html
Comment hidden (spam)

Comment 35

8 years ago
Workaround III: (In reply to comment #28)

1. Forward the message
2. Open the Address Book
3. Select the list in the left column
4. Select the list members in the upper right column
5. Drag the selection to the addressing area of the forwarded message and drop it

Question is if any other solution would be easier for the user.

Comment 36

7 years ago
Paolo Kaosmos's AddExpandedList deals with this very nicely. 

https://nic-nac-project.org/~kaosmos/index-en.html#explist

Comment 37

7 years ago
While the AddExpandedList is nice and a step up for me, it does not expand Reply-to entries -- just To, Cc, and Bcc.  It would still be nice to have a method of expanding all of these lists.  The situation I'm currently running into is that I wish to create emails to send at a later time (using the Send Later extension).  If I put a group in to the Reply-To list, then I was hoping that it would get expanded, just as the To, Cc, and Bcc lists do, but it doesn't.  :-(  Even if I use the method in Comment 27 -- which I had been doing prior to being made aware of the AddExpandedList extension -- the 'Reply-To' list is not expanded.  So, I really have no workaround currently for this particular situation.  Hence, the continued request to make something available to reliably and conveniently expand all of the possible lists (To, Cc, Bcc, Reply-To, ...).
Comment hidden (spam)

Comment 39

5 years ago
My wife's parents each came from very large families, so I have a mailing list for each family.  I also have a mailing list for my own mother's large family.  Thus, my daughter appears in three different mailing lists.  My wife's nephew and niece each appear in two mailing lists.  

When we send out our annual newsletter to family and friends, we personalize the E-mail message according to the mailing list.  Thus, each mailing list receives a different message.  I do not want to send three different messages to my daughter or two different messages to my wife's nephew and niece.  

Note:  This was a capability of Eudora Lite more than 15 years ago.  Why cannot this be a Thunderbird capability?

Comment 40

5 years ago
(In reply to Chris Ramsden from comment #36)
> Paolo Kaosmos's AddExpandedList deals with this very nicely. 
> https://nic-nac-project.org/~kaosmos/index-en.html#explist

Another AddOn for this task is PopMailListRecipients. It gives a simple toolbar button and doesn't depend on the Contacts Sidebar.
https://addons.mozilla.org/de/thunderbird/addon/popmaillistrecipients
Comment hidden (spam)

Comment 42

5 years ago
Re comment #40:  

Since posting my comment #39, I found the PopMailListRecipients extension and installed it.  However, extensions can only represent short-term work-arounds to problems.  We cannot rely on developers to keep modifying their extensions in response to changes in the basic applications, especially when basic applications are changed in a way that prevents any reasonable interface with an extension.  

See, for example, bug #825588 and bug #847863, which is eliminating the Preserve Download Modification Timestamp extension as a solution to bug #733954 as documented in bug #918188.  In this case, changes to the Downloads Manager effectively prevent any modification to the extension that might work-around bug #733954.

Updated

4 years ago
Duplicate of this bug: 622114

Updated

4 years ago
Duplicate of this bug: 861483

Comment 45

4 years ago
OK, i've installed this add-on. However, i'm having problems trying to figure out how to use it. I enter the list name, but don't see any "PopMailListRecipients" to click on? 

Does this add-on only work with compose/send, or will it work when forwarding an e-mail as well?

Comment 46

4 years ago
(In reply to bobbert from comment #45)
> OK, i've installed this add-on. However, i'm having problems trying to
> figure out how to use it. I enter the list name, but don't see any
> "PopMailListRecipients" to click on? 
> 
> Does this add-on only work with compose/send, or will it work when
> forwarding an e-mail as well?

You need to add the toolbar button that comes with this add-on (a red star) to the compose window.
Add a list to the message and press the add-on button - voilá!

Comment 47

4 years ago
Great, how do i do that? It is NOT apparent to me!

Comment 48

4 years ago
What is not apparent to you? Don't you know how to add an add-on button to a tool-bar?

Comment 49

4 years ago
Bingo! Yes, i admit i've never done it and have no clue how to.

Comment 50

4 years ago
Success........after much investigation, i've figured out how to add an add-on button to the toolbar.

Thanks to all for your help on this.
You need to log in before you can comment on or make changes to this bug.